Autor Thema: Debian Atari 68K ...  (Gelesen 6682 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #100 am: So 09.09.2018, 21:29:11 »
Falcon 060 läuft ja. Die Frage ist halt ob und was es bei einem ST mit Fastram und 030 CPU und auf einem Atari TT macht !?!

Falcon original 030 mit 14MB Ram müsste doch auch gehen, oder?

Auf der Mailing Liste ist bis jetzt auch nichts zu Lesen zu dem Thema.
« Letzte Änderung: So 09.09.2018, 21:31:20 von Lukas Frank »

Offline gh-baden

  • Benutzer
  • Beiträge: 1.175
Re: Debian Atari 68K ...
« Antwort #101 am: So 09.09.2018, 21:45:31 »
Falcon original 030 mit 14MB Ram müsste doch auch gehen, oder?

Da war (hier) zu lesen, dass das nur in der sysv-init-Version geht. Mit Systemd ist’s zuwenig RAM.
Wider dem Signaturspam!

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #102 am: So 09.09.2018, 21:56:35 »
Ich dachte vielleicht weil ich gelesen hatte das ein Apple 68k LCII mit seinen 36MB gehen soll.

Offline Beetle

  • Moderator
  • *****
  • Beiträge: 875
Re: Debian Atari 68K ...
« Antwort #103 am: Mo 10.09.2018, 18:33:02 »
Hallo,

erstmal sorry, das ich mich so spät melde. Leider gibts nicht viel neues, und gestern
war ich von früh bis spät abends auf ehrenamtlich verplant. Dann musste ich heute morgen
auch noch morgens um 5 los zur Arbeit. Ich gebe zu, ich hätte noch ne Stunde schlafen gekonnt, oder 4.

zum Thema:

TT030 und MegaST PAK030 hängen nach wie vor nach der Meldung
NR_IRQS: 200Beim Falcon ist die nächste Meldung:
Console: color dummy device 80x25
Ein Amiga mir 030 (2MB Chip, 64MB Fastram), und auch beim Mac LCIII (=Performa 450)
mit 030 CPU und 36 MB RAM bootet der Kernel, wenn gleich der Mac noch vor dem Login mit free mem exhausted hängt.

Ein generelles 030 Problem kann man daher ausschließen. Es wurden beim TT und PAK Rechner jegliche sinnvolle Kombination probiert, Kernel ins ST oder TT RAM, mit und ohne ST memory Pool, sogar ohne Grafik und Login nur auf seriellem Terminal.

Geert hat in der Woche vor dem Meeting absagen müssen, und Adrian musste leider noch am Freitag abend absagen. Das waren leider genau die Leute, die sich mit Kernel-interna und Atari entsprechend auskennen und eigentlich dort sein wollten.

Also Trost kann ich noch melden, das die Installation auf dem 64MB A1200 wegen low memory abbrach, und auf einem A3000 wegen Erkennungsproblemen am und IDE SCSI Bus nicht recht starten wollte. Immer beim laden des Partitionswerkzeuges und der entsprechenden Hardware streikte entweder das Zielmedium, oder die Quell-CD war plötzlich "weg".

So hatten wir zwar ein schönes Wochenende mit viel seltener oldschool Hardware, aber kaum neue Erkentnisse. Gequalmt hats auch, mir ist ein Flachbildschirm abgeraucht. Immer dieser neumodische Schund. ;-)

Es war ein Wikipedia-Mitarbeiter da, scrollt doch auf https://de.wikipedia.org/wiki/Debian mal runter bis "Trivia".

Gruß,
Beetle
 
Falcon ct63 ->68060@90MHz im Ex-ST Gehäuse, 14/512 MB, DVD-Brenner, 120GB SSD, EtherNAT (Netzwerk, USB), MicroCosmos (nur USB->IKBD Funktion), SuperVidel, 27" 16:9 TFT 2560x1440

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #104 am: Mo 10.09.2018, 19:00:25 »
Wenn sich beim Thema Atari TT was tut, werde ich gerne Beta Testen wollen ...

Offline pakman

  • Benutzer
  • Beiträge: 82
Re: Debian Atari 68K ...
« Antwort #105 am: Mo 10.09.2018, 20:00:45 »
TT030 und MegaST PAK030 hängen nach wie vor
Schade.
Wie geht es jetzt weiter?
Ich hoffe, ihr gebt noch nicht auf..
PAK68/3 54MHz mit Flash-ROMs, FRAK/1 16 MByte, Panther/2 mit ATI Mach32
CompactFlash Adapter (modifizierter Panther/1)

Offline ari.tao

  • Benutzer
  • Beiträge: 2.222
  • a tha yo ga a nu sha sa nam
Re: Debian Atari 68K ...
« Antwort #106 am: Mo 10.09.2018, 20:24:09 »
... scrollt doch auf https://de.wikipedia.org/wiki/Debian mal runter bis "Trivia".
Das Bild sieht interessant aus. Leider steht zu wenig Legende daneben. Habe ich da richtig auf dem Typenschild ´Falcon 060´ gelesen?
Falcon+ddd32MHz, TT+CrazyDotsGK und noch ein paar andere.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #107 am: Mo 10.09.2018, 20:30:11 »
Ein Falcon mit CT60/63

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #108 am: Di 11.09.2018, 16:25:45 »
Ohne die Video Option läuft es auch nicht.

-------
ABCEGHIJK
[    0.000000] Linux version 4.16.0-1-m68k (debian-kernel@lists.debian.org) (gcc version 7.3.0 (Debian 7.3.0-16)) #1 Debian 4.16.5-1 (2018-04-29)
[    0.000000] console [debug0] enabled
[    0.000000] Atari hardware found: TT_SHIFTER ST_MFP TT_MFP TT_SCSI_DMA TT_SCSI YM2149 PCM SCC_DMA SCC VME SCU IDE MICROWIRE TT_CLK FDC_SPEED ACSI
[    0.000000] On node 0 totalpages: 2560
[    0.000000]   DMA zone: 25 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 2560 pages, LIFO batch:0
[    0.000000] On node 1 totalpages: 65536
[    0.000000]   DMA zone: 640 pages used for memmap
[    0.000000]   DMA zone: 0 pages reserved
[    0.000000]   DMA zone: 65536 pages, LIFO batch:15
[    0.000000] initrd: 1080d284 - 11000000
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc:
  • 0

[    0.000000] Built 2 zonelists, mobility grouping on.  Total pages: 67431
[    0.000000] Kernel command line: root=/dev/ram debug=ser console=tty load_ramdisk=1 BOOT_IMAGE=f:\install\kernels\vmlinux
[    0.000000] Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
[    0.000000] Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Sorting __ex_table...
[    0.000000] Memory: 255848K/272384K available (2741K kernel code, 391K rwdata, 964K rodata, 144K init, 204K bss, 16536K reserved, 0K cma-reserved)
[    0.000000] Virtual kernel memory layout:
[    0.000000]     vector  : 0x003d0bd8 - 0x003d0fd8   (   1 KiB)
[    0.000000]     kmap    : 0xd0000000 - 0xf0000000   ( 512 MiB)
[    0.000000]     vmalloc : 0x11800000 - 0xd0000000   (3048 MiB)
[    0.000000]     lowmem  : 0x00000000 - 0x11000000   ( 272 MiB)
[    0.000000]       .init : 0x(ptrval) - 0x(ptrval)   ( 144 KiB)
[    0.000000]       .text : 0x(ptrval) - 0x(ptrval)   (2742 KiB)
[    0.000000]       .data : 0x(ptrval) - 0x(ptrval)   (1356 KiB)
[    0.000000]       .bss  : 0x(ptrval) - 0x(ptrval)   ( 205 KiB)
[    0.000000] random: get_random_u32 called from __kmem_cache_create+0x34/0x492 with crng_init=0
[    0.000000] SLUB: HWalign=16, Order=0-3, MinObjects=0, CPUs=1, Nodes=8
[    0.000000] NR_IRQS: 200
......................................................................................
« Letzte Änderung: Di 11.09.2018, 16:27:18 von Lukas Frank »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #109 am: Di 11.09.2018, 18:10:39 »
Habe mal aus Interesse eine 68k Debian 2.2 Version auf dem PAK030 Rechner laufen lassen und da bootet der Kernel und der Installer scheint zu laufen ...

Denke auf einen Atari TT funktioniert es ebenso.


debug Ausgabe über die serielle Schnittstelle ->
-------

ABCEGHIJ
Linux version 2.2.10 (root@aahz) (gcc version 2.7.2.3) #6 Sun Apr 2 15:16:13 CEST 2000
Atari hardware found: STND_SHIFTER ST_MFP STND_DMA YM2149 IDE MSTE_CLK ACSI
Console: colour dummy device 80x25
Calibrating delay loop... 12.42 BogoMIPS
Using 2104k (526 pages) of ST-RAM as swap space.
Memory: 65536k/69632k available (952k kernel code, 3076k data, 68k init)
kmem_create: Forcing size word alignment - filp
VFS: Diskquotas version dquot_6.4.0 initialized
kmem_create: Forcing size word alignment - dquot
POSIX conformance testing by UNIFIX
Linux/m68k PCI BIOS32 revision 0.01
PCI: No PCI bus detected
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
kmem_create: Forcing size word alignment - sock
kmem_create: Forcing size word alignment - skbuff_head_cache
NET4: Unix domain sockets 1.0 for Linux NET4.0.
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
kmem_create: Forcing size word alignment - tcp_open_request
Initializing RT netlink socket
Starting kswapd v 1.5
Console: switching to mono frame buffer device 80x25
Determined 640x400, depth 1
fb0: Atari Builtin autodetect frame buffer device, using 36K of video memory
WARNING: keyboard self test failed!
M68K Serial driver version 1.01
pty: 256 Unix98 ptys configured
Atari mouse installed.
RAM disk driver initialized:  16 RAM disks of 4096K size
loop: registered device at major 7
ide0: Falcon IDE interface
hda: PA25-8, ATA DISK drive
hdb: Hitachi XXM2.3.0, ATA DISK drive
ide0 at fff00000 on irq 0x0000000f
hda: PA25-8, 7551MB w/1kB Cache, CHS=15343/16/63
hdb: Hitachi XXM2.3.0, 244MB w/1kB Cache, CHS=695/15/48
Atari floppy driver: max. HD, track buffering
Probing floppy drive(s):
fd0
md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
scsi : 0 hosts.
scsi : detected total.
Partition check:
Probing ACSI devices:
  Vendor: IBM       Model: DCAS-34330W       Rev: S65A
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected disk ada at id 0 lun 0 4134 MByte
  Vendor: PLEXTOR   Model: CD-ROM PX-12TS    Rev: 1.00
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected cdrom adb at id 3 lun 0 (removable) (read-only)  unkown size, using default 1024 MByte
Found 2 ACSI device(s) total.
 ada: AHDI ada1 ada2 ada3 XGM<
No valid subpartition in extended partition!
 >
 adb: DOS
 hda: AHDI hda1 hda2 hda3 XGM< hda4 hda5 >
 hdb: unknown partition table
RAMDISK: Compressed image found at block 0
EXT2-fs warning: checktime reached, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem).
Warning: unable to open an initial console.
« Letzte Änderung: Di 11.09.2018, 18:12:54 von Lukas Frank »

Online Arthur

  • Benutzer
  • Beiträge: 8.563
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Debian Atari 68K ...
« Antwort #110 am: Di 11.09.2018, 18:20:43 »
Sehr schön. Jetzt ist noch interessant wie flüssig sich das im Betrieb verhällt.

Offline gh-baden

  • Benutzer
  • Beiträge: 1.175
Re: Debian Atari 68K ...
« Antwort #111 am: Di 11.09.2018, 20:21:16 »
Sehr schön. Jetzt ist noch interessant wie flüssig sich das im Betrieb verhällt.

Kernel 2.2 läuft auf Singleprozessorsystemen prima, wenn man nicht zuviele Threads eröffnet. Die Fixes für "sehr viele Threads" kamen erst im Laufe von 2.4.

Allerdings will man "sehr viele Threads" auch mit 2.4 oder 2.6 nicht auf einem 68030@32@16. Da schläft einem schon auf einem Pentium 200 MMX das Gesicht ein.

Für Standard-UNIX-Software (nroff, LaTeX, mutt, pine, elm, tr, tin, graphviz/dot etc.pp.) ist aber sowohl ein 030er als auch Kernel 2.2 absolut okay. Und 64 MB RAM sind dann mehr als genug, schöne Kiste dafür.
Wider dem Signaturspam!

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #112 am: Mi 12.09.2018, 09:01:11 »
Die Installation beim Debian 2.2 m68k lief einwandfrei durch bis zu den beiden letzten Abschluss Punkten. Bootloader auf der Festplatte kann nicht installiert werden und Boot Floppy kann nicht erstellt werden.

Wie kann ich Debian von der ext2 Platte booten?

Edit: ... habs gefunden einfach die bootargs ändern. Ich boote von hdb1. Das ist meine 4GB CF Karte auf dem IDE Bus als Slave.

-s -k linux -r root.bin root=/dev/hdb1 video=keep load_ramdisk=1


Problem ist jetzt das ACSI/SCSI CDROM auf ID3 in apt einzurichten ...


@Arthur ... zur Geschwindigkeit kann ich sagen das der Rechner knapp unter einer Minute zum booten bis zum Logging braucht. So lange wie EasyMiNT zum booten braucht über das init
« Letzte Änderung: Mi 12.09.2018, 12:25:34 von Lukas Frank »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #113 am: Do 13.09.2018, 18:33:32 »
Ich komme zur Zeit nicht weiter weil ich das CD Rom nicht Mounten kann. Das CD Rom sollte /dev/adb sein. Ohne das CD Rom läuft apt nicht weil mir ein Netzwerk fehlt und lange Dateinamen auf den Atari
 TOS Partionen nicht möglich ist.

mount -t iso9660 /dev/adb /cdrom

... klappt nicht. Ein adb0 ebensowenig.

Offline czietz

  • Benutzer
  • Beiträge: 2.075
Re: Debian Atari 68K ...
« Antwort #114 am: Do 13.09.2018, 19:08:10 »
Also ist Dein CD-Laufwerk das Gerät mit der ID=1 am ACSI-Bus?
Existiert /dev/adb denn?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #115 am: Do 13.09.2018, 19:42:05 »
ide0: Falcon IDE interface
hda: PA25-8, ATA DISK drive
hdb: CF CARD, ATA DISK drive
ide0 at fff00000 on irq 0x0000000f
hda: PA25-8, 7551MB w/1kB Cache, CHS=15343/16/63
hdb: CF CARD, 3831MB w/1kB Cache, CHS=7785/16/63
Atari floppy driver: max. HD, track buffering
Probing floppy drive(s):
fd0
md driver 0.36.6 MAX_MD_DEV=4, MAX_REAL=8
scsi : 0 hosts.
scsi : detected total.
Partition check:
Probing ACSI devices:
  Vendor: IBM       Model: DCAS-34330W       Rev: S65A
  Type:   Direct-Access                      ANSI SCSI revision: 02
Detected disk ada at id 0 lun 0 4134 MByte
  Vendor: PLEXTOR   Model: CD-ROM PX-12TS    Rev: 1.00
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected cdrom adb at id 3 lun 0 (removable) (read-only)  unkown size, using default 1024 MByte

Found 2 ACSI device(s) total.
 ada: AHDI ada1 ada2 ada3 XGM<
No valid subpartition in extended partition!
 >
 adb: DOS
 hda: AHDI hda1 hda2 hda3 XGM< hda4 hda5 >
 hdb: AHDI hdb1 hdb2
-------

Unter /dev ist alles da auch adb

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 481
Re: Debian Atari 68K ...
« Antwort #116 am: Do 13.09.2018, 19:53:47 »
iUnter /dev ist alles da auch adb

Weiss jetzt nicht ob das bei 2.2 auch schon so war, aber zum mounten müsste das normalerweise /dev/adb0 sein. Ansonsten mal dd probieren ob sich das device überhaupt ansprechen lässt.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #117 am: Do 13.09.2018, 20:06:01 »
/dev/adb0    does not exist

Offline czietz

  • Benutzer
  • Beiträge: 2.075
Re: Debian Atari 68K ...
« Antwort #118 am: Do 13.09.2018, 20:08:06 »
"Klappt nicht" ist immer so eine unklare Fehlerbeschreibung. Was passiert denn bei...

mount -t iso9660 /dev/adb /cdrom

Fehlermeldung? Was steht danach in der Ausgabe des "dmesg"-Befehls?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.115
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Debian Atari 68K ...
« Antwort #119 am: Do 13.09.2018, 20:10:33 »
In der fstab steht ...

/dev/cdrom    /cdrom   iso9660 defaults,ro,user,noauto

Wenn ich eintippe ...

mount -t iso9660 /dev/cdrom /cdrom
mount: /dev/cdrom is not a valid block device