Autor Thema: ATW 800 Blossom Videoausgang  (Gelesen 5287 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline shock__

  • Benutzer
  • Beiträge: 184
Re: ATW 800 Blossom Videoausgang
« Antwort #80 am: Mo 08.04.2019, 14:02:17 »
In Mode1 den ich aktuell fahre gehen laut Unterlagen 256 Farben gleichzeitig aus einer Palette von 16 Millionen (Auflösung 1024x768) - sprich es sollte möglich sein, das komplette "show colours" Fenster zu füllen (auch wenn dann Farben die das System schon anderweitig nutzt überschrieben werden). Das Bild über VGA ist recht sauber, der Monitor an dem der Rechner bislang hing war nicht so der Bringer.
Wenn ihr euch das Video genauer anguckt, verwirrt mich das Verhalten von dem Programm - ab einem Punkt überschreibt es Farben (würde ich womöglich als hängendes Bit interpretieren), liest aber die alten die schon/noch im Speicher sind. Die Farben die geschrieben werden, werden aus einer Datei mit Klarnamen/Aliasen für Farbwerte aus der X-Bibliothek ausgelesen (<root>/lib/X11/rgb.txt [oder rgb.pag - bin mir da grade nicht sicher]).

EDIT: Video vom (Schiebe) Puzzle mit Mandrill, welches Teils zur Promo verwendet wurde (https://images.pcworld.com/news/graphics/225872-atari_evolution_12_original.jpg) https://www.youtube.com/watch?v=waISm6McAPw
« Letzte Änderung: Mo 08.04.2019, 15:25:59 von shock__ »

Offline shock__

  • Benutzer
  • Beiträge: 184
Re: ATW 800 Blossom Videoausgang
« Antwort #81 am: Di 09.04.2019, 10:17:10 »
Bei Helios 1.31 und der entsprechenden X Version ist ein lowlevel tool "harness" dabei welches auch unter meiner Installation läuft (Helios 1.3 mit der X Version für 1.2). Das Tool arbeitet scheinbar an X vorbei, verwendet aber den unter newXrc angegebenen Treiber. Damit hab ich grade verifizieren können, dass die Hardware scheinbar kein Problem hat.

https://i.imgur.com/CayjGfe.jpg
Sieht ordentlich kaputt aus, ist aber gut so (Video wollte ich jetzt keins machen) ... harness macht erstmal ein Testbild mit vertikalen Balken und setzt dabei die komplette CLUT (Color Lookup Table). Lass ich dann showcols drüber laufen hab ich wieder das übliche Muster (statt 0-255 zu setzen passiert dann folgendes Prozedere: 0-63, überschreiben von 0-63, 128-191, überschreiben von 128-191, Werte 64-127 und 192-255 werden jeweils übersprungen)
Ich vermute dann mal recht stark, dass irgendwas mit X nicht so ganz stimmt.

EDIT: xdpyinfo output -> https://pastebin.com/zhiN9fmZ
harness output -> https://pastebin.com/AyjbQJsT
Wirkt auf mich jetzt erstmal stimmig? X läuft nach xrdb im Pseudocolor Modus.
« Letzte Änderung: Di 09.04.2019, 13:06:11 von shock__ »

Offline Arthur

  • Benutzer
  • Beiträge: 8.841
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: ATW 800 Blossom Videoausgang
« Antwort #82 am: Di 09.04.2019, 16:21:43 »
Wenn mann das Bild am Monitor betrachtet... hat der Monitor das automatisch gestreckt oder konntest du das Timing genau anpassen?

« Letzte Änderung: Di 09.04.2019, 17:19:37 von Arthur »

Offline shock__

  • Benutzer
  • Beiträge: 184
Re: ATW 800 Blossom Videoausgang
« Antwort #83 am: Di 09.04.2019, 17:30:07 »
Das war die Glotze von alleine. Timing kannste auch sicherlich über die newXrc anpassen, aber da geh ich nicht ran sofern ich das nicht muss - läuft ja aktuell auch so ohne Probleme in allen 3 Modi.

Offline shock__

  • Benutzer
  • Beiträge: 184
Re: ATW 800 Blossom Videoausgang
« Antwort #84 am: Mi 10.04.2019, 12:53:37 »
Ich glaub der Port ist verbuggt, liefert aber seinen eigenen ganz heißen Hotpatch.
https://i.imgur.com/i3NhLh2.jpg

Video vom Bug + Hotfix: https://youtu.be/WIwuuDOhUGQ
« Letzte Änderung: Mi 10.04.2019, 13:58:16 von shock__ »

Offline shock__

  • Benutzer
  • Beiträge: 184
Re: ATW 800 Blossom Videoausgang
« Antwort #85 am: Do 11.04.2019, 08:48:23 »
Gibt's denn irgendwas (an Software?) wozu ihr euch Videos/Fotos/Texte wünschen würdet? Nach meinem Verständnis ist der Rechner jetzt erstmal fertig, bis die Farmcard kommt.
Leider hab ich im Netz nicht wirklich viel interessante Software gefunden und die X11 Demos sind zwar ganz Nett für die Blossom-Karte, haben aber jetzt erstmal eher weniger mit der Architektur zu tun und dürften ihren Overhead mitbringen. Auf Youtube gibts ein Video von 1997 welches an der FH Hamburg entstanden ist, wo man einen Fahrsimulator auf dem ATW800 laufen sieht - allerdings sind die Quelltexte/Binaries leider verschollen. Video hier: https://www.youtube.com/watch?v=yFyW5BIvXjc&feature=youtu.be&t=161

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: ATW 800 Blossom Videoausgang
« Antwort #86 am: Do 11.04.2019, 11:33:08 »
Versuche doch mal raus zu bekommen, ob mit der ATW irgendwelche Diplomarbeiten angefertigt wurden (Wiesbaden, Braunscheig, und neu für mich Hamburg). Dann kannst du versuchen, diese Leute ausfindig zu machen, vielleicht existiert bei denen ja die Software noch. Einen ehem. Diplomanden der FH-Wiesbaden, der auf der ATW was gemacht hat, hab ich vor 7 Jahren zufällig kennen gelernt, der war bei mir in der Firma, wir sind aber beide nicht mehr in dieser Firma, ich habe leider keinen Kontakt und weiß nicht mal mehr, wie der heißt.

Aufgrund der geringen Verbreitung der ATW dürfte es dafür sehr wenig Software geben. Da ist wohl eher selber programmieren/portieren angesagt. Auch im Bereich Amiga-Transputer-Helios solltest du mal stöbern, vielleicht ist Software dafür auftreibbar und lauffähig?
« Letzte Änderung: Do 11.04.2019, 13:51:57 von 1ST1 »
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline Arthur

  • Benutzer
  • Beiträge: 8.841
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: ATW 800 Blossom Videoausgang
« Antwort #87 am: Do 11.04.2019, 13:15:53 »
Gibt's denn irgendwas (an Software?) wozu ihr euch Videos/Fotos/Texte wünschen würdet?

Ich denke das Software, die die Fähigkeiten des Transputers aufzeigt, natürlich interessant wäre... auch im Bezug auf die Rechenleistung damaliger Systeme. Wenn man das, was dazu veröffentlicht worden ist sieht, ich denke gerade an die Schmetterlinge... dann reißt es einen heut zu Tage nicht vom Hocker. Interessant wäre für mich, wie z.B. ein Linux Programm durch kompilieren auf der ATW dort zu laufen kommt, auch wenns nur eine ultrakleine Mini App ist. Oder generell eine Übersicht der mitgelieferten Programme und Tools.

Offline geekdot

  • Benutzer
  • Beiträge: 36
Re: ATW 800 Blossom Videoausgang
« Antwort #88 am: Do 11.04.2019, 15:58:04 »
Hallo Zusammen!

Ich bin der Neue ;-) Naja, nur hier im Forum... eigentlich von Götz hierher gelockt.
Schön, daß es hier noch Transputer-Recken und Interessenten gibt!

Ich frickel mit dem Thema ja nun so ca. 10 Jahre rum. Da kommt so einiges Zusammen:
http://www.geekdot.com/hardware/transputer/

Auch wenn ich anno-dunnemalstm Erstkontakt mit der ATW auf dem ATARI Stand hatte, keimte die Liebe erst Später... dann aber heftig und nativ, sprich ich halte mich eher an INMOS Standards.
So kam es zu eigenen Transputer-Modulen (TRAMs), die dann ihren Weg in den Apple IIgs oder C64 fanden... und nun in etwas größerem Rudel unterwegs sind. Ach ja, Ich las hier etwas von einem Limit bei 128 T's. Das ist natürlich quatsch... es gibt kein Limit - die Kommunikation wird halt irgendwann recht träge, wenn sie durch 100 T's geroutet wird.

Natürlich ist Helios (NICHT HeliOS!!!!einsElf!!) ein Thema bei mir. Ein Install-Tutorial findet sich hier.
Mit Segen von Tim King habe ich die Sources von 1.3 soweit reanimiert, daß die unter Solaris 8 kompilieren... erhältlich in meiner Git-Repository hier.
Es gibt ein "Projekt" Helios mal in mehreren Schritten in die Gegenwart zu holen. Mehr Zu Helios-NG hier.

Naja, irgendwie hat Götz meine kleine Ecke im Web ausfindig gemacht (vielleicht lag's am exzessiven Mac 68k gehacke)... und er fragte mich nach einer Farm-Card... "nichts leichter als das, sagte Frederik, komm mit!"  ;D
Nur: Isch 'abe gaa keine ATW... aber nach dem Manual, welches ich besitze, sollte das eine leichte Übung sein... und dann aber "in richtig" - also nicht á la Perihelion die T's auf die Platine sondern als TRAM carrier! So kann der geneigte ATW Besitzer (alle 5?  :P) wählen, was da werkeln soll - und die Auswahl ist immens!

Langer Rede kurzer Sinn: Schön hier zu sein! Mal sehen, was wir rocken können...

VG Axel

P.S: Irgendjemand eine ATW abzugeben?  :P

Offline shock__

  • Benutzer
  • Beiträge: 184
Re: ATW 800 Blossom Videoausgang
« Antwort #89 am: Do 11.04.2019, 20:32:59 »
Hi Axel,
cool, dass du jetzt auch hier bist :) Hatte dich zuletzt kurz im IRC gesehen und wollte schon "ah, die Transputer-Prominenz ist angekommen" schreiben, aber da warst du schon wieder weg ;)
Helios-NG hatte ich mir zu Anfang kurz angeguckt in der Hoffnung, dass der mitgelieferte ST-SCSI Treiber nicht diese doofe 16MB Beschränkung bei der IO-Partition hat ... allerdings scheint die dort auch vorhanden zu sein und inzwischen bin ich mittels HeliosFS ja auch zum Ziel gekommen.

Offline geekdot

  • Benutzer
  • Beiträge: 36
Re: ATW 800 Blossom Videoausgang
« Antwort #90 am: Fr 12.04.2019, 11:09:53 »

cool, dass du jetzt auch hier bist :) Hatte dich zuletzt kurz im IRC gesehen und wollte schon "ah, die Transputer-Prominenz ist angekommen" schreiben, aber da warst du schon wieder weg ;)

Ja, ich bin wie ein Geist... ein verwirrter Geist. Mit Projekt-ADHS  :D
Naja, war nur ein Test und ich ja auch eher Freund der asynchronen Kommunikation  ;D

Hast Du denn schon etwas angefangen bzgl. "Farmcard reloaded"?

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: ATW 800 Blossom Videoausgang
« Antwort #91 am: Fr 12.04.2019, 12:11:18 »
[Edit/Johannes: Off-Topic entfernt]
« Letzte Änderung: Fr 12.04.2019, 17:28:16 von Johannes »
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline shock__

  • Benutzer
  • Beiträge: 184
Re: ATW 800 Blossom Videoausgang
« Antwort #92 am: Fr 12.04.2019, 13:25:55 »
Nicht wirklich ... ich hab ja noch keine Karte hier und mein eigentliches Projekt befindet sich grade kurz vor der Produktionsphase ... kann also 3-4 Monate dauern bis ich erste Ergebnisse vorzeigen kann.
Aber ... wie würdest du ein Reverse Engineering der GALs angehen? Damit hab ich mich bislang noch nicht befassen müssen und bin dort entsprechend ahnungslos (weiss aber, dass sowas geht und kenn 1-2 Wege wie man ans Ziel kommen kann).

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: ATW 800 Blossom Videoausgang
« Antwort #93 am: Fr 12.04.2019, 14:10:42 »
GAL reverse-Engeneering:

Wenn der Leseschutz nicht aktiviert ist, lassen die sich auslesen. Damit könnte man bei Prototypen Glück haben. Die ATW ist ein Prototyp in ca. 250 Exemplaren.

Wenn der Leseschutz aktiv ist, dann musst du die Schaltung drumherum analysieren, um erstmal rauszubekommen, was an dem GAL als Ein und Ausgang definiert ist. Dann hilft möglicherweise, die Eingänge systematisch High/Low zu setzen und zu sehen, was an den Ausgängen rauskommt. Das klappt aber nicht, oder nur mit größerer Mühe, wenn in den GALs "Automaten" (Schaltungen, deren Ausgangsstatus wieder den Eingang beeinflussen) oder Flipflops o.ä. umgesetzt sind.

Hier ein bischen Lesestoff zu Automaten zum Einstieg, komplexes Thema, auch CPUs sind solche Automaten:
- http://www.mathematik.uni-marburg.de/~thormae/lectures/ti1/ti_7_4_ger_web.html#1
- https://de.wikipedia.org/wiki/Moore-Automat
- https://de.wikipedia.org/wiki/Mealy-Automat
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline Arthur

  • Benutzer
  • Beiträge: 8.841
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: ATW 800 Blossom Videoausgang
« Antwort #94 am: Fr 12.04.2019, 14:32:04 »
GAL reverse-Engeneering:

Wenn der Leseschutz nicht aktiviert ist, lassen die sich auslesen. Damit könnte man bei Prototypen Glück haben. Die ATW ist ein Prototyp in ca. 250 Exemplaren.

Wenn wir deine Tipps nicht hätten.

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: ATW 800 Blossom Videoausgang
« Antwort #95 am: Fr 12.04.2019, 14:35:16 »
Ich weiß, der Fall ist trivial. Aber ohne das wäre die Antwort unvollständig.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline geekdot

  • Benutzer
  • Beiträge: 36
Re: ATW 800 Blossom Videoausgang
« Antwort #96 am: Fr 12.04.2019, 16:17:41 »
Wenn wir deine Tipps nicht hätten.

 :D
Yup, ich hätte es kurz gefasst so vorgeschlagen:
... sonst LA dran und neu/besser machen  ;)

@shock__ : Ich mache gleich mal einen neuen Fred zum Thema "FarmCard reloaded" auf. Das Blossom Ding ist ja quasi durch, oder?

Offline shock__

  • Benutzer
  • Beiträge: 184
Re: ATW 800 Blossom Videoausgang
« Antwort #97 am: Fr 12.04.2019, 17:13:59 »
Wenn wir deine Tipps nicht hätten.

 :D
Yup, ich hätte es kurz gefasst so vorgeschlagen:
... sonst LA dran und neu/besser machen  ;)

@shock__ : Ich mache gleich mal einen neuen Fred zum Thema "FarmCard reloaded" auf. Das Blossom Ding ist ja quasi durch, oder?
Jo, mach mal :)

Offline Johannes

  • Administrator
  • *****
  • Beiträge: 1.765
  • ATARI-HOME.DE - online for more than 15 years...
Re: ATW 800 Blossom Videoausgang
« Antwort #98 am: Fr 12.04.2019, 17:27:44 »
Dann mache ich hier mal zu. @shock__ bitte kurze Nachricht, wenn Du oder andere hier noch etwas hinzufügen möchten.
Falcon060 /w SV - TT030 - Mega STE4 - Mega ST4 - Mega ST2 - 1040 ST(F/M) - Lynx II - Portfolio
non-Atari: SUN Ultra 1, SGI Indigo 2, Casio PB-1000