Autor Thema: Wasserschaden am 1040 STFM und externer Floppy  (Gelesen 1618 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Compu-User

  • Benutzer
  • Beiträge: 131
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #40 am: Di 19.04.2022, 22:25:43 »
Zuerst war der SM124  und dann ein TFT über Kabeladapter angeschlossen. Bei keinen der beiden Monitore war irgend ein Bild oder Flimmern sichtbar. Ich würde vermuten, dass nichts an den Monitor gesendet wird. Es ist zwar schon einige Monate (im Juni wird es ein Jahr) her, das der ST in Betrieb war, aber nach dem Einschalten gab is immer eine Reaktion auf dem Monitor. Wenn es auch nur die Grundhelligkeit war.

Offline czietz

  • Benutzer
  • Beiträge: 3.024
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #41 am: Di 19.04.2022, 22:32:59 »
Gar kein Bild, auch nicht mit einem Farbmonitor, könnte in der Tat auf einen komplett fehlenden 32-MHz-Takt oder ein Problem mit dem Shifter hindeuten. Der Shifter ist unter der "Blechdose" und meist auch gesockelt. Hattest Du diesen Sockel auch kontrolliert? (Wimre hattest Du keine Fotos bei geöffneter Blechdose gepostet.)

Andere Möglichkeit: Kontaktproblem am der Monitorbuchse.

Offline Compu-User

  • Benutzer
  • Beiträge: 131
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #42 am: Di 19.04.2022, 23:07:03 »
Das habe ich auch schon vermutet. Hatte über einen direkten Anschluss nachgedacht, weil ich keine neue oder andere Buchse habe. Ein Reinigungsversuch wird schwierig werden.
Da du das auch vermutest, sollte ich das mal probieren. Wenn ich noch eine Buchse für VGA- Anschluss habe, könnte ich die mit kurzen Kabeln zum testen anlöten. Was meist du? Könnte das funktionieren?
Dafür muß ich erst mal die Belegung suchen, oder am bestehenden Adapterkabel nachschauen.

Offline czietz

  • Benutzer
  • Beiträge: 3.024
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #43 am: Mi 20.04.2022, 07:52:35 »
Den Shifter und das sonstige Innenleben der Metalldose hattest Du aber bereits kontrolliert?

Offline Compu-User

  • Benutzer
  • Beiträge: 131
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #44 am: Mi 20.04.2022, 11:44:36 »
Kontrolliert ist ein großer Begriff.
In dem Fall, Reinigung und optische Kontrolle wurde durchgeführt.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.622
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #45 am: Mi 20.04.2022, 13:54:24 »
Wenn ein Multimeter da ist mal schauen ob der CPU Pin18 (Reset) High ist also 5 Volt hat, ebenso wie der CPU Pin17 (Halt). Der Pin Reset muss auch reagieren wenn man die Reset Taste drückt, geht dann auf Low also auf 0 Volt und geht nach loslassen der Reset Taste wieder auf High ...

Offline czietz

  • Benutzer
  • Beiträge: 3.024
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #46 am: Mi 20.04.2022, 17:42:05 »
Wenn keine bessere Möglichkeit vorhanden ist, den Takt zu prüfen (Oszilloskop, Multimeter mit Frequenzzähler, Kurzwellenradio...), so kann man sich zumindest zunutze machen, dass ein Multimeter in der Einstellung DC-Spannung grob den Mittelwert schnell veränderlicher Signale anzeigt. Am Takteingang der CPU (Pin 15) sollte das Multimeter also ca. 2,5 V "Gleichspannung" anzeigen. Zeigt es hingegen 0 V oder 5 V, fehlt der Takt vermutlich. In diesem Fall braucht man langsam aber wirklich ein Oszilloskop. Die Takterzeugung ist je nach genauem Modell mehr oder weniger komplex und spielt sich in der "Blechdose" (Shifter-Chip + Außenbeschaltung) und im MMU-Chip ab.
« Letzte Änderung: Mi 20.04.2022, 17:42:57 von czietz »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.622
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #47 am: Mi 20.04.2022, 18:05:45 »
... je nach Multimeter sind beim Clock ca. 2V DC auch in Ordnung.

Offline Compu-User

  • Benutzer
  • Beiträge: 131
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #48 am: Mi 20.04.2022, 21:47:05 »
Hallo,
danke für die Infos. Werde das so bald wie möglich überprüfen. Den Shifter mach ich auch noch mal raus. Eventuell habe ich doch etwas übersehen.

Betreffs Oszilloskop, habe natürlich vor, mir wieder eins zuzulegen. Was verwendet ihr so? Ich muss einen für mich vertretbaren Kompromiss zwischen Preis und Leistung finden. Entsprechen auch einen neuen Funktionsgenerator.
Wenn ich da so auf die im Markt verfügbaren Geräte schaue, bin ich mit der Auswahl "überfordert". Ich bin mir nicht sicher, ob die Geräte im Niedrigpreissegment für meine "Hobbyanforderungen" ausreichend sind.

Offline Ektus

  • Benutzer
  • Beiträge: 885
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #49 am: Do 21.04.2022, 08:28:56 »
Ich habe seit einem Jahr das da: https://joy-it.net/de/products/JT-DMSO2D72

Das Ding kann Multimeter, 70MHz Oszilloskop und Funktionsgenerator.

Für Hobby-Zwecke mehr als ausreichend und das chinesische Original dazu (Hantek?) ist auch noch billiger zu bekommen. Da aber aufpassen, es gibt auch Varianten ohne PC-Schnittstelle und Funktionsgenerator.

Ich habe es allerdings bisher nur als Multimeter genutzt und den Funktionsgenerator zum Abgleich des mitgelieferten Tastkopfs...
« Letzte Änderung: Do 21.04.2022, 08:33:26 von Ektus »

Offline czietz

  • Benutzer
  • Beiträge: 3.024
Oszilloskop (war: Wasserschaden am 1040 STFM und externer Floppy)
« Antwort #50 am: Do 21.04.2022, 12:36:04 »
Ich habe ein Rigol DS1054Z, weil mir vier Kanäle sehr wichtig sind. Es ist bereits mein zweites Scope von Rigol; man sieht also, ich bin zufrieden mit deren Geräten. (Letzteres ist zu einem gewissen Grad natürlich subjektiv. Jemand anderes hier im Forum würde z.B. abseits von LeCroy nichts anfassen ;).)

Definitiv abraten würde ich von diesen portablen Geräten (mit 2,4"-Bildschirm), die unter verschiedenen Namen für unter 50 € bei eBay, AliExpress u.dgl. angeboten werden. Ich hatte einmal versucht, jemandem, der so ein Gerät hat, bei der Rechnerreparatur zu assistieren. Dabei ist herausgekommen, dass dieses "Scope" sogar mit Signalen im 100-kHz-Bereich bereits arge Probleme hat. => Bestenfalls für Audio-Anwendungen geeignet.

Hier testet Adrian Black ein Scope, das verdächtig wie das Modell von Ektus aussieht, darauf, ob es sich zur Reparatur alter Rechner eignet: https://www.youtube.com/watch?v=puWXEqVQ4Yk

Offline neualtuser

  • Benutzer
  • Beiträge: 444
  • Habt spass und bleibt Gesund
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #51 am: Do 21.04.2022, 18:59:25 »
moin
Zitat
Ich habe ein Rigol DS1054Z
Ich auch, kann viel mehr wie ich verstehe... Nette Leute im Vertrieb.
@Compu-User
Falls du jemanden hast der alte Hameg Oszis repariert,hab hier noch 3 Stk. mit kleinen defekten. Z.B. 1 Eingang durch. Röhren und Rest o.k.
/TT-VME/ Rhotron Umbau

P.s. Leider gibt es hier einen Phantasielosen User der eine Verwechselung hervorruft.
Nicht Täuschen lassen !

Offline Compu-User

  • Benutzer
  • Beiträge: 131
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #52 am: Do 21.04.2022, 21:16:44 »
Hallo,
danke an euch für die Infos betreffs Oszilloskop.

Ursprünglich hatte ich vor mir wieder ein Desktopgerät zuzulegen.
Als ich mir das "VDMSO2D72" auf der Webseite des Herstellers betrachtet habe, war ich erst mal erschrocken, weil es ein mobiles und Akku betriebenes Gerät ist. Das war bei mir bis heute quasi fast tabu. Anderseits wurde ich neugierig. Wenn es  erfolgreich von einem Computerbastler eingesetzt wird, vermutlich an ATARI-Technik, wird es seinen Zweck erfüllen.
Preislich liegt es bei preisgünstigen Desktopgeräten. Sehr hilfreich war das Video, bei dem ich mir die Frage gestellt habe, was will ich eigentlich damit machen. Es kommt eher selten bis gar nicht vor, dass sehr genaue Messungen durchgeführt werden müssen. Meistens geht es schlicht und einfach um die Kontrolle von Flanken, suchen von Störimpulsen, messen von Pegeln usw. bei denen es nicht extrem um Genauigkeit geht.
Bedenken habe ich wegen dem kleinem Display. Im Allgemeinen würde ich vermuten, das dieses Gerät für die Arbeit am ST und ähnlichen Systeme geeignet sein kann.
Ideal wäre es, wenn jemand von euch mit dem Gerät schon an der Takterzeugung bzw. Taktkontrolle/Verfolgung des ST gearbeitet hat. Da könnte eine realistische Aussage getroffen werden.

Für mich ist, abgesehen von der daraus resultierenden Größe des Displays, die Baugröße von Vorteil, da ich wenig Platz habe. Der Funktionsgenerator ist auch mit eingebaut. Quasi ein Gerät weniger, welches Stellfläche braucht.

@czietz: Wie würdest du das sehen? Klar ist, es kommt nicht an die Leistung, Komfort und Bedienbarkeit eines Desktopgerätes ran und auf dem kleinen Monitor könnte es ein "gefriepsel" werden.

@neualteruser: Ich habe keinen der Hameg Oszis repariert. Diese Leute sind dünn gesäht (soweit ich das überschauen kann) und es werden immer weniger. Dann ist noch das Problem mit dem Platz für ein solches Gerät. Trotz dem danke für das Angebot. Wenn sich da bei mir etwas zum Positiven ändert, würde ich darauf zurückkommen.

Offline czietz

  • Benutzer
  • Beiträge: 3.024
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #53 am: Do 21.04.2022, 22:46:44 »
Ich kann zu diesem Handheld-Scope keine fundierte Meinung abgeben; einfach weil ich es nie in der Hand gehalten habe. Allerdings mag ich bei einem Scope viele Knöpfe und Drehregler. Wenn man sich erst mit Cursortasten durch Menüs tippen müsste, würde mich das stören.

Offline Compu-User

  • Benutzer
  • Beiträge: 131
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #54 am: Mo 25.04.2022, 00:37:38 »
Hallo, konnte am Wochenende den Shifter noch mal rausmachen. Habe zuvor die "Blechdose" ausgelötet. Diese Bereiche noch mal gereinigt und optisch kontrolliert. Nach dem Trocknen wieder zusammengesteckt und getestet.
Leider keine Verbesserung.

Folgende Werte konnten bei den Messungen ermittelt werden:

CPU-Pin     Zustand                          Messwert

15               ----                                         0,8 V
17               Reset nicht gedrückt        4,75 V
17               Reset gedrückt                  0 V
18               Reset nicht gedrückt        4,75 V
18               Reset gedrückt                  0 V

Wie es aussieht, ist der Pegel des Systemtaktes vermutlich im verbotenen Bereich. Wenn eine Frequenz anliegt, ist diese noch unbekannt. Da sollten eigentlich 8 oder 7,09 MHz anliegen oder ? Habe jetzt auf die schnelle nichts dazu gefunden.

Offline czietz

  • Benutzer
  • Beiträge: 3.024
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #55 am: Mo 25.04.2022, 08:11:09 »
Die Pegel an /RESET (18) und /HALT (17) zeigen das erwartete, korrekte Verhalten.

Takt: Von einer Oszillatorschaltung rund um den Shifter werden 32 MHz erzeugt. (Genauer: ca. 32,085 MHz in einem PAL-System.) Der Shifter teilt den Takt auf 16 MHz, die MMU weiter auf 8 MHz. Letzteres ist der Prozessortakt an Pin 15.

Offline Compu-User

  • Benutzer
  • Beiträge: 131
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #56 am: Mo 25.04.2022, 09:11:28 »
(Anbei noch zwei Bilder vom Bereich "Shifter".)
Die Bilder konnten nicht hochgeladen werden.
Folgende Meldung wurde angezeigt:
"
Your attachment has failed security checks and cannot be uploaded. Please consult the forum administrator.
"
Wie ist das zu verstehen? Sicherheitsprüfung auf Malware, Kopierrechte ...?


Im Bereich "Shifter" auf dem Mainbord ist ein 32 MHz Quarz. Den hatte ich im Schaltplan erst nicht gefunden. Der Zweite ist nicht bestückt. Nach einigem hin- und her-Scrollen wurde der Bereich zur Takterzeugung im Schaltplan erkennbar.

Liegen die 32 und 16 MHz am Shifter bzw. allgemein mit 5V-Pegel an? (Frage ist nur zur Sicherheit)

Shifter
Pin   2 -> 32 MHz
Pin 39 -> 16 MHz

MMU
Pin   5 -> 16 MHz
Pin 20 ->   8 MHz
Pin   8 ->   4 MHz

Ist das so richtig? Der Schaltplan ist etwas unscharf. Gibt es diese Schaltpläne in einer besseren Qualität?
Sind Messpunkte auf dem Mainboard gekennzeichnet? Sieht erst mal nicht so aus.

(edit: Versuch Bilder hinzufügen)
« Letzte Änderung: Mo 25.04.2022, 20:24:03 von Compu-User »

Offline czietz

  • Benutzer
  • Beiträge: 3.024
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #57 am: Mo 25.04.2022, 09:52:54 »
Security-Checks: Ist ein Bug in der Foren-SW und liegt an EXIF-Daten im Foto. Siehe hier: https://forum.atari-home.de/index.php/topic,15069.msg238200.html#msg238200. Immer noch ein offener Punkt auf der Agenda unseres Admins @yalsi, nehme ich an.

Taktsignale: Ja, sie haben 5-V-Pegel; wobei das 32-MHz-Signal recht "rundgeschliffen" ist. Beachte aber, dass die Messung des "DC"-Werts mit Multimeter nur ein Notbehelf ist. Besser wäre es mit Frequenzmesser, Scope, o.ä.

"Der" Schaltplan / Pinbelegungen: Es gibt nicht "den" Schaltplan. Auf https://docs.dev-docs.org/ sind knapp ein Dutzend Schaltpläne, für unterschiedlichen Mainboard-Revisionen. Zumindest was die Pinbelegung an ICs angeht, die ändert sich nicht, Du kannst Dir also den lesbarsten Plan nehmen, z.B. diesen hier eines 520ST (ohne Floppy!): https://docs.dev-docs.org/htm/search.php?find=520ST+Schematic+%28Rev+M%29

Extra Messpunkte: Gibt's nicht. "Power without the price."  ;D
« Letzte Änderung: Mo 25.04.2022, 09:53:43 von czietz »

Offline Arthur

  • Benutzer
  • Beiträge: 9.863
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #58 am: Mo 25.04.2022, 14:51:20 »
(Anbei noch zwei Bilder vom Bereich "Shifter".)
Die Bilder konnten nicht hochgeladen werden.
Folgende Meldung wurde angezeigt:
"
Your attachment has failed security checks and cannot be uploaded. Please consult the forum administrator.
"
Wie ist das zu verstehen? Sicherheitsprüfung auf Malware, Kopierrechte ...?

Verwende die selbe Prozedur mit der du die ersten Fotos hochgeladen hast... inklusive der entsprechenden Arbeitsschritte für Dateigröße etc.

Offline Compu-User

  • Benutzer
  • Beiträge: 131
Re: Wasserschaden am 1040 STFM und externer Floppy
« Antwort #59 am: Mo 25.04.2022, 22:13:54 »
Die Bilder zum Beitrag von 09:11 Uhr sind hochgeladen. EXIF-Daten wurden entfernt, Dateigröße noch etwas verkleinert. Eigentlich habe ich die selbe Vorbereitung wie bei den vorherigen Bildern gemacht. Dateigröße war fast gleich. Dann lag es an den EXIF-Daten. Eventuell gab es zwischendurch ein Update für "Gimp", welches ich so nicht mitbekommen habe. Wie dem auch sei, wieder etwas dazu gelernt. Hoffentlich vergesse ich es nicht so schnell.

Mit dem Mainboard bin ich weiter gekommen. Was soll ich sagen. Mein Atari 1040 STFM läuft wieder.  :)
Bin schrittweise die Taktung durchgegangen und habe Störquellen beseitigt oder verringert. Bauteile waren glücklicher Weise nicht defekt. Das Oszilloskop war da sehr hilfreich. Für solche Arbeiten wirklich sehr zu empfehlen.

Wurden das befestigen von Kabel mit Heißleim original von ATARI so angewendet? Die alten EPROM's sahen auch schon sehr verdächtig nach "Eingriffen" aus. Das Gerät habe ich 1990 oder 1991 gebraucht, privat gekauft. Habe vermutlich nie einen originalen ST von innen gesehen.

Floppy - Emu funktioniert auch. Als nächstes das "Gigafile" und Maus anschliessen.
Wenn das auch geht, geht es weiter mit den externen Floppy's .
Betreffs Floppy habe bestimmt noch viele Fragen.
Jetzt bin ich erst mal froh, dass der ST wieder läuft. :)

Im Anhang noch einige Bilder.
Wellenformen: 32, 16 und 8 MHz
Die 32 MHz sind der Hammer. Ist fast Sinus! (jedenfalls bei dem Oszi)

Als Oszi wurde der DSMS02D72 verwendet. Wir haben darüber kurz "geschrieben". Danke für die Infos.
Mit der Bedienung des Gerätes muss ich mich noch beschäftigen. Entschuldigt bitte diese qualitativ schlechten Fotos. Habe es direkt vom Display fotografiert. 2x auch die gespeicherte Ansicht. Irgendwie soll das auch direkt über PC gehen. So weit bin ich mit dem Gerät noch nicht.

@czietz: Mir fehlen da auch die vielen Knöpfe, Druckschalter, Taster und Regler. Quasi kann ich das jetzt praktisch nachvollziehen. Wird noch einige Zeit brauchen, bis ich im Umgang mit den Menüs schnell und sicher bin.