Autor Thema: Neuzugang eingetroffen. ST/MSTE/FALCON  (Gelesen 3726 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline czietz

  • Benutzer
  • Beiträge: 2.412
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #60 am: Di 28.05.2019, 15:11:05 »
Evtl. ein neuen Thread im 8-Bit-Forum öffnen? Ich kenne mich mit diesen Laufwerken (oder jeglicher 8-Bit-Peripherie) nicht aus.

Aber: Mit welcher Abtastrate läuft Dein Scope, wenn Du glaubst 50 kHz zu sehen? Evtl. bist Du Aliasing auf den Leim gegangen -- ein "beliebter" Fehler bei DSOs.

Offline Arthur

  • Benutzer
  • Beiträge: 9.000
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #61 am: Di 28.05.2019, 16:08:35 »
Bei digitalen Oszilloskopen werden sehr häufig auch sehr optimistische obere Frequenzen angegeben. :D

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #62 am: Di 28.05.2019, 16:13:21 »
200 kHz ist bei einem Digital-Oszilloskop nicht wirklich viel. Das ist nicht die Grenzfequenz eines Signals, die so ein Oszi messen und darstellen kann, sondern die Abtastrate. Um eine Periode einer Wellenform wenigstens einigermaßen abzubilden, braucht man in der Periode mal mindestens 4-8 Abtastpunkte, das heißt effektiv kann dieses Oszi Wellenformen mit maximal 50, wenn nicht gar nur 25 kHz einigermaßen akurat darstellen - für Audiosignale geeignet. Mit Anzahl Bits (Roh-Bits in MFM oder GCR-Kodierung!) pro Spur (soundso viele Sektoren, Sektorvorspann, Prüfsumme am Sekotorende, Lücken/Füllbytes, Syncbytes...) und Drehgeschwindigkeit der Diskette kann man dann mal die grobe Richtung ausrechnen, was ein Oszi können muss, damit  man zuverlässig die Kopfdaten sehen kann.
Ausgeloggter Mitleser, der hier NIE mehr aktiv wird. Am besten, meine Inhalte komplett löschen. Dabei berufe ich mich auf mein Urheberrecht, die DSGVO und auf die Rechte, die mir unter Impressunm&Datenschutz zugestanden werden. Tschö!

Offline Arthur

  • Benutzer
  • Beiträge: 9.000
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #63 am: Di 28.05.2019, 18:53:58 »
Bei 1M Sample kommt das mit 200KHz doch einigermaßen hin... ist aber trotzdem schnarchlahm.

Offline X-Ray

  • Benutzer
  • Beiträge: 224
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #64 am: Do 30.05.2019, 22:26:25 »
Habe mich heute noch einmal mit dem Falcon Soundproblem auseinander gesetzt, mein kleines Oszilloskop war für diese Zwecke zu gebrauchen.
Habe den Schaltplan studiert, bin die Wege der Sounds nachgegangen und konnte diese mit dem kleinen Teil auch anzeigen lassen. Soweit, so gut.
Hängengeblieben bin ich dann am Codec Chip.
Dort untersuchte ich folgende PINs:
26 - RIN2 = Rechter Eingang vom PSG-Signal (AUDIOS)
28 - LIN2 = Linker Eingang vom PSG-Signal (AUDIOS)
15- ROUT = Rechter Audio Ausgang
16 -LOUT = Linker Audio Ausgang
Im angehängten Bild habe ich die untersuchten Wege farblich markiert.

Dabei stellte ich fest, dass gravierende Unterschiede zu meinem funktionierenden Falcon bestehen.
Als Test habe ich beide Falcon "nackt" gebootet und nur das XCONTROLL.ACC geladen.
Um gleiche Bedingungen im Sound zu erhalten, habe ich auf beiden noch das SNDRESET.PRG ausgeführt.
Das kam bei heraus:

PIN / Volt am funktionierenden Falcon
26 - 1.90V
28 - 1.90V
15 - 2.29V
16 - 2.29V

PIN / Volt am Problem Falcon
26 - 0.95V
28 - 1.90V
15 - 0.91V
16 - 1.96V

Wie man erkennt, liegen am Eingang und Ausgang des rechten Kanals weniger Spannung als links.
Ohne vorher SNDRESET zu starten, sieht das noch ganz anders aus.
Merkwürdig ist aber, dass der Sound eigentlich i.O. ist, zumindest bis zum nächsten Neustart.
Wenn ich im Soundpanel die Balance oder die Verstärkung je Kanal ändere, verändern sich auch die Voltzahlen.
Am rechten Kanal steigt der Wert an PIN 15 für zwei Stufen und fällt dann ab der dritten ab und es geht in ein Rauschen über.
Also SNDRESET hilft zwar, aber der Verstärker schmiert dennoch ab.

Habe mir die Bauteile bei AUDIOS angeschaut und verglichen. Soweit alles gut.
C133 und C139 liefern leicht unterschiedliche Werte, ich weiß aber nicht ob das daran liegt, weil ich diese im eingebauten Zustand gemessen habe.
Diese konnte ich auch noch nicht mit dem anderen Gerät vergleichen, ist alles auf der Unterseite der Platine.

Es dürfte auch nicht am PSG-Sound liegen, denn auch ohne laufenden Sound ist die Spannung an PIN 15/16 schon unterschiedlich.

Wo suche ich jetzt weiter?


« Letzte Änderung: Fr 31.05.2019, 08:16:47 von X-Ray »

Offline Arthur

  • Benutzer
  • Beiträge: 9.000
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #65 am: Fr 31.05.2019, 02:13:57 »
Habe mir die Bauteile bei AUDIOS angeschaut und verglichen. Soweit alles gut.
C133 und C139 liefern leicht unterschiedliche Werte, ich weiß aber nicht ob das daran liegt, weil ich diese im eingebauten Zustand gemessen habe.
Diese konnte ich auch noch nicht mit dem anderen Gerät vergleichen, ist alles auf der Unterseite der Platine.

Es dürfte auch nicht am PSG-Sound liegen, denn auch ohne laufenden Sound ist die Spannung an PIN 15/16 schon unterschiedlich.

Wo suche ich jetzt weiter?

Die Kondensatoren würde ich trotzdem mal gegeneinander tauschen bevor ich den Codec näher unter die Lupe nehmen würde.

Offline X-Ray

  • Benutzer
  • Beiträge: 224
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #66 am: Fr 31.05.2019, 21:18:09 »
Kondensatoren gegeneinander tauschen hatte ich mir eigentlich für heute vorgenommen, dann kam mir aber noch eine andere Idee.
Ich habe den Codec aus seinen Sockel genommen und den Vogel ohne ihn gestartet.
Dann die Spannung an den PINS gemessen:
15 - 1.50V
16 - 1.50V
26 - 0V
28 - 0V
Drücke ich eine Taste, so kommen an 26/28 je 0.12V an.
Die gleichen Werte liegen auch direkt nach dem Widerstand R155 an, also noch vor den beiden Kondensatoren.

Das sieht doch ganz danach aus, als wenn der Codec-Chip hier die falschen Spannungen erzeugt und somit mein Sorgenkind zu sein scheint. Leider hat mein anderer Falcon einen verlöteten Codec.
Ich mache gleich mal einen Suche-Beitrag auf, vielleicht hat ja jemand einen Chip übrig.

Offline Arthur

  • Benutzer
  • Beiträge: 9.000
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #67 am: Fr 31.05.2019, 21:52:20 »
Ich mache gleich mal einen Suche-Beitrag auf, vielleicht hat ja jemand einen Chip übrig.

Die sind normalerweise immer verlötet. Welche Revision hat denn dein Bord?

Offline X-Ray

  • Benutzer
  • Beiträge: 224
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #68 am: Fr 31.05.2019, 22:15:32 »
Rev. A, Produktionsnummer 611 wenn ich das richtig abgelesen habe. Wohl eines der ersten.

Habe noch etwas entdeckt.
An PIN 18/19/20 liegt keine Spannung an. Bei meinem anderen Falcon habe ich dort 2.29V gemessen.
18/19 sind mit 20 über zwei Kondensatoren verbunden, ich kann im ausgeschalteten Zustand einen Widerstand von 1k messen. Beim Problem-Falcon ist da nichts!
[Korrektur: An Pin 20 liegen 1.94V an, nur nicht an 18/19]
Ich verstehe den Sinn hinter dieser Verbindung leider noch nicht.

« Letzte Änderung: Fr 31.05.2019, 23:00:16 von X-Ray »

Offline X-Ray

  • Benutzer
  • Beiträge: 224
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #69 am: Fr 31.05.2019, 22:42:33 »
Habe das Board wieder ausgebaut und mir die Rückseite angeschaut.
C125/C126 sind auch bei der Revision A vorhanden und ich kann bei beiden keinen Widerstand messen.
Ich weiß, das sind Kondensatoren und mit dem Durchgangsprüfer kann man den wahren Wert nicht wirklich messen, aber im Gegensatz zum anderen Falcon wird mir hier gar nichts angezeigt.
[Korrektur: An Pin 20 liegen 1.94V an, nur nicht an 18/19]
Sie sollen 680pF haben.

Wer weiß wofür die Schaltung 18/19/20 zuständig ist?
Im Datenblatt zum Codec heißt es "PIN 20: To optional input buffers". Atari hat diesen aber wieder mit dem Chip selbst verbunden.
« Letzte Änderung: Fr 31.05.2019, 23:00:44 von X-Ray »

Offline Arthur

  • Benutzer
  • Beiträge: 9.000
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #70 am: Fr 31.05.2019, 23:04:06 »
Habe das Board wieder ausgebaut und mir die Rückseite angeschaut.
C125/C126 sind auch bei der Revision A vorhanden und ich kann bei beiden keinen Widerstand messen.

Für Gleichstrom geht der Widerstand gegen unendlich, das ist normal.

Offline X-Ray

  • Benutzer
  • Beiträge: 224
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #71 am: Fr 31.05.2019, 23:52:38 »
Na ja, nur frage ich mich dann, warum kann ich zwischen PIN 20 und 18/19 bei einem was messen, bei dem anderen nicht. Auch nicht bei gleichen Bedingungen, also eingebauten Codec.
Die haben doch nicht für Spaß die Spannung von 20 nach 18/19 rüber geführt, die bei dem einen hier ja nicht ankommt.
Irgendwas stimmt doch da nicht.

Übrigens, laut CnC wäre 18/19 gar nicht belegt. Bringt mich jetzt noch mehr durcheinander.
« Letzte Änderung: Fr 31.05.2019, 23:56:33 von X-Ray »

Offline X-Ray

  • Benutzer
  • Beiträge: 224
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #72 am: Sa 01.06.2019, 22:41:03 »
Habe mir heute neue SMD 680pF Kondensatoren geholt und auch schon ausgetauscht.
Leider bleibt alles wie vorher.
PIN 20 gibt zwar die 1.94V raus, aber bei 18/19 kommt nichts an. Dazwischen sind nur die beiden Kondensatoren, sonst nichts, ich verstehe das nun überhaupt nicht mehr.
Selbst wenn der Codec -wie auch immer- kaputt wäre, das muss doch was ankommen.

Offline Arthur

  • Benutzer
  • Beiträge: 9.000
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #73 am: So 02.06.2019, 00:02:02 »
Habe mir heute neue SMD 680pF Kondensatoren geholt und auch schon ausgetauscht.
Leider bleibt alles wie vorher.
PIN 20 gibt zwar die 1.94V raus, aber bei 18/19 kommt nichts an. Dazwischen sind nur die beiden Kondensatoren, sonst nichts, ich verstehe das nun überhaupt nicht mehr.
Selbst wenn der Codec -wie auch immer- kaputt wäre, das muss doch was ankommen.

Als Codec kannst Du entweder den ITT ASCO 2300 (Atari Falcon) oder alternativ auch Crystal CS 4216-KL nehmen.

Offline X-Ray

  • Benutzer
  • Beiträge: 224
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #74 am: So 02.06.2019, 00:43:12 »
Eingebaut ist der Crystal CS 4216-KLEP, als gesockelte Version. Den muss ich erstmal finden.

An RIN1/LIN1 (Microeingang) liegt auch keine Spannung an, obwohl der Eingang funktioniert.
Wenn ich das System einschalte und der Knackser beim Soundinitialisieren ertönt, fällt an ROUT die Spannung um 50% mehr ab als an LOUT.
Stelle ich die Gesamtläutstärke auf 0, haben ROUT/LOUT die gleiche Spannung. Ab Stufe 3 fällt ROUT schneller ab.

Wenn ich keinen Codec finde, gebe ich das Gerät auf.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.232
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #75 am: So 02.06.2019, 08:33:19 »
Bei BEST in den USA gibt es Ersatzteile ->   http://www.best-electronics-ca.com/custom-i.htm

Ich meine 40 Dollar für das Teil.

Offline Arthur

  • Benutzer
  • Beiträge: 9.000
  • Mein Atari erinnert mich an die gute alte Zeit..

Offline X-Ray

  • Benutzer
  • Beiträge: 224
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #77 am: So 02.06.2019, 15:29:51 »
Bei dem für 20€ hatte ich bereits eine Anfrage gestellt. Warte noch auf Antwort.
40$ + Versand wäre mir zu teuer, nachher stellt sich auch noch heraus, der Codec ist gar nicht das Problem.

Momentan ist es so, dass er normalen Sound bringt, sobald das XCONTROL.ACC geladen wurde.
[EDIT: Stelle gerade fest: Ist der Rechner etwas länger aus, klappt das leider auch nicht mehr]
In den Sound Einstellungen ist die Verstärkung für beide Kanäle auf 0 und die Systemlautstärke auf maximal.
Darf nur nicht die Verstärkung hochdrehen, ab Stellung 3 ist der rechte Kanal aus.
Das FSOUND.CPX scheint also auch das Soundsubsystem zu reseten.

Weil ich schon einen Batteriehalter gekauft hatte, habe ich heute wenigstens das NVRAM wieder mit Strom versorgt.
Die alte Batterie hatte noch 0.4V.

 
« Letzte Änderung: So 02.06.2019, 15:41:02 von X-Ray »

Offline TPAU

  • Benutzer
  • Beiträge: 199
  • Atari-Fan der ersten Stunde! ;-)
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #78 am: So 02.06.2019, 20:16:04 »
Was sind denn das neben dem NVRAM bei U65 für "Buchsen"? Steckte da was drauf? :-\

Offline Arthur

  • Benutzer
  • Beiträge: 9.000
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #79 am: So 02.06.2019, 20:23:18 »
Gut gelöst... und auch etwas für die Umwelt getan.