Autor Thema: Programmstarter / TOS 2.06/MultiGEM  (Gelesen 14114 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

virgo660824

  • Gast
Programmstarter / TOS 2.06/MultiGEM
« am: Di 10.05.2011, 17:52:38 »
Hallo zusammen,

kann mir jemand bei der Suche nach einem Programm helfen, was folgendes leistet.
Es soll als ACC oder im Auto-Ordner gestartet werden und dann, nach einer einstellbaren Zeit, weitere Programme starten (also eine Art Programmstarter).
Es soll unter TOS 2.06 und MultiGEM (II) lauffähig sein.

Gibt es so etwas?

Herzlichen Dank und viele Grüße
René

Offline tuxie

  • Benutzer
  • Beiträge: 6.799
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #1 am: Di 10.05.2011, 19:25:13 »
Wie soll man das jetzt verstehen! Als eine Art zeitgesteuerter Prozess? Oder beim Starten des Rechners?
Tschau Ingo

Offline m0n0

  • Benutzer
  • Beiträge: 983
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #2 am: Di 10.05.2011, 19:29:04 »
Hallo, bietet MultiGEM dafür keine möglichkeit? In Magic konnte man sowas wie eine Autoexec.bat verwenden =) Vielleicht gibt es ähnliches auch in MultiGEM?


virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #3 am: Di 10.05.2011, 19:32:15 »
Mist, daß ich nicht mehr progammieren kann.  >:(
Also es könnte ein ACC sein, was über eine Ressourcen-Datei erfährt, wann es nach dem booten (reset) des Rechners ein Programm starten soll (zum nach einem Ablauf einer gewissen Zeit in Sekunden). Und das ACC wird beim Boot-Vorgang automatisch gestartet (steht also entweder in AUTO oder im root).
Sowas sollte es sein.  ;)

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #4 am: Di 10.05.2011, 19:37:47 »
@m0n0: Zu früh auf "antworten" gedrückt   :)
Ich gehe davon aus, daß MultiGEM so etwas anbietet, aber ich bin echt zu dusslig, das Konfig-Programm zu verstehen. Da kann man ne ganze Menge einstellen, aber ich verstehe die ganzen Optionen leider nich. Ich habe mir schon die "Finger wund" gesucht im Netz nach einer Art Anleitung für MultiGEM, aber leider: Nüschd.  :(
Von einer Autoexec habe ich bei MultiGEM auch nichts lesen können.

Danke,
René

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #5 am: So 22.05.2011, 13:22:49 »
Hallo,

das Thema möchte ich noch einmal "auffrischen" und auch erläutern, um was es geht.
Ich möchte beim Systemstart automatisch FTP_SERV starten. Allerdings benötigt dieses WDIALOG.
Wenn ich beide in den AUTO-Ordner lege (WDIALOG natürlich vor FTP_SERV), dann wird WDIALOG gestartet und direkt danach FTP_SERV. Aber offenbar zu schnell, denn FTP_SERV beschwert sich, daß WDIALOG noch nicht geladen ist.
Daher suche ich nach einer Möglichkeit, FTP_SERV verzögert starten zu können.

Herzlichen Dank und viele Grüße,
René

PS: HW ist STe 1040, SW ist TOS 2.06 und MultiGEM II.

Offline ragnar76

  • Benutzer
  • Beiträge: 492
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #6 am: So 22.05.2011, 17:27:22 »
Du brauchst egtl. nur eine Zeitverzögerung. C hilft hier ganz einfach:

main()
{
  sleep(9);
  return(0);
}
Das Programm macht nichts anderes als 10 Sekunden zu warten und sich dann zu beenden.
( Der geübtere Coder mag mir meinen Schlampigen Programmierstil verzeihen, bin halt kein Proficoder  ;D )

Datei einfach umbenennen

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #7 am: Mo 23.05.2011, 19:27:59 »
Ja, das könnte ich machen. Mache ich auch.  :D
Aber kann ich einfach ein Programm schreiben und das in den AUTO-Ordner legen? Muß das keine bestimmte Aufrufsyntax einhalten?

Danke und Grüße,
René

Offline ragnar76

  • Benutzer
  • Beiträge: 492
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #8 am: Mo 23.05.2011, 23:40:55 »
Nicht das ich wüsste, darfst halt nur kein GEM oder AES benutzen.

Offline Arthur

  • Benutzer
  • Beiträge: 9.953
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #9 am: Di 24.05.2011, 00:41:30 »
Hallo,

das Thema möchte ich noch einmal "auffrischen" und auch erläutern, um was es geht.
Ich möchte beim Systemstart automatisch FTP_SERV starten. Allerdings benötigt dieses WDIALOG.
Wenn ich beide in den AUTO-Ordner lege (WDIALOG natürlich vor FTP_SERV), dann wird WDIALOG gestartet und direkt danach FTP_SERV. Aber offenbar zu schnell, denn FTP_SERV beschwert sich, daß WDIALOG noch nicht geladen ist.
Daher suche ich nach einer Möglichkeit, FTP_SERV verzögert starten zu können.

Herzlichen Dank und viele Grüße,
René

PS: HW ist STe 1040, SW ist TOS 2.06 und MultiGEM II.


Das ist ganz einfach zu machen. WDIALOG bleibt wie gehabt im Autoordner.  FTP_SERV meldest Du im Desktop als Autostartprogramm an so das es vom Desktop automatisch gestartet wird. Desktop.inf speichern nicht vergessen.


virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #10 am: Di 24.05.2011, 19:58:45 »
Hallo Arthur,

lieben Dank. Das probiere ich doch mal aus.

Viele Grüße,
René

Offline Arthur

  • Benutzer
  • Beiträge: 9.953
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #11 am: Do 26.05.2011, 07:21:14 »
Hallo René, das klappt ganz sicher. Für FTP_SERV muß natürlich GEM ausgewählt sein.

Offline tuxie

  • Benutzer
  • Beiträge: 6.799
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #12 am: Do 26.05.2011, 07:42:51 »
Ich denke das Problem wird nicht daran liegen das Wdialog noch nicht fertig ist, sondern eher das GEM noch nicht geladen ist, was der Server zum ausführen natürlich benötigt.
Tschau Ingo

afalc060

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #13 am: Do 26.05.2011, 19:00:35 »
Der TOS-Desktop ist eine GEM Applikation  ;)

Der Desktop läst auch nur über pexec starten  :)

Offline tuxie

  • Benutzer
  • Beiträge: 6.799
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #14 am: Do 26.05.2011, 20:21:24 »
Versteh ich jetzt nicht!

Tschau Ingo

Offline Arthur

  • Benutzer
  • Beiträge: 9.953
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #15 am: Fr 27.05.2011, 17:28:21 »
Das GEM-Programme nichts im Autoordner zu suchen haben sollte jetzt aber klar sein....wieso hat Atari in den neueren TOS-Versionen denn sonst die Autostartoption für GEM-Programme nachgerüstet...

@Virgo...wie schauts denn jetzt aus, kommst Du weiter oder gibt es noch Unklarheiten?

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #16 am: Fr 27.05.2011, 17:42:33 »
Hallo Arthur,

na, noch muß ich bis heute 22 Uhr arbeiten.  :(
Dann geht's in die Heija und morgen früh ab nach Hause -> 500 km über die AB. Dann ist der Samstag schon fast gelaufen und Montag früh gehts wieder 500 km retour.
Also keine Panik: In der Regel sage ich doch immer Bescheid, wenn's geklappt hat oder hake weiter nach  ;)

OK?

Offline Arthur

  • Benutzer
  • Beiträge: 9.953
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #17 am: Fr 27.05.2011, 17:55:41 »
Dauert auch echt nur eine Minute... und natürlich ist das OK? ;D

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #18 am: So 29.05.2011, 17:35:04 »
Hallo,

also ich wollte mich heute abend mal dranmachen und Arthurs Tip ausprobieren.
@Arthur und alle: Du hast ja geschrieben, daß GEM-Programme gar nicht in den Auto-Ordner gehören.  :o Hmmh. Nun habe ich einige Programme im Auto-Ordner, aber wie zu Geier kann denn einer wie ich erkennen, ob ein Programm ein GEM-Programm ist?  ???

Danke Euch.
Grüße,
René

Offline Arthur

  • Benutzer
  • Beiträge: 9.953
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #19 am: So 29.05.2011, 18:30:32 »
GEM Programme haben in aller Regel eine Menuleiste und meist die typischen GEM-Fenster. Typische Vertreter wären 1STWord, QED, FTP_SERV, AFTP und tausende andere  etc.. Programme für den Autoordner benutzen keine echten GEM Elemente/Funktionen und sind eher textbasierend und tastaturgesteuert. Es gibt aber Programme bei denen die Programmierer eigene Programmroutinen geschrieben haben so das diese sich z.B. mit der Maus bedienen lassen wie z.B. XBOOT. Im Zweifelsfall das besagte Programm einfach in den Autoordner stecken und schauen ob es von dort richtig läuft. ;)