Autor Thema: Neuzugang eingetroffen. ST/MSTE/FALCON  (Gelesen 2595 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Guus.Assmann

  • Benutzer
  • Beiträge: 131
Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #20 am: Mo 13.05.2019, 19:27:29 »
Wenn ich mich recht erinnere, wird den Tastenklick vom MFP erzeugt.
Und die 3 Kanäle sind zusammen angeschlossen, also Mono. (Hab im Schaltplan gesehen)
Tasten-Klick ist also kein guter Test.
Ein Test-modul ist da etwas besser.
Oder selber ein Test schreiben (GFA Basic ? )

MFG/
Guus

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #21 am: Mo 13.05.2019, 20:10:59 »
MFP ist der Interruptcontroller 68901. Der macht ganz sicher keine Töne. Der Tastenklick kommt aus dem Yamaha-Soundchip und der ist Mono. Wenn man den Falcon-Schaltplan studiert, stellt man fest, dass dessen Mono-Ausgang auf den linken und rechten Kanal des Soundmixers draufgechaltet wird. Also wenn Tastenklicks aus einem Kanal kommen, ist der Yamaha-Chip Ok. Ich würde jetzt als nächstes mal irgendwas starten, was den STE-Sound nutzt, um zu sehen, ob auch das nur aus einem Kanal rauskommt. Am Desktop könnte man da z.B. das Paula][.ACC mit einem Amiga-Modfile nutzen. Wenn auch das nur auf einer Seite raus kommt, dann hat eher der Mixer/Verstärker ein Problem. Wenn das Stereo rauskommt, dann stimmt was mit dem Mixer-Eingang für den Yamaha-Soundchip nicht. Als letztes sollte man dann noch was mit Falcon-Sound ausprobieren, z.B. den AniPlayer mit einem MP3. Auch der Falcon-Sound geht auf diesen Mixer. Daraus kann man dann weitere Schlüsse ziehen.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline X-Ray

  • Benutzer
  • Beiträge: 175
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #22 am: Mo 13.05.2019, 23:58:00 »
So, habe dann mal die Vorschläge ausprobiert.

Paula:
Es kommt Stereo raus. Allerdings ist die Soundqualität nicht so gut wie auf meinem anderen Falcon,
besonders auf dem rechten Kanal.
Aniplayer:
Auch Stereo, allerdings beim Start eines MP3 folgende Meldung:
"Fehler in der DSP-Ansteuerung
CPU ID: MxP
DSP ID: $12121220"
Er versucht dann ohne DSP zu spielen aber das gelingt nicht wirklich, dauernde Loops, auch bei 128kBit MP3s. Sound ist auch nicht gerade gut.
Dieser Falcon hat allerdings auch nur 4MB.

Wings of Death:
Hängt sich beim Laden auf

Xenon 2:
Jeder Sound nur auf dem linken Kanal zu hören.

Wie ich schon mal schrieb, baut DMA2DSP.PRG einen grünen Balken in der oberen Bildschirmhälfte von links nach rechts auf. Das auch viel schneller als mein "normaler" Falcon.
Ist das so korrekt? Evtl. stimmt doch was nicht mit dem HS-40 Beschleuniger Modul.

[EDIT]
Fällt mir noch der Clock-Patch ein. Könnte es auch da dran liegen? Denke ich löte morgen alles mal nach.
« Letzte Änderung: Di 14.05.2019, 00:02:45 von X-Ray »

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #23 am: Di 14.05.2019, 07:27:36 »
DMA2DSP.PRG ist ein Testprogramm für den Clockpatch. Grüner Balken = alles gut, kein Clockpatch notwendig.

Dass Aniplayer bei 128 MBit MP3 ohne DSP loopt, ist normal. Das schafft ein 68030 nicht, nichtmal im TT bei 32 Mhz, selbst ein 68060 mit 66 Mhz ist da sehr sehr grenzwertig (auf einem entsprechend ausgestatteten Amiga 1200 getestet). Mein Falcon mit ct60e mit 95 Mhz schafft das auch ohne DSP, aber bei recht hoher CPU-Last. Da sieht mn dann, was so ein kleiner DSP leistet, denn damit sinkt bei meinem Falcon die Last deutlich unter 10%, während ein originaler Falcon mit DSP bei 95% und höher liegt.

Ich denke, dass man sich bei deinem Falcon mal den Mixer und den ganzen Analgogteil da herum näher ansehen muss. Ein Oszilloskop wäre da hilfreich, um die Audiosignale an den ganzen Bauteilen mal gegenzuchecken,
« Letzte Änderung: Di 14.05.2019, 07:30:21 von 1ST1 »
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline ari.tao

  • Benutzer
  • Beiträge: 2.248
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #24 am: Di 14.05.2019, 09:45:55 »
DMA2DSP.PRG ist ein Testprogramm für den Clockpatch. Grüner Balken = alles gut, kein Clockpatch notwendig. 
Das ist FALSCH!
RICHTIG ist:
DMA2DSP.PRG ist ein Testprogramm für den Clockpatch. Grüner Balken = alles gut, keine Änderung am  Clockpatch notwendig.
Außer dem in #16 zitierten CPX (-> Edit.) gibt es noch das SndReset.PRG für den Falcon. Mal ausprobiert? Quelle:
   PhilippDonze@gmx.ch
Übrigens: Bei Einbau des ddd-CPU-Beschleunigers sollte afaik der ClockPatch entfernt werden, macht das ddd-Teil wohl selber.
« Letzte Änderung: Di 14.05.2019, 09:47:33 von ari.tao »
Falcon+ddd32MHz, TT+CrazyDotsGK und noch ein paar andere.

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #25 am: Di 14.05.2019, 11:25:15 »
DMA2DSP.PRG ist ein Testprogramm für den Clockpatch. Grüner Balken = alles gut, kein Clockpatch notwendig. 
Das ist FALSCH!
RICHTIG ist:
DMA2DSP.PRG ist ein Testprogramm für den Clockpatch. Grüner Balken = alles gut, keine Änderung am  Clockpatch notwendig.
Und wo ist da jetzt der Unterschied zu meiner Aussage ? ? ?

Er hat einen Falcon ohne Clockpatch und bekommt den grünen Balken. Bedeutet doch, er braucht nichts zu ändern...

Ein Falcon ohne Clockpatch, der keinen grünen Balken anzeigt, braucht einen Clockpatch, und wenn der eingebaut ist, und der grüne Balken mit dem Testtool kommt, war der Einbau erfolgreich.

Verwirr doch bitte die Leute nicht so...
« Letzte Änderung: Di 14.05.2019, 11:27:30 von 1ST1 »
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline X-Ray

  • Benutzer
  • Beiträge: 175
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #26 am: Di 14.05.2019, 13:20:26 »
Doch der Clockpatch ist verbaut, siehe Foto weiter oben. Dachte nur das vielleicht etwas damit nicht stimmt.
Habe noch ein Tool namens IPHIGENY gefunden, teste ich heute Abend.
Hat jemand SndReset.PRG zur Hand? Finde es nicht und selbst bei Phillip Donze wird es nicht gelistet.

Lötstellen rund um den Yamaha Chip werde ich ebenfalls mal genauer anschauen.

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #27 am: Di 14.05.2019, 13:45:11 »
Ich glaube nicht, dass dir SndReset hilft, denn den toten Audiokanal hast du ja schon unmittelbar nach dem Einschalten des Falcon. Und ich gehe davon aus, dass am Yamaha alles Ok ist. Schau dir besser den Bereich des Audiomixers an.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline X-Ray

  • Benutzer
  • Beiträge: 175
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #28 am: Di 14.05.2019, 13:55:55 »
Mache ich.

Im Auto-Ordner lag übrigens die Datei FPATCH2.PRG. Wie ich jetzt lese hat die auch etwas mit Sound Problembehebung zu tun.
Allerdings hatte ich die später entfernt und einen Unterschied konnte ich nicht festellen.

Man, warum bekomme ich dauernd die Problem-Ataris?

Offline ari.tao

  • Benutzer
  • Beiträge: 2.248
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #29 am: Di 14.05.2019, 14:06:28 »
^^-- Weil Du mit dem Matatu* fährst; sonst nämlich: Hakuna matata!

*Matatu (Kisuaheli) = ein Sammel-Taxi
Hakuna matata = kein Problem


Edit.: Zitierung von Leautreamont wieder entfernt. Nicht jeder mag Klassiker...
Und nicht jeder, der Ironie für sich beansprucht, verträgt auch welche.
« Letzte Änderung: Mi 15.05.2019, 11:29:48 von ari.tao »
Falcon+ddd32MHz, TT+CrazyDotsGK und noch ein paar andere.

Offline X-Ray

  • Benutzer
  • Beiträge: 175
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #30 am: Di 14.05.2019, 19:30:11 »
So, da bin ich wieder.
Dank ari.tao habe ich ja nun SNDRESET und IPHIGENY habe ich auch besorgt.
Beides gestartet und resetet was geht und siehe da, Sound plötzlich normal aus beiden Kanälen auch bei z.B. Xenon2.
Das ja schon mal positiv, aber.....

Nach Reset kommt der Tastenklick erstmal solange nur aus einem Lautsprecher, bis das XCONTROL mit dem Sound.cpx geladen wurde. Danach ist wieder gut und beide Kanäle funktionieren.
Hochfahren mit gedrückter Control-Taste, also ohne jegliche ACCs etc., dann läuft nur der linke Kanal.
Paula spielt Mods zwar weiterhin auf beiden Kanälen ab, aber etwas übersteuert. Xenon2 hat dann wieder nur den linken Kanal.
Starte ich dann SNDRESET, ist auch ohne das Sound.cpx wieder alles gut.

Echt komisch, irgendwie merkt der sich das nicht.
Auch merkwürdig ist, ich konnte zwar das Desktop im NVRAM auf Deutsch umstellen, und das bleibt auch so behalten, aber die Uhrzeit merkt er sich nicht. Ok, Batterie leer, aber müsste sich dann nicht der Desktop auch immer wieder auf Englisch umstellen? Weiß gar nicht mehr wie was war.

Mikrofone hört sich allerdings noch nicht so gut an, sehr leise und nicht klar.

Offline ari.tao

  • Benutzer
  • Beiträge: 2.248
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #31 am: Di 14.05.2019, 19:43:49 »
Die NVRAM-Batterie zu erneuern , das ist grundsätzlich das allererste, was an einem F30 zu tun ist - sonst ist das Boot-Verhalten stochastisch!
Du solltest vielleicht auch mal streng nach Handbuch den Einbau des ddd-HS40 überprüfen.
Ist der Falcon-Patch wieder im AUTO\ ?
Falcon+ddd32MHz, TT+CrazyDotsGK und noch ein paar andere.

Offline X-Ray

  • Benutzer
  • Beiträge: 175
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #32 am: Di 14.05.2019, 20:54:35 »
Nur habe ich noch keine NVRAM-Batterie zur Hand, bei meinem anderen Falcon hatte ich die zersägt und dann eine Batterie angelötet.
Getauscht wird das aber noch.
Den Falcon Patch habe ich noch nicht im Auto-Ordner, aber per Hand gestartet. Es knackt zwar in den Lautsprechern, aber helfen tut er in meinem Fall nicht.

Eine Einbauanleitung für den HS-40 habe ich nicht, war ja schon verbaut.
Allerdings steht auf dem Teil drauf welches Kabel an welchen PIN soll, eines was an U37 soll kann ich erst prüfen wenn das ich das Board ausbaue und mir die Rückseite anschaue.

Offline ari.tao

  • Benutzer
  • Beiträge: 2.248
  • Gesperrter User
Falcon+ddd32MHz, TT+CrazyDotsGK und noch ein paar andere.

Offline Arthur

  • Benutzer
  • Beiträge: 8.844
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #34 am: Mi 15.05.2019, 20:55:17 »
Nur habe ich noch keine NVRAM-Batterie zur Hand, bei meinem anderen Falcon hatte ich die zersägt und dann eine Batterie angelötet.
Getauscht wird das aber noch.
Den Falcon Patch habe ich noch nicht im Auto-Ordner, aber per Hand gestartet. Es knackt zwar in den Lautsprechern, aber helfen tut er in meinem Fall nicht.

Eine Einbauanleitung für den HS-40 habe ich nicht, war ja schon verbaut.
Allerdings steht auf dem Teil drauf welches Kabel an welchen PIN soll, eines was an U37 soll kann ich erst prüfen wenn das ich das Board ausbaue und mir die Rückseite anschaue.

Ich würde eher einen Batterie-Mod nutzen oder alternativ auch das NVRAM-Platinchen mit Batterie die Exxos in seinem Store anbietet.




Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #35 am: Mi 15.05.2019, 21:01:58 »
Für Exxos sein Platinchen muss man aber den NVRAM Chip auslöten. Da der Falcon eine Multilayer-Platine hat, ist das für weniger geübte Lezte eine große Herausforderung, den Chip auszulöten ohne die Platine zu beschädigen.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline Arthur

  • Benutzer
  • Beiträge: 8.844
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #36 am: Mi 15.05.2019, 21:47:07 »
Der MOD ist auch günstiger und eine 2032 hält auch lange... und ja, es gibt immer wieder Probleme beim entlöten des NVRAM.

Offline X-Ray

  • Benutzer
  • Beiträge: 175
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #37 am: Do 16.05.2019, 00:47:47 »
Na vielleicht gehe ich vorher lieber wieder mit dem Dremel an den Dallas und suche wieder die Kontakte.

@ari.tao
Danke für den Link zur Anleitung, ist bei mir alles korrekt angeschlossen.

Ich habe heute festgestellt dass derjenige, welcher den HS-40 eingebaut hatte, vorher das braune Kabel direkt an den DSP PIN 74 löten wollte. Das hat wohl nicht geklappt und er hat es dann doch laut Anleitung gemacht.
Allerdings hat er dadurch eine Verbindung zwischen PIN 74 und 75 geschaffen, welche immer noch bestand.

Ich habe das eben korrigiert, was ein Sau-Arbeit war (nicht schön, aber funktioniert), leider ist das Soundproblem weiter vorhanden.

Habe mir den Schaltplan dazu angeschaut:
https://www.atariworld.org/files/docs/Atari_Falcon030_Schematic.pdf
DSP 74 (Extal) war mit 75 (Reset) verbunden. Kennt sich jemand damit aus?

Übrigens, morgen erwarte ich den nächsten Kandidat, ein 1040 STE, für kleines Geld.
Werkzeug liegt schon bereit, optisch sah er gut aus, aber was heißt das schon.
Ihr freut euch doch genauso wie ich auf die kommende Arbeit, oder? :-D
« Letzte Änderung: Mo 20.05.2019, 21:45:46 von X-Ray »

Offline X-Ray

  • Benutzer
  • Beiträge: 175
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #38 am: Do 16.05.2019, 01:10:35 »
Oha, Oha, Oha!
Wie ich gerade erfreut feststellen durfte, konnte ich durch meine PIN 74/75 Aktion doch eines der beiden Probleme lösen.
Der Mikrofon Eingang funktioniert wieder korrekt!
DMA2DSP.PRG baut nun den grünen Balken auch nicht mehr so rasend schnell auf wie vorher.
Gerade bei diesem Test waren vorher auch viele kleine flackernde Pixel zu sehen. Nun alles sauber.

Auch sehr erfreulich, Aniplayer spielt mir nun mit DSP-Unterstützung 128kBit Songs ab und zwar ohne Loops!

Es geht voran.


Offline ari.tao

  • Benutzer
  • Beiträge: 2.248
  • Gesperrter User
Re: Neuzugang eingetroffen. ST/MSTE/FALCON
« Antwort #39 am: Do 16.05.2019, 01:45:52 »
Gratuliere!
Falcon+ddd32MHz, TT+CrazyDotsGK und noch ein paar andere.