Autor Thema: Atari Falcon Soundprobleme DSP  (Gelesen 2120 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline kohli79

  • Benutzer
  • Beiträge: 12
Atari Falcon Soundprobleme DSP
« am: So 09.05.2021, 18:00:21 »
Hallo Atarifreunde,
eigentlich wollte ich den Falcon aufgeben weil ich einfach keine Nerven mehr habe für die Kiste.
Aber vielleicht ist jemand hier, der mir helfen kann oder Tips hat.  :)

Dann mal los, sorry wird etwas länger  ;)

Anfang des Jahres einen Falcon gekauft, soweit alles original. Habe nur den Ram(14MB)+FPU+CF Karte eingebaut/getauscht. Der Falcon lief auch wunderbar.
Habe dann den ACE2 Tracker (Musikprogramm) installiert und bemerkt, dass aus dem rechten Lautsprecher meine Anlage sowie auch aus dem Falconlautsprecher Störgeräusche(Knistern) kommen.

Mir wurde dann das Testprogramm DMA2DSP.prg empfohlen und siehe da es zeigt viele rote Zacken beim Testlauf. Da die Batterie eh platt war habe ich mir dann bei Exxos einen neuen NVRam+den ClockPatch gekauft und einbauen lassen. Das Netzteil wurde auch gleich gerecapt mit dem Exxoskit.

Problem bestand nach wie vor, kein Unterschied! Bloß das der Falcon jetzt deutlich instabiler war und ab und an abstürzte wenn er länger lief(2 Bomben). Der Exxos Clockpatch hat auch 2 Modi, Delay on/off. Mit Delay off läuft die Kiste deutlich besser, so habe ich ihn auch momentan wieder am laufen. Geliefert wurde mit Delay on. Hat aber keinen Einfluss auf die Soundprobleme. Über 3 Lötpunkte kann man das einstellen.

Mein Computerspezi meinte ich soll mal mit Kältespray probieren. Spray besorgt und die ganzen IC´s abgeklappert, keine Auswirkungen bis auf dem SDMA. (der wurde auch nur lauwarm im Betrieb)

Sobald ich da drauf bin mit dem Spray, konnte ich beim DMA2DSP Testprogramm sehen wie die roten Zacken verschwunden sind und auch beim ACE Tracker waren die Störungen weg für kurze Zeit. Halt so lange, wie ich immer mal draufgesprüht habe. Also dachte wir uns der SDMA hat einen weg. Er hat ihn dann erstmal nachgelötet aber ohne Erfolg. Also habe ich mir einen neuen bei  Best-Electronics aus den USA besorgt und den tauschen lassen. Leider sind die Probleme immer noch da, kein Unterschied.  >:(

Außer, dass jetzt das Kältespray überhaupt keinen Einfluss mehr auf den SDMA hat.

Wenn der Falcon länger aus ist, also wirklich kalt, dann läuft alles nach dem Booten ohne Probleme. Testprogramm zeigt grünen Balken und der ACE Tracker hat kein Knistern. Aber allerhöchstens für 20-25sek., dann gehts wieder los.

Ich hänge mal paar Videos mit an, die sind noch von vor dem Tausch des SDMA.
Danke im voraus!

MfG Uwe

https://youtu.be/6Mr0kqsFWJE
https://youtu.be/zdgAOAEQ4JI
https://youtu.be/pWdyMsqvECc

Offline Arthur

  • Benutzer
  • Beiträge: 9.701
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Atari Falcon Soundprobleme DSP
« Antwort #1 am: So 09.05.2021, 20:53:02 »
Du benötigt einen SDMA-Patch....

Den mit z.B. 68 Ohm Widerstand


oder auch den Kondensator...



Offline czietz

  • Benutzer
  • Beiträge: 2.848
Re: Atari Falcon Soundprobleme DSP
« Antwort #2 am: So 09.05.2021, 21:35:35 »
Du benötigt einen SDMA-Patch....

Aber er hat doch einen Clock-Patch! Es gibt x Varianten, von denen offensichtlich je nach Falcon mal der eine und mal der andere besser funktioniert. Miro Kropáček hat sich die Mühe gemacht, alle bekannten Patches zusammenzutragen: https://mikrosk.github.io/clockpatch/

Offline kohli79

  • Benutzer
  • Beiträge: 12
Re: Atari Falcon Soundprobleme DSP
« Antwort #3 am: So 09.05.2021, 21:53:39 »
Du benötigt einen SDMA-Patch....

Aber er hat doch einen Clock-Patch! Es gibt x Varianten, von denen offensichtlich je nach Falcon mal der eine und mal der andere besser funktioniert. Miro Kropáček hat sich die Mühe gemacht, alle bekannten Patches zusammenzutragen: https://mikrosk.github.io/clockpatch/
Danke aber die Seite kenne ich!  ;)
Ja, der Exxos ClockPatch. Was meint Arthur? Jetzt bin ich verwirrt!  ;)

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.252
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Atari Falcon Soundprobleme DSP
« Antwort #4 am: So 09.05.2021, 22:26:48 »
Er meinst den ->   https://mikrosk.github.io/clockpatch/

... ab 2.1 mit dem 150pF Konensator ganz kurz vor dem SDMA Clock Eingang.

Offline Latz

  • Benutzer
  • Beiträge: 563
  • Falcon forever!
Re: Atari Falcon Soundprobleme DSP
« Antwort #5 am: Mo 10.05.2021, 08:40:09 »
Hi,

wenn Du den Exxos Clockpatch eingebaut hast, solltest Du den SDMA 68 Ohm Widerstand
nicht einbauen. Denn der wirkt -zusammen mit dem Widerstand auf dem Clockpatch-Board-
als Spannungsteiler und es kommt dadurch nur ca. die Hälfte (Amplitude) des Taktsignals am SDMA
an.

Zum Thema Knistern fällt mir leider auch nicht viel ein...prüfe evtl. mal die Durchkontaktierungen rund
um den SDMA, es kann ja sein daß das Kältespray vorher auch diese "beeinflusst" hat und der Fehler
dadurch verschwand...

Latz
Falcon/CT60 80 MHz, CTPCI+Radeon 9250 + RTL8139 Netzwerkkarte + USB- Karte, Carte Eiffel+LCD, 80 GB HD, DVD-RW
Falcon/CT63 95 MHz, CTPCI+Radeon 9250 + RTL8139 Netzwerkkarte, Carte Eiffel+LCD, 16 GB CF, CD-RW

Offline kohli79

  • Benutzer
  • Beiträge: 12
Re: Atari Falcon Soundprobleme DSP
« Antwort #6 am: Mo 10.05.2021, 22:44:28 »
Ok, danke für die Info.
Schade, hatte gehofft das diese kleine Modifikation vielleicht was bringt.
Wie gesagt, das Kältespray hat jetzt keinen Einfluss mehr. Vorher war es ja auch nur der SDMA!

Die Jungs im Exxos Forum meinten, dass eventuell auch ein Ram Baustein vom DSP einen weg hat!?

Offline gh-baden

  • Benutzer
  • Beiträge: 1.639
Re: Atari Falcon Soundprobleme DSP
« Antwort #7 am: Mo 10.05.2021, 23:08:18 »
Die Jungs im Exxos Forum meinten, dass eventuell auch ein Ram Baustein vom DSP einen weg hat!?

Das wäre ja (digital) prüfbar: Muster reinschreiben und auslesen.
Wider dem Signaturspam!

Offline Latz

  • Benutzer
  • Beiträge: 563
  • Falcon forever!
Re: Atari Falcon Soundprobleme DSP
« Antwort #8 am: Di 11.05.2021, 08:35:08 »
Hi,

hast Du schon mal die Testprogramme für SDMA und DSP(RAM) probiert?

Latz
Falcon/CT60 80 MHz, CTPCI+Radeon 9250 + RTL8139 Netzwerkkarte + USB- Karte, Carte Eiffel+LCD, 80 GB HD, DVD-RW
Falcon/CT63 95 MHz, CTPCI+Radeon 9250 + RTL8139 Netzwerkkarte, Carte Eiffel+LCD, 16 GB CF, CD-RW

Offline dbsys

  • Benutzer
  • Beiträge: 3.939
  • n/a
Re: Atari Falcon Soundprobleme DSP
« Antwort #9 am: Di 11.05.2021, 11:10:06 »
Hi,

hast Du schon mal die Testprogramme für SDMA und DSP(RAM) probiert?

Latz

Was es so alles gibt!    :o

Offline czietz

  • Benutzer
  • Beiträge: 2.848
Re: Atari Falcon Soundprobleme DSP
« Antwort #10 am: Di 11.05.2021, 12:46:15 »
Das Thema Clockpatch beim Falcon ist offenbar weitgehend unverstanden, wie auch Miro auf seiner Webseite schreibt. Oder vielmehr: Anscheinend hat sich niemand (mit passendem Equipment und analytischen Fähigkeiten) damit auseinandergesetzt, es wirklich zu verstehen.

Somit ist das alles "trial and error", welche Modifikation im jeweiligen Falcon funktioniert. Wenn Exxos' Clockpatch nichts verbessert (sondern die Stabilität des betroffenen Falcons sogar verschlechtert), wäre es dann nicht angebracht ihn wieder auszubauen und andere Modifikationen zu probieren?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.252
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Atari Falcon Soundprobleme DSP
« Antwort #11 am: Di 11.05.2021, 13:02:15 »
Als Beispiel ist mein Atari Falcon original ohne Clockpatch und ich habe keine Probleme.

Offline kohli79

  • Benutzer
  • Beiträge: 12
Re: Atari Falcon Soundprobleme DSP
« Antwort #12 am: Di 11.05.2021, 14:12:03 »
Hi,

hast Du schon mal die Testprogramme für SDMA und DSP(RAM) probiert?

Latz
Ja den SDMA Test habe ich! Den Ram Test kannte ich nicht, danke!  :)
Da zeigte alles "OK" an.

Offline kohli79

  • Benutzer
  • Beiträge: 12
Re: Atari Falcon Soundprobleme DSP
« Antwort #13 am: Di 11.05.2021, 14:25:59 »
Das Thema Clockpatch beim Falcon ist offenbar weitgehend unverstanden, wie auch Miro auf seiner Webseite schreibt. Oder vielmehr: Anscheinend hat sich niemand (mit passendem Equipment und analytischen Fähigkeiten) damit auseinandergesetzt, es wirklich zu verstehen.

Somit ist das alles "trial and error", welche Modifikation im jeweiligen Falcon funktioniert. Wenn Exxos' Clockpatch nichts verbessert (sondern die Stabilität des betroffenen Falcons sogar verschlechtert), wäre es dann nicht angebracht ihn wieder auszubauen und andere Modifikationen zu probieren?
Wäre es ja, aber dafür fehlt mir die Erfahrung und das Wissen in Bezug auf den Falcon.
Vielleicht lasse ich ihn wieder rückrüsten, Clockpatch raus und die 3 SMD Widerstände rein, sodass er zumindest wieder stabil läuft wie vorher. Dann mal schauen ...
« Letzte Änderung: Di 11.05.2021, 16:27:09 von kohli79 »

Offline TPAU

  • Benutzer
  • Beiträge: 292
  • Atari-Fan der ersten Stunde! ;-)
Re: Atari Falcon Soundprobleme DSP
« Antwort #14 am: Di 11.05.2021, 19:54:21 »
Als Beispiel ist mein Atari Falcon original ohne Clockpatch und ich habe keine Probleme.
Auch nicht dieses Knisterproblem bei z.B. ACE Tracker 2 oder Digit II (siehe das eine Video von @kohli79 )?
Bei mir tritt dieser Fehler erst so nach ganz grob 15 Minuten allmählich auf.
Hab somit erst ziemlich spät rausgefunden, dass mein Raubvogel auch dieses Knisterproblem hat.
Erst nach 'ner Weile (halbe Stunde?) ausschalten ist das Knistern weg, kommt dann aber natürlich bald wieder. ;)

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.252
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Atari Falcon Soundprobleme DSP
« Antwort #15 am: Di 11.05.2021, 20:11:23 »
Zero X macht keine Probleme bei mir mit DSP Nutzung.

Offline kohli79

  • Benutzer
  • Beiträge: 12
Re: Atari Falcon Soundprobleme DSP
« Antwort #16 am: Di 01.06.2021, 15:59:44 »
Exxos hat sich mein Board mal angeschaut. Er scheint wieder zu laufen...  :D :D :D

Ich mache mal den Link vom Forum rein.
https://www.exxoshost.co.uk/forum/viewtopic.php?f=23&t=3912&start=50

"It seems one of the clock lines is not happy and needs a 100K resistor on it to keep it happy.. Easy fix.."  8)

Offline tuxie

  • Benutzer
  • Beiträge: 6.728
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: Atari Falcon Soundprobleme DSP
« Antwort #17 am: Di 01.06.2021, 19:22:44 »
Exxos und seine ganzen Verschlimmbesserungen mit seinen PullUp / Pulldown Widerständen.

Das erste was man machen sollte ist das Takt Signal am Compel Eingang zu einem echten Takt machen. Das was von dem Frequenzgenerator rein kommt ist echt große Müll manchmal..

Der Clockpatch dient dazu das taktsignal zu verstärken, der Ausgang des Combels ist nicht stark genug um die drei Taktleitungen sauber zu treiben.

Baut man jedoch einen buffer ein (clockpatch) kommt es zu einer Verschiebung des taktsignals. Was bei der Übernahme der Daten zu Problemen führen kann. ( zum Teil muss der nächste Takt abgewartet werden. Was gerade beim DMA zu Problemen führen kann.

Leider habe ich keinen Falcon mehr, mit dem Equipment was ich jetzt habe könnte ich das wunderbar aufzeichnen.
Tschau Ingo


PC Intel i7 4820, 16gb quad @2400,Mac OS X El Capitan
http://tuxie.de http://hwbot.org/user/tuxie/

Offline dbsys

  • Benutzer
  • Beiträge: 3.939
  • n/a
Re: Atari Falcon Soundprobleme DSP
« Antwort #18 am: Di 01.06.2021, 19:41:26 »

Das erste was man machen sollte ist das Takt Signal am Combel Eingang zu einem echten Takt machen. Das was von dem Frequenzgenerator rein kommt ist echt große Müll manchmal..


Was genau sollte man am Combel Eingang tun? Welche Maßnahmen und Bauteile sind nötig?

Offline tuxie

  • Benutzer
  • Beiträge: 6.728
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: Atari Falcon Soundprobleme DSP
« Antwort #19 am: Di 01.06.2021, 19:48:29 »
Man hat rechts neben dem Uhrenchip, eine Schaltung welche die 32mhz erzeugt und dann über Spule L102 zum Combel führt. Bei dieser Schaltung müssen einige Widerstände angepasst werden damit ein sauberes Rechtecktaktsignal von 32mhz raus kommt .
Tschau Ingo


PC Intel i7 4820, 16gb quad @2400,Mac OS X El Capitan
http://tuxie.de http://hwbot.org/user/tuxie/