Autor Thema: 256MB TT-RAM und MinT streikt  (Gelesen 3270 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
256MB TT-RAM und MinT streikt
« am: Sa 04.08.2018, 16:10:22 »
Hallo zusammen,

heute Morgen sind meine 256MB EDO für die Storm angekommen und natürlich habe ich sie gleich eingesteckt.
YAART gibt im 1. Pass keine Fehler aus und TOS/MagiC starten ohne Probleme.
Wenn ich allerdings MinT starte, gibts zwei Bomben beim Booten und der TOS Desktop erscheint.

Gibt es unter MinT sowas wie einen Bootlog, damit ich nachlesen kann was da abschmiert?

Die Gegenprobe mit 2x32MB in der Storm ist erfolgreich, damit startet MinT durch. Mein MinT ist allerdings auch noch nicht richtig konfiguriert. Habe es als Anfänger auch nur mit Ach und Krach auf den aktuellen Trunk aktualisieren können und dabei habe ich sicherlich nicht alles richtig gemacht.


Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #1 am: Sa 04.08.2018, 16:40:10 »
Ups, falsche Gruppe. Wollte es in Alternative Betriebssysteme posten. Sorry.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.112
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: 256MB TT-RAM und MinT streikt
« Antwort #2 am: Sa 04.08.2018, 18:25:33 »
Halte beim Aufstarten vom mint.prg die linke Shifttaste gedrückt und schalte mal die Memory Protection aus falls sie an ist zum Probieren. Dort kannst du auch das Log einschalten ...

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #3 am: Sa 04.08.2018, 18:45:54 »
Hab jetzt mal den original EasyMint Installationsordner zurückbenannt in MINT und die mint.030.prg von diesem in den AUTO-Ordner gelegt - hiermit gehts, Mint startet durch mit den 256MB.

Ich probiere das jetzt mal mit deinem Tip

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #4 am: Sa 04.08.2018, 19:19:09 »
Memory Protection ist es. Ohne startet Mint durch.


Funktioniert nicht:
<2> Load external XFS : no
<3> Load external XDD: no
<4> Execute AUTO PRGs: no
<5> Memory protection: yes

Funktioniert :
<2> Load external XFS : yes
<3> Load external XDD: yes
<4> Execute AUTO PRGs: yes
<5> Memory protection: no

Die letzte Zeile die ich im Bruchteil einer Sekunde sehe bevor gebombt wird und der TOS Desktop erscheint ist "FAT/VFAT ..... Frank Naumann" irgendwas.

Offline czietz

  • Benutzer
  • Beiträge: 2.072
Re: 256MB TT-RAM und MinT streikt
« Antwort #5 am: Sa 04.08.2018, 19:41:11 »
Memory Protection ist es. Ohne startet Mint durch.

Das ist dann aber ein Bug! Der MiNT-Kernel muss schon mit Speicherschutz (memory protection) funktionieren.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.112
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: 256MB TT-RAM und MinT streikt
« Antwort #6 am: Sa 04.08.2018, 19:49:32 »
Was nicht geht und wo mint stoppt ist wenn auch ein Medium mit HDDriver TOS/Windows mit ByteSwap eingerichtet hat. Das geht nur mit dem Helmut Kernel aber dafür hat der Helmut Kernel kein Ramfs.

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #7 am: So 05.08.2018, 00:07:01 »
Meine Seagate ist mit HDDRIVER partitioniert, nur TOS Kompatibilität, kein ByteSwap.
Ich versuche es jetzt noch mal mit meiner zweiten, identischen Seagate von der Picke auf. Ich mache sie patt und richte die Partitionen erneut ein. Lade mir für die Neuinstallation auch erneut den aktuellen Trunk herunter.
Bei euch funktioniert das ja auch, also muss es auch bei mir klappen.

@czietz
Wenns ein Systembug wäre, hättet ihr das bestimmt schon vor mir bemerkt. Ich denke mal der Bug bin ich ...  :)
Werd aber schon rauskriegen an was es hängt.

Offline Arthur

  • Benutzer
  • Beiträge: 8.557
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: 256MB TT-RAM und MinT streikt
« Antwort #8 am: So 05.08.2018, 00:32:45 »
Was für Erweiterungen hast du?

Thunder, Storm, Lightning... evtl Grafikkarte?

Zitat
Funktioniert nicht:
<2> Load external XFS : no
<3> Load external XDD: no
<4> Execute AUTO PRGs: no
<5> Memory protection: yes

Das ist ja mal eine sehr konservative Einstellung... keine weiteren Filsysteme und keine Treiber und Autoordner-Programme aber Speicherschutz an.

Zitat
Funktioniert :
<2> Load external XFS : yes
<3> Load external XDD: yes
<4> Execute AUTO PRGs: yes
<5> Memory protection: no

Das ist eigentlich der Normalfall, doch wie @czietz schrieb sollte es auch mit Speicherschutz laufen. Wenn dann die ein oder anderen Anwendung mit Speicherschutz nicht funktioniert kann man den ja ausschalten.

Offline Arthur

  • Benutzer
  • Beiträge: 8.557
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: 256MB TT-RAM und MinT streikt
« Antwort #9 am: So 05.08.2018, 00:58:06 »
Bin durch einen Tipp von @Gaga auf VanillaMiNT gekommen. Lauft sehr stabil.

https://atari.joska.no/VanillaMiNT/ für den TT die 030er Downloaden.

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #10 am: So 05.08.2018, 15:28:41 »
Bin durch einen Tipp von @Gaga auf VanillaMiNT gekommen. Lauft sehr stabil.

https://atari.joska.no/VanillaMiNT/ für den TT die 030er Downloaden.

Hallo Arthur,

habe meine Platte komplett neu partitioniert. Habe dann VanillaMiNT heruntergeladen und den Inhalt auf die C: kopiert. Auch MINT030.PRG im AUTO-Ordner ist das von VanillaMiNT. Außer HDDRIVER.SYS und XBOOT wird nur der Treiber für die ET4000 vor dem MINT030.PRG gestartet, sonst nichts.

Erster Start: 2 Bomben und anschließend grüner TOS Desktop.
Zweiter Start ohne Memory Protection: Bootet komplett durch zum TERADESK Desktop.

Was zum Geier kann das sein? Könnten das Probleme mit der Partitionierung von HDDRIVER 10.12 sein?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.112
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: 256MB TT-RAM und MinT streikt
« Antwort #11 am: So 05.08.2018, 15:38:14 »
Schalte doch mal zum probieren in der xaaes.cnf ganz am Ende Teradesk aus. Oder die desktop.cnf. Einfach an den entsprechenden Zeilen ein # voranstellen. Kann sein das Teradesk mit der Memory Protection nicht läuft? Das System sollte dann mit Memory Protection ein bis ins XaAES mit allen ACC booten ...

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #12 am: So 05.08.2018, 16:05:24 »
Schalte doch mal zum probieren in der xaaes.cnf ganz am Ende Teradesk aus. Oder die desktop.cnf. Einfach an den entsprechenden Zeilen ein # voranstellen. Kann sein das Teradesk mit der Memory Protection nicht läuft? Das System sollte dann mit Memory Protection ein bis ins XaAES mit allen ACC booten ...

Habe ich eben gemacht. Keine Änderung. Wie auch unter EasyMiNT (+Trunk) sehe ich nur einen sehr kurzen Bootvorgang, letzte Zeile an der Unterkante des Bildschirms ist für den Bruchteil einer Sekunde "FAT/VFAT/FAT32 ....". Mit MP=on gibt es nach wie vor 2 Bomben und anschließend den TOS Desktop. Der TT kommt auch gar nicht erst zum Laden des Desktops. Die Bomben gibt´s schon weit vorher.

Ich habe auf Verdacht auch mal XBOOT und die ET4000 Treiber deaktiviert. Es werden also nur noch HDDRIVER.SYS und MINT030.PRG beim Einschalten des TT geladen. Keine Änderung.

Kann es was mit dem Filesystem zu tun haben, da das ja die letzte Bootzeile ist die ich zu Gesicht bekomme?

Offline Arthur

  • Benutzer
  • Beiträge: 8.557
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: 256MB TT-RAM und MinT streikt
« Antwort #13 am: So 05.08.2018, 16:10:17 »
Hallo @DonQuichote, mal eine LOG Datei in MiNT erstellen lassen oder für MiNT die Einzelbestätigung beim Systemstart aktivieren um zu sehen wann der Fehler genau auftaucht. Auch mal einen Test ohne den Grafikkartentreiber über den Falcon Monitorausgang.

Welchen ET4000/Karte bzw. Treiber benutzt du?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.112
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: 256MB TT-RAM und MinT streikt
« Antwort #14 am: So 05.08.2018, 16:20:32 »
Kann es was mit dem Filesystem zu tun haben, da das ja die letzte Bootzeile ist die ich zu Gesicht bekomme?

Ich kann eigentlich nicht Helfen da ich immer mit Memory Protection off arbeite. Aber nach deiner letzten Zeile lässt EasyMiNT e2fsck also eine Filesystem Reparatur über deine ext2 Partition laufen wenn beim letzten Mal das System nicht sauber runtergefahren wurde. Da steht auch so in der mint.cnf ...

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #15 am: So 05.08.2018, 16:44:42 »
Habe mal aus lauter Verzweiflung die Storm herausgeholt. Mint startet jetzt durch, nur mit ST-RAM und mit MemoryProtection=on.

Probiere weiter ...

Offline Arthur

  • Benutzer
  • Beiträge: 8.557
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: 256MB TT-RAM und MinT streikt
« Antwort #16 am: So 05.08.2018, 16:58:24 »
Wie sind deine Jumpersettings auf der Storm? Evtl. mal den Burst-Mode deaktivieren.

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #17 am: So 05.08.2018, 17:03:04 »
Storm wieder drin mit 2x32MB EDO im Burst mode -> MiNT startet durch mit MemoryProtect=on

2x128 MB EDO wieder in die Storm gesetzt, diesmal ohne Burst Mode, MiNT bombt.

Jetzt habe ich noch mal YAART gestartet, 2x128MB EDO im Burst Mode (J3=on). Lasse diesmal mehrere Passes durchlaufen.

Offline Arthur

  • Benutzer
  • Beiträge: 8.557
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: 256MB TT-RAM und MinT streikt
« Antwort #18 am: So 05.08.2018, 17:10:48 »
Du könntest ja auch mal nur ein Modul einsetzen... 128MB. Wenn's klappt dann das andere auch einzeln testen.

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #19 am: So 05.08.2018, 17:11:54 »
 Gute Idee. Mach ich gleich mal.