Autor Thema: Netsurf 3.8 Testbuild  (Gelesen 1873 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Arthur

  • Benutzer
  • Beiträge: 8.427
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Netsurf 3.8 Testbuild
« Antwort #20 am: Sa 16.06.2018, 15:46:20 »
Das sollte doch darauf sehr ordentlich laufen. Das NetSurf am TT so langsam ist ist natürlich nicht so schön. Ich hoffe da gibt es noch ein paar Möglichkeiten da etwas zu optimieren... 2-3 Minuten fänd ich noch ok. Vielleicht für TT mit viel RAM das da noch was geht... Trotzdem hab ich mich voll darüber gefreut als ich gesehen habe das bei Netsurf 2.9 nicht das Ende der Fahnenstange erreicht ist.

Wird bei diesen https Seiten die FPU viel genutzt... dann kann ich die ja mal etwas übertakten.  >:D Träum



Netsurf auf der Firebee oder besser das WWW und die Firebee ... also ... ja ... das geht, aber man sollte von modernen, komplexeren Seiten die Finger lassen. Das verkraftet die Biene auch nicht wirklich. Wer wirklich ungebremst im Netz unterwegs sein will und das ohne große Behinderungen, der sollte dafür einen halbwegs akutellen Computer und Browser nutzen. ;)
[/quote]

Offline Arthur

  • Benutzer
  • Beiträge: 8.427
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Netsurf 3.8 Testbuild
« Antwort #21 am: Sa 16.06.2018, 15:54:33 »
Netsurf auf der Firebee oder besser das WWW und die Firebee ... also ... ja ... das geht, aber man sollte von modernen, komplexeren Seiten die Finger lassen. Das verkraftet die Biene auch nicht wirklich.

Da das Zeitgefühl sehr subjektiv ist kann ich mit der Aussage wenig anfagen. Besser wäre einen der Letzten Testbilds von Netsurf zu starten und mal zu schauen wie "schnell" forum.atari-home.de damit aufgebaut wird.

Das verkraftet die Biene auch nicht wirklich. Wer wirklich ungebremst im Netz unterwegs sein will und das ohne große Behinderungen, der sollte dafür einen halbwegs akutellen Computer und Browser nutzen. ;)

Hat doch jeder... sogar mehr als genug... aber darum geht es hier doch nicht.  ;D

Offline czietz

  • Benutzer
  • Beiträge: 2.053
Re: Netsurf 3.8 Testbuild
« Antwort #22 am: Sa 16.06.2018, 16:00:55 »
Das sieht aus wie in in Chrome und Netscape einfach Top. Mich würde interessieren, wenn die CPU im PC mit 32 MHz liefe wer dann schneller wäre. PC oder TT? :D

Nun sind Benchmarks von verschiedenen Prozessorarchitekturen ja grundsätzlich problematisch, aber folgender Unterschied ist schon sehr groß: 68030 @ 33 MHz = 3,1 - 3,6 Dhrystone MIPS, 80386 @ 40 MHz = 10,1 - 11,5 Dhrystone MIPS. (http://www.netlib.org/performance/html/dhrystone.data.col1.html) Eine moderne x86-CPU herunter skaliert auf 32 MHz hätte aufgrund der viel besseren Architektur noch mehr MIPS.

Offline Arthur

  • Benutzer
  • Beiträge: 8.427
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Netsurf 3.8 Testbuild
« Antwort #23 am: Sa 16.06.2018, 16:08:26 »
Das sieht aus wie in in Chrome und Netscape einfach Top. Mich würde interessieren, wenn die CPU im PC mit 32 MHz liefe wer dann schneller wäre. PC oder TT? :D

Nun sind Benchmarks von verschiedenen Prozessorarchitekturen ja grundsätzlich problematisch, aber folgender Unterschied ist schon sehr groß: 68030 @ 33 MHz = 3,1 - 3,6 Dhrystone MIPS, 80386 @ 40 MHz = 10,1 - 11,5 Dhrystone MIPS. (http://www.netlib.org/performance/html/dhrystone.data.col1.html) Eine moderne x86-CPU herunter skaliert auf 32 MHz hätte aufgrund der viel besseren Architektur noch mehr MIPS.

Christian das ist auch nicht ganz ernst gemeint gewesen... und oft haben die dann auch 8 oder mehr Kerne.

Offline 1ST1

  • Benutzer
  • Beiträge: 8.325
  • Sehr langer Urlaub.
Re: Netsurf 3.8 Testbuild
« Antwort #24 am: Sa 16.06.2018, 21:06:39 »
Und, das wurde ja im Apollo-Forum ziemlich ausführlich diskutiert, ist ein reiner MIPS-Test nicht sonderlich aussagekräftig, kommt ja immer drauf an, welche Befehle man nutzt, und wie skalar die CPU ist. Eine konkrete Aufgabe eigent sich besser, z.B. Mandelbrot-Menge mit den gleichen Startparametern berechnen. 

Irgendwo habe ich mal die Aussage gefunden, ein Atari TT entspräche in seiner Anwendungs-Performance einem Pentium 90, was ich aber auch wiederherum eher anzweifle.
« Letzte Änderung: Sa 16.06.2018, 21:08:50 von 1ST1 »
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline gh-baden

  • Benutzer
  • Beiträge: 1.175
Re: Netsurf 3.8 Testbuild
« Antwort #25 am: Sa 16.06.2018, 22:06:46 »
Und, das wurde ja im Apollo-Forum ziemlich ausführlich diskutiert, ist ein reiner MIPS-Test nicht sonderlich aussagekräftig, kommt ja immer drauf an, welche Befehle man nutzt, und wie skalar die CPU ist. Eine konkrete Aufgabe eigent sich besser, z.B. Mandelbrot-Menge mit den gleichen Startparametern berechnen. 

Irgendwo habe ich mal die Aussage gefunden, ein Atari TT entspräche in seiner Anwendungs-Performance einem Pentium 90, was ich aber auch wiederherum eher anzweifle.

Wieso, beim Gucken-auf-den-blinkenden-Cursor könnte das stimmen. In so ziemlich allen anderen Fällen  ist so ein Satz natürlich Humbug. Ein TT kann höchstens noch manchen 386ern das Wasser reichen, bei den ersten 486ern ist's schon rum.

Trotzdem arbeite ich halt lieber mit That’s Write, X-Act, Papyrus, Texel, als mit StarOffice oder MS Word 6.
Wider dem Signaturspam!

Offline 1ST1

  • Benutzer
  • Beiträge: 8.325
  • Sehr langer Urlaub.
Re: Netsurf 3.8 Testbuild
« Antwort #26 am: Sa 16.06.2018, 23:35:32 »
Naja, das sind ja auch Sachen, die man zur Not, oder aus Style-Gründen, noch mit einer mechanischen Schreibmaschine machen kann.

Aber ein TT ist halt Anwendungen mit heutigen Datenmengen nicht mehr gewachsen. Und eine moderne https-Seite tippst du ja auch nicht auf einer Schreibmaschine ab, oder?
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline gh-baden

  • Benutzer
  • Beiträge: 1.175
OFF: Vergleich TT mit anderem Altzeugs (was: Netsurf 3.8 Testbuild)
« Antwort #27 am: So 17.06.2018, 00:34:54 »
Naja, das sind ja auch Sachen, die man zur Not, oder aus Style-Gründen, noch mit einer mechanischen Schreibmaschine machen kann.

„Schlimmer geht immer.“

Aber ein TT ist halt Anwendungen mit heutigen Datenmengen nicht mehr gewachsen. Und eine moderne https-Seite tippst du ja auch nicht auf einer Schreibmaschine ab, oder?

Sicher, aber ich will darauf ja auch keine Bilder meiner Canon EOS600D öffnen. Und nebenbei, ein typischer P90 (d.h. so 16-32 MB RAM, 400er IDE-Platte mit so 3-5 MB/s, Windows 95) macht auch kein Spaß mit EOS600D-Bildern. Und dabei ist das nichtmal eine moderne Kamera, die hat nur 18 MP.
Wider dem Signaturspam!

Offline 1ST1

  • Benutzer
  • Beiträge: 8.325
  • Sehr langer Urlaub.
Re: Netsurf 3.8 Testbuild
« Antwort #28 am: So 17.06.2018, 11:58:49 »
18 MPixel ist doch schon ziemlich gut. Ich habe meinen TT mal eine JPG von meier Nikon D7200 (24 MPixel) öffnen lassen... Nach 3 Stunden hat Photoline die Füße weit von sich gestreckt... (Das JPG von meiner D80 (10 MPixel) wurde nach etwas über 1 Stunde angezeigt...)


So kann ich doch nicht arbeiten!
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline Arthur

  • Benutzer
  • Beiträge: 8.427
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Netsurf 3.8 Testbuild
« Antwort #29 am: Mo 18.06.2018, 11:17:15 »
Hätte gern ein paar schöne Screenshots gemacht aber die beiden Tools die ich verwendet habe Snapper (24Bit) und JML-Snapshot (max. 256 Farben) speichern in IMG format. Werden am PC fehlerhaft geladen... gibt nicht das auch jpg in 24Bit speichern kann?

Dank xaaessnap (danke @Lukas Frank)... hier nochmal das Forum im Netsurf auf einem Atari TT mit TSL (Thunder, Storm u. Lightning). Schön anzusehen aber nur als Studie. Zum Arbeiten müßte es mindestens 3x Fixer sein.
« Letzte Änderung: Mo 18.06.2018, 11:20:52 von Arthur »

Offline Gaga

  • Benutzer
  • Beiträge: 2.084
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: Netsurf 3.8 Testbuild
« Antwort #30 am: Mo 18.06.2018, 11:18:58 »
Na bitte, es geht und sieht gut aus. Alles eine Frage der Zeit.
Thunder - Storm - Lightning VME/ST

Offline Arthur

  • Benutzer
  • Beiträge: 8.427
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Netsurf 3.8 Testbuild
« Antwort #31 am: Do 05.07.2018, 19:03:49 »
Nachdem mein Atari TT so einigermaßen flüssig läuft und auch die Netzwerkkonfiguration für die Hydra geklappt hat wollte ich mal schauen was denn mit unserem https://forum.atari-home.de und Netsurf geht.

Zuerst habe ich mir einfach eine der letzten Testbuilds besorgt und daraus die cabundle mit den Zertifikarten, was aber nicht half... immer unbekannter Fehler.

Dann hab ich auf dem PC das Zertifikat für Let's Encrypt für das Forum im Firefox gespeichert und in die cabundle-Datei hinzugefügt. Hat aber nicht geholfen... Die https meiner Bank funzte aber mit Netsurf 2.9...wieso also nicht beim Forum?

Also einen Testbuild herunter geladen und los. Die neuen Testbuilds erkennen das ein Problem mit dem Zertifikat besteht... man kann dann weiter laden oder in einer Art Zertifikatsmanager dem Zertifikat vertrauen... leider fügt das nicht das Zertifikat zu der cabundle-Datei hinzu. Aber... mit etwas gedult ca. 6 Minunten  >:D :D wird man mit einem sauber gerenderten Forum-Seite beglückt.


In Aranym unter Windows 10 hab ich nach Installation eines Tap0 Adapters den letzten 3.8er Netsurf-Build in Aranym Installiert. Ich bin davon ausgegangen das der Browser einigermaßen vorkonfiguriert ist... aber gerade cabundle, ist für SSL wichtig, und nicht Standartmäßig konfiguriert. Nach dem der Pfad hinzugefügt worden ist werden auch https-Seiten ohne nervige Nachfrage geladen. Unter Aranym ist die Seite von https://forum.atari-home.de dann nach ca. 3-4 Sekunden aufgebaut.


Online Thorsten Otto

  • Benutzer
  • Beiträge: 466
Re: Netsurf 3.8 Testbuild
« Antwort #32 am: Do 05.07.2018, 20:19:55 »
aber gerade cabundle, ist für SSL wichtig, und nicht Standartmäßig konfiguriert. Nach dem der Pfad hinzugefügt worden ist werden auch https-Seiten ohne nervige Nachfrage geladen. Unter Aranym ist die Seite von https://forum.atari-home.de dann nach ca. 3-4 Sekunden aufgebaut.

Hm ging bei mir auch ohne daß ich da was eingetragen hätte. Ähnliche Konfiguration, Netzwerk-Zugriff über ein tap-device, allerdings Aranym auf linux, nicht Windows. Seite nach ca. 2.5 sek aufgebaut.

Irgendwie sehen nur die Fonts ein bisschen eigenartig aus, vor allem kleiner, trotz gleicher Schriftgrösse wie mit Firefox auf dem gleichen Rechner. Font-Engine dürfte auch die gleiche sein, beide benutzen FreeType.