Autor Thema: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...  (Gelesen 13874 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #100 am: Sa 19.01.2019, 17:16:45 »
Sysinfo spinnt, ich würde sagen es kommt mit dem Nova Treiber nicht zurecht.

Die Bildschirmfehler sind die auch bei 640x480 /256 Farben und 60Hz ?

Offline TheNameOfTheGame

  • Benutzer
  • Beiträge: 57
  • Almost Heaven, West Virginia
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #101 am: Sa 19.01.2019, 17:36:01 »
Hmm, ich installierte ein anderes ET4000 und das Problem ist viel weniger.

Aber auch bei 640x480x256 Nova-Ouput ohne GDOS manchmal ein Pixel oder zwei verloren geht. Aber die Farbverschiebung ist weg.

Vielleicht ist das Timing besser mit dieser Karte? Oder die Kontakte sind sauberer?

Vielleicht muss ich das Flachbandkabel verkürzen.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #102 am: Sa 19.01.2019, 17:42:04 »
Die Flachband Kabel dürfen nicht zu lang sein beim VOFA Adapter. Wenn der Adapter von mir fertig gekauft wurde ist der ISA Slot neu. Also Kontakte an der ISA Karte reinigen. Gebrauchte ISA Slots beim selbst bauen machen manchmal Probleme.

Offline TheNameOfTheGame

  • Benutzer
  • Beiträge: 57
  • Almost Heaven, West Virginia
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #103 am: Sa 19.01.2019, 17:47:52 »
ja, ich kaufte den Adapter von Ihnen.

Offline SolderGirl

  • Benutzer
  • Beiträge: 352
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #104 am: Sa 19.01.2019, 17:54:00 »
Hmm, ich installierte ein anderes ET4000 und das Problem ist viel weniger.

Aber auch bei 640x480x256 Nova-Ouput ohne GDOS manchmal ein Pixel oder zwei verloren geht. Aber die Farbverschiebung ist weg.

Vielleicht ist das Timing besser mit dieser Karte? Oder die Kontakte sind sauberer?

Vielleicht muss ich das Flachbandkabel verkürzen.


Selbst wenn die VGA-Karte mit der 68000 CPU funktionieren würde, spätenstens wenn du eine PAK einbaust bekommst du damit massiv Probleme. Denn die PAK hat deutlich kürzere Signalzyklen, und dadurch wird das Problem deutlich verstärkt.
{PoFo 512kb RAM, 6,5 MHz, CF-Slot, 1MB SRAM Disk}
{520 STm 4MB, 2x CF-Cards, 2x HD-Floppy}
{Mega ST1 4MB, PAK68/2, µEiffel, VoFa ET4000}

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #105 am: Sa 19.01.2019, 19:58:42 »
I did a test with my ET4000 ISA card and all are fine at 1024x768 /256 Colors. I not know what are the problem with your setup. I test with my Atari Mega ST4. The Mega ST has 4,7k pullups at the address lines. The Atari 260/520ST has 10k pullups, maybe that is the problem !?!

For the PAK68/3 you can change the Pullups for the address lines to 2,2k and the data lines to 4,7k.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #106 am: So 20.01.2019, 17:50:54 »
I make a test today with the VOFA CPU Version and on top a PAK68/2 Speeder card. All works fine in a Atari Mega ST at 1024x768 /256 Colors. The PAK has TOS 2.06 and I boot the nova driver from floppy.

The graphiccard output to the screen is nice and clean.

Your problem have to do with the ET4000 card that you use and the 10k Pullups from the 260/520ST Computer.








With a Mega4000 ET4000 ISA Adapter there are working a little amount of graphiccards. From 10 cards perhaps 2 cards. With a VOFA there are working more cards but not all. And with a Nova VME Adapter there are working 98% of all cards.

With the Nova driver there are working more cards than with NVDI ET4000/NVDI5 ...
« Letzte Änderung: So 20.01.2019, 18:11:54 von Lukas Frank »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #107 am: So 20.01.2019, 18:34:07 »
Habe es mal auf die Spitze getrieben und noch ein IDE Interface dazwischen gesteckt. Und alles läuft einwandfrei ohne Probleme über die Grafikkarte. Als Treiber läuft CBHD 5.02 und einer 16MB CF Karte.




Offline Arthur

  • Benutzer
  • Beiträge: 8.394
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #108 am: So 20.01.2019, 18:47:39 »
I did a test with my ET4000 ISA card and all are fine at 1024x768 /256 Colors. I not know what are the problem with your setup. I test with my Atari Mega ST4. The Mega ST has 4,7k pullups at the address lines. The Atari 260/520ST has 10k pullups, maybe that is the problem !?!

For the PAK68/3 you can change the Pullups for the address lines to 2,2k and the data lines to 4,7k.
Die Flachband Kabel dürfen nicht zu lang sein beim VOFA Adapter. Wenn der Adapter von mir fertig gekauft wurde ist der ISA Slot neu. Also Kontakte an der ISA Karte reinigen. Gebrauchte ISA Slots beim selbst bauen machen manchmal Probleme.

Das dürften die wesentlichen Punkte sein die es zu beachten gibt. Ein stabile Spannungsversorgung voraus gesetzt.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #109 am: So 20.01.2019, 18:53:10 »
Ich nutze das originale gute Atari Netzteil. Das hat genug Leistung und ist Stabil.

Offline Arthur

  • Benutzer
  • Beiträge: 8.394
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #110 am: So 20.01.2019, 19:02:21 »
Ich nutze das originale gute Atari Netzteil. Das hat genug Leistung und ist Stabil.

Ja das glaube ich dir. Es gibt dennoch auch Netzteile wo die Elkos mal erneuert werden sollten weil die einfach hinüber sind... sind ja Verschleißteile. >:D

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #111 am: So 20.01.2019, 19:33:55 »
Vielleicht ist dieses PicoPSU teils des Problems, keine Ahnung ...

So ein 260/520ST hat diesen dicken 4700uF Elko nicht auf dem +5V Zweig.
« Letzte Änderung: So 20.01.2019, 20:45:53 von Lukas Frank »

Offline Arthur

  • Benutzer
  • Beiträge: 8.394
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #112 am: So 20.01.2019, 20:54:55 »
Vielleicht ist dieses PicoPSU teils des Problems, keine Ahnung ...

So ein 260/520ST hat diesen dicken 4700uF Elko nicht auf dem +5V Zweig.

Ich denke auch das der sich als Puffer für die 5V gut machen würde.

Offline TheNameOfTheGame

  • Benutzer
  • Beiträge: 57
  • Almost Heaven, West Virginia
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #113 am: Mo 21.01.2019, 01:42:14 »
Es ist alles gut. Das System ist stabil. Die Netzteil Spannung ist stabil. Nur ein paar Pixel hier und da verloren gehen.  Dies ist ein spaß Experiment während des kalten Winter.  :)

Ich werde die 10k-Pullups ersetzen und ein kürzeres Flachbandkabel verwenden.

Vielen Dank für die Hilfe und Ihre VoFa-Adapter ist sehr gut!

Offline TheNameOfTheGame

  • Benutzer
  • Beiträge: 57
  • Almost Heaven, West Virginia
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #114 am: Sa 26.01.2019, 01:59:32 »
Ok, 15cm Flachbandkabel macht ein perfektes Bild hier.  Keine verlorenen Pixels.  :)

Nächstes muss ich die 10K Pull-ups veränderung und dann überprüfen ob das original Flachbandkabel mit keine verlorenen Pixels funktioniert.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #115 am: Sa 26.01.2019, 09:09:46 »
Ich denke wenn die 10k Pullups auf 4,7k oder 3,3k runter sind kann man die Kabel wieder etwas länger machen.

Offline TheNameOfTheGame

  • Benutzer
  • Beiträge: 57
  • Almost Heaven, West Virginia
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #116 am: So 27.01.2019, 19:27:31 »
Ich habe die Pull-ups für Adressbus und Datenbus geändert.
Adressbus - 2.2K
Datenbus - 4.7k



Hilft nicht, die verlorenen Pixel und Farbverschiebung mit dem original Flachbandkabel.  :(  Mit dem 15cm Flachbandkabel ist alles gut.

Mit dem PuPla/2 unter dem VoFa-Adapter und dem originalen Flachbandkabel und neuen Pull-ups ... ist alles gut.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #117 am: So 27.01.2019, 19:47:08 »
Das liegt/hängt auch immer mit der verwendeten ISA ET4000 Grafikkarte ab.

Aber wenn die PuPla das Problem behebt ist ja alles gut.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.011
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: VOFA ET4000 Grafikadapter für Mega ST Bus Platinen Projekt ...
« Antwort #118 am: Fr 15.03.2019, 14:56:52 »
Habe zum probieren mal über einen halben Meter Flachbandkabel zwischen VOFA Hauptplatine und ISA Bus Platine eingesteckt ohne Probleme. Das hängt aber auch ein wenig von der Qualität der Grafikkarte ab.