Autor Thema: c´t IDE Interface ...  (Gelesen 9085 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
c´t IDE Interface ...
« am: Di 08.03.2016, 14:01:03 »
Habe mir den Artikel von Heise gekauft aber leider ist die Qualität der Scans so schlecht das man rein garnichts beim Schaltplan erkennen kann.

Hat jemand die Ausgabe und kann mal den Schaltplan in 300dpi einscannen ?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #1 am: Di 08.03.2016, 19:07:34 »
Habe mal das IDE Listing aus der c´t mit JEDI übersetzt. Ich musste nur die Klammern auflösen da JEDI das wohl nicht versteht ...

// 16.04.93 Kai Scheffer
// 20.06.93 Kai Scheffer Pinbelegung gem„ž c't Layout abge„ndert

GAL-Listing fr IDE-Platten-Adapter am ATARI ST (c't 9/93)

IDE-Register $F00000 bis $F1FFFF
ROM-Breich   $E00000 bis $EFFFFF und ROM2-Select

Erzeugung von:
/DTACK  zum Atari
/CS0            geht zur IDE-Platte Pin 37
/CS1            geht zur IDE-Platte Pin 36
/IORD   geht zur IDE-Platte Pin 25
/IOWR           geht zur IDE-Platte Pin 23
/G                      Enable-Signal fr die Datenbustreiber (2x74HCT245)
/INT    Interrupt-Signal zum Atari (DMA-Port Pin 10)

*IDENTIFICATION
 IDE_ST;
 
*TYPE
 GAL20V8;
 
*PINS
 /AS = 3,
 RW = 5,
 A5 = 1,
 /ROM2 = 2,
 A17 = 6,
 A18 = 7,
 A19 = 9,
 A20 = 8,
 A21 = 10,
 A22 = 11,
 A23 = 13,
 /LDS = 4,
 /IOCHRDY = 14,
 IRQ14 = 23,

 /INT.T = 19,
 /TOS.T = 20,
 /IOWR.T = 22,
 /IORD.T = 21,
 /G.T = 16,
 /CS1.T = 18,
 /CS0.T = 17,
 /DTACK.T = 15;
 
*BOOLEAN-EQUATIONS

TOS.E    = VCC;
IOWR.E   = VCC;
IORD.E   = VCC;
G.E      = VCC;
CS1.E    = VCC;
CS0.E    = VCC;

  INT.E    = IRQ14;
  INT      = IRQ14;

DTACK    = /A17 & /A18 & /A19 & A20 & A21 & A22 & A23
   + TOS;

  DTACK.E  = /IOCHRDY & AS & /A19 & A21 & A22 & A23;
     
CS0      = /A5 & /A17 & /A18 & /A19 & A20 & A21 & A22 & A23;

CS1      =  A5 & /A17 & /A18 & /A19 & A20 & A21 & A22 & A23;

G        = LDS & RW & /A17 & /A18 & /A19 & A20 & A21 & A22 & A23
+      /RW & /A17 & /A18 & /A19 & A20 & A21 & A22 & A23;
 
IORD     = LDS &  RW & CS0 + LDS &  RW & CS1;
     
IOWR     = LDS & /RW & CS0 + LDS & /RW & CS1 + LDS & /RW & TOS; % Signal TOS wegen EEPROMs %

TOS      = ROM2
   + AS & A23 & A22 & A21 & /A20 & /A19;

*END



Jetzt fehlt mir nur noch der Schaltplan zum Interface aus der (Allesfresser) c't 09/1993 ...
« Letzte Änderung: Di 08.03.2016, 20:34:21 von Lukas Frank »

Offline czietz

  • Benutzer
  • Beiträge: 1.813
Re: c´t IDE Interface ...
« Antwort #2 am: Di 08.03.2016, 19:17:29 »
Du könntest -- zumindest, um zu sehen, was passiert -- beim Heise-Verlag reklamieren. Immerhin hast Du für einen Artikel mit lesbaren Grafiken bezahlt.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #3 am: Di 08.03.2016, 19:33:34 »
Habe mal jemanden gefragt, wenn das nichts ergibt kann ich das mal machen. Ich vermute mal das die c´t Jahrgang DVD auch nicht besser ist ...

Offline tuxie

  • Benutzer
  • Beiträge: 6.165
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: c´t IDE Interface ...
« Antwort #4 am: Di 08.03.2016, 19:39:58 »
Ich bezweifel das die diese Alten Ausgaben in besserer Qualität haben. Hab das auch schonmal gekauft und sehr unleserlich.
Tschau Ingo


PC Intel i7 4820, 16gb quad @2400,Mac OS X El Capitan
http://tuxie.de http://hwbot.org/user/tuxie/

Online Arthur

  • Benutzer
  • Beiträge: 7.566
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: c´t IDE Interface ...
« Antwort #5 am: Di 08.03.2016, 19:40:26 »
Habe mal jemanden gefragt, wenn das nichts ergibt kann ich das mal machen. Ich vermute mal das die c´t Jahrgang DVD auch nicht besser ist ...

Ja die sind genau so bescheiden... das betrifft die Jahrgänge 1990-2003 davor sind es PDF und danach meine ich, sind es auch wieder PDF.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #6 am: Di 08.03.2016, 19:49:23 »
PDF ist doch in Ordnung aber es sieht so aus als ob die Bilder 10dpi Scans sind und die größeren Bild Dateien die beiliegen sind genau so schlecht. Da kann man keine Zahl oder Buchstaben lesen/erkennen ...

Online Arthur

  • Benutzer
  • Beiträge: 7.566
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: c´t IDE Interface ...
« Antwort #7 am: Di 08.03.2016, 20:01:18 »
Die PDFs sind gut... wie eine original C't nur als PDF... aber der HTML-Dreck von 1990-2003 geht gar nicht... :-[

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #8 am: Mi 09.03.2016, 19:52:57 »
Habe den Scan in guter Qualität, löte das Teil auch schon zusammen ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #9 am: Fr 11.03.2016, 21:57:32 »
Das Interface läuft aber macht noch Probleme. Ich habe keine HCT244/245 und habe nur F244 und LS244 sowie LS245. Mit den LS Treibern in den Datenleitungenn läuft es nicht, habe deshalb Brücken gesteckt. Mit dem F244 läuft es nicht richtig, der LS244 geht so allerdings lassen sich nur kleine Programme starten incl. dem HDDriver.sys im Rootverzeichnis auf C:\ also bootet der Rechner die CF einwandfrei. Habe jetzt erstmal bei Kessler die fehlenden Bausteine bestellt. Vielleicht liegt es aber doch am GAL ?


Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #10 am: Sa 12.03.2016, 12:14:47 »
Das ist schon ein sehr schönes Teil. Vielleicht überwinde ich mich mal versuche mich doch mal an einer Platine in Eagle, mal schauen ...

Offline czietz

  • Benutzer
  • Beiträge: 1.813
Re: c´t IDE Interface ...
« Antwort #11 am: Sa 12.03.2016, 12:28:09 »
Sind die Treiber-ICs denn jetzt da? Oder läuft's ohne Treiber stabil?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #12 am: Sa 12.03.2016, 12:40:26 »
Nein, noch nicht da aber ich bin zuversichtlich.

Alles unter 30kB läuft, da ist bestimmt eine minimale Verzögerung wenn erst die Treiberbausteine umgeschaltet werden über das G Signal, keine Ahnung. Seltsamerweise läuft es gar nicht wenn ich die Signale am 244 Brücke, mit Baustein alles gut ...

Offline skul

  • Benutzer
  • Beiträge: 224
Re: c´t IDE Interface ...
« Antwort #13 am: So 13.03.2016, 22:32:03 »
Moin,

auf den Treiber für die Steuersignale (244) kann man nicht verzichten. Wenn sonst nicht gerade zwanzig Erweiterungen am Datenbus hängen, kann man auf die bidirektionalen Treiber verzichten. Ich hatte auch mit Pak3 und Romportkram ohne die 245er keine Probleme.
Auf- und Umrüstung von STs auf TOS2.06, HD-Floppy und IDE-Port: Ein Gal 20v8, zwei Eproms, ein Treiber 244, Pfostenleiste 40pol (oder 44), etwas Draht - fertig. Hab davon bestimmt 30-40 Stück gebaut, alles ohne Probleme. Eine Platine kam oft nicht in Frage, weil bei einigen 1040ern die CPU vorn am Rand unter der Tastatur liegt. Geht eh nicht und die freie Verdrahtung dauert nicht wirklich länger als der Platineneinbau (war auch 'ne Kostenfrage :-)).

Gruß
skul
 

Gruß

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #14 am: Do 17.03.2016, 14:34:51 »
Die Kessler Bauteile sind da und mit dem HCT244 läuft das Interface jetzt einwandfrei.

Allerdings funktioniert es nicht mehr wenn die beiden HCT245 Treiber für die Datenleitungen einsetze. Habe auch noch ein anderes JED File von skul bekommen aber mit beiden das gleiche verhalten. Wenn die Schaltung in Ordnung ist muss da ein Fehler beim GAL sein ...

Ich bin erstmal froh das es so jetzt funktioniert.

Online Arthur

  • Benutzer
  • Beiträge: 7.566
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: c´t IDE Interface ...
« Antwort #15 am: Do 17.03.2016, 16:13:08 »
Moin,

auf den Treiber für die Steuersignale (244) kann man nicht verzichten. Wenn sonst nicht gerade zwanzig Erweiterungen am Datenbus hängen, kann man auf die bidirektionalen Treiber verzichten. Ich hatte auch mit Pak3 und Romportkram ohne die 245er keine Probleme.

Bietet den so ein Treiber nicht auch einen Schutz für die CPU oder so?

Die Kessler Bauteile sind da und mit dem HCT244 läuft das Interface jetzt einwandfrei.

Allerdings funktioniert es nicht mehr wenn die beiden HCT245 Treiber für die Datenleitungen einsetze. Habe auch noch ein anderes JED File von skul bekommen aber mit beiden das gleiche verhalten. Wenn die Schaltung in Ordnung ist muss da ein Fehler beim GAL sein ...

Ich bin erstmal froh das es so jetzt funktioniert.

Hallo Frank, klasse Leistung... ein Benchmark mit Howfast wäre noch interessant.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #16 am: Do 17.03.2016, 16:33:34 »
Was soll da schneller oder langsamer sein. Meine MonSTer kommt auf 1290kb und das c´t Interface ist genau so schnell, um genau zu sein auf 1300kB. Ich habe noch kein IDE Interface gesehen das da auf einem normalen ST von ausbricht. Die SCSI Platte mit dem Hostadapter von Wolfgang Förster ist genau so schnell, das bedeutet wohl das man da nicht mehr heraus bekommt.


Bietet den so ein Treiber nicht auch einen Schutz für die CPU oder so?

Wieso Schutz? Der Romport oder wenn man eine Erweiterung auf die CPU setzt ist da auch nichts geschützt. Was ich mir vorstellen kann ist das man vielleicht extrem lange IDE Kabel benutzen kann. Aber wer braucht das schon. Wäre natürlich trotzalledem schön wenn das Interface mit den beiden Treibern laufen würde ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #17 am: Do 30.06.2016, 12:30:09 »
Die beiden 245iger Treiber funktionieren nicht ...

Ich hatte damals so ein Interface von eMedia oder wie der Vertriebsladen von Heise hieß und da funktionierte alles wunderbar.

Ich gehe mal stark davon aus das der Schaltplan richtig ist und der Fehler in der Quelldatei zum GAL liegt. Das stammt irgendwie aus dem Netz. Das Interface funktioniert ohne die beiden Treiber wunderbar mit einem Master und einem Slave Device.

Hat jemand eine Idee wegen dem GAL ?

Die GAL Quelldatei ist im zweiten Beitrag ...

Offline tuxie

  • Benutzer
  • Beiträge: 6.165
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: c´t IDE Interface ...
« Antwort #18 am: Do 30.06.2016, 13:19:47 »
Hallo Frank, ich hab das interface jetzt mit einem cpld nachgebildet, hab ein dev board bestellt aber ist noch nicht da. Dort hab ich alle datenleitungen mit durch den cpld geschleusst so das keine bustreiber notwendig sind. ich berichte wenn ich gegestet habe.
Tschau Ingo


PC Intel i7 4820, 16gb quad @2400,Mac OS X El Capitan
http://tuxie.de http://hwbot.org/user/tuxie/

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.431
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: c´t IDE Interface ...
« Antwort #19 am: Do 30.06.2016, 13:42:55 »
Hallo Ingo, ich will/möchte das ja so weit original mit dem 20V8 aufbauen. Das hilft mir das da doch bestimmt nicht weiter, oder ?

Ich könnte mir Vorstellen das es verschiedene Versionen des GALs gab und diese nicht ganz funktionierende irgendwie im Netz gelandet ist. Den original Autor ausfindig machen und vielleicht kann er helfen wäre vielleicht was ...

Das GAL Listing steht doch gar nicht im Artikel, oder ?