Autor Thema: Aufbau Mega4000 Grafikkarten Adapter ...  (Gelesen 41639 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #20 am: So 13.09.2015, 17:22:35 »
Wenn man so ein PicoPSU verwendet und den Blechträger etwas anpasst kann man die Platine zum Mega4000 Adapter so benutzen wie sie ist ...



Ich ziehe jetzt erst mal um und habe in den nächsten Wochen keine Zeit mich um meine eignene Mega4000 zu kümmern.
« Letzte Änderung: So 13.09.2015, 21:47:35 von Lukas Frank »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #21 am: Di 15.09.2015, 22:54:43 »
Ich würde vielleicht dazu Raten die Platine erstmal ganz zu lassen, aufzubauen und zu Testen. Das Netzteil kann man etwas zur Seite auslagern. Wenn alles einwandfrei läuft überlegt man sich was man macht wegen dem Netzteil und dem Blechträger dazu. Entweder man kürzt die Platine mit Hilfe eines Schleifbocks ganz vorsichtig ein oder man baut um auf ein PicoPSU ...

Offline Baert

  • Benutzer
  • Beiträge: 155
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #22 am: Do 17.09.2015, 20:53:28 »
Bei mir ist ebenfalls der Umschlag angekommen  :)
Gerade habe ich per PayPal noch für die Gals nachgeschossen.
Wie schaut es wohl an der Grafikkarten-Front aus, hast Du
vielleicht nun noch eine für mich übrig? Muß nicht sofort sein!
mfG, Baert
Mega ST/E, MiSTer, Falcon

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #23 am: Do 17.09.2015, 20:56:54 »
Ich ziehe zur Zeit um und habe da keinen Kopf und Ruhe für ...

Ich habe so 10 ET4000 Karten aber noch keinen Mega4000 Adapter zusammen der läuft. Will die Karten auch erstmal in einem PC ISA Mainboard testen um zu schauen ob die Karten überhaupt in Ordnung sind.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #24 am: Mo 02.11.2015, 19:38:12 »
Hatte jetzt etwas Zeit und habe gestern Abend mal eine Karte ohne diese einzukürzen aufgebaut. Ich habe mit einer Cardek ET4000 Karte getestet. Das VMG Programm vom NVDI 4.11 ET4000 sagt es wäre keine Grafikkarte ansprechbar und die Version des VMG Programmes aus dem Mega4000 Paket meckert zwar nicht das keine Karte da wäre aber bringt kein Bild und der Frequenztest läuft Stundenlang ohne das der Rechner noch reagiert.

Habe mal alle Verbindungen unter einer Lupe angesehen und teilweise nachgelötet. Die Platine ist schon schwer zu löten aber es geht. Habe auch Flußmittel verwendet.

Habe mich heute nochmal hingesetzt und den Schaltplan überarbeitet, der alte war ziemlich schlecht und um die GALs viel zu klein und unübersichtlich. Ein PDF ist bei den Dateianhängen ...




Ich komme auch mit Tempelmon nicht zurecht. Wenn ich die Adresse aus der Anleitung eingebe mit dem Wert kommt immer die Fehlermeldung das die Endadresse größer als die Anfangsadresse ist !?!

-----------------------------------------------------------------------
:FF03C3 01   ; Video Subsystem Enable, Address $03B0
:FF03BF 03   ; Herkules Comp. Register, KEY setzen
:FF03D8 A0   ; Display Mode Control, KEY setzen
:FF03D4 36   ; CRTC Index -> Select CRTC Reg. $36
:FF03D5 F1   ; Video System Configuration 1, 16Bit I/O, 16Bit MEM,
             ; Memory contiguous
Befehle für TEMPLMON, die Kommentare ab den ";" werden natürlich nicht
eingegeben...
Mit Schreibzugriffen auf $FF03D4 sollten sich jetzt Werte von $00 bis $3F
schreiben und so auch wieder lesen lassen.

:FF03D4 15   ; CRTC Index -> Select CRTC Reg. 15
:FF03D5 xx   ; Vertical Blank Start Bit 0-7
Mit Schreib-/Lesezugriffen auf $FF03D5 sollten sich jetzt Werte von
$00-$FF schreiben und so auch wieder lesen lassen.
-----------------------------------------------------------------------

Brauche beim Tempelmon Hilfe von jemanden der sich damit auskennt ...
« Letzte Änderung: Mo 02.11.2015, 19:40:44 von Lukas Frank »

Offline czietz

  • Benutzer
  • Beiträge: 2.574
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #25 am: Mo 02.11.2015, 20:19:58 »
Die Syntax für die Tempelmon-Befehle ist grundsätzlich richtig. (Ich nehme an, Du gibst den führenden Doppelpunkt auch ein und den Kommentar inkl. Semikolon nicht.)

Welche Tempelmon-Version benutzt Du denn?

PS: Weiß jemand, ob die "ausführliche Anleitung", die man damals zu Tempelmon erwerben konnte, irgendwo verfügbar ist?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #26 am: Mo 02.11.2015, 20:24:27 »
Habe nur FF03C3 01 eingegeben ...

Der Doppelpunkt steht da ja schon, oder ?

-> http://www.tempel.org/main-d.html

Nutze Version 2.01 ...

Offline neogain

  • Benutzer
  • Beiträge: 1.251
  • ...?
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #27 am: Mo 02.11.2015, 20:38:03 »
Ich verfolge mal deinen Aufbau gespannt weiter, Lukas. Hab bis jetzt mir nur mal die 2 Gals gebrannt, wobei das wohl auch sinnlos ist (kann ja sein, dass ich eine ET4000 erwische, für das die Gals dann nicht korrekt sind.

Naja, suche noch eine ET4000 Grafikkarte, ohne aufzubauen macht keinen Sinn. Letzte Woche hatte ich beim Wertstoffhof ein uraltes gehäuse gefunden. Hab nur die Rückseite angeschaut und das ding direkt ins auto getragen. Altes AT Gehäuse, DIN Tastaturstecker...

Leider war das Innenleben ein Pentium -S mit 100Mhz, Cirrius Logic Grafikkarte (vermtl. S3?) ne Dlink 10/100Mbit Netzwerkkarte und 4x8MB PS/2 Ram. AT Netzteil funktionierte auch noch, so dass die Krücke tatsächlich noch lief.

Naja, wird auf jeden Fall wieder zurückgebracht :)

Offline czietz

  • Benutzer
  • Beiträge: 2.574
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #28 am: Mo 02.11.2015, 20:39:29 »
Habe nur FF03C3 01 eingegeben ...

Der Doppelpunkt steht da ja schon, oder ?

-> http://www.tempel.org/main-d.html

Nutze Version 2.01 ...

Da steht ein "!" als Prompt, den Doppelpunkt musst Du selbstverständlich mit eingeben. Das ist ja gerade der Befehl, um eine Speicherstelle zu beschreiben.

Edit: Da die Version, die Du oben verlinkst, offenbar komplett ohne Anleitung daherkommt, noch ein Tipp. Laut Anleitung sollst Du ja auch Speicherstellen/Register lesen. Das wäre dann "m Adresse".

« Letzte Änderung: Mo 02.11.2015, 21:07:47 von czietz »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #29 am: Mo 02.11.2015, 21:01:41 »
Naja, suche noch eine ET4000 Grafikkarte ...

Ich habe noch so um die 10 Stück (oder mehr !?!) ET4000 ISA Karten. Vier von den Teilen laufen in einem PC, die anderen nicht. Allerdings fehlen da teilweise die VGA ROMs, die der Atari ja gar nicht braucht. Eigentlich sollten die alle irgendwie laufen ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #30 am: Mo 02.11.2015, 21:23:32 »
Da steht ein "!" als Prompt, den Doppelpunkt musst Du selbstverständlich mit eingeben. Das ist ja gerade der Befehl, um eine Speicherstelle zu beschreiben.

Danke, das hätte ich nie im Leben geschnallt !

Schreibe mal was ich genau eingeben muss zum Lesen der Speicherstellen.


Das bekomme ich, diese seltsamen Zeichen am Ende der jeweiligen Eingabe Zeile wenn ich Return drücke ...

« Letzte Änderung: Mo 02.11.2015, 21:25:08 von Lukas Frank »

Offline czietz

  • Benutzer
  • Beiträge: 2.574
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #31 am: Mo 02.11.2015, 21:33:21 »
Die "komischen Zeichen" sind einfach die Darstellung des jeweiligen Bytes als ASCII (naja, Atari-Zeichensatz). Das ist schon OK so.

Um z.B. ein Byte von der Adresse 0xFF03D4 zu lesen, musst Du

m FF03D4

eingeben.

Leider hast Du eine Tempelmon-Version ohne Anleitung erwischt. Die (ältere) Version, die ich habe, zeigt bei Eingabe von "?" wenigstens die wichtigsten Kommandos. Der Rest steht auch dort nur in der kostenpflichtigen Anleitung, die ich gerne hätte.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #32 am: Mo 02.11.2015, 21:48:45 »
Vielen Dank für deine Hilfe ...

Ja eine Anleitung wäre schon Hilfreich. Vielleicht hat hier aus dem Forum ja jemand eine und macht sich die Arbeit und scannt das Werk mal ein ...

Offline tuxie

  • Benutzer
  • Beiträge: 6.601
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #33 am: Mo 02.11.2015, 21:56:45 »
Hallo Frank,

welche ET4000 Karten hast du? Es gehen leider nicht alle Grafikkarten am ST. Bei mir liefen damals von 5 Grafikkarten die ich damals hatte nur 3. Weiß aber nicht mehr welche das waren.
Tschau Ingo


PC Intel i7 4820, 16gb quad @2400,Mac OS X El Capitan
http://tuxie.de http://hwbot.org/user/tuxie/

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #34 am: Mo 02.11.2015, 22:06:28 »
Das kommt auch auf den Adapter drauf an, was läuft und was nicht. Und natürlich auf den RAMDAC.

Hatte damals einen VOFA Adapter und da lief fast nichts mit.

Meine Cardek muss laufen da die bei dem Projekt neben der ColorMaster+ angegeben ist. Wenn der Adapter mal laufen sollte kann ich die anderen Karten testen.

Keine Ahnung was für Karten ich habe, da steht nichts drauf. Ich denke die meisten Musterdesign von TSENG ...

Offline Arthur

  • Benutzer
  • Beiträge: 9.382
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #35 am: Di 03.11.2015, 17:33:33 »
Vielleicht postet ihr hier einfach erfolgreich getestete Exemplare (ET4000 Karten) direkt als Foto.
« Letzte Änderung: Di 03.11.2015, 18:56:15 von Arthur »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #36 am: Di 03.11.2015, 17:45:53 »
Klar aber der Adapter muss ja erstmal laufen. Ich vermute der läuft noch nicht richtig bei mir ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.662
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #37 am: Di 03.11.2015, 18:20:37 »
Also irgendwie ist da etwas da ...

"mFF03D5" gibt ein FF zurück ohne alles auch wenn ich zuvor ":FF03D5 F1" eingegeben habe kommt ein FF

Wenn der Adapter nicht im Rechner ist kommt ein Buserror, soweit so gut ...


Mit welchem Befehl kann ich schreiben oder ist das ":" und Lesen mit "m" ?

Offline czietz

  • Benutzer
  • Beiträge: 2.574
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #38 am: Di 03.11.2015, 18:51:04 »
Ja, schreiben ist

:Adresse Byte

also z.B.

:FF03D5 00 

Lesen ist

m Adresse

also z.B.

m FF03D5

Beachte aber, dass sich die VGA- bzw. CRTC-Register (mit denen spielst Du da gerade herum) teilweise "seltsam" verhalten. D.h. es lassen sich nicht alle zurücklesen. Kannst Du denn ganz am Ende der Anleitung nach dem ":FF03D4 15", Werte die Du danach in FF03D5 schreibst wieder auslesen?

Offline czietz

  • Benutzer
  • Beiträge: 2.574
Re: Aufbau Mega4000 Grafikkarten Adapter ...
« Antwort #39 am: Di 03.11.2015, 18:54:12 »
Wenn der Adapter nicht im Rechner ist kommt ein Buserror, soweit so gut ...

PS: Das heißt nur, dass das GAL das /DTACK-Signal generiert. Ob die Seite zur Grafikkarte hin funktioniert, siehst Du letztendlich nur mit Scope und/oder Logic-Analyzer.