Autor Thema: Lightning VME - USB für den MegaSTE und TT  (Gelesen 26432 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline ari.tao

  • Benutzer
  • Beiträge: 2.240
  • a tha yo ga a nu sha sa nam
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #360 am: Sa 09.06.2018, 11:24:02 »
Bloß nix verkünsteltes, wofür man erst mal wieder ein rtfm braucht!
Falcon+ddd32MHz, TT+CrazyDotsGK und noch ein paar andere.

Offline ari.tao

  • Benutzer
  • Beiträge: 2.240
  • a tha yo ga a nu sha sa nam
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #361 am: Sa 09.06.2018, 11:30:09 »
Selbstverständlich als Laufwerk A:, bootfähig.
Als Ersatz für ein vorhandenes Floppy.
Nachteil: Man müsste das Gehäuse bearbeiten. Ich stelle nachher mal ein Bild hier ein. Habe es bei mir gemacht.
Könnte man das TEAC FD-CR7 zB. am TT auch als Laufwerk B betreiben?
Wo ist das Bild?
« Letzte Änderung: Sa 09.06.2018, 11:31:51 von ari.tao »
Falcon+ddd32MHz, TT+CrazyDotsGK und noch ein paar andere.

Offline czietz

  • Benutzer
  • Beiträge: 2.182
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #362 am: Sa 09.06.2018, 13:47:11 »
Noch eine Neuigkeit: Ich habe das uip-tool portiert, um die Asix USB2LAN-Adapter an der Lightning VME unter Plain TOS nutzbar zu machen. (Unter MiNTNet wurden diese Adapter schon vorher unterstützt.) Wie Ihr vermutlich wisst, erlaubt das uip-tool, Dateien über Netzwerk vom Atari bzw. auf den Atari zu kopieren.

Ihr könnt meinen Port des uip-tool (inkl. Source Code) hier finden: https://bitbucket.org/czietz/uip-tools/downloads/. Ich habe es mit einer Lightning VME am Atari TT getestet und ca. 130 kByte/s Downloadrate erreicht. Bitte lest den Thread des Autors von uip-tool, wenn Ihr genauer wissen wollt, wie es funktioniert: http://atari-forum.com/viewtopic.php?f=14&t=27365. Auch sind alle Fragen, die nicht die USB-Unterstützung betreffen, besser dort aufgehoben.

Auch wenn das Programm bei meinen Tests stabil lief, betrachtet es bitte als "Proof of Concept" oder Beta-Version.

Offline 1ST1

  • Benutzer
  • Beiträge: 8.637
  • Sehr langer Urlaub.
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #363 am: Sa 09.06.2018, 21:23:00 »
Bleibt noch die Microsoft-Methode: auf wechselbaren Medien einfach nur eine einzige Partition zulassen.

Bei CF/SD Karten wäre es etwas, womit man eventuell leben könnte.

Bei über USB angebundenen SD/CF hab ich da auch nichts dagegen. Die sind ja vor allem für den Datenaustausch gedacht, und da reicht das.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline 1ST1

  • Benutzer
  • Beiträge: 8.637
  • Sehr langer Urlaub.
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #364 am: Sa 09.06.2018, 21:26:23 »

Ist das betreffende Laufwerk schon belegt, gibt es eine Fehlermeldung und es passiert nichts weiter.
Nein. In dem Fall ein anderer Laufwerksbuchstabe. Es wäre dann zu diskutieren, ob das System diese Karte dann auch wieder unter dem neuen Buchstaben bereitstellt, oder wieder unter dem Alten, wenn das andere Medium nicht mehr da ist.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline Arthur

  • Benutzer
  • Beiträge: 8.824
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #365 am: So 10.06.2018, 00:00:00 »
Noch eine Neuigkeit: Ich habe das uip-tool portiert, um die Asix USB2LAN-Adapter an der Lightning VME unter Plain TOS nutzbar zu machen. (Unter MiNTNet wurden diese Adapter schon vorher unterstützt.) Wie Ihr vermutlich wisst, erlaubt das uip-tool, Dateien über Netzwerk vom Atari bzw. auf den Atari zu kopieren.

Ihr könnt meinen Port des uip-tool (inkl. Source Code) hier finden: https://bitbucket.org/czietz/uip-tools/downloads/. Ich habe es mit einer Lightning VME am Atari TT getestet und ca. 130 kByte/s Downloadrate erreicht. Bitte lest den Thread des Autors von uip-tool, wenn Ihr genauer wissen wollt, wie es funktioniert: http://atari-forum.com/viewtopic.php?f=14&t=27365. Auch sind alle Fragen, die nicht die USB-Unterstützung betreffen, besser dort aufgehoben.

Auch wenn das Programm bei meinen Tests stabil lief, betrachtet es bitte als "Proof of Concept" oder Beta-Version.

Hallo Christian, erst mal vielen Dank dafür. Ist das so zu verstehen das auf einem nackten Atari MSTE oder TT nur das UIPTOOL ausreicht, wie beim Original, also keine weiteren Treiber mehr notwendig sind?

Ist die uip-1.0-changelog.txt bei dem sourecode von Dir?

Offline czietz

  • Benutzer
  • Beiträge: 2.182
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #366 am: So 10.06.2018, 09:05:41 »
Hallo Christian, erst mal vielen Dank dafür. Ist das so zu verstehen das auf einem nackten Atari MSTE oder TT nur das UIPTOOL ausreicht, wie beim Original, also keine weiteren Treiber mehr notwendig sind?

USB.PRG und BLITZ*.PRG müssen weiterhin geladen sein, d.h. ein USB-Stack wird schon vorausgesetzt.

Ist die uip-1.0-changelog.txt bei dem sourecode von Dir?

Nein, das ist das Changelog von uip (nicht von uip-tool!). uip ist der TCP/IP-Stack, den der Autor von uip-tool für seine Implementierung genommen hat. Du kannst übrigens im Source-Code sehen, was von mir ist: Alles was unter https://bitbucket.org/czietz/uip-tools/src/master/ älter als von gestern ist, ist nicht von mir erstellt oder modifiziert.

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #367 am: Fr 22.06.2018, 19:32:45 »
Hallo zusammen,

bei der Fehlersuche an meinem MSTE ist mir aufgefallen, dass wenn ich unter MagiC 5.20 das STORAGE.PRG (Treiberpaket 1.20)  der Lightning VME boote, Partitionen über 512MB auf den SD-Karten in der UltraSatan nicht mehr angesprochen werden können - "Ungültiges Laufwerk, Fehler #-46"
Benenne ich das STORAGE.PRG in PRX um und starte den MSTE neu, sind die Partitionen wieder da.

1. SD-Karte in der US: C-511,9MB / D-511,9MB / E-511,9MB / F-511,9MB
2. SD-Karte in der US: G-1999MB / H-1999MB / I-1999MB / J-1999MB

Der 1GB USB Stick an der Lightning (2 Partitionen) funktioniert problemlos wenn STORAGE.PRG geladen ist.

Hab ich da was übersehen?

Ach ja - setze HDDRIVER 10.12 auf dem MSTE ein.
« Letzte Änderung: Fr 22.06.2018, 19:35:00 von DonQuichote »

Offline Arthur

  • Benutzer
  • Beiträge: 8.824
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #368 am: Fr 22.06.2018, 19:52:47 »
Welche Programme und in welcher Reihenfolge sind in AUTO?

Die 2GB sind alle BGM Partitionen?

Offline czietz

  • Benutzer
  • Beiträge: 2.182
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #369 am: Fr 22.06.2018, 19:58:46 »
Ich habe eine Idee, was das sein könnte. Kannst Du bitte das alte STORAGE.PRG aus dem Rev.-102-Treiberpaket (unten auf: http://www.newtosworld.de/downloads/treiber/lightning-vme) unter MagiC testen und sagen, ob das Problem damit behoben ist?

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #370 am: Fr 22.06.2018, 20:25:21 »
Der Download Button bei der 102 funktioniert bei mir nicht.

Offline czietz

  • Benutzer
  • Beiträge: 2.182
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #371 am: Fr 22.06.2018, 20:31:16 »

Offline Arthur

  • Benutzer
  • Beiträge: 8.824
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #372 am: Fr 22.06.2018, 20:37:10 »
Sollte jetzt wieder gehen. 8)

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #373 am: Fr 22.06.2018, 20:37:32 »
Welche Programme und in welcher Reihenfolge sind in AUTO?

Nur Magicboot und die Lightning Treiber in richtiger Reihenfolge. Jungfräuliche Installation.

Die 2GB sind alle BGM Partitionen?

Nein. HDDRUTIL hat partitioniert, zeigt $06 als Typ an.
Eine weitere 1GB Karte mit einer 999MB Partition ist BGM. Die wird aber auch nicht erkannt.



Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #374 am: Fr 22.06.2018, 20:46:40 »
Ich habe eine Idee, was das sein könnte. Kannst Du bitte das alte STORAGE.PRG aus dem Rev.-102-Treiberpaket (unten auf: http://www.newtosworld.de/downloads/treiber/lightning-vme) unter MagiC testen und sagen, ob das Problem damit behoben ist?

Jepp, mit der 102 STORAGE.PRG gehts, alles da! Danke!

Muss ich mit der 102 was beachten?

Offline czietz

  • Benutzer
  • Beiträge: 2.182
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #375 am: Fr 22.06.2018, 21:00:06 »
Danke, dann weiß ich, was der Fehler ist. Rev. 102 fehlen einige Funktionen, wie z.B. Floppy-Unterstützung.

Daher ist hier ist ein STORAGE.PRG mit allen Features der Rev. 120, aber ohne den Fehler. (Wie üblich, bitte von .prg.pdf in .prg umbenennen.) @DonQuichote: Ich würde mich freuen, wenn Du auch dieses kurz testen und berichten könntest.
« Letzte Änderung: Fr 22.06.2018, 21:02:15 von czietz »

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #376 am: Fr 22.06.2018, 21:04:07 »
Danke, dann weiß ich, was der Fehler ist. Rev. 102 fehlen einige Funktionen, wie z.B. Floppy-Unterstützung.

Daher ist hier ist ein STORAGE.PRG mit allen Features der Rev. 120, aber ohne den Fehler. (Wie üblich, bitte von .prg.pdf in .prg umbenennen.) @DonQuichote: Ich würde mich freuen, wenn Du auch dieses kurz testen und berichten könntest.

Bin schon dabei.

Offline Arthur

  • Benutzer
  • Beiträge: 8.824
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #377 am: Fr 22.06.2018, 21:17:23 »
Danke, dann weiß ich, was der Fehler ist. Rev. 102 fehlen einige Funktionen, wie z.B. Floppy-Unterstützung.

Daher ist hier ist ein STORAGE.PRG mit allen Features der Rev. 120, aber ohne den Fehler. (Wie üblich, bitte von .prg.pdf in .prg umbenennen.) @DonQuichote: Ich würde mich freuen, wenn Du auch dieses kurz testen und berichten könntest.

Die MiNT TT-Treiber ist OK?

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #378 am: Fr 22.06.2018, 21:34:27 »
Daher ist hier ist ein STORAGE.PRG mit allen Features der Rev. 120, aber ohne den Fehler. (Wie üblich, bitte von .prg.pdf in .prg umbenennen.) @DonQuichote: Ich würde mich freuen, wenn Du auch dieses kurz testen und berichten könntest.

Test mit der fehlerbereinigten STORAGE.PRG ist erfolgreich, funktioniert!

Alle Laufwerke sind da. Sowohl die 1GB SD Karte (999MB, BGM) als auch die 8GB Karte (4x 1999MB, $06) sind ansprechbar. Sieht gut aus!

Offline czietz

  • Benutzer
  • Beiträge: 2.182
Re: Lightning VME - USB für den MegaSTE und TT
« Antwort #379 am: Fr 22.06.2018, 21:48:21 »
Die MiNT TT-Treiber ist OK?

Ja, es war ein Problem mit einem Workaround, den ich speziell für MagiC einbauen musste, und somit natürlich nur in STORAGE.PRG. Nächste Woche packe ich das Update auch in den Downloadbereich von newtosworld.

Test mit der fehlerbereinigten STORAGE.PRG ist erfolgreich, funktioniert!

Danke für die Rückmeldung.