Autor Thema: DMA-Fehler / 2 Bomben / Festplatten-Crash  (Gelesen 2590 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

rainers

  • Gast
DMA-Fehler / 2 Bomben / Festplatten-Crash
« am: Sa 02.06.2012, 17:45:13 »
Hallo,

ich kenne mich mit Datenbussen (auch dem DMA) überhaupt nicht aus, daher hier eine Frage an die Spezialisten.
Gestern abend stellte ich fest, daß bei Zugriffen auf die FPs (lesend, schreibend) unregelmäßig 2 Bomben "geworfen" werden. Habe ich zunächst nicht weiter beachtet.
Heute mußte ich nun feststellen, daß es zumindest die eine MF30 "zerlegt" hat. Diese ist nicht mehr anzusprechen.
Das System ist ein STe 1040, TOS 2.06, 2 x MF30, 1 x MF44. HD-Driver ist Hushi.
Nun meine Frage: Kann es sein, daß ein defektes DMA-Kabel Auslöser für diesen FP-Defekt ist? Denn nachdem ich ein anderes Kabel angeschlossen hatte, konnte ich zumindest die 2. MF30 und die MF44 wieder zum Leben erwecken.
Was mir auch auffiel, daß SCSITOOL beim formatieren der MF30 voreingestellt Interleave 1 hatte, obwohl 0 normal ist. Das nur als Erwähnung.

Kann jemand helfen oder erklären?

Danke und Gruß.
Rainer

Burkhard Mankel

  • Gast
Re: DMA-Fehler / 2 Bomben / Festplatten-Crash
« Antwort #1 am: Sa 02.06.2012, 19:49:24 »
Ich hatte mit meiner ersten M30 - die ich von meinem Vater Mitte der 90er übereignet bekam, anfangs ähnliche Probs. Erst wollte die Festplatte nicht erkannt werden, ich hatte aber auch nur den Original Treiber. Mein Vater hatte die Stecker des Kabels spezel beschriftet ("E"ingang ST und "A"usgang Megafile). Ich hatte es umgedreht angeschlossen, was normalerweise auch nicht problematisch sein sollte, aber das Kabel hatte wohl einen leichten Defekt, der aber übersehen werden konnte, wenn das Kabel in einer bestimmten Richtung angeschlossen ist. Ich empfehle, wenn Du mehrere Geräte am ACSI betreibst, das scheinbar defekte Kabel zum Anschluß des letzten Gliedes der ACSI-Kette anzuwenden und es in der Richtung zu "tauschen" (der Stecker, der zuvor in Ri ST ging, wird jetzt an der Festplatte angeschlossen ...)

Sollte das die verlorene Festplatte nicht wiederfinden lassen, dann würde ich die defekte M30 äußerlich kennzeichnen, vorsichtig Laufwerk entnehmen und an die Platine der funktionstüchtigen Platte anschließen. So kann man ein bißchen eingrenzen, wo ein Defekt zu suchen wäre! Sollten beide Laufwerke noch arbeiten, müßtsest Du beide Laufwerke - ggfs mit einer kleinen Modifikation der (P/G)AL's und unterschiedlicher Jumperung der Select-Signale - an einer Platine betreiben können!

« Letzte Änderung: So 03.06.2012, 08:32:20 von Burkhard Mankel »

rainers

  • Gast
Re: DMA-Fehler / 2 Bomben / Festplatten-Crash
« Antwort #2 am: So 03.06.2012, 10:14:40 »
Hallo,

ich denke, ich habe das Problem gefunden, leider aber nicht behoben.
Der "Übeltäter" ist der STe selbst. Die gesamte Konstellation arbeitet mit meinem 1. STe (über Stunden im Dauerbetrieb) völlig fehlerfrei, es hat überhaupt nichts mit dem getauschten DMA-Kabel zu tun.
Leider habe ich gar keine Ahnung, warum und wie der STe dafür "sorgen" kann, daß die FP zerstört wurde.

-Rainer

PS: Den STe habe ich übrigens hier im Forum als 100% OK gekauft. Also Vorsicht bei solchen Aussagen. Zumal das "100% OK", wie ich jetzt erfuhr, sich auf den STe OHNE Festplatte bezog.

Offline Ryo

  • Benutzer
  • Beiträge: 218
Re: DMA-Fehler / 2 Bomben / Festplatten-Crash
« Antwort #3 am: So 03.06.2012, 12:59:05 »
Vom 1040STE gibt es eine Serie mit verbugten DMA-Chip.
Der verbugte Chip hat diese Bezeichnung:
C025913 - 38 PH23 - 001A

Der gute Chip hat diese:
C398739 - 001A (Atari-1990)-31

rainers

  • Gast
Re: DMA-Fehler / 2 Bomben / Festplatten-Crash
« Antwort #4 am: So 03.06.2012, 14:33:48 »
Hallo Ryo,

der bei mir in beiden STe verbaute Chip hat diese Bezeichnung:

C025913-38 PH23-030 9J290

Heißt das, das der "verbugte" Chip Fehler haben kann, aber nicht muß?

Danke.
Rainer

Offline Lukas Frank

  • Benutzer
  • Beiträge: 10.921
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: DMA-Fehler / 2 Bomben / Festplatten-Crash
« Antwort #5 am: So 03.06.2012, 14:38:48 »
Vom 1040STE gibt es eine Serie mit verbugten DMA-Chip.
Der verbugte Chip hat diese Bezeichnung:
C025913 - 38 PH23 - 001A

Der gute Chip hat diese:
C398739 - 001A (Atari-1990)-31

Aus der Chips n´Chips ...


1040STe und Probleme beim Festplattenbetrieb

   In dieser Konfiguration hat es vereinzelt Fälle gegeben, in denen
   es zu sporadischen Verfälschungen von Daten oder verstümmelten
   Directories auf der Festplatte gekommen ist.

   Folgende Abhilfe wird vorgeschlagen:
 
   (1) Überprüfen, ob zwischen Pin 9 des Widerstandsnetzwerkes P105
   und Pin 1 des Videoshifters U401 eine Verbindung besteht (Daten-
   bit DB7). Wenn dies nicht der Fall ist, eine verbindung zwischen den
   beiden Punkten mittels eines Drahtes herstellen.
   (2) Widerstandsnetzwerk P100 (2.2 KOhm, kann auch ab Werk eine 2 KOhm
   Ausführung sein) durch eines mit 8*1.2 KOhm ersetzen.
   (3) Einen Kondensator von 30pf zwischen Pin 5 des Widerstands-
   netzwerkes P100 und Masse einlöten (XBR).

 
   Sehr oft werde ich gefragt warum nicht der C025913-38A als DMA-Chip
   in der Liste steht. Die Antwort ist ganz einfach, der 520/1040STE,
   MegaSTE und TT030 haben eine geänderte ACSI-DMA Schnittstelle und
   in den vorhin genannten Computern arbeitet nur der C398739-001
   bzw. C398789-001A (DMA-Chip STE (U300)) als DMA-Chip einwandfrei.
 
   Folgende Symptome lassen auf einen C025913-38 /-38A als ACSI-DMA-
   Controller schliessen: Mitten im Formatiervorgang wird die Mel-
   dung ausgeben die Diskette sei schreibgeschützt.
   Schreibzugriffe auf eine oder mehrere angeschlossene Festplatten
   enden mit Datenverlust, Lesezugriffe funktionieren aber!
---

Einzige Quelle für den  C398739-001 DMA Baustein ist wahrscheinlich -> http://www.best-electronics-ca.com/

http://www.best-electronics-ca.com/custom-i.htm
« Letzte Änderung: So 03.06.2012, 14:57:20 von Lukas Frank »

rainers

  • Gast
Re: DMA-Fehler / 2 Bomben / Festplatten-Crash
« Antwort #6 am: So 03.06.2012, 17:03:13 »
Vielen Dank für die Erklärungen.
Aber ich werde daraus nicht schlau.
Ich gehe mal davon aus, daß wenn der "gute" Chip die Jahreszahl 1990 trägt, daß dann sehr viele STe mit dem schlechten "Chip" geliefert wurden.
Und der eine meiner STe mit diesem Chip funktioniert fehlerfrei.

Die Erläuterung zum prüfen, wie Abhilfe geschaffen werden kann, kann ich leider nicht nachvollziehen, dazu fehlen mir einfach die notwendigen Kenntnisse.