Autor Thema: Programmstarter / TOS 2.06/MultiGEM  (Gelesen 14118 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

afalc060

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #20 am: So 29.05.2011, 19:49:59 »
Eigentlich sollte es so sein:

Programme haben die Endung PRG und sind nicht auf GEM angewiesen.

Applikationen haben die Endung APP und setzen GEM voraus.

TOS-Programme verzichten auf eine Grafische Ausgabe und laufen im VT52 oder so.

TTP sind TOS mit vorheriger Parameterabfrage

GTP sind Applikationen mit vorheriger Parameterabfrage.

Nur PRG haben was im Autoordner zu suchen und auch nur dann wenn sie explizit für die Verwendung im Autoordner geschrieben sind. Also Systemprogramme die sich in Vektoren einklinken und oder ersetzen. Typischerweise zB NVDI, MINT, METADOS und dergleichen.

Fakt ist aber: Ob PRG, APP, TOS, TTP, GTP, Alle haben den gleichen Header und können wirklich nur an der Endung erkannt werden. Aber das nur nebenbei.  ;)

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #21 am: So 29.05.2011, 20:52:23 »
Hallo an alle,

also das mit den GEM-Programmen habe ich begriffen.  :)
Offenbar habe ich unbewußt tatsächlich nur nicht-GEM-Programme im AUTO-Ordner.

Das anmelden von FTP_SERV als Autostart-Anwendung ging aber gründlich in die Hose.  :(
Es hatte bewirkt, daß, bevor MultiGEM startete, FTP_SERV gestartet wurde (WDIALOG war zu diesem Zeitpunkt ebenfalls noch nicht aktiv). FTP_SERV ließ sich danach aber nicht mehr beenden.
Ich habe dann die NEWDESK.INF wieder auf den vorherigen Stand gebracht. Nun startet das System wie gehabt.
Es wird mir wohl nichts übrig bleiben, als mir ein kleines Programm zu schreiben. Aber ich bin mir nicht sicher, ob das funktionieren wird. Offenbar fehlt mir doch zuviel Wissen darüber, wie sich der Systemstart gestaltet.  ???
Zurzeit ist das System wie folgt eingestellt:
MultiGEM liegt im AUTO-Ordner
WDIALOG wird über die Autostartfunktion von MultiGEM gestartet (klappt fehlerfrei)
Versuche ich FTP_SERV über die Autostartfunktion von MultiGEM von MultiGEM zu starten, beschwert es sich halt, das WDIALOG noch nicht geladen ist.
Naja, und wie gesagt, als Autostart-Anwendung geht’s gar nicht.

Lieben Dank und viele Grüße,
René

afalc060

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #22 am: So 29.05.2011, 21:11:51 »
Mir stellt sich ja immer noch die Frage, warum überhaupt MultiGem?? Ein wilder SystemHack und mit nichts kompatibel. Ebenso Wdialog. Gilt als unsaubere Lösung und sollte vermieden werden. Stattdessen ganz darauf verzichten, Xaaes verwenden (funktionen integriert) oder auf ndialog ausweichen.

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #23 am: So 29.05.2011, 21:39:54 »
@afalc060:
Ach: Es ist MultiGEM II  ;D
Naja. Es läuft ja bei mir sehr stabil.
Und FTP_SERV verlangt nun einmal nach WDIALOG.
Was Du das nennst, sagt mir leider nichts und wird in der Doku zu FTP_SERV auch nicht erwähnt.
Was soll ich machen.  ??? Ich kann doch nur lesen.

Offline michschmi

  • Benutzer
  • Beiträge: 642
  • Ich liebe dieses Forum!
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #24 am: So 29.05.2011, 23:23:20 »

Versuche ich FTP_SERV über die Autostartfunktion von MultiGEM von MultiGEM zu starten, beschwert es sich halt, das WDIALOG noch nicht geladen ist.
Naja, und wie gesagt, als Autostart-Anwendung geht’s gar nicht.



wenn ich mich recht entsinne,  funktionierte Multigem(II) mit dem normalen Desktop. Hast du das Prpgramm in Multigem als Autostart-Progamm angegeben oder im Desktop. Ich meine, bei Multigem ist das nicht identisch.

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #25 am: Mo 30.05.2011, 19:44:55 »
Also ich bin mir nicht sicher, ob ich die Frage richtig beantworte, aber ich gebe mir Mühe.

MultiGEM II wird über den AUTO-Ordner von TOS 2.06 gestartet
WDIALOG wird über MultiGEM II, dessen Autostartfunktion, gestartet
FTP_SERV hatte ich als Anwendung über das Desktop angemeldet und dort auf AUTO gestellt

Und das klappt nicht. Offenbar wird als erstes diese Auto-Anwendung gestartet (d.h. FTP_SERV). Weder WDIALOG noch MultiGEM II sind zu diesem Zeitpunkt schon geladen bzw. gestartet.

Vielen Dank
René

Offline Arthur

  • Benutzer
  • Beiträge: 9.953
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #26 am: Mo 30.05.2011, 20:23:26 »
Pack doch WDIALOG mal als allererstes in den Autoordner des TOS 2.06 und starte MULTIGEM II danach...oder hast Du das schon gemacht?

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #27 am: Mo 30.05.2011, 21:01:25 »
Nee, den Versuch hatte ich noch nich.
WDIALOG war schon mal im AUTO-Ordner, aber ganz am Ende.
Hört sich aber gut an. Mach ich  ;) Also auf jeden schieb ich es vor MultiGEM.

In diesem Zusammenhang: Gibt es eigentlich ne komfortable Möglichkeit, den AUTO-Ordner bzgl. der Startreihenfolge anzuordnen?
Bisher nehme ich immer alles raus und schiebe es dann entsprechend der gewünschten Reihenfolge wieder hinein.

Offline ragnar76

  • Benutzer
  • Beiträge: 492
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #28 am: Mo 30.05.2011, 21:16:57 »
Zitat
In diesem Zusammenhang: Gibt es eigentlich ne komfortable Möglichkeit, den AUTO-Ordner bzgl. der Startreihenfolge anzuordnen?
Klar gibt es sowas, ich hab dir das auf meine Seite gelegt : https://freeshell.de/~ragnar76/pearls/soft/dir_sort.zip

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #29 am: Mo 30.05.2011, 21:24:14 »
Danke  :-*

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #30 am: Fr 03.06.2011, 11:47:20 »
Hallo,

also ich werde wirklich alt.  :(
Klar hatte ich WDIALOG schon mal vor MultiGEM II im Auto-Ordner. Das Ergebnis: MultiGEM startet nicht mehr korrekt. Das WDIALOG scheint wirklich sehr eigen zu sein.
FTP_SERV verlangt halt "blöderweise" danach.
Also ich werde mich doch mal ransetzen und ein kleines Programm schreiben. Mit TOS- und anderen Bordmitteln bekomme ich das wohl nicht hin.

@ragnar76: Das dir_sort funktioniert aber sehr gut. Danke nochmal.

Viele Grüße,
René

afalc060

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #31 am: Fr 03.06.2011, 12:06:08 »
einfach mal ndialog versuchen..

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #32 am: Fr 03.06.2011, 12:10:21 »
Gibste mir ne Quelle  :D wo ich kann das finden?

afalc060

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #33 am: Sa 04.06.2011, 02:24:21 »
pdf = zip

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #34 am: Sa 04.06.2011, 20:45:43 »
Hee, Du bist Klasse.  :D
Danke.

Offline Arthur

  • Benutzer
  • Beiträge: 9.953
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #35 am: Sa 04.06.2011, 21:50:40 »
Also hat es jetzt geklappt?

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #36 am: Sa 04.06.2011, 22:26:21 »
Ach. Das war für den "Transfer".  ;)

Nee: NDIALOG ist nich für TOS/MultiGEM II.  :(
Man kanns zwar ausführen, aber es passiert nichts  :(

Im README steht ja auch: Für N.AES und MINT.

Icke habe keen MINT.

afalc060

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #37 am: So 05.06.2011, 12:44:58 »

NDialog wurde von den N.Aes Machern Nachprogrammiert, da WDialog eigentlich nichts unter Mint zu suchen hat. NDialog ist quasi die saubere Ausführung von WDialog. Wenn man das so überhaupt sagen kann, sauber...

Wieso muss es unbedingt Multigem sein? Hapert es an RAM? Versuch doch mal ein CrippleMint..

virgo660824

  • Gast
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #38 am: So 05.06.2011, 20:44:06 »
Ja, mit dem Gedanken spielte ich schon einmal, aber mehr als 4 MB gehen bei mir leider nicht rein und das ist auch für CM zu wenig  :(
Schade isses, denn es wäre schon schön, etwas UNIX-Feeling auf meinem STe zu haben.
Naja. Was nicht geht, geht nicht.

Offline Arthur

  • Benutzer
  • Beiträge: 9.953
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Programmstarter / TOS 2.06/MultiGEM
« Antwort #39 am: So 05.06.2011, 21:35:54 »
Eine echte Alternative könnte µMiNT sein wenn es für den 68000er neu compiliert würde.

@Virgo, wie kommst Du denn darauf das der Speicher für Cripple MiNT nicht reicht? Mußt halt dein System finetunen.