Autor Thema: HxC Floppy Emu, SD - Version  (Gelesen 12382 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Gaga

  • Benutzer
  • Beiträge: 2.306
  • Wer nicht nachfragt, bekommt auch keine Antwort!
HxC Floppy Emu, SD - Version
« am: Sa 27.11.2010, 12:09:02 »
Hurra,

mein SD-Floppy Emulator für meinen 1040 STE ist eben per Einschreiben aus Polen eingetroffen. Es ist die Variante mit Display. Eine 16GB SDHC Karte habe ich schon dazu. Hoffentlich reicht die auch ;-)

Demnächst hier mein Erfahrungsbericht.

VG Gaga
Thunder - Storm TT/ST - Lightning VME/ST - Cloudy - Speedy - T*****

Offline Heinz Schmidt

  • Benutzer
  • Beiträge: 1.182
  • Atari, Linux, OS/2, MacOS, ... no need for Windows
Re: HxC Floppy Emu, SD - Version
« Antwort #1 am: So 28.11.2010, 00:06:28 »
Hallo Gaga,

das ist ja mal ein nettes Vorweihanchtsgeschenk, das Du Dir da gemacht hast. Ich bin gespannt auf Deine Erfahrungen, weil ich mit diesem Grät auch liebäugle. Was hast Du denn mit Porto für das gutes Stück hinblättern müssen?

Gruß Heinz
FireBee #8 im Test --- Milan 060/50, Ethernet, CF/SD-CardReader, DVD-RW, ATI Grafik --- Falcon CT63/CTPCI/ATI, CF-Card als HDD, Altec iDrive --- 1040 STE, 4MB, SatanDisk --- ...

Offline Arthur

  • Benutzer
  • Beiträge: 9.699
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: HxC Floppy Emu, SD - Version
« Antwort #2 am: So 28.11.2010, 00:23:05 »
Hallo Gaga, das ist genau die Variante die ich auch gewählt hätte. Freue mich schon auf deinen Bericht.

Offline Gaga

  • Benutzer
  • Beiträge: 2.306
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: HxC Floppy Emu, SD - Version
« Antwort #3 am: So 28.11.2010, 00:24:21 »
Ich habe alles in allem genau 80 Euro gezahlt. Ist ne Menge Holz, aber meine Überlegung war: alle Games auf eine SD Karte und nie wieder ne Diskette mitnehmen.

Meine ersten Erfahrungen heut abend sind überaus negativ.

Der STE meldet, dass er auf die Diskette (den EMU) nicht zugreifen kann. Vielleicht liegt es an meinem HDD Modul oder meinem IDE Interface (wenn das nämlich ab ist, geht das alles etwas weniger schlechter ;-) ). Ich werde den Emu also mal an einem puren 1040 STFM testen. Dort habe ich bereits die USB Variante erfolgreich getestet. Die funktionoert wunderbar und hat mich 1/8 der SD Version gekostet. Will also schauen, ob es am Atari oder dem Emu liegt.

Zudem schließe ich das Ganze morgen mal am TV an, denn im Moment habe ich nur den TFT (also s/w) dran und da läuft kaum ein Spiel. Ich will auch sehen, ob der Card-Manager funktioniert, denn bei hunderten Games ist alles andere eine Qual.

Also: demnächst mehr, hoffentlich mit besseren News.

Gute Nacht

Gaga
Thunder - Storm TT/ST - Lightning VME/ST - Cloudy - Speedy - T*****

Offline Gaga

  • Benutzer
  • Beiträge: 2.306
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: HxC Floppy Emu, SD - Version
« Antwort #4 am: So 28.11.2010, 23:33:12 »
Also am 1040 STFM hat der SD Emu prima funktioniert...solange, bis der ST jetzt nur noch 8 Bomben schmeißt und gar nichts mehr macht. Daran ist aber wahrscheinlich nicht der EMU Schuld.

Der SD Card Manager funktioniert sehr gut, die Schrift ist aber zumindest auf meinem TV sehr sehr schlecht zu lesen (weiß auf schwarz bei mittlerer Auflösung).

Am 1040 STE mit TOS 2.06 macht das Teil nach wie vor nichts. Es kommt die Meldung, dass er nicht auf die Diskette zugreifen kann. Ich habe das gleiche Problem mit dem Emu auf USB Basis. Ob das mit dem TOS 2.06 zusammen hängt? Im STFM werkelt ein 1.2 oder 1.4.

Ich bleib dran und berichte weiter.

Zudem stehe ich vor der Frage: statt der Floppy ins ST-Gehäuse einbauen oder eher in ein extra Gehäuse stecken. Was würdet ihr machen?

VG Gaga
Thunder - Storm TT/ST - Lightning VME/ST - Cloudy - Speedy - T*****

guest2374

  • Gast
Re: HxC Floppy Emu, SD - Version
« Antwort #5 am: So 28.11.2010, 23:54:43 »
Was für ein EMU bei der Usb Version?

Es funktioniert alles genau so wie es soll. auch am STE mit Tos2.06
Erklär mal was du da machst.

Ich hab mir so ein Gehäuse gebastelt, da kann ich das HxC anklemmen wo ich mochte (zb auch am amiga 500) Hab überall Flachbankabel dran gemacht.



mehr gibts unter www.bitmania.de

Offline Gaga

  • Benutzer
  • Beiträge: 2.306
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: HxC Floppy Emu, SD - Version
« Antwort #6 am: Mo 29.11.2010, 00:15:42 »
Ich habe genau solch ein Gerät, nur mit viel schiönerer roter Platine, Rev. C.

Ich kenne Dein USB HxC und auch das Gehäuse hast Du mir auf der OFAM schon gezeigt. Ich mache hier alles ganz genauso, wie ich es auf der OFAM gesehen habe.

Vorgehensweise: Emu an den Floppystecker, richtig herum. USB Kabel an den Emu, anderes Ende an einen USB PC (bei mir ein iMac, auf dem VMWare Fusion mit Win XP läuft). Ich habe die neueste Software von der Herstellerseite. Ich wähle ein Abbild (*.st), ziehe es auf das Programmfenster und dann sollte es auf dem EMU per USB sein, spätestens, wenn ich den STE resete. Egal was ich mache: "Diskette A antwortet nicht".

Mach ich was falsch?

Mit der SD Variante genau die gleiche Fehlermeldung. Dort wandele ich aber per Batch die Images *.st und *msa in *.hcx Files um, kopiere sie auf die SD Karte, stecke die SD Karte in den Emu am ST und schalte ihn an. Am STFM gehts prima, am STE nicht. Komisch: auf Diskette B kann ich zugreifen, wenn ich den SD Card Manager (autoboot) auf der SD Karte habe. Auf Laufwerk A kann ich aber nicht zugreifen, weder vom Desktop, noch bootet da irgend ein Image nach getroffener Auswahl.

Idee?

VG Gaga
Thunder - Storm TT/ST - Lightning VME/ST - Cloudy - Speedy - T*****

guest2374

  • Gast
Re: HxC Floppy Emu, SD - Version
« Antwort #7 am: Di 30.11.2010, 16:12:10 »
zitat:

USB PC (bei mir ein iMac, auf dem VMWare Fusion mit Win XP läuft

das wird das Problem sein, mein kumpel hatte unter linux in einer virtual box xp installiert, das funktionierte auch nicht. er hat sich dann eine linux version gebastelt.

Offline Gaga

  • Benutzer
  • Beiträge: 2.306
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: HxC Floppy Emu, SD - Version
« Antwort #8 am: Di 30.11.2010, 17:00:55 »
Ich glaube nicht, dass das das Problem ist. Immerhin konnte ich gestern den USB HXC an einem anderen 1040 STF über USB am iMac erfolgreich betreiben.

Ich glaube eher, es liegt entweder am HD Modul im STE oder dessen TOS 2.06.

@Officer: hat Dein STE TOS 1.62 oder TOS 2.06?

VG Gaga
Thunder - Storm TT/ST - Lightning VME/ST - Cloudy - Speedy - T*****

guest2374

  • Gast
Re: HxC Floppy Emu, SD - Version
« Antwort #9 am: Di 30.11.2010, 22:53:48 »
also ich habe vorher tos 1.62 und jetzt tos 2,06 beide machten keine probleme. was steht auf deinem floppy controller drauf? wd 1772 -ph
das ist meiner

Offline Gaga

  • Benutzer
  • Beiträge: 2.306
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: HxC Floppy Emu, SD - Version
« Antwort #10 am: Di 30.11.2010, 23:18:49 »
Also scheint es am TOS nicht zu liegen, hm...

Ich habe als Floppy Controller auch den WP 1772 - PH 02 02. Der sollte den HD Betrieb verkraften, was er auch macht, denn das 1,44MB Floppy funzt seit Jahren.

Noch ein Wort zu USB und iMac: dieselben Probleme habe ich doch auch mit der SD version, da ist stand alone ohne USB.

Laut Display nimmt er ja die Images von der SD Karte, aber er bootet nicht.

Muss man beim Start irgendeine Taste drücken? Alternate hat bisher nichts gebracht.

Gruss Gaga
Thunder - Storm TT/ST - Lightning VME/ST - Cloudy - Speedy - T*****

guest2374

  • Gast
Re: HxC Floppy Emu, SD - Version
« Antwort #11 am: Mi 01.12.2010, 18:26:25 »
ich besitze die sd version (noch) nicht, ich werde aber bald davon berichten.

Offline Gaga

  • Benutzer
  • Beiträge: 2.306
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: HxC Floppy Emu, SD - Version
« Antwort #12 am: Do 16.12.2010, 00:01:30 »
So, ich habe mal ein wenig weiter getestet mit dem SD HxC.

TOS 2.06 schließe ich als Fehlerquelle jetzt mal aus, denn der Rechner an sich funktioniert ja und hängt auch nicht beim Diskettenzugriff.

Auch das interne IDE Interface (ein Ideal-Adapter) mach ich nicht für die Fehlermeldung verantwortlich, wobei das Interface an sich genug Probleme bereitet, was den HDD Zugriff anbelangt. Ich werde hier noch nachbessern müssen oder komplett auf SCSI extern umsteigen.

Ich tippe vielmehr auf das HD-Modul von DDD, hier genauer gesagt die Steprate. Ich bin in der glücklichen Lage, intern ein 1,4MB Floppy zu haben, welches auch wunderbar funktioniert - aber nur wenn ich über den Auto Ordner das Stepratenprogramm DDD-Step starten lasse, welches die Steprate auf 6ms umstellt. Nur dann funktioniert der Diskettenbetrieb zuverlässig.

Des weiteren habe ich einen Bootfloppyschalter eingebaut. Das bedeutet, ich kann wählen, ob der STE von der internen Floppy A oder einer externen Floppy B booten soll. Dieses Relikt stammt noch aus der Zeit, als ich noch ein 5,25" Floppy als B Laufwerk am STE hatte und so maches Soiel von dort bootete.

Jedenfalls: der SD HxC greift als Laufwerk A, also intern angesteckt, gar nicht auf die SD Karte zu. Er macht einfach nichts.

Ich habe mir also eine externe Variante gebastelt, also ein Floppygehäuse, Netzteil und Kabel. Lege ich meinen Bootfloppyschalter so um, dass der STE von Laufwerk B booten soll, wird der SD Hxc tatsächlich angesprochen. Zuerst dachte ich, dass er wirklich geht, denn ich konnte tatsächlich 1 von 5 Spielen laden. Da schob ich es noch auf defekte Images. Erfreut war ich auch, als ich am TV den SD-Manager sah, dieser also geladen wurde (übrigens mit deutlich besserem Bild an meinem Wohnzimmer-TV, sehr gut lesbar, das schlechte Bild liegt sicher am billigen Zweit-TV). Jedoch wurde es zur Gewissheit, dass es doch nicht geht, als immer und immer wieder der Fehler kam, dass auf die SD Karte nicht zugegriffen werden könne (Fehler 6). An der SD Karte liegt es nicht, habe mehrere probiert.

Wie gesagt, liegt es am HD Modul, genauer gesagt an der Steprateneinstellung, meine ich jedenfalls. Ohne DDD-Step lassen sich auch ganz normale Disketten entweder nicht oder nur kurz oder sporadisch ansprechen - genau der Effekt wie mit dem SD HxC.

Ich werde also versuchen, mir ein anderes HD Modul mit automatischer Steparteneinstellung zu besorgen. Vielleicht auch gleich einen Ajax in diesem Zusammenhang.

Was mich nur etwas verwirt: ich dachte immer, die Steprateneinstellung wäre mechanisch bedingt, was ja beim HxC nicht der Fall ist.

Ich berichte jedenfalls dann hier wieder!

Gute Nacht!

Gaga
« Letzte Änderung: Do 16.12.2010, 00:05:56 von Gaga »
Thunder - Storm TT/ST - Lightning VME/ST - Cloudy - Speedy - T*****

Offline Arthur

  • Benutzer
  • Beiträge: 9.699
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: HxC Floppy Emu, SD - Version
« Antwort #13 am: Do 16.12.2010, 02:05:54 »
Hallo Gaga, das nenne ich mal einen ausführlichen Bericht. Also wenn du das HxC im HD-Betrieb verwendest dann kann's am Floppykontroller liegen. Irgendwo hab ich gesehen dass das Modul als DD-Laufwerk konfiguriert werden kann. Das wäre evtl. mal einen Versuch Wert um andere Fehler auszuschließen.

Noch etwas zur Steprate, dem Diskettenlaufwerk ist es gleich wie die 3ms erzeugt werden, also durch eine entsprechende Schaltung  oder durch setzen der Steprate auf 6ms per Software denn in beiden Fällen kommen fürs Laufwerk 3ms dabei heraus. Du bräuchtest dann aber ein Programm im Autoordner weniger...doch den Cookie für  HD-Betrieb mußt du trotzdem laden.

Offline gehtjanx

  • Benutzer
  • Beiträge: 454
Re: HxC Floppy Emu, SD - Version
« Antwort #14 am: Do 16.12.2010, 20:20:10 »
cooler wäre natürlich ein menü welches man mit dem Amiga/Atari/whatever mischen könnte. Da gabs mal einen Versuch.

SD ist zwar cooler als USb, aber der offene Aufbau und das Display sagen mir nicht so zu.

gehtjanx

Offline Arthur

  • Benutzer
  • Beiträge: 9.699
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: HxC Floppy Emu, SD - Version
« Antwort #15 am: Fr 17.12.2010, 15:47:53 »
Schieb Gaga... ;)

Offline Gaga

  • Benutzer
  • Beiträge: 2.306
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: HxC Floppy Emu, SD - Version
« Antwort #16 am: So 23.01.2011, 19:39:34 »
So, hier ein paar News:

Ich habe jetzt ein neues Floppy Modul für den High Density Betrieb eingebaut. Das funktioniert zumindest mit dem interenn 1,44MB Floppy ganz hervorragend. Ein als Laufwerk B angeschlossenes HD Floppy indes bereitet Probleme (lässt sich nicht formatieren, aber da schau ich nochmal nach).

Im Gegensatz zu meiner ersten Floppy HD Lösung von DDD (Digital Data Deicke) hat mein neues Modul nun eine automatische Stepratenanpassung und er 16MHz wird vom Shifter eingespeist. Die DDD Lösung hat den 16MHz Takt selbst geniert. Ich dachte mir, dass der Takt vom Board nun besser funktioniert, als ein separat erzeugter Takt (letzterer könnte vom Systemtakt abweichen und daher Inkompatibiläten verursachen).

Wie gesagt: ein normales 1,44MB Floppy als interenes Drive A funktioniert wunderbar.

Nächster Schritt: Floppy ab und den SD HxC dran. Leider genau dasselbe, wie oben in meinen Beiträgen beschrieben :-( Das bedeutet: der SD HxC reagiert zwar, aber es kommt bei Autostartdisketten nur der Desktop. Ich kann Laufwerk A öfnnen, sehe die Dateien, aber wenn ich auf den Autoordner doppelklicke, kommt: Kann Laufwerk A nicht lesen. Das leider bei jeder der von mir ausprobierten Disk-Images (Automation Disks 1, 9, 13 und 14).

Daher dieser Versuch, mit etwas mehr Erfolg, aber dennoch im Ergebnis unbrauchbar: interne Floppy wieder dran, SD HxC als Floppy B extern angesteckt (das HD Signal wird auch auf die externe Floppybuchse geschickt). Dann meinen Bootfloppywähler so eingestellt, dass von Laufwerk B (also dem HxC) gebootet wird. Hier wird zumindest das SD Menü geladen, ich kann ein Disk Image auswählen, abspeichern und neu starten. Dann kommt sogar der Diskbootloader der ausgewählten Disk (hier: grün mit Schrift: Little Green Desktop). Nach dem Speichertest (TOS 2.06) und dem Druck auf die Taster Alternate wird das Image weiter geladen, jedoch stürzen alle von mir versuchten Images mit 3 Bomben ab.

Sh*t.

Ich schließe nach alledem folgende Fehlerquellen aus:

- den 1040 STE an sich (alle gesockelten Chips geprüft)
- den internen Ideal IDE Adapter
- den 4MB Hauptspeicher
- das FDD HD Modul

Es bleiben als Fehlerquellen noch:

- mein Bootfloppywähler, wobei das nur ein einfacher Umschalter ist, der die Pins 19 und 20 am Soundchip tauscht
- der Floppy Controller, wobei ich bald einen Ajax bekomme
- die SD Karte im SD HxC, aber da habe ich verschiedene mit dem gleichem, schlechten Erfolg probiert
- die Konfiguration des SD HxC (hat einer eine funktionierende CFG Datei für mich?)

und vor allem:

- der SD HxC an sich.

Hat jemand auch so ein Teil an einem STE mit gleicher Hardware wie ich, der sich für einen Test bereit erklären würde?

Bin der Verzweiflung nahe, zumal es doch so schön wäre, wenn es funzen würde.

Eigentlich wollte ich den SD HxC intern in meinem STE haben, aber ich habe mir überlegt, dass es sicher besser ist, dort die (funktionierende) 1,44MB Floppy zu belassen.

Extern würde ich dann meinen USB HxC betreiben. Dafür habe ich ein passenden Gehäuse und das Beste: das Teil bezieht die Stromversorgung über den USB. Nachteil: ein PC oder Mac zum Aufspielen der Images wird benötigt.

Den SD HxC werde ich wohl intern an einem normalen, ungepimpten 1040STfM mit Tos 1.4 und 1MB RAM ohne HD Mudul und ohne Festplatte betreiben. Quasi als reiner Spiele ST. Zu den Treffen müsste ich aber dann den STE und den STfM mitbringen... Was meint ihr dazu?

VG Gaga
« Letzte Änderung: So 23.01.2011, 19:45:52 von Gaga »
Thunder - Storm TT/ST - Lightning VME/ST - Cloudy - Speedy - T*****

guest2374

  • Gast
Re: HxC Floppy Emu, SD - Version
« Antwort #17 am: Mo 24.01.2011, 19:21:59 »
korrektur

das !!SD!! HxC läuft nicht am 1040st E mit Tos 2.06, ich habe meins wieder verkauft, da ich keine luist hatte dem entwickler wie schon beim kauf in den Popo zu kriechen.

Offline Gaga

  • Benutzer
  • Beiträge: 2.306
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: HxC Floppy Emu, SD - Version
« Antwort #18 am: Mo 24.01.2011, 19:29:31 »
Ui, interessant.

Officer, weisst Du, weshalb das nicht am 1040STE nicht funktioniert?

Dein !!!USB!!! HxC geht aber am STE? Nur das ich das richtig verstehe.

Hoffe, wir sehen uns bald wieder?!

VG Gaga
Thunder - Storm TT/ST - Lightning VME/ST - Cloudy - Speedy - T*****

Offline Heinz Schmidt

  • Benutzer
  • Beiträge: 1.182
  • Atari, Linux, OS/2, MacOS, ... no need for Windows
Re: HxC Floppy Emu, SD - Version
« Antwort #19 am: Di 25.01.2011, 08:50:47 »
Hallo Gaga, hallo Officer,

danke für eure hilfreichen Infos zum HxC SD. Das es nicht am 1040STE mit TOS 2.06 läuft ist ja sehr ärgerlich. Vor allem, weil das nirgens offiziell beschrieben ist. Genau für so ein Gerät wollte ich mir dieses Jahr auch ein HxC SD kaufen. So wie es aussieht, ist as ja nun doch nur was für den 08/15 ST. Vielleicht ist es am besten das Ding in ein externes Disktettenlaufwerk zu bauen, dann kann ich es wenigstens an verschiedenen STs ausprobieren.

Gruß Heinz
FireBee #8 im Test --- Milan 060/50, Ethernet, CF/SD-CardReader, DVD-RW, ATI Grafik --- Falcon CT63/CTPCI/ATI, CF-Card als HDD, Altec iDrive --- 1040 STE, 4MB, SatanDisk --- ...