Autor Thema: Atari STBook Display: Kondensator defekt...  (Gelesen 2176 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline OnkelTom71

  • Benutzer
  • Beiträge: 287
Atari STBook Display: Kondensator defekt...
« am: Fr 09.07.2010, 18:13:24 »
Hallo zusammen,

habe leider ein Problem mit meinem STBook. Ich lade es alle paar Monate mal auf und jetzt ist mir aufgefallen, dass (anscheinend) die obere Hälfte des Displays nicht funktioniert:



Wenn ich aber den Kontrast erhöhe, dann erscheint dort doch etwas:



Ich habe also die Abdeckung des Displays hinten abgenommen:



Und beim Kondensator C3 ist mir aufgefallen, dass er anscheinend ausgelaufen ist, weil an seinen Beinchen solch ein Gekrissel ist:



An die Experten: Liege ich hier richtig? Welchen Kondensator benötige ich für den Austausch? Habe auf Anhieb bei Conrad und Reichelt leider nichts gefunden...

Würde mich über Hilfe sehr freuen!

Danke und Gruß,
Thomas
« Letzte Änderung: Fr 09.07.2010, 18:18:44 von OnkelTom71 »
TT030, 4MB ST + 32 MB TT Ram, 4GB Festplatte, MagiC, MiNT, N.AES, Geneva, ...
STBook, 1MB Ram, 80MB Festplatte
Falcon030, 4MB Ram, 64MB Festplatte

Offline Arthur

  • Benutzer
  • Beiträge: 9.208
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Atari STBook Display: Kondensator defekt...
« Antwort #1 am: Fr 09.07.2010, 20:05:16 »
Leider habe ich im Schaltplan dazu nichts 100%tiges passendes gefunden. Wenn ich mich aber nicht vertan habe, dann haben die beiden Kondensatoren nichts mit dem Display zu tun. Der Bereich der fotografiert ist müßte für die Tastatur zuständig sein. Als erstes habe ich versucht den Chip und R6, R7, C2 und C3 zu finden. Dann hab ich mich an dem Aufdruck der von C2 und C3 orientiert. Einzig auf Seite 8 von 12 könnte zu deinem Foto passen. Zum LCD-Kontrast findest Du etwas auf Seite 9 von 12.


Viel Glück

Arthur

Offline Arthur

  • Benutzer
  • Beiträge: 9.208
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Atari STBook Display: Kondensator defekt...
« Antwort #2 am: Fr 09.07.2010, 20:48:33 »
Kannst Du mal das Flachbandkabel fürs Foto entfernen oder hochbiegen? Dann hat man mehr Anhaltspnkte.

Offline OnkelTom71

  • Benutzer
  • Beiträge: 287
Re: Atari STBook Display: Kondensator defekt...
« Antwort #3 am: Fr 09.07.2010, 21:11:28 »
Die Bilder 3 und 4 sind von der Rückseite des Displays, deshalb denke ich nicht, dass es etwas mit der Tastatur zu tun hat. Aus dem gleichen Grund denke ich, dass es im Schaltplan des STBooks auch gar nicht enthalten ist, weil das Display sicher eine Einheit (war die nicht von Epson?) ist.

Das weisse Flachbandkabel ist recht dick und unflexibel. Aber über der 22 hört das Bauteil auf (dort, wo der weiße Rahmen auf der Platine ist). Ob es dort ebenfalls angelötet ist, kann ich nicht sagen.

Gruß,
Thomas
TT030, 4MB ST + 32 MB TT Ram, 4GB Festplatte, MagiC, MiNT, N.AES, Geneva, ...
STBook, 1MB Ram, 80MB Festplatte
Falcon030, 4MB Ram, 64MB Festplatte

Offline Arthur

  • Benutzer
  • Beiträge: 9.208
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Atari STBook Display: Kondensator defekt...
« Antwort #4 am: Fr 09.07.2010, 21:45:09 »
Für das Display hab ich keine Shematic gefunden. Löte mal zwei neue Elkos ein. Ich schätze mal das die wie die Beschriftung zeigt 22mf/16V haben. Exact die gleiche Bauform ist schwer zu bekommen. Ich würde die Kontakte so weit es geht oben abkneifen und diese hier dort anlöten.

Das Foto ist nur ein Muster, die Werte stimmen nicht!

Offline OnkelTom71

  • Benutzer
  • Beiträge: 287
Re: Atari STBook Display: Kondensator defekt...
« Antwort #5 am: Fr 09.07.2010, 21:50:16 »
Ok, danke für die Hilfe. Ich warte mal noch andere Meinungen ab und werde dann wohl die Elkos austauschen.

Müssen ja keine SMD Elkos sein, vielleicht finde ich ja andere - lötfreundlichere...  ;)

Gruß,
Thomas
TT030, 4MB ST + 32 MB TT Ram, 4GB Festplatte, MagiC, MiNT, N.AES, Geneva, ...
STBook, 1MB Ram, 80MB Festplatte
Falcon030, 4MB Ram, 64MB Festplatte

Offline skul

  • Benutzer
  • Beiträge: 226
Re: Atari STBook Display: Kondensator defekt...
« Antwort #6 am: Sa 10.07.2010, 20:08:53 »
Moin,

ich hab' noch 'ne ganze Latte SMD Elkos, auch 22µF, muss nur 'mal nachsehen, ob auch die radiale Bauform dabei ist.
Gruß
skul

Offline wfoerster

  • Benutzer
  • Beiträge: 304
  • ATARI in VHDL - This is Future!
Re: Atari STBook Display: Kondensator defekt...
« Antwort #7 am: So 08.08.2010, 13:53:51 »
Hallo,
ich kenne das Problem. Ich hatte exakt den gleichen Fehler an meinem STBook. Es liegt vermutlich an dem IC LM324 (4-fach OP). Ich habe dieses Chip und vorsorglich die Kondensatoren gegen Tantalkondensatoren (in Tropfenform) getauscht. Danach ging es wieder.  Sei vorsichtig. Die Flex-Prints sind empfindlich gegen Biegen an der Leiterplatte. Das Display bekommst Du garantiert nicht mehr als Ersatz.


Viele Grüße

Wolfgang