Autor Thema: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.  (Gelesen 25879 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Wer Lust hat, kann ja selber mal ausprobieren wie sich der Open Source Browser Netsurf auf einem realen Atari TT, Atari Falcon oder einem Leistungsstarken Klon verhält. Ich selber habe alle Versuche unter Aranym inkl. Netzwerk auf einen PC mit Windows Vista 64 gemacht.

Eigentlich braucht es für Tests außer Mint (z.B. EasyMiNT) möglichst viel RAM-Speicher und evtl. ein Netzwerkdevice, wie z.B. EtherNec, Hydra etc. und der Software und vielleicht einer Grafikkarte nichts weiteres. Alle Tipps setzen voraus das ihr ein funktionierendes System habt und Grafikkarte, Netzwerkdevice und EasyMiNT soweit fehlerfrei laufen.

Das Ataricompilat vom Netsurf könnt ihr euch derzeit nur von m0n0s Seite runter laden. Die noch fehlenden und benötigten Fonts könnt ihr hier runter laden, da Netsurf ohne Fonts sonst mit einer Fehlermeldung abbricht.

In dem ersten Paket sind neben Netsurf noch andere Ordner und Dateien vorhanden. Diesen Ordner solltet Ihr nach Möglichkeit auf eine Ext2 Partition kopieren da das Dateihändling dort wesentlich schneller ist als auf eine GEM oder BGM Partition ist. Da viel über die Konsole zum Beispiel der Bash oder der Konsole in TosWin2 gearbeitet wird sollte der Ordner nach dem kopieren als erstes noch umbenannt werden z.B. von nsfbalpha nach nsf dann spart man sich etwas Tipperei.

Danach müssen aus dem Fontarchiv "dejavu-fonts-ttf-2.31" der Inhalt des Ordners ttf nach /usr/share/fonts/truetype/ttf-dejavu kopiert werden. Auch hier würde ich aus Performance Gründen ein Verzeichnis auf einer Ext2 Partition anlegen das nach Möglichkeit die selbe Verzeichnis-Hierarchie hat. Für diesen Ordner muß in der mint.cfg (zumindest wenn Aranym benutzt wird) ein symbolischer link angelegt werden. Unter Aranym habe ich die Verzeichnisstruktur übrigens auf Laufwerk C: erstellt und der Eintrag in der mint.cfg für den symbolischen Link sah dann so aus:

# Setting up the root filesystem for UNIX environment
sln c:/usr      u:/usr



Dort befinden sich aber noch ähnliche weitere Einträge in der mint.cfg.

Wenn Ihr so weit fertig seid dann kann nach einem Reboot  Netsurf (nsfb) auf Herz und Nieren getestet werden. Wer schon eine funktionierende Netzwerkverbindung zum Internet hat kann es ja erst mal ohne Script und nur per doppelklick auf nsfb Netsurf starten. Nach dem Doppelklick kommt ein Fenster wie dieses hier:


Wo ihr zum Beispiel folgendes eingeben könnt:

-w 800 -h 600 -b 16

Also die breite des Fenster in Pixel ist 800 sowie die Höhe des Fensters in Pixel ist 600 und die Farbtiefe/Farbpalette die Netsurf benutzt laut m0n0 16Bit. Wenn man für sich eine Einstellung gefunden hat kann man diese ja in ein Shellscript eintragen und spart sich das immer neue eintippen der Parameter.

Wer möchte kann durchaus auch noch http://www.google.de beim start als Parameter dazu schreiben oder irgendeine andere URL. Es passt mehr in diese Zeile rein da diese Durchläuft wenn der Rand erreicht ist. Das sieht dann ungefähr so aus:

-w 800 -h 600 -b 16 http://www.google.de

Zumindest in Aranym ist es schwierig nachträglich eine Url in Netsurf einzugeben (es klappt aber es ist eine Pein) da die Anpassungen noch verfeinert werden müssen.

Wer noch kein funktionierendes Internet hat kann aber auch eine lokale Website im einfachsten Fall eine HTML -Datei mit Netsurf anzeigen lassen. Wer keinen Plan hat wie das gehen könnte der Frage jemanden der es weis oder wartet einfach noch bis ich das hier posten werde. Viel Spaß damit...
« Letzte Änderung: Mi 30.06.2010, 13:34:31 von Arthur »

Offline Johannes

  • Administrator
  • *****
  • Beiträge: 1.844
  • ATARI-HOME.DE - online for more than 20 years...
Hallo Arthur,

super Anleitung :)

Ich bin eigentlich genauso vorgegangen, wie Du (nur dass ich nsfb direkt über die netsurf.sh gestartet habe. Die Fonts werden korrekt geladen, auch ein "loading page" erscheint kurz in der Statusleiste, jedoch bleibt mein Netsurf-Fenster bis auf die Fensterelemente schwarz.

Mein Setup: Aktuelles EasyMint, Hydra funktionierend, CTPCI funktionierend in 1024x768x32, CT63 mit 100 MHz stabil.

Vielleicht jemand eine Idee? Scheint mit als könne die Grafikausgabe nicht initialisiert werden!?

Grüße
Johannes
Falcon060 /w SV - TT030 - Mega STE4 - Mega ST4 - 1040 ST(F/M) - Lynx II - Portfolio
non-Atari: DEC Vaxstation 4000 VLC, SGI Fuel, SGI Octane, SGI Indigo 2 R10K, SGI Indy, Casio PB-1000

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Wenn Du kannst benutze 16Bit Farbtiefe für deine Grafikkarte. In Netsurf benutze die Option -b 16.

Hier mal ein Beispielscript:

Zum aufruf von forum.atari-home.de benutze ich dies hier.

Der Inhalt meines forum.sh Shellscripts:

NETSURFRES=./framebuffer/res/
export NETSURFRES
./nsfb -v -b 16 http://forum.atari-home.de



Ich starte das Script aus dem selben Ordner in dem auch Netsurf liegt folgendermaßen über die Komandozeile.

#./forum.sh + Enter-Taste

Netsurf startet dann mit der default Fenstergröße 800*600 und der 16Bit Farbpalette. Hier könnte man Netsurf auch mal mit 32Bit (-b 32) oder 8Bit(-b 8) Farbpalette starten. Da die Bilder meist in 16, 24 oder 32Bit Farbtiefe vorliegen müssen die Bilder an die Zielfarbtiefe angeglichen werden was zu einem Geschwindigkeitsverlust führt.

Wenn Netsurf gestartet wird und keine URL wird angegeben, dann lädt Netsurf eine standard Startseite ähnlich Firefox & Co. Eine gute Seite zum testen ist z.B. Google, da die Seite nicht so komplex ist. Ich empfehle im Fehlerfall erst einmal eine lokale HTML-Datei von der Platte zu laden um andere Fehler auszuschließen. Wenn das einwandfrei funktioniert können auch Seiten aus dem Internet aufgerufen werden sofern eine Verbindung besteht..

Hier ein Script das das Netsurffenster auf 1024*768 Pixel einstellt und die Farbpalette auf 16 Bit stellt anschließend wird eine lokale HTML-Datei aufgerufen die in c:\nsf\ liegt und den Namen index.html hat..

NETSURFRES=./framebuffer/res/
export NETSURFRES
./nsfb -v -w 1024 -h 768 -b 16 file:///c/nsf/index.html
« Letzte Änderung: Mi 30.06.2010, 13:44:45 von Arthur »

Offline m0n0

  • Benutzer
  • Beiträge: 984
Zitat
jedoch bleibt mein Netsurf-Fenster bis auf die Fensterelemente schwarz.
...
Vielleicht jemand eine Idee? Scheint mit als könne die Grafikausgabe nicht initialisiert werden!?

Hallo,

Ja, warte einfach mal ab... Bei ebay brauchte es bestimmt 60 Sek. bevor das Schwarz weg war, dann nochmal 25 Sek.
zum fertig rendern. Schwarzer Bildschirm deutet darauf hin das alles OK ist, aber Du Dich gedulden musst ;)

Sonst lade einfach mal eine page mit Hallo Welt und weissem hintergrund... und schau was passiert :)
Und achte auf der Spinner Rechts oben, wenn sich da ab und zu was tut, ist netsurf am arbeiten.

Und ausserdem, den Konsolen Output beachten, da sind doch wichtige Infos drinne!!! Dafür am besten den Puffer der Konsole auf einen hohen Wert stellen, um auch noch Zeilen anzeigen zu können die aus dem Fenster gescrollt wurden.
« Letzte Änderung: Di 15.06.2010, 12:32:58 von m0n0 »

Offline m0n0

  • Benutzer
  • Beiträge: 984
Anleitung SSL mit Netsurf
Hallo, hier noch eine Anleitung für SSL - ich selbst habe es noch nicht getestet, aber so sollte es in etwa gehen ;)

Ihr braucht dafür das tool curl (zum downloaden der benötigten Dateien), könnt ihr entweder auf der sparemint webseit runterladen oder hier:
http://nic-nac-project.org/~monokrom/monochrom.net/atari/ports/curl

( falls ihr von meiner Page runterladet, curl muss ins Verzeichnis /usr/bin kopiert werden )

dann folgende Kommandos auf der Shell ausführen um die SSL Zertifikate zu installieren ( Btw. es sind nicht die neuesten...):

mkdir -p /etc/ssl
cd /etc/ssl/
curl http://curl.haxx.se/ca/cacert.pem -o cacert.pem
curl http://nic-nac-project.org/~monokrom/monochrom.net/atari/ports/certs.tar.gz  -o certs.tar.gz
tar xfz ./certs.tar.gz
rm certs.tar.gz
(Am besten in eine Datei kopieren und dann ausführen, damit keine Schreibfehler unterlaufen ;) )

Dann in der Netsurf Konfigurationsdatei ( /root/.netsurf/Choices-fb )folgende Einträge machen:
http_proxy:0
ca_bundle:/etc/ssl/cacert.pem
ca_path:/etc/ssl/certs

Und dann mal SSL probieren, ich bin gespannt :) !
Bei der Option ca_bundle:/etc/ssl/cacert.pem bin ich mir nicht 100% sicher - es könnte auch sein das netsurf dort nur einen Pfad erwartet und dann einen Dateinamen dort anhängt.
« Letzte Änderung: Di 15.06.2010, 16:54:08 von m0n0 »

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Hallo m0n0, mal sehen ob ich das SSL nach dieser schönen Anleitung von Dir noch installiert bekomme.  :) Die Arbeit der MiNT-Prof's hat sich wirklich gelohnt. Ohne diese Arbeit müßte man wohl erst bei Null anfangen aber so gibt es schon einen stabilen Unterbau...

Offline m0n0

  • Benutzer
  • Beiträge: 984
Zitat
Die Arbeit der MiNT-Prof's hat sich wirklich gelohnt. Ohne diese Arbeit mu:sste man wohl erst bei Null anfangen aber so gibt es schon einen stabilen Unterbau...

Definitiv. FreeMiNT halt ;D

PS... blo:derweise ist mein Freeshell provider gerade offline, bzw. schon mehrere Stunden. Das heisst die Zertifikate ko:nnen nicht heruntergeladen werden. :( Aber wenn ihr ein Linux habt, ko:nnt Ihr auch einfach die Dateien aus /etc/ssl/certs nehmen ;)

PS2: Das Archiv mit den Zertifikaten hat nur Symbolische Links zu den echten Zertifikaten enthalten, d.h. es ist nutzlos, sobald der provider wieder online ist, lade ich ein neues Paket hoch.

PS3: Ansonten funktioniert CURL mit diesen Zertifikaten, d.h. SSL Seiten lassen sich damit abrufen. SSL sollte also funktionieren - sofern euer Atari die Entschlu:sselung innerhalb von 30 Sec. schafft - denn sonst ist das Timeout das durch netsurf gesetzt wird erreicht.

Die Zertifikate sind nun unter http://zorn.freeshell.org/certs.tar.gz zu erreichen.

« Letzte Änderung: Mi 16.06.2010, 10:48:15 von m0n0 »

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Hab jetzt mal einen ersten Erfolg auf meinem Falcon mit Netsurf verbucht. Es läuft besser als ich es gedacht hätte. Als Farbtiefe kann man auf einem Standard-Falcon entweder 256 oder 65535 Farben benutzen. Hier ein Screenshoot in 65535 Farben. Mit ner CTPCI und einer CT6X sollte das meiner Meinung nach schon recht ordentlich laufen. Von der Auflösung mal abgesehen lief es gar nicht mal so schlecht...ich hab ja einen Afterburner im Falcon und keine CT6X. Leider ist die Hydra schneckenlangsam...6Kb/Sek. Sonst gab es keine größeren Unterschiede im Vergleich zu Aranym mit Jit auf dem PC. Es kam mir sogar (30-40) % schneller vor. Tastatureingaben klappten auch wesentlich besser.




Offline tuxie

  • Benutzer
  • Beiträge: 6.830
  • Falcon! Milan! Schuetzt die Raubvoegel!
Da sage ich doch einfach mal Wow.

Das ist echt der Hammer!!
Tschau Ingo

Offline m0n0

  • Benutzer
  • Beiträge: 984
Hallo Arthur,

danke für diesen coolen Screenshot und das testen! :D

Zitat
Leider ist die Hydra schneckenlangsam...6Kb/Sek.

Das stimmt nicht! ;) Entweder das liegt am treiber, oder an der Treiberkonfiguration, oder daran das netsurf das system so auslastet das nur sehr selten die netzwerkdaten abgeholt werden können. Aber die Hardware kann schneller.

Hast du schonmal mit wget oder curl getestet wie schnell Du runter laden kannst? Ich komme definitiv auf mehr speed dabei (ziemlich genau 45 kb/s).

Gruß,
Ole

Edit: warum hast Du so eine niedrige Auflösung genutzt?

Und: ich benutze den Treiber ne2kenec.xif für die Hydra, vielleicht nutzt Du einen anderen? Es gibt ja mehrere...
« Letzte Änderung: Mo 21.06.2010, 12:19:40 von m0n0 »

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #10 am: Mo 21.06.2010, 14:38:48 »
Hallo Ole, ich hab die Geschwindigkeit, der Hydra, mit FTP-Serv getestet. Habe dann die nsfb 3,71 MB Datei vom PC auf den Falcon kopiert und das hat 12 Minuten gedauert (unter TOS). Filezilla zeigte 5.6Kb/Sek. an. Also definitiv zu lahm. Schreib also bitte nicht einfach "Das stimmt nicht!".

Edit: warum hast Du so eine niedrige Auflösung genutzt?

Lies den Text dazu vielleicht noch mal komplett.;)   65535Farben und Falcon= kleines Guckloch ohne Grafikkarte oder Screenblaster und ähnliches.

Offline m0n0

  • Benutzer
  • Beiträge: 984
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #11 am: Mo 21.06.2010, 15:20:23 »
Zitat
Hallo Ole, ich hab die Geschwindigkeit, der Hydra, mit FTP-Serv getestet. Habe dann die nsfb 3,71 MB Datei vom PC auf den Falcon kopiert und das hat 12 Minuten gedauert (unter TOS). Filezilla zeigte 5.6Kb/Sek. an. Also definitiv zu lahm. Schreib also bitte nicht einfach "Das stimmt nicht!".

Schreib ich ja auch nicht einfach so - ich wollte aber auch nicht das es so aussieht als ob die Hydra so lahm ist! Auch unter tos hatte ich nicht solche lahmen Geschwindigkeiten... ich habe zwar nicht mit der PC Seite gemessen, aber ich glaube nicht das alle Geschwindigkeitsanzeigen auf dem Atari Falsch sind... Da ist noch irgend was anderes faul.

Wegen der Auflösung,... achso ja, wenn man so viele Farben mit dem Falcon nutzt, dann ist die ja so gering... sorry, hab ich net dran gedacht.

P.S. die ersten patches für Atari wurden in das netsurf SVN eingepflegt *freu* - allerding mit nem falschen Kommentar - Es wurde Amiga mit Atari verwechselt ;)
« Letzte Änderung: Mo 21.06.2010, 15:24:50 von m0n0 »

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #12 am: Di 22.06.2010, 21:43:34 »
Vielleicht eine Unverträglichkeit mit dem Afterburner 040 in meinen Falcon?

Offline tuxie

  • Benutzer
  • Beiträge: 6.830
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #13 am: Mi 23.06.2010, 09:53:37 »
Hast du Busbeschleunigung in deine, Falcon? Welchen Treiber hast du? Versuch doch mal den Treiber für die CT60 vielleicht ist es dann besser.

Das die Netzwerkkarten am Romport schnarchlahm sind, ist so oder so richtig. Ob nun am TT oder Falcon es dauert schon seine Zeit. Das liegt mehr oder weniger daran das der Romport nur zum Lesen ausgelegt ist und man sich mit Tricks behilft darauf zu schreiben.

Tschau Ingo

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #14 am: Fr 25.06.2010, 22:00:49 »
Hast du Busbeschleunigung in deine, Falcon? Welchen Treiber hast du? Versuch doch mal den Treiber für die CT60 vielleicht ist es dann besser.

Nein, eine Busbeschleunigung habe ich noch nicht eingebaut. Würde aber gerne eine Phantoms einbauen. Das mit dem Treiber könnte ich mal testen.

Das die Netzwerkkarten am Romport schnarchlahm sind, ist so oder so richtig.  Ob nun am TT oder Falcon es dauert schon seine Zeit. Das liegt mehr oder weniger daran das der Romport nur zum Lesen ausgelegt ist und man sich mit Tricks behilft darauf zu schreiben.

Aber das ist für die meisten Atarianer auch keine Neuigkeit mehr. Und es gab Festplattenlösungen für den Romport die waren um Ellen schneller als Hydra oder NetUSBee. Unter MagiC ist es, wie ich gelesen habe, auch wesentlich schneller. Bei den Treibern gibt es also noch ne Menge Optimierungspotential.

Offline m0n0

  • Benutzer
  • Beiträge: 984
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #15 am: Sa 26.06.2010, 13:29:30 »
Zitat
Unter MagiC ist es, wie ich gelesen habe, auch wesentlich schneller. Bei den Treibern gibt es also noch ne Menge Optimierungspotential.

Wie bereits gesagt... ich bekommen 45 kb/s unter FreeMiNT.

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #16 am: Sa 26.06.2010, 22:12:01 »

Wie bereits gesagt... ich bekommen 45 kb/s unter FreeMiNT.

Sag ich doch, das ist ein richtiges Nadelöhr. Wenn eine IDE-Platte am Romport 300-600KB schafft dann gibt es noch viel Potential bei der Treiber und evtl. auch Hardwareoptimierung.
« Letzte Änderung: Sa 26.06.2010, 22:14:19 von Arthur »

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #17 am: So 27.06.2010, 23:41:32 »
Mich würde mal interessieren wer den Netsurf schon auf einem Atari laufen lassen hat oder evtl. noch die ein oder andere Schwierigkeit damit hat.

Offline Arthur

  • Benutzer
  • Beiträge: 10.304
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #18 am: Do 01.07.2010, 23:24:06 »

mkdir -p /etc/ssl
cd /etc/ssl/
curl http://curl.haxx.se/ca/cacert.pem -o cacert.pem
curl http://nic-nac-project.org/~monokrom/monochrom.net/atari/ports/certs.tar.gz  -o certs.tar.gz
tar xfz ./certs.tar.gz
rm certs.tar.gz

Dann in der Netsurf Konfigurationsdatei ( /root/.netsurf/Choices-fb )folgende Einträge machen:
http_proxy:0
ca_bundle:/etc/ssl/cacert.pem
ca_path:/etc/ssl/certs

Und dann mal SSL probieren, ich bin gespannt :) !
Bei der Option ca_bundle:/etc/ssl/cacert.pem bin ich mir nicht 100% sicher - es könnte auch sein das netsurf dort nur einen Pfad erwartet und dann einen Dateinamen dort anhängt.


Hab das weiter oben mal ausprobiert aber bei
curl http://nic-nac-project.org/~monokrom/monochrom.net/atari/ports/certs.tar.gz  -o certs.tar.gzhat er nur immer 250Byte runter geladen.
Hab die Datei dann auf dem PC runter geladen und per FTP auf den Falcon kopiert.tar xfz ./certs.tar.gz
rm certs.tar.gz
Entpacken und löschen hat anschließend funktioniert.

Leider blendet Netsurf unten in der Statuszeile irgenwas mit ssl ein und dann passiert nichts. Kennt wer eine einfache https-Seite zum testen?

Gruß Arthur
« Letzte Änderung: Do 01.07.2010, 23:30:24 von Arthur »

Offline m0n0

  • Benutzer
  • Beiträge: 984
Re: Tipps zu einer Testumgebung für Netsurf, Aranym, TT, Falcon und Co.
« Antwort #19 am: Fr 02.07.2010, 00:50:12 »
https://freeshell.de/

Bitte dran denken den log zu posten... und die Meldung in der Statuszeile...
Und es kann durchaus dauern bis die SSL Verbindung steht, ... Bei manchen Servern dauert das auf meinem PC sogar schon 30 Sek. ... wobei ich nicht weiss ob das dann auf dem Atari noch länger dauern würde.

auf meiner webseite ist auch eine Version der binary die mehr debug log ausspuckt. Dowload: http://nic-nac-project.org/~monokrom/monochrom.net/atari/dl/nsfb.gz

Einfach mit gzip -d nsfb.gz in dem netsurf Verzeichniss entpacken, in dem jetzt nsfb liegt... vorher die alter version evt. löschen?.

(Die Version funktioniert so wie ich das sehe übrigens auch mit aranym-jit)  

Gruß!