Autor Thema: FreeMiNT Netzwerk Autostart Problem  (Gelesen 3247 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline DonQuichote

  • Benutzer
  • Beiträge: 341
FreeMiNT Netzwerk Autostart Problem
« am: So 28.04.2024, 19:31:29 »
Hallo zusammen,

ich habe ein Problem bei der Installation des Netzwerkes mit der aktuellen FreeMiNT Version "freemint-latest-02060-tt_falcon_clones.zip" vom 17.04.2024 auf meinen TT.
Ich kann das Netzwerk nur manuell über die bash starten. Über die mint.cnf und dem mount in der xaaes.cnf klappt das nicht.

Hardware:
TT030 / Storm 256MB EDO / 10MB ST-RAM / Lightning VME / NOVA MACH32 2MB / 73GB SCSI HDD (HDDRIVER 12.04) / ASIX 88772A USB2LAN Adapter

Die Partition K: ist EXT2, und die Verzeichnisse darin haben den jeweiligen Inhalt von C:\MINT\1-19-CC5\SYS-ROOT, manuell vom USB-Stick unter MinT hineinkopiert. Die langen Dateinamen sind auf K:\ und U: vorhanden.

mint.cnf:

sln k:/bin      u:/bin
sln k:/boot     u:/boot
sln k:/etc      u:/etc
sln k:/home     u:/home
sln k:/lib      u:/lib
sln k:/mnt      u:/mnt
sln k:/opt      u:/opt
sln k:/root     u:/root
sln k:/sbin     u:/sbin
sln k:/share    u:/share
sln k:/tmp      u:/tmp
sln k:/usr      u:/usr
sln k:/var      u:/var

In der mint.cnf habe ich des Weiteren unterhalb von "exec u:/sysdir/usb/loader.prg" folgende Zeilen eingefügt:

exec u:/bin/ifconfig asx0 addr 192.168.10.190 netmask 255.255.255.0 up
exec u:/bin/route add default asx0 gw 192.168.10.1

In der xaaes.cnf habe ich den mount unterhalb der Zeile von "run u:\opt\GEM\toswin2\toswin2.app" hinzugefügt:

run u:\bin\mount_nfs -v -o rw,rsize=1024,wsize=1024,retrans=10 192.168.10.250:/volume1/ATARI/16Bit /nfs/Diskstation

Beim Booten bekomme ich dann diese Zeilen zu sehen:

asx0: cannot get FLAGS: No such file or directory
cannot add route: Network is unreachable.


Wenn MinT durchgestartet ist und ich in Teradesk die TosWin2 Shell aufrufe, kann ich das hier Zeile für Zeile eingeben und das Netzwerk incl. gemounteter NAS unter u:/nfs funktioniert:

[root@TT030] ~]# ifconfig asx0 addr 192.168.10.190 netmask 255.255.255.0 up [Return]

[root@TT030] ~]# route add default asx0 gw 192.168.10.1 [Return]

[root@TT030] ~]# mount_nfs -v -o rw,rsize=1024,wsize=1024,retrans=10 192.168.10.250:/volume1/ATARI/16Bit /nfs/Diskstation [Return]

Ach ja - die ASIX.XIX in C:\MINT\1-19-CC5\ ist umbenannt in ASIX.XIF und in C:\MINT\1-19-CC5\USB\ sind nur die Dateien von der Lightning VME Treiberdisk V3.33 vorhanden:

BLITZ030.UCD
ETH.UDD
LOADER.PRG
STORAGE.UDD
USB030.KM

Was habe ich nach gefühlt unzähligen Stunden übersehen? Berechtigungsprobleme? Komme hier nicht mehr weiter.
Kann mir jemand einen Tip geben?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.216
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: FreeMiNT Netzwerk Autostart Problem
« Antwort #1 am: So 28.04.2024, 19:43:34 »
Die mount befehle gehören auch in die mint.cnf hinter die Netzwerk Aufrufe ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.216
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: FreeMiNT Netzwerk Autostart Problem
« Antwort #2 am: So 28.04.2024, 19:51:11 »
Meine cnf vom Falcon ...

# MINT.CNF erstellt von EasyMiNT Installer am 09.07.2018 um 17:54:56
#
SLICES=2
#
# filesystem cache (kb)
# more memory increases the filesystem speed
CACHE=256
#
# enable VFAT (long names) for this drives
# (can be changed in runtime by FSetter too)
VFAT=A,F
#
# enable write protection for this drives
# (can be changed in runtime by FSetter too)
# WRITEPROTECT=
#
# completly remove drive B:
# HIDE_B=Y
#
# Links zu EasyMiNT
sln e:\bin   u:\bin
#sln c:\mint\1-19-cur\sys-root\bin u:\bin
sln e:\lib   u:\lib
sln e:\etc   u:\etc
sln e:\home   u:\home
sln e:\usr   u:\usr
sln e:\tmp   u:\tmp
sln e:\var   u:\var
sln e:\sbin   u:\sbin
sln e:\root   u:\root
sln e:\opt   u:\opt
sln e:\mnt   u:\mnt
sln e:\boot   u:\boot
echo
#
setenv LOGNAME root
setenv USER    root
setenv HOME      /root
setenv SHELL   /bin/bash
# Environment
setenv PCONVERT PATH,HOME,SHELL
setenv UNIXMODE /brUs
setenv PATH u:\bin,u:\usr\bin,u:\usr\sbin,u:\sbin,u:\boot\mint\bin,c:\mint\1-19-cur\xaaes
#
#
# Autostartprogramme
# Filesystemcheck (mandatory)
exec u:\c\mint\bin\sh u:\c\mint\bin\fscheck.sh
echo

#
# Timezone (mandatory)
#exec   u:\sbin\tzinit -l
#echo
#
# Check filesystems.
#exec u:\e\sbin\e2fsck e:

# Set up system folders etc
#include u:/c/mint/1-19-cur/sys-root/sys.cnf

# Initalize network.
exec c:\mint\1-19-cur\sys-root\bin\ifconfig.ttp ne0 addr 192.168.2.14 netmask 255.255.255.0 up
exec c:\mint\1-19-cur\sys-root\bin\route.ttp add default ne0 gw 192.168.2.1

#include u:/c/mint/1-19-cur/sys-root/network.cnf
#
# USB
exec u:\c\mint\1-19-cur\usb\loader.prg
#
# Additional tools
# Draconis to MiNT-Net gateway
#exec u:\c\mint\1-19-cur\sys-root\opt\gem\mgw\mgw.prg
# echo
# Gluestik - STiK/STiNG to MiNT-Net gateway
exec u:\c\mint\1-19-cur\sys-root\opt\gem\gluestik\gluestik.prg
echo
#
# mount nfs
exec /sbin/mountnfs.ttp -v -o rw,rsize=1024,wsize=1024,retrans=10 192.168.2.118:/Users/frank/Downloads/Atari /nfs/MacPro
echo
#
#setenv SLBPATH '.\;c:\mint\slb\;c:\gemsys\xtension\;c:\gemsys\slb\'
#setenv SDL_VIDEODRIVER gem
#setenv TMPDIR u:\ram
#
cd u:\
#INIT=u:\bin\bash
GEM=u:\c\mint\1-19-cur\xaaes\xaloader.prg
#INIT=u:\c\mint\1-19-cur\xaaes\xaloader.prg
#INIT=u:\c\mint\oaesis\oaesis.prg
echo Setup complete, now booting system...
echo

Offline czietz

  • Benutzer
  • Beiträge: 3.623
Re: FreeMiNT Netzwerk Autostart Problem
« Antwort #3 am: So 28.04.2024, 19:57:30 »
Eventuell mal eine Pause in MINT.CNF nach dem Starten der USB-Treiber und vor dem Aufruf von ifconfig einfügen? Vielleicht braucht LAN-Interface zu lange für die Initialisierung? Für einen ersten Test vielleicht ein Programm, das auf einen Tastendruck wartet, wie von Thorsten hier gepostet: https://www.atari-forum.com/viewtopic.php?p=420714#p420714

Offline DonQuichote

  • Benutzer
  • Beiträge: 341
Re: FreeMiNT Netzwerk Autostart Problem
« Antwort #4 am: So 28.04.2024, 21:00:20 »
Danke ihr beiden dass ihr euch das angesehen und auch so schnell geantwortet habt! Das Problem ist gelöst! Nicht zu glauben dass ich wegen so einer banalen Sache so viele Stunden vor dem TT verbracht habe.

Ursache: Ich habe in der frischen mint.cnf aus dem Download den ifconfig-Netzwerkinit in den Teil der cnf gesetzt, wo der Netzwerkstart dokumentiert ist. Was ich aber nicht beachtet habe ist, dass diese Zeilen ja noch vor dem Start der USB-Treiber aufgeführt sind. Daher klar, ohne USB kein LAN-Adapter und kein Netzwerk beim Aufruf von ifconfig.
Boah..., manchmal sieht man den Wald vor lauter Bäumen nicht mehr  :-\

@ Frank:
Ich habe die mount-Zeile, wie du sagtest, hinter die Netzwerkinit-Zeilen in der mint.cnf gesetzt und zugleich aus der xaaes.cnf heraus genommen. Würde mir so auch viel besser gefallen, dass die Netzwerksachen beisammen sind. Der TT schmiert dabei aber ab. Xaaes wird gestartet, dann wird der Bildschirm verpixelt grau und man kann nur noch einige Zeilen mit "terminiert" und "unmount" o.ä. erkennen, dann freeze.
Jetzt, wo ich die mount-Zeile wieder zurück in die xaaes.cnf verschoben habe, klappt es. Warum weiß ich nicht.

Also, noch mal vielen Dank an euch!

Gruß, DQ

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.216
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: FreeMiNT Netzwerk Autostart Problem
« Antwort #5 am: So 28.04.2024, 21:47:04 »
Bei mir klappt das immer alles aus der mint.cnf heraus. Das Beispiel vom Falcon nutzt kein USB Teil sonders den Netzwerkteil einer NetUSBee. Auf meinem Atari TT und MegaST mit PAK nutze ich EasyMiNT und da läuft das alles ein wenig anders ...

Offline DonQuichote

  • Benutzer
  • Beiträge: 341
Re: FreeMiNT Netzwerk Autostart Problem
« Antwort #6 am: Do 02.05.2024, 20:15:04 »
Geht jetzt auch bei mir aus der mint.cnf heraus, so wie es soll. Die Abstürze kamen offenbar von der SCSI Platte. Die ist den sporadischen Lauten nach zu urteilen die sie jetzt macht EOL.
Mit der gleichen, aber externen Platte läuft es bisher gut.
Mal sehen was noch so kommt ;-)