Autor Thema: GFA Basic bis 3.06 TT und PS/2-Tastaturen via Tastaturadapter am ATARI  (Gelesen 816 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline mike9876

  • Benutzer
  • Beiträge: 15
Problem
GFA-Basic macht zB auf dem TT030 beim Starten einen weissen Bildschirm, nur Mauszeiger sichtbar und Tastaturklicks hörbar ??
Ursache
GFA-Basic benötigt eine Tastatur, die am TT angeschlossen ist. bei original-ATARI-Tastaturen startet GFA einwandfrei. Bei PS/2-tastaturen mit PS/2-Adapter bisher nicht.
Es scheint ein Timing-Problem zu sein, was NICHT bei meinem MEGA-STE, 4 MB, TOS 2.06 UND KEINWERLEI Programme im Autoordner UND 8 MHz Systemtakt auftritt !!
Bei einem anderen ATARIANER tritt das Problem auf am MSTE, er hat den auch auf 16 MHz geschaltet im Kontrollfeld.....
Irgendwie muß GFA also seine Tastaturabfrage OHNE Timerprobleme machen können.....
Die Tastatur wird abgefragt, wobei es erstmal unwichtig ist, ob joystik-port, tastatur selber oder maus-port abgefragt werden.das hauptproblem scheint ein Timing-problem zu sein, was vorallem mit der Taktfrequenz der CPU zusammenhängt.
Not-Lösung
Damit diese Tastatur-Abfrage seitens GFA reibungslos läuft, GFA PRG starten mit angeschlossener original ATARI-Tastatur, das GFA-Editor-Fenster erscheint mit menue-Zeile und ganz rechts Uhrzeit-Anzeige. Jetzt die ATARI-Tastatur ausstöpseln und den PS/2-Tastaturadapter mit angeschlossener PS/2 Tastatur/Maus einstecken; 2-3 sekunden warten, bis adapter synchronisiert hat.
Nun lässt sich die Maus bewegen, und im Editor lassen sich Programme schreiben und mittels -run-
auch störungsfrei ausführen (habe nur kleine GFA-Programme getestet...)
Vermeiden Sie erstmal programme, die auf den Joystik-Port zugreifen, denn die handelsüblichen
PS/2 - tastaturadapter haben keinen Joystik-Anschluss !!
Nun können Sie GFA wieder verlassen mit -quit-. Sie können jetzt wie vorher auch, ganz normal auf
dem desktop herumnavigieren und andere programme starten, wie zB Calamus, ect.
--> Sobald Sie aber erneut GFA.PRG starten vom Desktop aus, haben wie wieder das ursprüngliche problem: Bildschirm bleibt weis. Also dann wieder vorher ATARI-tastatur anstöpseln und erst die tastatur wechseln, wenn das GFA-Editor-fenster geöffnet ist.
------
Entgültige Lösung: Tastaturadapter müssten hardwaremässig einen Joystik-Port vorgaukeln, keinenJoystik selber. Denn dann liefert die tastatur betreffs des Joystik-ports die Antwort <false>, was
dem GFA sagt, dass kein Joystik angeschlossen ist. und das reicht auch schon aus !!
---  Eine weniger akzeptable Lösung wäre ein Timer-Schalter für den ATARI TT, der im AUTO-ordner
beim Booten ausgeführt ist und dem Anwender Zeit gibt, binnen zB 30 sek. das GFA-PRG zu starten.
Danach schaltet der Timer die Taktfrequenz des TTs wieder auf 32 MHz (vorrausgesetzt, dass dies geht
ohne einen Kaltstart des Computers).
Soweit....

Offline czietz

  • Benutzer
  • Beiträge: 3.349
Siehe auch diesen Thread, der dasselbe Problem und eine gepatchte GFA-Basic-Version enthält: https://forum.atari-home.de/index.php/topic,16929.msg260159.html#msg260159