Autor Thema: 1040-STE - Blitter Fix  (Gelesen 1085 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline R^2

  • Benutzer
  • Beiträge: 57
1040-STE - Blitter Fix
« am: So 18.09.2022, 14:24:24 »
Hallo liebe Mitleser!

Beim herumbasteln in meinem 1040-STE ist mir etwas aufgefallen. Der dortige Blitter hat ein Problem(chen). Dabei ist egal, ob es sich um den in U400 verbauten Blitter oder um den solitären Blitter im Sockel U101 handelt.

Bei der Übergabe des Busses zum Blitter kann es auf der /BG Leitung (Bus Grant) zu einem Spike (einer Impulsnadel) kommen, die die Übergabe an den Blitter verhindert. Dieses Problem ist im 1040-STE grundsätzlich immer vorhanden. Es wird nur beim Einsatz von Beschleunigerkarten für den 1040-STE eher schlimmer statt besser.

Abhilfe bringt hier ein keramischer Kondensator mit einer Kapazität von etwa 47 pF an dieser /BG-Leitung gegen Masse. Wichtig dabei ist, dass dieser Kondensator immer möglichst direkt an dem jeweiligen Blitter sitzt.

Dies bedeutet:
  • Sitzt der Blitter im Chip U400 integriert, dann muss der Kondensator in der Nähe von U400 eingelötet werden. Gut geeignet in diesem Fall ist eine Durchkontaktierung links neben U400, die mit Pin 11 des 68000er Sockels Verbindung hat. Die Masse kann man gut an C404 abgreifen. Siehe hierzu das beigefügte Bild.
  • Sitzt der Blitter solitär im Sockel von U101, dann muss der Kondensator möglichst bei U101 eingelötet werden. Gut geeignet in diesem Fall ist der nicht bestückte Platz von R111. Davon ist der untere Kontakt der richtige Kontakt. Dieser hat wiederum Kontakt mit Pin 11 des 68000er Sockels. Die Masse kann man in diesem Fall gut an C106 abgreifen. Siehe hierzu das weitere beigefügte Bild.
Beste Grüße
Robert
« Letzte Änderung: Do 22.09.2022, 22:42:20 von Lynxman »

Offline Highspeed

  • Benutzer
  • Beiträge: 281
Re: 1040-STE
« Antwort #1 am: So 18.09.2022, 16:14:50 »
Danke für die Info, ist das der Grund wieso der STE bei der Testung der Twister gerne mahl fehler gebracht hat?
Sollte man diesen Mod bei der Verwendung von Turbokarten im STE immer durchführen und gibt es den fehler auch beim MSTE?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: 1040-STE
« Antwort #2 am: So 18.09.2022, 17:11:17 »
Vielen Dank für den Tech Tipp, baue den Kondensator gleich morgen mal ein ...

Offline R^2

  • Benutzer
  • Beiträge: 57
Re: 1040-STE
« Antwort #3 am: So 18.09.2022, 18:19:27 »
Hallo Highspeed!
... ist das der Grund wieso der STE bei der Testung der Twister gerne mahl fehler gebracht hat?

Ja und nein. Bei meiner Mitwirkung bei der TwiSTEr hatte ich zwar auch mit diesem Phänomen zu kämpfen, aber auch damit, dass der Blitter bei vielen Operationen auch auf das 8MB große Alternate RAM zugreifen möchte. Bei der TwiSTEr ist diese Herausforderung gelöst. Blitter und der jeweilige Prozessor (68000er oder wahlweise 68020er) laufen ganz problemlos miteinander.

Zitat
Sollte man diesen Mod bei der Verwendung von Turbokarten im STE immer durchführen ..
Ja, im 1040-STE macht der Patch auf jeden Fall Sinn. Auch ohne Beschleunigerkarte konnte ich messen, dass eine Busübergabe zum Blitter das eine oder andere Mal schief läuft. Es wird zwar dann versucht den Bus noch einmal an den Blitter zu übergeben, aber man verliert Zeit. Kommt dies häufig vor, so wird immer wieder der Bus arbitriert und man kann spürbar den Zeitverlust messen.

Zitat
... und gibt es den fehler auch beim MSTE?

Diesen Fehler habe ich bisher nur beim 1040-STE nachgemessen. Beim Mega-STE habe ich diesen Fehler bisher nicht messen können. Dieser Patch ist folglich nur für den 1040-STE gedacht.

Beste Grüße
Robert


Offline R^2

  • Benutzer
  • Beiträge: 57
Re: 1040-STE
« Antwort #4 am: So 18.09.2022, 18:57:15 »
Was ich noch vergessen hatte zu schreiben:

Der Patch ist auch deshalb wichtig, weil der Blitter bei der TwiSTEr in den langsamen Betriebsmodi der beiden Prozessoren auch den USB-Betrieb in der Transferleistung unterstützt. Damit werden hohe Übertragungsraten erreicht. Gerade dann, wenn der 68000er oder der 68020er mit 8 MHz betrieben werden. Auch deswegen ist der Patch wichtig. Würde der Blitter dabei eine Neuarbitrierung ständig antreten, geht die Performance ganz schön in den Keller.

Allerdings muss man fairer Weise sagen, dass der 68020er in seinem schnellen Modus auf der TwiSTEr mit 24 MHz Taktbetrieb den Blitter zur Unterstützung gar nicht mehr benötigt. Er ist einen Hauch schneller ohne Blitter im Gegensatz wenn man den Blitter anlässt - gerade bei grafischen Ausgaben. Ein Coremark-Wert der TwiSTEr von 8,29 spricht für sich.

Beste Grüße
Robert

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: 1040-STE
« Antwort #5 am: Do 22.09.2022, 14:22:29 »
@ R^2 ... habe nur 39pF

Habe noch zwei 100pF in Reihe also 50pF. Mein Oszilloskop ist bestimmt viel zu langsam um mir das ansehen zu können.

Offline R^2

  • Benutzer
  • Beiträge: 57
Re: 1040-STE
« Antwort #6 am: Do 22.09.2022, 15:41:38 »
Hallo Frank!
@ R^2 ... habe nur 39pF

Das reicht aus. Nimm 39 pF.

Zitat
Habe noch zwei 100pF in Reihe also 50pF. Mein Oszilloskop ist bestimmt viel zu langsam um mir das ansehen zu können.

Nee, parallel und in Reihe sieht nicht gut aus. Und - wie oben erwähnt - ist es nicht notwendig.

Gruß Robert

Offline Lynxman

  • Moderator
  • *****
  • Beiträge: 1.989
  • Nicht Labern! Machen!
Re: 1040-STE - Blitter Fix
« Antwort #7 am: Do 22.09.2022, 22:55:50 »
Ich habe auf Wunsch von gh-baden und R^2 das Thema geteilt.

2 kleine Beiträge sind dabei unter die Räder gekommen, aber da die Fragen im weiteren beantwortet wurden ist das nicht so relevant. (Trotzdem sorry tuxie und gh-baden.)
Aktuelle Lynx FlashCard Firmware: hier klicken

Nerd? I prefer the term INTELLECTUAL BAD ASS

Ich kann nicht alle glücklich machen, ich bin ja keine Pizza!

Werde auch Du Fan von Lynxmans Basteltagebuch!  Klick mich, Du willst es doch auch! ;)