Autor Thema: Speicher Defekte Atari 260/520ST ...  (Gelesen 1136 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Speicher Defekte Atari 260/520ST ...
« am: Sa 20.08.2022, 18:18:47 »
Habe hier ein 520ST Board mit zwei 512kB Rambänken also obenauf auf die Bank_0 aufgelötete Bank_1 Bausteine. Der Rechner läuft allerdings nur mit 512kB also nur Bank_0 läuft. Alle Adressen MAD0-8 sind da und RAS und beide CAS haben keinen Schluss nach VCC oder GND. Alle Lötverbindungen sehen gut aus und kein Baustein wird warm. Habe die zusätzliche Bank_1 mal auf Bank_0 gelegt aber der Rechner ist so tot auch mit Testmodul und Nullmodemkabel. Weiss nichts ausser alles runter und neue Chips auflöten?

Weiss jetzt erstmal nicht weiter und brauche Tipps ...

Offline czietz

  • Benutzer
  • Beiträge: 3.262
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #1 am: Sa 20.08.2022, 21:20:38 »
Je nach Fehler und verbauter MCU kann funktionieren: Mit 512 kiB (Bank 0) booten, YAARTTT starten, "M" für den manuellen Modus drücken, dann zu testende Adressen 0x80000 bis 0xFFFFF eingeben.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #2 am: Sa 20.08.2022, 22:35:03 »
Kann ich mal versuchen ...

MMU ist die Atari keine IMP. Habe einen Mega ST1 mit 8Stk. 1Mx4 Chips und da war mal die zweite 2MB Bank weg. Eine Adresse fehlte weil kein Kontakt über das SMD Pad. Wenn RAS und CAS da ist weiss ich nicht was eine ganze Bank sonst noch ausfallen lässt?

Offline SpyVsSpy

  • Benutzer
  • Beiträge: 5
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #3 am: So 21.08.2022, 11:35:48 »
Wenn RAS und CAS da ist weiss ich nicht was eine ganze Bank sonst noch ausfallen lässt?
Wenn /WE keinen Kontakt hat, kann kein Prüfmuster reingeschrieben werden.

Manche Youtube-Retro-Bastler hatten wohl Erfolg bei der Diagnose, wenn sie ein funktionstüchtiges DRAM auf ein (vermeintlich) defektes DRAM gedrückt habe, so daß alle Pins Kontakt hatten. Kann sicher funktionieren. Ansonsten Oszi nehmen und schauen, ob ein Datenpin (Pins 2 & 14 sind kurzgeschlossen) im Betrieb knallhart gegen festes Potential zieht.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #4 am: So 21.08.2022, 12:08:46 »
Bank_0 funktioniert ja und die 16Stk. 256x1 Ram Bausteine der Bank_1 sind alle 1:1 auf die Bausteine der Bank_0 draufgelötet ausser RAS und CAS ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #5 am: So 21.08.2022, 14:09:46 »
Je nach Fehler und verbauter MCU kann funktionieren: Mit 512 kiB (Bank 0) booten, YAARTTT starten, "M" für den manuellen Modus drücken, dann zu testende Adressen 0x80000 bis 0xFFFFF eingeben.

Nur lauter Errors fortlaufend.

Beim ST Ram Test fehlerfrei, also die ersten 512kB

Offline Arthur

  • Benutzer
  • Beiträge: 9.974
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #6 am: So 21.08.2022, 14:15:32 »
Hallo Frank, hat das mal funktioniert in diesem Atari oder ist er dir defekt zugeflogen? Kannst du mal ein Bild davon machen.

Offline czietz

  • Benutzer
  • Beiträge: 3.262
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #7 am: So 21.08.2022, 14:39:50 »
Nur lauter Errors fortlaufend.

Ja, das ist klar. Würde der Speicher funktionieren, hättest Du keine Probleme damit. Du solltest aus den Fehlermeldungen schließen, worin das Problem besteht.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #8 am: So 21.08.2022, 14:45:33 »
Du solltest aus den Fehlermeldungen schließen, worin das Problem besteht.

Ja kann ich aber nicht

!
Hallo Frank, hat das mal funktioniert in diesem Atari oder ist er dir defekt zugeflogen? Kannst du mal ein Bild davon machen.

Ja natürlich lief der Rechner mal ohne Fehler. Sieht im Prinzip genau so aus ...
« Letzte Änderung: So 21.08.2022, 16:52:13 von Lukas Frank »

Offline Arthur

  • Benutzer
  • Beiträge: 9.974
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #9 am: So 21.08.2022, 17:50:17 »
Auf Kabelbruch hast du schon getestet?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #10 am: So 21.08.2022, 18:06:47 »
Ja

Habe auch die drei Kabel vom PLCC Sockel von unten weg gemacht und neue von oben auf die Lötaugen incl. 68 Ohm Widerständen für CAS Low und High bestückt. Das ist vorgesehen auf der 260/520ST Platine ...
« Letzte Änderung: So 21.08.2022, 18:17:13 von Lukas Frank »

Offline gh-baden

  • Benutzer
  • Beiträge: 1.790
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #11 am: So 21.08.2022, 19:26:49 »
Du solltest aus den Fehlermeldungen schließen, worin das Problem besteht.

Ja kann ich aber nicht

Okay. Ich auch nicht.

Aber wenn du die Fehlermeldungen hier nicht postest, dann kann es niemand. Manchmal bist du schon unnötig grantelig bei der Fehlersuche  :D
Wider dem Signaturspam!

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #12 am: So 21.08.2022, 19:35:16 »
Habe das Board jetzt erstmal für ein bis zwei Wochen bei Seite gelegt ...

Offline Megatari

  • Benutzer
  • Beiträge: 132
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #13 am: Mo 22.08.2022, 13:24:23 »
Vielleicht ist einer der Rams defekt. Das kann nach knapp 35 Jahren mal passieren.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #14 am: Mo 22.08.2022, 13:32:46 »
Da die alle oben aufgelötet sind ist das schwer bis ummöglich zu finden. Wenn man einen runternimmt und RAS sowie CAS Pins wieder runterbiegt brechen die bestimmt ab.
« Letzte Änderung: Mo 22.08.2022, 14:10:33 von Lukas Frank »

Offline Lynxman

  • Moderator
  • *****
  • Beiträge: 1.989
  • Nicht Labern! Machen!
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #15 am: Mo 22.08.2022, 23:35:43 »
Je nach Fehler und verbauter MCU kann funktionieren: Mit 512 kiB (Bank 0) booten, YAARTTT starten, "M" für den manuellen Modus drücken, dann zu testende Adressen 0x80000 bis 0xFFFFF eingeben.

Nur lauter Errors fortlaufend.

Beim ST Ram Test fehlerfrei, also die ersten 512kB

Ist es so schwer ein Bild von den Fehlermeldungen zu Posten?
Aktuelle Lynx FlashCard Firmware: hier klicken

Nerd? I prefer the term INTELLECTUAL BAD ASS

Ich kann nicht alle glücklich machen, ich bin ja keine Pizza!

Werde auch Du Fan von Lynxmans Basteltagebuch!  Klick mich, Du willst es doch auch! ;)

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #16 am: Di 23.08.2022, 14:10:26 »
Hatte etwas Zeit und das Board hervorgeholt ...

Pass:   1. Test #1: Address test, own address.

Errors:      0.

Pass:   1. Test #1: Address test, own address.

Errors:      1. Last error: 0x00080002 (0020!=0000)

Pass:   1. Test #1: Address test, own address.

Errors:      2. Last error: 0x00080006 (0424!=0004)

Pass:   1. Test #1: Address test, own address.

Errors:      3. Last error: 0x0008000a (0028!=0008)

Pass:   1. Test #1: Address test, own address.

Errors:      4. Last error: 0x0008000e (042c!=000c)

Pass:   1. Test #1: Address test, own address.

Errors:      5. Last error: 0x00080012 (0030!=0010)

Pass:   1. Test #1: Address test, own address.

Errors:      6. Last error: 0x00080016 (0434!=0014)

Pass:   1. Test #1: Address test, own address.

Errors:      7. Last error: 0x0008001a (0038!=0018)

Pass:   1. Test #1: Address test, own address.

Errors:      8. Last error: 0x0008001e (043c!=001c)

Pass:   1. Test #1: Address test, own address.

Errors:      9. Last error: 0x00080022 (0400!=0020)

Pass:   1. Test #1: Address test, own address.

Errors:     10. Last error: 0x00080026 (0028!=0008)

Offline czietz

  • Benutzer
  • Beiträge: 3.262
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #17 am: Di 23.08.2022, 17:39:18 »
Mindestens mal die Bits für 0x400 und 0x20 kaputt, also D10 und D5. Ob nun die entsprechenden RAM-Bausteine defekt sind oder sie vielleicht eine wacklige Verbindung haben, kann man aus der Ferne nicht sagen.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.985
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #18 am: Di 23.08.2022, 17:44:32 »
Danke ...

Aber ist es nicht so das wenn nur zwei Datenbits defekt sind das Atari Testmodul mir 1MB mit Fehlern anzeigen sollte?  Das Testmodul zeigt mir immer nur 512kB an also nur Bank_0

Offline czietz

  • Benutzer
  • Beiträge: 3.262
Re: Speicher Defekte Atari 260/520ST ...
« Antwort #19 am: Di 23.08.2022, 17:46:26 »
Aber ist es nicht so das wenn nur zwei Datenbits defekt sind das Atari Testmodul mir 1MB mit Fehlern anzeigen sollte?

Keine Ahnung.