Autor Thema: defekter Mega ST4 ...  (Gelesen 111 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.063
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
defekter Mega ST4 ...
« am: Gestern um 16:06:00 »
Seltsamer Fehler bei einem Atari Mega ST4 Mainboard ...

Der Chipsatz ist in Ordnung. Das Testmodul testet den Speicher mit pass und Blittertest ebenso mit pass. Im Service Manual hat jemand mit Bleistift geschrieben beim T4 Error (MMU) aber die ist in Ordnung und das DE und Vsync Signal ist an der MMU da von der GLUE. Der Pixelmüll beim ST-Hoch Desktop kommt wenn man mit der Maus in die Menüleiste fährt. Dachte zuerst an den Blitter aber der Baustein ist in Ordnung und das Board ist nicht verbastelt ausser das es ein Mega2 war und jemand die zweite Rambank bestückt hat und die beiden 74LS373 gesockelt wurden, sieht aber alles gut aus ...
« Letzte Änderung: Gestern um 16:11:35 von Lukas Frank »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.063
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: defekter Mega ST4 ...
« Antwort #1 am: Gestern um 19:02:40 »
Daten und Adress Signale zwischen CPU, MMU und den vier Latches (244/373) und dem Shifter geprüft und alles in Ordnung.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.063
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: defekter Mega ST4 ...
« Antwort #2 am: Gestern um 19:34:19 »
Habe die zweite 2MB Ram Bank entfernt und der Desktop Pixelmüll ist deutlich weniger aber immer noch da und es wird schlimmer je mehr man die Maus bewegt.

Blitter entfernt und jetzt läuft der Rechner und bootet von einer Festplatte und führt Programme aus. YAART meldet nach sechs durchläufen kein Problem.

Die zweite Rambank hatte keine Bausteine bekannter Hersteller, sieht so nach noname aus. Aufdruck ist "51100B-70 / F0791"

Es ist ein alter Mega ST2  mit Blitter aber ohne die Blitter Patch Platine von Atari. Das Mainbaord hat diese unterbrochene Leiterbahn nicht. Normalerweise funktioniert das auch ohne diese Patch Platine. Muss als nächster alle 68 Kontakte am Blitter Sockel nachmessen, mal schauen ...?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.063
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: defekter Mega ST4 ...
« Antwort #3 am: Gestern um 19:37:43 »
Lila Hintergrund anstatt weiss unter ST-Gering ist noch da und die Floppy geht garnicht. DS0 ist dauerhaft selektiert ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.063
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: defekter Mega ST4 ...
« Antwort #4 am: Gestern um 20:09:31 »
ProVME Pro32 einmal nur mit 16Mhz und dann mit 16Mhz und Cache an ...

Scheint immer auf 16Mhz mit Cache aus zu laufen und man kann den Cache an oder ausschalten über PSG Pin15 aber da liegt beim Mega ST das GPO Signal ...!?!

Vielleicht umlegen auf Pin14 ...?
« Letzte Änderung: Gestern um 22:33:17 von Lukas Frank »

Offline skul

  • Benutzer
  • Beiträge: 247
Re: defekter Mega ST4 ...
« Antwort #5 am: Gestern um 21:02:22 »
Moin,

bei ST-high sieht man über den Monitor sozusagen direkt ins Ram. Für mich sieht es so aus, als würden invalide Daten ins Ram geschrieben. Wenn der Fehler auch mit der original Rambank 0 auftritt, könnte ein Bustreiber zu lahmarschig geworden sein. Vielleicht die beiden mal totlegen und statt dessen die von Bank 1 benutzen, lässt sich über die Widerstände wohl recht flott umlöten, oder gleich neue einbauen.
Die Huckepackplatine für den Bitter (74LS74 wenn ich mich recht entsinne) war wohl nur beim IMP Chipsatz für einen timinggerechten Blitterzugriff notwendig.

Gruß
skul

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.063
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: defekter Mega ST4 ...
« Antwort #6 am: Gestern um 21:52:08 »
So wie es scheint ist der Blitter das Problem, der Baustein ist aber in Ordnung.

Du meinst die beiden 74xx244 die die Steuersignale von der MMU zu den Ram Bänken Treiben? Sollten F244 sein so wie ich das kenne aber in dem Board sind es zwei LS244 und das Ram der Bank 1 hat 150ns alles original Atari ...