Autor Thema: Restauration Atari 260ST  (Gelesen 703 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline kernal

  • Benutzer
  • Beiträge: 90
Re: Restauration Atari 260ST
« Antwort #20 am: Di 24.05.2022, 05:49:11 »
Keine Ahnung, ob das mit FlashFloppy auch möglich ist. Man muss dazu die "Drehzahl" der emulierten Floppy halbieren, damit die Bitrate bei doppelter Sektorzahl gleich bleibt.

Sollte funktionieren. In der IMG.CFG [1] kann die "Drehzahl" vom Image konfiguriert werden.
Ausprobiert habe ich es noch nicht.
Zitat
rpm = 1-1000 (300*)

Rotational RPM

[1] https://github.com/keirf/flashfloppy/wiki/IMG.CFG-Configuration-File

Offline Mado

  • Benutzer
  • Beiträge: 193
Re: Restauration Atari 260ST
« Antwort #21 am: Fr 03.06.2022, 22:19:25 »
So, der vorletzte Schritt meiner Instandsetzung hat jetzt auch funktioniert: Ich habe jetzt EmuTOS im ROM, gerade frisch programmiert. Denn in meinem ollen 260ST waren EPROMs verbaut:

GI 27C256-25 https://pccomponents.com/datasheets/GI-27256-20.PDF

15 Minuten mit UV gelöscht, dann mit dem TL866II+ mit 12,5V programmiert. Da der TL866II+ den Chip nicht kennt, ist wohl zu alt, habe ich die Werte vom 27C256 von Intel genommen. Hat wohl annähernd die gleiche Werte.

Und: Erst lief es nicht, da ich die ROMs falsch gesteckt hatte. Es ist genau umgekehrt, wie bei den 1040ern: Steht der Rechner mit der Tastatur zu einem, dann geht es von vorne nach hinten in dieser Reihenfolge:

L0, L1, L2 dann H0, H1, H2 (L=Low, H=High)
Die MicroSD-Card-Festplatte vom Ultrasatan Mini wird vom EmuTOS direkt ohne weitere Treiber erkannt. Beide 512MB-Partitionen. Backup läuft so: MicroSD-Karte in meinen Laptop stecken, mounten und ein Zip draus machen.

Zusätzlich habe ich das aus dem Magic Mac von Thorsten zusammengebaute NVDI2.5 drauf. Damit habe ich jetzt assembleroptimierte VDI-Routinen und das ganze ist angenehm flott trotz langsamem 68000er:

GEMBENCH 608 Build 31
======================================
     REFERENCE            SYSTEM     
======================================
TOS 1.04  AES 1.40  TOS 1.04  AES 1.40
BLiTTER NP          BLiTTER NP       
RES 640*400*2       RES 640*400*2     
GEMDOS v0.20        GEMDOS v0.15     
ST 68000            ST 68000         
FPU Not present     FPU not present   
NVDI 2.52 present   NVDI not present 
CACHE D=OFF  I=OFF  CACHE D=OFF  I=OFF
Ran from ST-RAM     Ran from ST-RAM   
======================================
GEM Dialog Box:            6.290  344%
VDI Text:                  2.185  963%
VDI Text Effects:          2.930  805%
VDI Small Text:            5.070  595%
VDI Graphics:              9.665  281%
GEM Window:                5.110  295%
Integer Division:         31.520  100%
Float Math:                0.000    0%
RAM Access:               36.385  100%
ROM Access:               74.705  100%
Blitting:                  6.270  175%
VDI Scroll:                3.575  428%
Justified Text:            6.815  248%
VDI Enquire:              10.880  189%
ALT-RAM:                   0.000    0%
======================================
Graphics:                         369%
CPU:                              100%
Average:                          192%

Bei dem kleinen fehlt dann also vor allem Speicher. Der letzte Schritt meiner Restauration wird deswegen dann der Einbau einer Stormy ST von tuxie sein. Kommt, sobald ich sowas haben kann. Dann kann ich weitere Tools, sofern diese das zulassen, ins AltRAM laden und habe doch nur 1 MB ST-Ram. Mal gucken, was damit dann alles geht. Und wenn mir das ganze zu langsam wird, dann steck ich meine MicroSD-Karte in meinen Schreibtischrechner und habe dann Hatari oder Aranym mit 2560x1080 Bildschirmauflösung.

Wie dieses Hin- und Her mit Linux geht, habe ich hier beschrieben:

https://forum.atari-home.de/index.php/topic,17059.msg261002.html#msg261002
« Letzte Änderung: Sa 04.06.2022, 10:55:48 von Mado »
... ich bin ST-HIGH und eher so der Monochrom-Typ