Autor Thema: Kompatiblität EmuTOS zu Atari TOS ...  (Gelesen 1087 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.781
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Kompatiblität EmuTOS zu Atari TOS ...
« am: Di 01.02.2022, 16:52:12 »
Wie sieht es mit der kompatiblität zum Atari TOS mit EmuTOS aus ...

Über eine Viking Großbildschirmkarte mit EmuTOS 1.1.1 gibt es einen Buserror mit Papillon und Cubase Lite und das System hängt. NVDI 5.03 läuft da z.B. Papillon das ja voraussetzt und ohne sich nicht starten lässt.

Offline czietz

  • Benutzer
  • Beiträge: 3.134
Re: Kompatiblität EmuTOS zu Atari TOS ...
« Antwort #1 am: Di 01.02.2022, 16:56:53 »
Zu Cubase Lite: https://github.com/emutos/emutos/blob/352e50e7fb25b7750670b1c2da7d757889cf6faf/doc/incompatible.txt#L206

Zu Papillon: Läuft es ohne Viking-Karte? Bitte exakte Fehlermeldung posten! EDIT: Und exakte Versionsnummer von Papillon.

Und zur generellen Frage "Wie sieht es mit der kompatiblität zum Atari TOS mit EmuTOS aus" kann ich nur auf den Test in der ST-Computer verweisen, in der Hunderte(!) Programme getestet wurden und nur gut eine Handvoll Probleme bereitet hat. Von diesen Problemen wiederum wurden etliche mittlerweile gefixt.
« Letzte Änderung: Di 01.02.2022, 17:03:31 von czietz »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.781
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Kompatiblität EmuTOS zu Atari TOS ...
« Antwort #2 am: Di 01.02.2022, 17:16:55 »
Zum Cubase das hatte ich mir schon gedacht. Das betrifft dann wohl alle Midi Programme vermute ich mal ...

Papillon läuft doch. Zuvor gab es eine Error/Panic mit einem anderen Programm danach wollte Papillon wohl nicht. Papillon ist die 3.0

Offline czietz

  • Benutzer
  • Beiträge: 3.134
Re: Kompatiblität EmuTOS zu Atari TOS ...
« Antwort #3 am: Di 01.02.2022, 17:26:14 »
Zum Cubase das hatte ich mir schon gedacht. Das betrifft dann wohl alle Midi Programme vermute ich mal

Natürlich nicht! Es betrifft die im Link genannten Cubase-Varianten, die eben exakte Code-Sequenzen von Atari TOS im Speicher suchen. Das ist schlicht sch...recklich programmiert.

EDIT: Hingegen haben wir einen regelmäßigen EmuTOS-User, von dem ich weiß, das er mit Notator (und MIDI) musiziert.

Papillon läuft doch.

Freut mich. Ich habe nur Version 2.2 auf meinem MegaST mit Viking-Karte, aber die läuft ebenfalls unter EmuTOS.
« Letzte Änderung: Di 01.02.2022, 17:28:42 von czietz »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 11.781
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Kompatiblität EmuTOS zu Atari TOS ...
« Antwort #4 am: Di 01.02.2022, 17:37:43 »
Gerade mal Logic 2.01 mit Key probiert und läuft. Habe kein Midigerät aber sieht alles gut aus.