Autor Thema: p7zip für MiNT  (Gelesen 922 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 866
Re: p7zip für MiNT
« Antwort #20 am: So 23.08.2020, 16:43:35 »
Irgendwas ist da komisch. Die 7za-Version von Thorsten, 68000, auf Hatari 2.2.1 mit EmuTOS 0.9.12, aus dem Desktop gestartet mit "b" bringt die Hilfeseite.

Ja, passiert nur unter TOS, siehe auch Meldung von czietz. Sollte jetzt behoben sein. War kein Fehler in der mintlib, irgendwie mag 7za beim parsen der Kommandozeile kein leeres argv[0] element. Genaue Ursache habe ich zwar nicht gefunden, stattdessen wird in dem Fall argv[0] auf "/usr/bin/7za" gesetzt. Nicht perfekt, aber scheint jetzt auch unter TOS zu funktionieren.

Wer weitere Fehler findet, möge die bitte für sich behalten :D (ich hatte jetzt echt nicht vor, Maintainer für das Paket zu spielen, und alle scripts sind ja vorhanden, also im Zweifelsfall selber suchen ;)

Offline gh-baden

  • Benutzer
  • Beiträge: 1.432
Re: p7zip für MiNT
« Antwort #21 am: So 23.08.2020, 17:06:00 »
Irgendwas ist da komisch. Die 7za-Version von Thorsten, 68000, auf Hatari 2.2.1 mit EmuTOS 0.9.12, aus dem Desktop gestartet mit "b" bringt die Hilfeseite.

Ja, passiert nur unter TOS, siehe auch Meldung von czietz. Sollte jetzt behoben sein.

Die hatte ich ja gequotet, und wollte eigentlich nur die Hand „hier auch“ heben.

Wer weitere Fehler findet, möge die bitte für sich behalten :D (ich hatte jetzt echt nicht vor, Maintainer für das Paket zu spielen, und alle scripts sind ja vorhanden, also im Zweifelsfall selber suchen ;)

Danke dass du Maintai^Waua!

Spaß beiseite: danke für deine Mühen.

An alle Einsender: ich habe die Ergebniswerte eingetragen.
Wider dem Signaturspam!