Autor Thema: MiNT/XaAES und NVDI TC Matrix Treiber ...  (Gelesen 1750 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline czietz

  • Benutzer
  • Beiträge: 2.280
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #20 am: Di 04.02.2020, 19:19:33 »
Üblicherweise hilft es, zu fragen "wie kann ich zur Fehlersuche beitragen?" Wenn die Entwickler nach dem letzten Eintrag auf Github doch noch nicht komplett das Interesse verloren haben, Dir zu helfen, können sie Dir z.B. eine Version mit Debug-Ausgaben o.ä. bauen, die Du dann testen musst, weil nur Du diese spezielle HW-Konfiguration hast.

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 694
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #21 am: Mi 05.02.2020, 01:18:43 »
Geht mir ähnlich wie Christian. Natürlich kann ich deinen Unmut verstehen daß es nicht funktioniert, aber deine Kommentare in diversen Threads wie "großer Mist", "muss überarbeitet werden" etc. hilft auch nicht weiter. Keiner von uns hat offensichtlich eine Möglichkeit, dein Problem in einer halbwegs ähnlichen (dazu noch sehr speziellen) Umgebung nachzuvollziehen. Ohne diese Möglichkeit, bleibt nur wildes Gerate woran es liegen könnte. An XaAES scheint es ja nicht zu liegen, da es mit N.AES ja auch nicht funktioniert. Wenn es mit Mint 1.18 funktioniert, wäre wohl da der Startpunkt zu setzen, aber vermutlich liegt es dann an dir, herauszufinden welche Änderungen genau das verursacht hat. Wenn du dir das zutraust, und die Zeit dafür hast (und das kann vermutlich ziemlich zeitaufwendig werden), wird dir hier sicher gerne erklärt, wie du das machen kannst.


Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #22 am: Mi 05.02.2020, 09:11:16 »
Das NVDI mit XaAES nicht geht liegt offensichtlich an XaAES und zwar seit der 0.992. Frühere Versionen hatte ich nicht zur Verfügung. Helmut hat soviel ich weiss eine kleine Matrix Karte in einem seiner TT aber sich obwohl er wusste das es da Probleme gibt sich nicht darum gekümmert, keine Ahnung. XaAES hätte man anpassen können denke ich aber NVDI wohl eher nicht. Und NVDI ist sehr wichtig auch heute noch.

Das mit N.AES liegt am neuen 1-19er Kernel. Bei dem 1-18-0 läuft es ja einwandfrei.

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 694
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #23 am: Mi 05.02.2020, 09:20:23 »
Und NVDI ist sehr wichtig auch heute noch.

Ja, ohne Zweifel. Aber grundsätzlich funktioniert es ja, lediglich der Treiber für deine Karte (oder vlt. auch eines der anderen Programme) scheint Probleme zu machen.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #24 am: Mi 05.02.2020, 10:02:53 »
Scheint aber ein grundsätzliches Problem zu sein da es bei NVDI ET4000 auch vorkommt. Helmut hatte da mal kleine Patchprogramme geschrieben zu dem Problem. Die funktionieren aber nur bei NVDI ET4000.

Offline czietz

  • Benutzer
  • Beiträge: 2.280
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #25 am: Mi 05.02.2020, 10:30:18 »
Scheint aber ein grundsätzliches Problem zu sein

Grundsätzlich, d.h. ohne externe Grafikkarte, funktioniert NVDI mit XaAES ja auch.

Zitat
XaAES hätte man anpassen können denke ich aber NVDI wohl eher nicht.

Tja, wäre NVDI von den Autoren "open-sourced" worden...
« Letzte Änderung: Mi 05.02.2020, 10:49:43 von czietz »

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 694
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #26 am: Mi 05.02.2020, 11:47:20 »
Tja, wäre NVDI von den Autoren "open-sourced" worden...

Ja, da hoffe ich auch immer noch drauf. Ich kann mir auch ehrlich gesagt nicht vorstellen daß es da Probleme mit irgendwelchen Font-Technologien gibt die nicht von den Behnes selbst stammen. Die Speedo-Routinen zB sind schon seit Ewigkeiten Bestandteil von Xfree gewesen (mittlerweile aber wieder rausgeflogen, weil veraltet und durch TrueType ersetzt). Irgendwelche NDAs etc. dürften auch schon lange abgelaufen sein.

Allerdings würde das in diesem speziellen Fall möglicherweise nicht mal helfen, da die Treiber wohl nicht von den Behnes sind.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #27 am: Mi 05.02.2020, 13:14:23 »
Vielleicht liegt das Problem mit XaAES dort ...

------- NVDI MATGRAPH TC assign.sys ---
PATH = C:\GEMSYS\

01p SCREEN.SYS

02p SCREEN.SYS

03p SCREEN.SYS

04p SCREEN.SYS

05  NTC16M.SYS

06p SCREEN.SYS

07  NTC256.SYS

08  NTC2.SYS

09p SCREEN.SYS

10  NTC65K.SYS

; Die Ger„tekennung 08 ist auf dem ATARI TT mit der hohen Aufl”sung
; belegt.
; Wenn Sie neben der Grafikkarte noch einen Monochrommonitor TTM 194
; oder TTM195 am ATARI TT angeschlossen haben, sollten Sie den Treiber
; NTC2.SYS unter der Ger„tekennung 04 (ohne `p'!) eintragen und
; in den nachfolgenden Zeilen das Semikolon entfernen.
;

-------
------- NVDI ET4000 assign.sys ---
PATH = C:\GEMSYS\

01p SCREEN.SYS

02  XVGA65K.SYS

03  XVGA16M.SYS

04p SCREEN.SYS

05  XVGA16.SYS

06p SCREEN.SYS

07  XVGA256.SYS

08  XVGA2.SYS

09p SCREEN.SYS

10  XVGA32K.SYS
-------
Das Patchprogramm im Anhang von Helmut funktioniert nur mit NVDI ET4000 bei der 8-bit 256 Farben Auflösung. Alle Versuche auch solche Programm für andere Farbtiefen zu machen funktionierten nicht.
« Letzte Änderung: Mi 05.02.2020, 14:22:18 von Lukas Frank »

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 694
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #28 am: Mi 05.02.2020, 14:38:04 »
Wäre hilfreich zu wissen, was genau das Patch-Programm macht, und warum. Sourcen dazu wären auch nicht verkehrt.

Was ich noch nicht so ganz verstehe: funktionieren denn die ET4000 Treiber mit der Matrix Grafik-Karte? Oder hast du beide Konfigurationen? Und welche Treiber-Versionen sind das?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #29 am: Mi 05.02.2020, 15:01:12 »
NVDI ET4000 und NVDI MATGRAPH TC UND MATGRAPH CXX haben die gleichen Probleme mit XaAES


Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #30 am: Mi 05.02.2020, 15:05:58 »
Wäre hilfreich zu wissen, was genau das Patch-Programm macht, und warum. Sourcen dazu wären auch nicht verkehrt.

Ich kann da nur Raten ...

Ich denke XaAES erwartet den Screen an einer bestimmten Stelle und NVDI nutzt da eine andere und das Patch Programm vermittelt da, keine Ahnung. Helmut sprach davon das XaAES die richtige Workstation nicht öffnet oder öffnen kann so wie ich das verstanden habe.

Offline czietz

  • Benutzer
  • Beiträge: 2.280
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #31 am: Mi 05.02.2020, 18:17:26 »
Wäre hilfreich zu wissen, was genau das Patch-Programm macht

Ich denke, es geht um diesen Punkt, der in der Konfiguration kurz beschrieben wird:
https://github.com/freemint/freemint/blob/master/xaaes/src.km/example.cnf#L126. (Weitere Hintergründe kenne ich nicht und möchte ich auch nicht nachforschen.)

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #32 am: Do 06.02.2020, 12:59:00 »
Ja scheint das Problem zu sein ...

# If you don't have a Falcon <mode> can be:
# -----------------------------------------
#   - 2 =  320*200,  16 colour (ST-Low)
#   - 3 =  640*200,   4 colour (ST-Medium)
#   - 4 =  640*400,   2 colour (ST-High)
#   - 6 =  640*480,  16 colour (TT Medium)
#   - 8 = 1280*960,   2 colour (TT High)
#   - 9 =  320*480, 256 colour (TT Low)
#
#   All other values are ignored!


------- NVDI MATGRAPH TC ASSIGN.SYS ---
PATH = C:\GEMSYS\
01p SCREEN.SYS
02p SCREEN.SYS
03p SCREEN.SYS
04p SCREEN.SYS
05  NTC16M.SYS
06p SCREEN.SYS
07  NTC256.SYS
08  NTC2.SYS
09p SCREEN.SYS
10  NTC65K.SYS


Habe mal die Nummern getauscht ...

02 NTC16M.SYS
03 NTC65K.SYS
09 NTC256.SYS

... aber es funktioniert nicht.

Das einzige was fast geht ist mit 2 Farben. Aber nicht die über SLCT_DEV eingestellte Auflösung sondern die von REDIRECT benutze. Scheint also zu sein das XaAES das SCREEN.SYS 01 nicht wechseln kann. Das TOS Desktop und N.AES kann das aber XaAES nicht ...
« Letzte Änderung: Do 06.02.2020, 13:02:50 von Lukas Frank »

Offline Highspeed

  • Benutzer
  • Beiträge: 239
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #33 am: Fr 07.02.2020, 07:26:22 »
Ich nehme an du hast bei XAAES.CNF das 
slct_dev und et4000_hack=0 schon probiert.
damit läuft  bei mir die Crazy Dots 15bit unter Mint/Xaaes
Damit läuft bei mir Mint z.b mit 800x608 in 15bit


Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #34 am: Fr 07.02.2020, 08:33:13 »
@Highspeed zeige mal deine xa_video.cnf und die video.cnf ...

Und was von den drei NVDI Programmen ist bei dir im Autoordner vor MiNT? Wo ist/liegt bei ihr slct_dev.prg? Wird das zweimaal gestartet?

Bei mir geht das nicht. SLCT_DEV ist noch im Autoordner ein slct_dev oder auch ein u:/c/auto/slct_dev.prg in der xaaes.cnf bringen nichts.
« Letzte Änderung: Fr 07.02.2020, 17:53:26 von Lukas Frank »

Offline czietz

  • Benutzer
  • Beiträge: 2.280
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #35 am: Fr 07.02.2020, 17:34:25 »
Sag mal, wenn Du schreibst, dass das Problem mit NVDI ET4000 auch auftritt, lässt es sich dann auch mit Nova-Hardware, einer ET4000-Karte und XaAES (und natürlich NVDI ET4000) reproduzieren? Das würde die Basis an möglichen Testern doch deutlich erhöhen, denn Novas sind (auch dank Deines Nachbaus) deutlich häufiger als Matrix-TC-Karten.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #36 am: Fr 07.02.2020, 17:52:38 »
Der Nova Treiber hat keinerlei Probleme mit XaAES. Funktioniert einwandfrei. Der Nova Treiber setzt wohl rechtzeitig die mit menu.prg gesetzte Auflösung. Eine assign.sys oder ähnliches nutzt der Nova Treiber ja nicht. Ich kann mit dem REDIRECT.PRG von NVDI MATGRAPH TC jede mögliche Schwarz/Weiß Auflösung setzen und mit XaAES nutzen. Das funktioniert vermute ich weil die Auflösung schon gesetzt ist bevor XaAES startet. Alle anderen Auflösungen die mit SLCT_DEV.PRG gewählt werden, werden ja z.B. unter TOS erst gesetzt kurz bevor der DESKTOP startet, keine Ahnung!?!

Ich hatte es mal geschafft NVDI5 (ET4000) mit einem Nova VME Adapter laufen zu lassen. Aber es gehen mit NVDI ET4000 nur sehr wenige TSENG Karten wie ich feststellen musste.

NVDI5 ET4000 läuft einwandfrei vorausgesetzt man hat eine passende ET4000 Karte wunderbar mit meinem VOFA Mega ST Bus oder auch CPU ISA Adapter. Da ist aber das Problem das der Rechner nur 4MB hat und das reicht in aller Regel nicht das XaAES aufstartet ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #37 am: Fr 07.02.2020, 18:05:06 »
Kann es vielleicht sein das, dass Problem beim XaAES ist das die SCREEN.SYS Slots fest sind entsprechend der original System Atari Auflösungen der verschiedenen Rechner. Und das alle anderen Nummern bis 10 nicht genutzt werden ist gar nicht gut, das ist eine Einbandstraße.

Bei NVDI oder auch anderen Grafikkarten Treibern sind die aber nicht fest sondern variabel ...

------- Matrix TC Treiber ---
path = \GEMSYS\

01  TCXX_VDI.SYS      ; R‚solution actuelle

02  TCXX_VDI.SYS      ; basse r‚solution        (320*200*4)
03  TCXX_VDI.SYS      ; moyenne ST              (640*200*2)
04  TCXX_VDI.SYS      ; Haute ST               (640*400*1)
06  TCXX_VDI.SYS      ; Moyenne TT            (640*480*4)
08  TCXX_VDI.SYS      ; Haute TT               (1280*960*1)
09  TCXX_VDI.SYS      ; Basse TT               (320*480*8)
-------

------- Mega Vision 3000 ---
01p SCREEN.SYS
02p SCREEN.SYS
03p SCREEN.SYS
04p SCREEN.SYS
05 MV_16.SYS
06p SCREEN.SYS
07 MV_256.SYS
08p SCREEN.SYS
09p SCREEN.SYS
-------

------ Maxon MGE ---
Path=A:\ASSIGNS
01 vdi_mge.sys
02 vdi_mge.sys
03 vdi_mge.sys
04 vdi_mge.sys
-------

Und da gibt es auch noch andere Treiber.

Das alles kann ich unmöglich mit einem googleenglisch mitteilen. Ob es da überhaupt jemand gäbe der das ändern könnte bei XaAES. Da muss vielleicht fast alles neu, keine Ahnung ...
« Letzte Änderung: Fr 07.02.2020, 18:17:14 von Lukas Frank »

Offline Highspeed

  • Benutzer
  • Beiträge: 239
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #38 am: Sa 08.02.2020, 06:20:09 »
vergiss  die video.cnf  undauchdie xa_vide.cnf das war mal eine Sicherung  von meiner xaaes.cnf
habe jetzt mal  meinen  TT  angeschmissen und geschaut.
Aktuell habe ich in  meiner xaaes.cnf von logfile  bis  xa_bubble  alles drinnen  alles  andere  habe  ich  drausen  und  auch  keine Video.cnf oder  Videomode  drinnen  habe auch  meine  Startreihenfolge mal  angehängt  vieleicht  hilft dir das?
Verwenden tu  ich aktuell  Vanillamint

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.758
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: MiNT/XaAES und NVDI TC Matrix Treiber ...
« Antwort #39 am: Sa 08.02.2020, 09:25:49 »
Also bei mir funktioniert das so nicht. Habe es mit der 65k Auflösung probiert. Bei mir wird und muss XaAES über das init script und die ttab gestartet werden. SLCT_DEV wird beim booten gestartet und ich wähle die Farbtiefe und Auflösung. Wird aber kein zweites Mal über die xaaes.cnf gestartet und es bleibt beim Pixelmüll.

@Highspeed ... wieso nimmst du nicht den Nova Treiber für die CD ?

->   https://silicon-heaven.org/atari/nova/TT030/CrazyDots/
« Letzte Änderung: Sa 08.02.2020, 11:54:18 von Lukas Frank »