Autor Thema: Mega STe, interne HDD und Ultrasatan mit lesbaren Partitionen am PC  (Gelesen 135 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Schlampf

  • Benutzer
  • Beiträge: 48
Hallo,


bin grad etwas am verzweifeln, aber nur etwas...


Habe nicht wiederstehen können, und mir einen Mega Ste mit HD Disklaufwerk, 100MB Quantum HDD, 4MB zugelegt.

Mein vom 1040er ST vorhandenes Ultrasatan (im folgenden US) angeschlossen, und...nix

Habe dann festgestellt, dass die interne HDD und US die gleiche SCSI (ASCI) ID verwenden. Also DIP-Schalter umgestellt, und die US-Partitionen werden angezeigt.

Die US SD-Karten starten mit den Putnik Treibern von 2014 und sind am PC auslesbar. Die erkennen jedoch nicht die Partitionen der internen HDD. Die wurde vom vorbesitzer mit 4x25 MB vorformatiert und die waren auch ohne US startbar... Nach diversen Partitionsfummelleien sind sie es nun nicht mehr...

Was ich mir wünsche - Der Mega STe soll ohne US von der HDD bootbar sein, die HDD soll aber auch zugreifbar sein, wenn ich von US starte.. Dann fehlt mir noch das 8/16 Mhz Umschalt-Proggi.


Hat jemand ggf. ein SD-Karten Image, dass gut funktioniert, sowie ein Tool, mit dem ich die interne HDD Formatieren/Partitionieren kann, damit sie von den Putnik Treibern der US erkannt wird, aber auch "selbstständig" booten kann? Oder eine andere Lösung?


Davon abgesehen - falls es wen interessiert:

Als nächstes geplant: TOS 2.06 upgrade von 2.05 und Austausch des unfassbar lauten Lüfters durch Noctua NF-A6x25 FLX Lüfter, 60mm
--
Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit. Aber beim Universum bin ich mir noch nicht ganz sicher.
Mein ST: https://sway.office.com/55x5VxXCNzVGMs3Y?ref=Link

Offline Arthur

  • Benutzer
  • Beiträge: 8.827
  • Mein Atari erinnert mich an die gute alte Zeit..
Der Treiber von ppera sorgt dafür das auch auf Fat16 Partitionen  zugegriffen werden kann und somit ein einfacher Datenaustausch mit dem PC möglich ist.


Damit du auf die US zugreifen kannst benötigst du einen Treiber der also BGM, FAT16 unterstützt... HDDRIVER wäre da eine Möglichkeit .

CBHD 5.02 in Verbindung mit BigDOS (im Autoordner) könnte auch funktionieren. Evtl. kannst du den Treiber von ppera auch in den Autoordner (statt des BigDOS) der Festplatte in Kombination mit CBHD packen. Da bin ich mir aber nicht ganz sicher... ausprobieren oder mal ppera ( @Petari ) direkt fragen.

Online Lukas Frank

  • Benutzer
  • Beiträge: 9.450
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Was ich mir wünsche - Der Mega STe soll ohne US von der HDD bootbar sein, die HDD soll aber auch zugreifbar sein, wenn ich von US starte.. Dann fehlt mir noch das 8/16 Mhz Umschalt-Proggi.

Der Atari kann immer nur von ACSI ID0 booten. Das einzige was man machen kann ist die Taste eines anderes Laufwerkes z.B. "G" drücken. Beim HDDriver werden aber die ACCs trotzdem von C:\ geladen.

Offline Arthur

  • Benutzer
  • Beiträge: 8.827
  • Mein Atari erinnert mich an die gute alte Zeit..
Dann fehlt mir noch das 8/16 Mhz Umschalt-Proggi.

Das wird über das XControl.acc mit dem entsprechendem CPX eingestellt und über Arbeit sichern (im Desktop) in der newdesk.inf gespeichert (nicht 100% sicher mangels MSTE).

Offline 1ST1

  • Benutzer
  • Beiträge: 8.642
  • Sehr langer Urlaub.
Welche DIP-Schalter hast du eigentlich umgestellt? Hinweis: Der Mega-STE/STACY-SCSI-Hostadapter funktioniert nur auf SCSI-ID 0. Das heißt, du musst die US umstellen, die dann wiederum nicht am 1040er booten kann...

Wenn ich mir Burkis Erfahrungen durchlese, würde ich den PPera-Treiber gleich mal in die Tonne treten. Besser mal ein bischen in HDDRIVER investieren, und zusätzlich BigDOS in den Autoordner packen, da hast du mehr davon. CHBD geht auch, aber HDDRIVER ist tausendmal besser, wird außerdem noch weiterentwickelt.

Die Umschaltung 8/16 MHz erfolgt mit dem GENERAL.CPX für XControl von der Mega-STE-Langiage-Disk.

Wenn du verschiedene Bootkonfigurationen (Programme im Auto-Ordner, ACCs, CPXe, anderer Desktop, Magic, MultiTOS, MiNT, usw) brauchst, mach das besser über XBOOT.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline Petari

  • Benutzer
  • Beiträge: 152
Korrekzionen:
Atari wird booten immer von niedrigste ACSI Nummer - wann da ist valid Kode und checksum. Das ist mit alle TOS Versionen. So, wann zum Beispiel UltraSatan ist gestellt auf 2 and 3, es wird booten von 2 .  Und boot geht nicht von Partizion, es geht von MBR (Master boot record) von hard disk/Flash card .
Es ist möglich das einige (alte) Treibern unterstützen nur ACSI 0 autoboot, aber das is nicht Atari, TOS .

Mein Treiber SW ist gemacht für DOS type FAT16, besser sagt mit DOS/TOS kompatibel. Wegen einfach Datei Austausch mit modern Komputern. Aber es erkannt rein TOS , BGM Partizionen auch - zum Beispiel auf zweite SD Karte .
Na ja ...