Autor Thema: BetaDOS frisst Cookies??  (Gelesen 5197 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Count

  • Benutzer
  • Beiträge: 101
BetaDOS frisst Cookies??
« am: Fr 16.08.2019, 20:20:47 »
Moin,

ich habe mich schon länger gewundert, dass meine Aranym-Installation mit TOS 4.04 die NVRAM-Einstellungen ignoriert und z.B. der Desktop auf Englisch angezeigt wird.

Im AUTO-Ordner werden (in dieser Reihenfolge) BetaDOS (wegen des Host-FS-Treibers), VT52FIX, NVDI 5.03 und WDIALOG (Bestandteil von NVDI) ausgeführt. SysInfo zeigt, dass nur drei Cookies installiert sind: NVDI, FSMC und EdDI. Die ganzen System-Cookies fehlen. Auch _AKP, was die englische Sprache erklärt.  >:(

Verschiebe ich BetaDOS in der AUTO-Ordner-Reihenfolge ganz nach hinten, bleibt nur noch ein Cookie übrig (EdDI). Nun ist der Desktop aber seltsamerweise deutsch.  ::)

Deaktiviere ich BetaDOS im AUTO-Ordner, sind alle System- und Programm-Cookies da und der Desktop auf Deutsch. Scheinbar ist BetaDOS ein Alias des Krümelmonsters.  :o

Hat von euch schon einer diese Erfahrung gemacht und vielleicht eine Lösung für das Problem? Ich habe schon überlegt, zwei weitere Programme in den AUTO-Ordner zu legen, um vor BetaDOS die Cookies zu sichern und danach wieder einzutragen. Leider reduziert BetaDOS auch die Größe des Cookie-Jar auf acht Einträge.  >:(

Gruß
Oliver

Offline 1ST1

  • Benutzer
  • Beiträge: 8.547
  • Sehr langer Urlaub.
Re: BetaDOS frisst Cookies??
« Antwort #1 am: Fr 16.08.2019, 21:31:35 »
BetaDOS scheint demnach einen eigenen neuen Cookie-Jar anzulegen, ohne sich darum zu kümmern, ob es schon einen gibt. Ich habe BetaDOS nie ausprobiert, kenne es also nicht. Entweder gibts irgendwie in der Konfig einen Schalter, mit dem man das umschalten kann, oder es ist buggy. Vielleicht versuchst du es mal mit ExtenDOS, das ist seit einiger Zeit frei herunterladbar. http://www.anodynesoftware.com/e4/main.html
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.316
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: BetaDOS frisst Cookies??
« Antwort #2 am: Sa 17.08.2019, 11:39:55 »

Offline czietz

  • Benutzer
  • Beiträge: 2.158
Re: BetaDOS frisst Cookies??
« Antwort #3 am: Sa 17.08.2019, 11:56:12 »
->   https://github.com/ggnkua/Atari_ST_Sources/tree/master/ASM/Various/Ulf%20Ronald%20Andersson/BETADOS

... vielleicht behebt jemand den Fehler !?!

Ich sehe da keinen offensichtlichen Fehler, was das Cookie-Handling angeht. Wer weiß, ob @Count überhaupt die Version nutzt, deren Quelltext da unvollständig auf Github ist.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.316
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: BetaDOS frisst Cookies??
« Antwort #4 am: Sa 17.08.2019, 12:02:11 »
unvollständig ist ja doof ...

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 566
Re: BetaDOS frisst Cookies??
« Antwort #5 am: Sa 17.08.2019, 14:25:41 »
Irgendwann war es mal vollständig. Allerdings braucht es jede Menge include-Dateien (ein paar davon wurden übrigens auch für STinG benutzt). Die waren IMHO auch irgendwann mal dort zu finden. Auf jeden Fall hab ich hier lokal ne Version die sich übersetzen lässt, falls da jemand dringenden Bedarf hat.

Abgesehen davon ist BetaDOS mehr oder wenige 'ne gepatchte Version von MetaDOS, schon mal damit versucht?

Offline Count

  • Benutzer
  • Beiträge: 101
Re: BetaDOS frisst Cookies??
« Antwort #6 am: Sa 17.08.2019, 16:24:27 »
Wer weiß, ob @Count überhaupt die Version nutzt, deren Quelltext da unvollständig auf Github ist.
Das scheint Version 3.10 zu sein. Ich verwende 3.12.
Aber einen Versuch mit der alten Version ist es natürlich wert.

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 566
Re: BetaDOS frisst Cookies??
« Antwort #7 am: Sa 17.08.2019, 16:37:11 »
Vermutlich nicht, zwischen 3.10 und 3.12 hat sich kaum was geändert, insbesondere nicht beim Cookie-handling.

Offline czietz

  • Benutzer
  • Beiträge: 2.158
Re: BetaDOS frisst Cookies??
« Antwort #8 am: Sa 17.08.2019, 17:26:49 »
Ich habe gerade BetaDOS 3.12 getestet -- allerdings unter TOS 2.06, nicht unter Aranym mit TOS 4. Die "System-Cookies" (_CPU usw.), die TOS anlegt, bleiben alle erhalten.

Offline czietz

  • Benutzer
  • Beiträge: 2.158
Re: BetaDOS frisst Cookies??
« Antwort #9 am: Sa 17.08.2019, 17:51:52 »
PS: Ist der Bug vielleicht im HostFS-Treiber? Den konnte ich ohne Aranym ja nicht testen.

Offline Count

  • Benutzer
  • Beiträge: 101
Re: BetaDOS frisst Cookies??
« Antwort #10 am: Sa 17.08.2019, 18:05:07 »
Ich bin schon etwas weiter. Meine NVDI-Version (5.03) hängt da auch irgendwie drin. Wenn ich NVDI nicht starte, bleiben die Cookies ebenfalls erhalten. Nun also wenn entweder BetaDOS und/oder NVDI nicht gestartet werden.

Daraufhin bin ich zur alten NVDI-Version 2.51 zurückgekehrt und siehe da: Keine Probleme mit den Cookies mehr.

Offline czietz

  • Benutzer
  • Beiträge: 2.158
Re: BetaDOS frisst Cookies??
« Antwort #11 am: Sa 17.08.2019, 18:09:52 »
Der HostFS-Treiber war dennoch kaputt. Bis zu diesem Commit https://github.com/aranym/aranym/commit/ec787fa37cc3265873f2c3b6dac0f7d1a147ea77#diff-f5a2e2fb34c2d2d7a2490df5d925fa2e hat er den Cookie-Jar beschädigt. Manche Programme kommen damit vermutlich besser klar als andere.

Ich vermute mal, dass Du noch diese Version des HostFS-Treibers hast. @Thorsten Otto kann Dir sicherlich sagen, wo es den aktuellen Treiber gibt.

Offline Count

  • Benutzer
  • Beiträge: 101
Re: BetaDOS frisst Cookies??
« Antwort #12 am: Sa 17.08.2019, 18:33:33 »
Ok, das würde es erklären. Ich verwende den Treiber, der bei 3.12 mitgeliefert wurde. Er meldet sich mit "ARAnyM Host Filesystem 0.60" und Datum 16.10.2005.

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 566
Re: BetaDOS frisst Cookies??
« Antwort #13 am: Sa 17.08.2019, 20:25:29 »
Bis zu diesem Commit https://github.com/aranym/aranym/commit/ec787fa37cc3265873f2c3b6dac0f7d1a147ea77#diff-f5a2e2fb34c2d2d7a2490df5d925fa2e hat er den Cookie-Jar beschädigt.

Ich wüsste zwar nicht da was bzgl Cookies geändert zu haben, wäre aber möglich daß sehr alte Versionen da was vermurkst haben. Soweit ich mich errinnere legt der aber nur einen BDfh cookie an, und tut das auch nur wenn schon ein Cookie-Jar existiert und noch Platz ist. Ein komplett neuer CookieJar wird nicht angelegt.

Zitat
Thorsten Otto kann Dir sicherlich sagen, wo es den aktuellen Treiber gibt.

Da erinnerst du mich an was. Die diversen Atari-Tools die zu Aranym gehören sollten mal automatisch gebaut werden, ist aber noch nicht realisiert.

Zitat
Er meldet sich mit "ARAnyM Host Filesystem 0.60"

Ich glaub die Mühe dort die Versionsnummer zu ändern hat sich seit 20 Jahren keiner mehr gemacht, deswegen meldet sich die aktuelle Version auch damit.... lediglich das Datum dürfte anders sein. Versuchs mal mit der angehängten Version.


Offline Count

  • Benutzer
  • Beiträge: 101
Re: BetaDOS frisst Cookies??
« Antwort #14 am: So 18.08.2019, 14:37:57 »
Danke, Thorsten. Die neue Version setzt zumindest nicht mehr die (vermeintliche) Cookie-Jar-Größe auf 0.

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 566
Re: BetaDOS frisst Cookies??
« Antwort #15 am: So 18.08.2019, 15:12:08 »
Ja, den Fehler hatte ich damals wohl mitgefixt, war mir irgendwie entfallen (aber Christian hat mich darauf aufmerksam gemacht). Der dürfte wohl für beide Probleme verantwortlich gewesen sein: zum einen denkt NVDI dadurch daß der Cookiejar voll ist und legt einen neuen an, zum anderen kopiert er aus dem alten die alte Länge an Cookies (also 0).

Funktioniert damit denn jetzt alles?

Offline Count

  • Benutzer
  • Beiträge: 101
Re: BetaDOS frisst Cookies??
« Antwort #16 am: So 18.08.2019, 18:31:23 »
Funktioniert damit denn jetzt alles?
Einwandfrei. Sowohl mit NVDI 2.51 als auch mit 5.03. :D
« Letzte Änderung: So 18.08.2019, 18:42:55 von Count »