Autor Thema: NEWDESK.INF wird nicht gelesen  (Gelesen 536 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline herr_dreier

  • Benutzer
  • Beiträge: 41
  • Ich liebe dieses Forum!
NEWDESK.INF wird nicht gelesen
« am: Mi 27.02.2019, 08:01:05 »
Hallo,
habe Hatari mit TOS 2.06 auf einem iMac mit MacOS 10.13.6. als Host laufen.
Beim Starten wird die NEWDESK.INF nicht gelesen, sondern es erscheinen die standard Icons. Erst wenn ich auf "INF Datei lesen" gehe, wird mein Desktop so angezeigt, wie ich es konfiguriert habe.
Mit XBOOT ist es genauso.

Im englischen Forum habe ich das dazu gefunden:
http://www.atari-forum.com/viewtopic.php?f=51&t=32438&p=329710&hilit=newdesk.inf#p329710

Wenn ich das richtig verstehe, wird die INF Datei nicht gelesen, wenn man ein ACSI Laufwerk als Startlaufwerk wählt. Bei GEMDOS Laufwerken soll es funktionieren.

Kann das jemand bestätigen? Wie sieht es bei IDE Laufwerken aus? Wie lässt sich der im Thread beschriebene Verbose Mode aktivieren und wo liegt diese default NEWDESK.INF, von der da die Rede ist?
Schöne Grüße
Dreier
_________________
Atari F030/ Steinberg Audiospector/ Steinberg Cubase Audio 2.0.6/

Offline czietz

  • Benutzer
  • Beiträge: 2.109
Re: NEWDESK.INF wird nicht gelesen
« Antwort #1 am: Mi 27.02.2019, 08:19:01 »
Nutzt Du denn überhaupt eine Imagedatei als ACSI-Laufwerk? Nutzt Du denn die erweiterte VDI-Auflösung, die ja -- siehe verlinktes Post -- eine weitere Randbedingung ist, damit Hatari die INF-Datei manipulieren muss?

Offline herr_dreier

  • Benutzer
  • Beiträge: 41
  • Ich liebe dieses Forum!
Re: NEWDESK.INF wird nicht gelesen
« Antwort #2 am: Mi 27.02.2019, 08:23:16 »
Ja, die VDI Auflösung nutze ich und ein ACSI Image ebenfalls.
Schöne Grüße
Dreier
_________________
Atari F030/ Steinberg Audiospector/ Steinberg Cubase Audio 2.0.6/

Offline czietz

  • Benutzer
  • Beiträge: 2.109
Re: NEWDESK.INF wird nicht gelesen
« Antwort #3 am: Mi 27.02.2019, 08:37:10 »
Dann hast Du das Problem richtig identifiziert. Die folgende Kombination ist nicht möglich:

- erweiterte VDI-Auflösung und
- Festplattenimage (egal ob ACSI, SCSI, IDE) und
- eigene NEWDESK.INF.

Du wirst auf eines der drei Dinge verzichten müssen, z.B. durch Verwendung der GEMDOS-HD-Emulation.

Offline 1ST1

  • Benutzer
  • Beiträge: 8.405
  • Sehr langer Urlaub.
Re: NEWDESK.INF wird nicht gelesen
« Antwort #4 am: Mi 27.02.2019, 20:31:13 »
Von echter Hardware kenne ich das Problem nicht, ist das bedingt durch den Emulator?
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 510
Re: NEWDESK.INF wird nicht gelesen
« Antwort #5 am: Mi 27.02.2019, 21:27:55 »
Ja, er ersetzt während des bootens die NEWDESK.INF/DESKTOP.INF/EMUTOS.INF, um die Auflösung korrekt setzen zu können. Passiert auch bei anderen Gelegenheiten, z.b. wenn ein Programmname beim Start übergeben wird, der dann als Autostart angemeldet wird.