Autor Thema: 256MB TT-RAM und MinT streikt  (Gelesen 2920 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.897
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: 256MB TT-RAM und MinT streikt
« Antwort #20 am: So 05.08.2018, 17:28:43 »
Vielleicht hat es damit etwas zu tun ...

Das sind alles 3,3V Module, meine EDO und FPM aus den USA auf jeden Fall. Da sitzt ein kleiner SMD Spannungsregler drauf der aus den 5V -> 3,3V für die Chips macht. Die Ein und Ausgänge der Speicherchips hängen aber direkt an der 5V Logik des Atari TT Buses.

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #21 am: So 05.08.2018, 17:30:38 »
Mit einem 128MB Riegel in der Storm (SLOT A, J1/2/3=on, J4/5/6=off) startet MiNT mit MP=on durch. Mit dem anderen 128MB Riegel läuft´s auch.

Offline Arthur

  • Benutzer
  • Beiträge: 8.255
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: 256MB TT-RAM und MinT streikt
« Antwort #22 am: So 05.08.2018, 17:33:38 »
Auch in beiden PS/2-Slots gestestet?

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #23 am: So 05.08.2018, 17:46:41 »
Vielleicht hat es damit etwas zu tun ...

Das sind alles 3,3V Module, meine EDO und FPM aus den USA auf jeden Fall. Da sitzt ein kleiner SMD Spannungsregler drauf der aus den 5V -> 3,3V für die Chips macht. Die Ein und Ausgänge der Speicherchips hängen aber direkt an der 5V Logik des Atari TT Buses.

Da steht zwar 5V auf dem Riegel, aber wie du sagst, ein SMD Spannungswandler ist drauf.

Es scheint jedoch keine Probleme mit den 3,3 Volt für den TT-Bus zu geben, da wie gesagt zum Einen YAART bei zwei Modulen nicht meckert, zum Anderen TOS und MagiC problemlos laufen und wenn nur ein Riegel drin steckt, geht´s auch mit MiNT. Wären die 3,3 Volt zu wenig könnte ich mir vorstellen dass der TT bei allem Möglichen bomben würde wenn auch nur ein Bit kippt, selbst bei nur einem Riegel.


Offline 1ST1

  • Benutzer
  • Beiträge: 8.246
  • Sehr langer Urlaub.
Re: 256MB TT-RAM und MinT streikt
« Antwort #24 am: So 05.08.2018, 17:46:50 »
Versuche es mal mit 128 + 32 MB. Wenn auch das geht, liegt es wohl am Gesamt-Speicherausbau im Zusammenhang mit Memory-Protection.

Ich habe Memory Protection auch immer aus, weil damit laufen noch weniger Programme, als mit.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline Arthur

  • Benutzer
  • Beiträge: 8.255
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: 256MB TT-RAM und MinT streikt
« Antwort #25 am: So 05.08.2018, 17:50:12 »
Auch in beiden PS/2-Slots gestestet oder nur in Slot A?

Offline 1ST1

  • Benutzer
  • Beiträge: 8.246
  • Sehr langer Urlaub.
Re: 256MB TT-RAM und MinT streikt
« Antwort #26 am: So 05.08.2018, 17:50:42 »
Vielleicht hat es damit etwas zu tun ...

Das sind alles 3,3V Module, meine EDO und FPM aus den USA auf jeden Fall. Da sitzt ein kleiner SMD Spannungsregler drauf der aus den 5V -> 3,3V für die Chips macht. Die Ein und Ausgänge der Speicherchips hängen aber direkt an der 5V Logik des Atari TT Buses.

Da steht zwar 5V auf dem Riegel, aber wie du sagst, ein SMD Spannungswandler ist drauf.

Wenn auf dem Speicherriegel extra ein Spannungsregler drauf ist, dann ist davon auszugehen, dass die ganzen Signalleitungen der Speicherbausteine 5V Tolerant sind. Da auch der Speichertest fehlerfrei durchläuft, und der TT ohne Memory Protextion stabil läuft, gehe ich auch davon aus, dass der Speichercontroller auf der Storm mit 3,3V Signalen seitens der Speicherbausteine zurecht kommt.

Ich gehe jetzt erstmal von einem Softwareproblem von Mint mit Memory Protection und 256 MB RAM aus. Vielleicht gibts ja einen MiNT-Kernel, der das behebt, der von den einschlägigen Forengöttern hier in der Konfiguration verwendet wird. Oder Memory Protection ist bei allen Leuten hier ausgeschaltet.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline 1ST1

  • Benutzer
  • Beiträge: 8.246
  • Sehr langer Urlaub.
Re: 256MB TT-RAM und MinT streikt
« Antwort #27 am: So 05.08.2018, 17:51:53 »
Auch in beiden PS/2-Slots gestestet oder nur in Slot A?

Slot A der Storm muss auf jeden Fall bestückt werden, damit man B benutzen kann. Das Modul in A muss das größere sein. Man kann höchstens nochmal die beiden 128er miteinander tauschen, ich glaube aber nach derzeitigem Kenntnisstand nicht, dass das was bringt.
Meine Beiträge waren immer "IMHO". Der Urlaub wird deutlich verlängert. Ich KANN wieder schreiben, aber ob ich das noch WILL?

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #28 am: So 05.08.2018, 17:54:08 »
Versuche es mal mit 128 + 32 MB. Wenn auch das geht, liegt es wohl am Gesamt-Speicherausbau im Zusammenhang mit Memory-Protection.

Ich habe Memory Protection auch immer aus, weil damit laufen noch weniger Programme, als mit.

Jepp, 128MB in SLOT A und 32MB in Slot B gehen. MiNT startet durch.

Offline Arthur

  • Benutzer
  • Beiträge: 8.255
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: 256MB TT-RAM und MinT streikt
« Antwort #29 am: So 05.08.2018, 18:07:07 »
Hab es gerade mit memory protection getestet... läuft. Test allerdings mit 2x32MB in der Storm.

Offline Gaga

  • Benutzer
  • Beiträge: 2.077
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: 256MB TT-RAM und MinT streikt
« Antwort #30 am: So 05.08.2018, 18:20:44 »
Bin gespannt, welches Verhalten die beiden 128MB Module bei mir zeigen werden.
Thunder - Storm - Lightning VME/ST

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #31 am: So 05.08.2018, 18:30:22 »
Bin gespannt, welches Verhalten die beiden 128MB Module bei mir zeigen werden.

Die Module laufen bisher ja ganz gut in der Storm, auch mit Burst. Nur MemoryProtection=on in MiNT macht ja Probleme.
Hat denn noch jemand eine Storm mit 256MB unter MiNT laufen und könnte das mal mit dem MemoryProtect gegenprüfen? Möglicherweise hat @czietz direkt ins Schwarze getroffen und es ist wirklich ein Bug in MiNT.


Offline czietz

  • Benutzer
  • Beiträge: 2.021
Re: 256MB TT-RAM und MinT streikt
« Antwort #32 am: So 05.08.2018, 18:40:23 »
Bitte einmal die Diskussion in den Github-Issue-Tracker von FreeMiNT tragen: https://github.com/freemint/freemint/issues. Ich verstehe den Code auf Anhieb nicht vollständig, aber ich glaube, beim Anschalten der Memory-Protection auf einem 68030 berücksichtigt der MiNT-Kernel nicht, dass die obersten vier Bits der Adresse nicht 0000 (oder 1111 bei Zugriffen auf IO) sein können. Genau das passiert aber bei 256 MB TT-RAM.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.897
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: 256MB TT-RAM und MinT streikt
« Antwort #33 am: Mi 08.08.2018, 17:40:21 »
Trägt wohl niemand auf github ein ...

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #34 am: Mi 08.08.2018, 17:46:06 »
Würde mir ja eine Account einrichten um das dort einzutragen, aber als MiNT Newbie unter den Großen kann ich da nicht mithalten, ist ein Level zu hoch für mich. Beiss mir ja schon bei einer MiNT-Installation die Zähne aus.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 8.897
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: 256MB TT-RAM und MinT streikt
« Antwort #35 am: Mi 08.08.2018, 18:05:52 »
So wird das aber nicht besser und bringt das ganze nicht voran ...

Account einrichten und einfach nur den Fehler melden so wie czietz das erklärt hat, es Rest machen die anderen schon.

Offline czietz

  • Benutzer
  • Beiträge: 2.021
Re: 256MB TT-RAM und MinT streikt
« Antwort #36 am: Mi 08.08.2018, 18:28:42 »
Eben, nur so funktioniert Open-Source.

@DonQuichote: Keine Angst, Du hast doch schon sehr gute und systematische Fehlersuche betrieben. Melde Dich an, schildere das Problem und was Du schon unternommen hast, um es einzugrenzen (also: weniger RAM => OK, Memory Protection aus => OK), beantworte evtl. Rückfragen und Du wirst sehen, wenn es -- wie vermutet -- wirklich ein Bug in MiNT ist, wird es einen Fix geben.

Hier im Forum kann höchstens @Thorsten Otto noch etwas dazu sagen, ob die Implementierung der Memory-Protection im FreeMiNT 68030-Kernel für mehr als 256 MB RAM (ST-RAM und TT-RAM zusammen) ausgelegt ist.

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #37 am: Do 09.08.2018, 12:13:30 »
Hab mir jetzt einen Account eingerichtet und das Problem dort geschildert. Hoffe nur mich mit meinem Schulenglisch verständlich genug ausgedrückt zu haben ...

Offline Arthur

  • Benutzer
  • Beiträge: 8.255
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: 256MB TT-RAM und MinT streikt
« Antwort #38 am: Do 09.08.2018, 12:49:02 »
Das klappt schon. Die schreiben schon wenn was unklar ist. ;)

Offline DonQuichote

  • Benutzer
  • Beiträge: 304
Re: 256MB TT-RAM und MinT streikt
« Antwort #39 am: Do 09.08.2018, 18:32:49 »
Vielleicht hat es damit etwas zu tun ...

Das sind alles 3,3V Module, meine EDO und FPM aus den USA auf jeden Fall. Da sitzt ein kleiner SMD Spannungsregler drauf der aus den 5V -> 3,3V für die Chips macht. Die Ein und Ausgänge der Speicherchips hängen aber direkt an der 5V Logik des Atari TT Buses.

Hab noch mal darüber nachgegrübelt warum die US-Riegel als 5V belabelt sind, diese aber offensichtlich intern mit 3.3V arbeiten.
Kann es sein, dass nur die Speicherlogik der Cips mit 3.3V arbeitet (weniger Verlustleistung, schnellere Schaltzeiten), die Ein-/Ausgänge aber über integrierte Pegelanpassung verfügen und somit über 5V mit der Außenwelt angebunden sind? Welchen Sinn sollte es sonst haben, 3.3V Systeme mit 5V zu powern, um diese anschließend wieder auf 3.3V runterzuregeln? Kritzekratze?!? Hab leider kein Oszi um mal spaßeshalber nachzumessen.