Autor Thema: Neues BOOT 1.05 für CT60/CT63/CT60e  (Gelesen 2971 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline insane

  • Benutzer
  • Beiträge: 18
Neues BOOT 1.05 für CT60/CT63/CT60e
« am: Di 05.03.2019, 21:19:25 »
Hallo zusammen!
Ich habe die letzten Tage ein neues Boot ROM auf der Basis von 1.03c auf die Beine gestellt.
Ihr könnt es von meiner Homepage ziehen: http://insane.tscc.de/
Es lief die letzten Tage stabil auf meinem Falcon060, sowie die Falken von Beetle und mikro.

Boot Changelog seit v1.03c (Englisch)
- modified the sources for cross compilation on PC (huge thanks to mikro!)
- added fixes from 1.03c-PM (background color ESC-c)
- added fixes from 1.03d (flash chip id is 16bit, not 32bit)
- added v_pline fix from 1.04alpha
- added Patrice Mandin's CT60 Setup, enhanced it and bugfixed the setup loader
- added CTPCI IDE Port support (and nothing else regarding PCI!)
- limit CTPCI memory space to 0xC0000000-0xE0000000 (This way Ethernat+SuperVidel+CTPCI work)
- fixed boot modecode interlace setting when boot monitor != running monitor
- fixed VT52 emulator: ESC KoJEd all destroyed the saved cursor pos
- removed ataboot Linux Atari Bootstrap from ROM - It can't boot the current Linux/m68k Kernel
- Selecting Linux will launch C:\BOOTSTRA.TOS
- New Atari Logo Display Routine which doesn't use the Blitter (for SV Users)

Offline cyberish

  • Benutzer
  • Beiträge: 530
  • Ich liebe dieses Forum!
Re: Neues BOOT 1.05 für CT60/CT63/CT60e
« Antwort #1 am: Di 05.03.2019, 21:36:16 »
Riesenrespekt und vielen Dank!!!
Endlich ein gewichtiger Grund mehr meine CT60e einzubauen ;-)

Offline Arthur

  • Benutzer
  • Beiträge: 10.305
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Neues BOOT 1.05 für CT60/CT63/CT60e
« Antwort #2 am: Di 05.03.2019, 21:42:12 »
Klasse. :D

Offline insane

  • Benutzer
  • Beiträge: 18
Re: Neues BOOT 1.05 für CT60/CT63/CT60e
« Antwort #3 am: Di 05.03.2019, 22:22:55 »
Da die ersten Fragen kamen und CTPCI IDE and nothing else nicht eindeutig genug ist:
Wenn ihr auf der CTPCI wirklich PCI Geräte nutzt (Radeon etc) dann bleibt beim Boot2.
Hier wird tatsächlich (auf Wunsch von Beetle :) ) nur der IDE Port der CTPCI unterstützt