Autor Thema: Instandsetzung 520STM Board für PAK/FRAK/Panther ...  (Gelesen 31876 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline czietz

  • Benutzer
  • Beiträge: 3.623
Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
« Antwort #100 am: So 30.06.2024, 17:34:36 »
Ich hatte nach der Durchsicht von Peter Heidens Kommentaren im Code damals schon bezweifelt, daß dieser Weg zum Ziel führen wird. Das Patch erlaubt das gleichzeitige Einschalten von Atari und Festplatte, verzögert aber den Bootvorgang, bis die Platte hochgefahren ist. Der Atari bootet dann erst.

Genau so könnte man die Festplatte einige Zeit vor dem Atari einschalten und hätte den selben Effekt.

Vorsicht: Das ist nicht unbedingt äquivalent. Bei ausgeschaltetem Atari sind die ACSI-Leitungen in undefiniertem Zustand. Erst mit dem Einschalten nehmen sie definierte Zustände an. Wenn Du Ultrasatan solange wartet, bis die Leitungen in ihrem definierten Zustand sind und erst dann ihren internen Bootvorgang startet (Hypothese!!), dann kann es schon sein, dass eine ins ROM gepatchte Wartezeit beim Kaltstart hilft. Probier's aus, dann sind wir schlauer.  :)


Offline dbsys

  • Benutzer
  • Beiträge: 4.520
  • n/a
Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
« Antwort #101 am: So 30.06.2024, 21:20:07 »
Ich hatte nach der Durchsicht von Peter Heidens Kommentaren im Code damals schon bezweifelt, daß dieser Weg zum Ziel führen wird. Das Patch erlaubt das gleichzeitige Einschalten von Atari und Festplatte, verzögert aber den Bootvorgang, bis die Platte hochgefahren ist. Der Atari bootet dann erst.

Genau so könnte man die Festplatte einige Zeit vor dem Atari einschalten und hätte den selben Effekt.

Vorsicht: Das ist nicht unbedingt äquivalent. Bei ausgeschaltetem Atari sind die ACSI-Leitungen in undefiniertem Zustand. Erst mit dem Einschalten nehmen sie definierte Zustände an. Wenn Du Ultrasatan solange wartet, bis die Leitungen in ihrem definierten Zustand sind und erst dann ihren internen Bootvorgang startet (Hypothese!!), dann kann es schon sein, dass eine ins ROM gepatchte Wartezeit beim Kaltstart hilft. Probier's aus, dann sind wir schlauer.  :)

Das klingt plausibel.

Wenn ich bloß wüßte, wo ich die entsprechend gepatchten TOS Roms herbekomme. Einen Programmer besitze ich leider nicht.