Autor Thema: MagiC 6.20 - Uhrenproblem  (Gelesen 475 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline KarlMüller

  • Benutzer
  • Beiträge: 228
MagiC 6.20 - Uhrenproblem
« am: Mi 20.06.2018, 19:20:18 »
siehe Ursprungsthread

Ein Update auf 6.20 behebt das Problem leider nicht. 6.10 hatte ich nie.
Es gibt mindestens zwei Version von MagiC 6.20, dies sich nur durch das Erstellungsdatum unterscheiden. Die entsprechende letzte Version liegt auf der Seite von ASH (Habe es jetzt nicht getestest). Die 6.10 wird zum Entschlüssen benötigt.
Meine 6.21 meldet sich als v06.20 mit dem Datum 02.10.2000 - was gibt´s denn da noch? Ich habe sie erst am  05.06.07 gekauft, vorher hatte ich 5.03, 5.13 & 5.20; beim Kauf wollte ASH ganz genau wissen, auf welcher Maschine ich sie laufen lassen wollte - meine Antwort: TT & F30; als ich dann mal den 1040STE dafür ausprobierte, gab´s nicht nur das Uhren-Problem, sondern der Inhalt meiner HD wurde zerschossen...
Der hohe Preis soll vom Kauf abschrecken, weil ASH keinen Support mehr geben will. Aber da ja AK sich entschlossen hat, Quellen freizugeben, gibt´s vielleicht doch mal Abhilfe?

PS: Ich habe doch auch die Version 6.10 - aber, weil gebraucht gekauft, fehlen mir da die Ser.- & Reg.Nrn.


Zitat
Meine 6.21 meldet sich als v06.20 mit dem Datum 02.10.2000
Wo kommt die 6.21 her? Tippfehler oder steht das irgendwo drauf?

Zitat
was gibt´s denn da noch?
Siehe hier ganz unten. Und  in der MausNet Gruppe maus.computer.atari.software war es ein Thema.

Ich habe jetzt aber keine Ahnung bzw. müsste tiefer graben wie man erkennen kann ob man die Version mit dem BIOS vom 10.9.2001 hat.

Zitat
Kauf wollte ASH ganz genau wissen, auf welcher Maschine ich sie laufen lassen wollte
Logisch, denn es gibt ja drei Versionen für echte Ataris, den Hades und den Milan. Und letztere läuft z.B. nicht auf den Hades oder Atari.

Zitat
Aber da ja AK sich entschlossen hat, Quellen freizugeben, gibt´s vielleicht doch mal Abhilfe?
Die Quellen sind schon da, wenn sich jemand hinsetzt und es macht, dann ja.

Offline ari.tao

  • Benutzer
  • Beiträge: 1.624
  • a tha yo ga a nu sha sa nam
Re: MagiC 6.20 - Uhrenproblem
« Antwort #1 am: Do 21.06.2018, 05:51:27 »
^^-- Ein paar kleine Verbesserungen hätte ich schon gerne - aber ich kann kein C.
Zitat
Meine 6.21 meldet sich als v06.20 mit dem Datum 02.10.2000
Wo kommt die 6.21 her? Tippfehler oder steht das irgendwo drauf?
Wohl ein Tippfehler  8)  nee, ist bloß meine Bezeichnung, um meine gepätschte Version vom Original zu unterscheiden, hätte wohl besser 6.2@ geheißen.
Zitat
Kauf wollte ASH ganz genau wissen, auf welcher Maschine ich sie laufen lassen wollt
Logisch, denn es gibt ja drei Versionen für echte Ataris, den Hades und den Milan. Und letztere läuft z.B. nicht auf den Hades oder Atari.
Das hörte sich für mich am Telefon damals eher so an, als hätten sie es mir nicht verkauft, wenn ich es für ´nen (M)STE hätte haben wollen...

Ob ich das BIOS-Datum 10.09.2001 habe, das weiß ich nicht - vom Kauf-Datum her müßte ja eigtl. das neueste drin sein ... Mal sehen, ob ich´s finde. Danke für Links.
Falcon+ddd32MHz, TT+CrazyDotsGK und noch ein paar andere.

Offline KarlMüller

  • Benutzer
  • Beiträge: 228
Re: MagiC 6.20 - Uhrenproblem
« Antwort #2 am: Do 21.06.2018, 18:44:27 »
Ein paar kleine Verbesserungen hätte ich schon gerne - aber ich kann kein C.
Kein Thema, geschätzte 90% sind in Assembler. Nur Teile des AES sind in C.

Wohl ein Tippfehler  8)  nee, ist bloß meine Bezeichnung, um meine gepätschte Version vom Original zu unterscheiden, hätte wohl besser 6.2@ geheißen.
Persönlicher Gedanke von mir. Auf solche Nummern in der Öffentlichkeit verzichten, denn das führt zu Verwirrung. Und gleich Schreiben das es gepacht ist und mit welchem Patch.

Ob ich das BIOS-Datum 10.09.2001 habe, das weiß ich nicht - vom Kauf-Datum her müßte ja eigtl. das neueste drin sein.
Habe es verstanden. Das Datum steht im Systemheader. Muss sich also mit SysInfo auslesen lassen.