Autor Thema: [Gelöst] Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.  (Gelesen 7223 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline czietz

  • Benutzer
  • Beiträge: 3.457
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #20 am: Do 07.06.2018, 18:43:11 »
Wenn ich ein USB-Stick anschließe passiert rein gar nichts...

Ist denn ein neuer Laufwerksbuchstabe hinzugekommen? Je nach Desktop musst Du das Laufwerk (wie jedes andere Laufwerk) manuell hinzufügen.

Frage: Du siehst aber schon, dass die Treiber geladen werden, so wie im Bild in der Anleitung?
http://wiki.newtosworld.de/index.php?title=Datei:Lightning_Mint1.jpg
Wenn der USB-Stick beim Booten gesteckt ist, wird er Dir als "New USB device" angezeigt?

und im ACC wird nur 5 x Initialisiere angezeigt.

Das USB.ACC ist auch für MiNT nicht gedacht. (Steht auch so in der Anleitung im Wiki: "Dieses ACC sorgt unter TOS und Magic dafür, dass der USB-Bus hotplug fähig ist." [Hervorhebung von mir.])

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #21 am: Sa 09.06.2018, 16:56:52 »
Das USB.ACC ist auch für MiNT nicht gedacht. (Steht auch so in der Anleitung im Wiki: "Dieses ACC sorgt unter TOS und Magic dafür, dass der USB-Bus hotplug fähig ist." [Hervorhebung von mir.])

@Christian, das glaube ich dir ja auch. Mich hat nur verwirrt das es dann im  Ordner "mint\1-19-379\sysroot\GEM\usb" mitgeliefert wird? Ein Schelm ist wer... ;)

Wenn ich beim Booten eine unter Windows mit FAT formatierte SDCARD 1GB einstecke wird diese erkannt und ich kann lustig hin und her kopieren... wenn BIG-DOS im Autoordner ist. Das besagte ACC verwende ich dann zukünftig nur in TOS.
« Letzte Änderung: Mo 11.06.2018, 00:21:10 von Arthur »

Offline czietz

  • Benutzer
  • Beiträge: 3.457
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #22 am: Sa 09.06.2018, 17:24:09 »
@Christian, das glauber ich dir ja auch. Mich hat nur verwirrt das es dann im  Ordner "mint\1-19-379\sysroot\GEM\usb" mitgeliefert wird? Ein Schelm ist wer... ;)

Auf den Auslieferungsumfang von FreeMiNT haben die Lightning-VME-Entwickler keinen Einfluss. Im Quelltext (https://github.com/freemint/freemint/blob/master/tools/usb/usb.c) steht aber auch eindeutig: "USB Accessory for TOS."

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #23 am: Sa 09.06.2018, 18:43:32 »
Ach Christian, alles ist gut, erinnert mich nur an Per Anhalter durch die Galaxies... oder denkst Du ich schau mir eine Datei mit Teufelswerk  >:D an?


Offline czietz

  • Benutzer
  • Beiträge: 3.457
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #24 am: So 10.06.2018, 21:59:32 »
Auf den Auslieferungsumfang von FreeMiNT haben die Lightning-VME-Entwickler keinen Einfluss.

Naja, indirekt schon: https://github.com/freemint/freemint/issues/86. Ab jetzt wird USB.ACC nur noch im USB4TOS-Archiv mitgeliefert (wo es auch dazugehört) und nicht mehr in in den FreeMiNT-Snapshots unter ...\sysroot\GEM\usb.

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #25 am: So 10.06.2018, 23:39:39 »
Vorbildlich gelöst, obwohl so ein ACC so eine Funktion wie Auswerfen, ähnlich wie in Windows, anbieten könnte und Infos zu geladenen Geräten anzeigen.

Offline mfro

  • Benutzer
  • Beiträge: 1.636
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #26 am: So 10.06.2018, 23:45:18 »
Vorbildlich gelöst, obwohl so ein ACC so eine Funktion wie Auswerfen, ähnlich wie in Windows, anbieten könnte ...

warum sollte es das? Plain TOS braucht das nicht (MiNT allerdings schon).
And remember: Beethoven wrote his first symphony in C

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #27 am: So 10.06.2018, 23:47:04 »
bezog mich auf mint

Offline mfro

  • Benutzer
  • Beiträge: 1.636
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #28 am: So 10.06.2018, 23:54:02 »
bezog mich auf mint

Ich dachte, das wäre für MiNT gar nicht gedacht? Steht jedenfalls oben.
And remember: Beethoven wrote his first symphony in C

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #29 am: So 10.06.2018, 23:58:35 »
Nein... dies ist für TOS... aber es wär schön wenn es für mint eins gäbe dass das Auswerfen, ähnlich wie in Windows, anbieten könnte ...

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #30 am: Mo 11.06.2018, 00:25:21 »
@Christian, das glauber ich dir ja auch. Mich hat nur verwirrt das es dann im  Ordner "mint\1-19-379\sysroot\GEM\usb" mitgeliefert wird? Ein Schelm ist wer... ;)

Auf den Auslieferungsumfang von FreeMiNT haben die Lightning-VME-Entwickler keinen Einfluss. Im Quelltext (https://github.com/freemint/freemint/blob/master/tools/usb/usb.c) steht aber auch eindeutig: "USB Accessory for TOS."

Auf welcher Maschine compilierst Du das? Irgendeinen Crosscompiler auf PC mit Linux etc. oder auf echter Atari-Hardware bzw. compatiblen?

Offline mfro

  • Benutzer
  • Beiträge: 1.636
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #31 am: Mo 11.06.2018, 06:55:14 »
Nein... dies ist für TOS... aber es wär schön wenn es für mint eins gäbe dass das Auswerfen, ähnlich wie in Windows, anbieten könnte ...

Dann musst Du eben - zumindest solange es das (noch) nicht gibt, aber auch danach dürfte das die deutlich sicherere Methode sein - den MiNT-Schreibcache für wechselbare Laufwerke ab - oder gar nicht erst anschalten.
And remember: Beethoven wrote his first symphony in C

Offline czietz

  • Benutzer
  • Beiträge: 3.457
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #32 am: Mo 11.06.2018, 07:46:05 »
Auf welcher Maschine compilierst Du das? Irgendeinen Crosscompiler auf PC mit Linux etc. oder auf echter Atari-Hardware bzw. compatiblen?

Mit gcc auf einem Windows-PC: http://vincent.riviere.free.fr/soft/m68k-atari-mint/.

Offline 1ST1

  • Benutzer
  • Beiträge: 8.661
  • Gesperrter User
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #33 am: Mo 11.06.2018, 09:47:12 »
Nein... dies ist für TOS... aber es wär schön wenn es für mint eins gäbe dass das Auswerfen, ähnlich wie in Windows, anbieten könnte ...

Beim Auswerfen von USB-Speicher unter Windows geht es ja vor allem darum, dass Windows seinen Schreibcache für dieses Laufwerk auf das Laufwerk schreibt, bevor man den Stick rauszieht.

Die Frage sollte also sein, wie ist die Cache-Strategie von TOS und MiNT bzw. des Festplattentreibers, wie lange brauchen diese Systeme, um ihren Cache weg zu schreiben? Werden Wechsellaufwerke überhaupt gecachet?
Ausgeloggter Mitleser, der hier NIE mehr aktiv wird. Am besten, meine Inhalte komplett löschen. Dabei berufe ich mich auf mein Urheberrecht, die DSGVO und auf die Rechte, die mir unter Impressunm&Datenschutz zugestanden werden. Tschö!

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #34 am: Mo 11.06.2018, 15:19:33 »
Im Prinzip gehts genau darum.... oder reicht es vor dem Entfernen der SDKarte einmal die Escape-Taste zu drücken?

Offline mfro

  • Benutzer
  • Beiträge: 1.636
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #35 am: Mo 11.06.2018, 16:22:19 »
Im Prinzip gehts genau darum.... oder reicht es vor dem Entfernen der SDKarte einmal die Escape-Taste zu drücken?

Nach meinem Verständnis ist bei der USB-Lösung der Plattentreiber nicht beteiligt (HDDRIVER beispielsweise hätte eigenen Cache) sondern implementiert eigene Routinen im hdv_rw-Vektor.

Sofern die keinen Schreibcache halten (davon würde ich ausgehen), spricht nichts dagegen, nach dem Abspeichern von irgendwas den Stick ohne weitere Aktion zu ziehen (bei normalem TOS).

In MiNT ist der Schreibcache nur dann aktiv, wenn man ihn explizit (für das betreffende Laufwerk) eingerichtet hat (FS_WB_ENABLE in der mint.cnf). Wenn da nichts steht, gilt für MiNT dasselbe.

Die ESC-Taste im Desktop hat gänzlich nichts mit Media Change zu tun. Die dient lediglich dem Refresh des Desktop-Laufwerksfensters, sonst nix.
And remember: Beethoven wrote his first symphony in C

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #36 am: Mo 11.06.2018, 20:58:30 »
Danke für die ausführliche Info.

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #37 am: Fr 15.06.2018, 18:42:13 »
Folgendes Problem habe ich momentan. Ich kann über den Taskmanager in MiNT keinen Shutdown, Reboot oder Halt durchführen... die Folge ist das jetzt jedesmal einen Filsystemcheck auf der EXT2 Partition bekomme. Beim Tastaturreset funktioniert die Maus noch aber sonst keine Meldung und kein synking der Disks etc.. Wenn ich in der Bash Schutdown f eingebe wird eine entsprechende Meldung ausgespuckt und das System hängt...

Unter TOS funktioniert Warm und Kaltstart über die Tastatur. Als MiNT benutze ich die 1-19-379 und die 1-19-253 wo mich hier irritiert weshalb nach einer 379 eine 253er Version angeboten wird.

Offline czietz

  • Benutzer
  • Beiträge: 3.457
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #38 am: Fr 15.06.2018, 19:14:26 »
Folgendes Problem habe ich momentan. Ich kann über den Taskmanager in MiNT keinen Shutdown, Reboot oder Halt durchführen...

Was ist denn der "Taskmanager in MiNT"? Der in XaAES integrierte? Ich kann hier keinerlei Probleme damit feststellen. Du musst also leider etwas spezifischer werden. Was genau passiert, wenn Du z.B. auf den Knopf "Reboot" drückst? Tritt der Fehler nur auf, wenn der Lightning-VME-Treiber blitz030.ucd geladen ist? Oder immer? Tritt der Fehler nur auf, wenn ein bestimmter Gerätetreiber *.udd geladen ist? Tritt der Fehler nur auf, wenn ein bestimmtes Gerät angeschlossen ist?

Unter TOS funktioniert Warm und Kaltstart über die Tastatur. Als MiNT benutze ich die 1-19-379 und die 1-19-253 wo mich hier irritiert weshalb nach einer 379 eine 253er Version angeboten wird.

Weil das in Wahrheit die Snapshots "379f36081f2cc9f7b9071ce4fbaa519eb5c08656" und "253cd9596d17323c9a7de4ff42dcf4214b2f4c01" sind, was allerdings den Dateinamen geringfügig 8+3-inkompatibel machen würde. Siehe https://github.com/freemint/freemint/commits/master. git vergibt die IDs nach dem Hash des Repositories, was die IDs eindeutig aber natürlich nicht aufsteigend macht.

Offline Arthur

  • Benutzer
  • Beiträge: 10.285
  • Mein Atari erinnert mich an die gute alte Zeit..
Re: Lightning USB im Atari TT und Nova (Mach 64) funktioniert nicht.
« Antwort #39 am: Fr 15.06.2018, 21:09:19 »
Zitat
Was ist denn der "Taskmanager in MiNT"? Der in XaAES integrierte?

ja, Taskmanager vom xaaes.

Zitat
Was genau passiert, wenn Du z.B. auf den Knopf "Reboot" drückst?

Einige Programme werden beendet...  Ich knips mal ein Bild.




Werde die USB-Treiber dann mal deaktivieren und schauen wie es dann aussieht mit Kalt und Warmstart. Habe noch ein weiteres Problem das ich den Filesystemcheck nicht sehe... im Log ist er aufgeführt aber life findet er ausserhalb des sichtbaren Bildschirms statt... ;) unter dem Monitor. >:D
« Letzte Änderung: Fr 15.06.2018, 21:16:16 von Arthur »