Autor Thema: PAM Netzwerkkarte wird nicht erkannt ...  (Gelesen 981 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 7.073
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #20 am: Do 14.09.2017, 17:28:48 »
Habe mal auf github geschrieben ...

Die XIF Treiber werden in allen 1-19 Versionen nicht mehr geladen. Wenn man die Hardware nicht hat macht das nichts, es kommt in jedem Falle ein Meldung vom XIF Treiber.

Offline czietz

  • Benutzer
  • Beiträge: 1.265
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #21 am: Do 14.09.2017, 21:52:04 »
Hmm, ich habe gerade mal in meiner MiNT-Installation (1.19er-Snapshot von vor vielleicht zwei Wochen) die lance.xix im Ordner TT in lance.xif umbenannt. Dann sehe ich folgende Bootmeldung, d.h. offensichtlich wird der Treiber bei mir schon geladen -- findet aber natürlich keine Karte.

« Letzte Änderung: Do 14.09.2017, 21:54:19 von czietz »

Offline czietz

  • Benutzer
  • Beiträge: 1.265
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #22 am: Do 14.09.2017, 21:52:55 »
Sorry, habe mich selbst zitiert und gepostet. War ein langer Tag heute...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 7.073
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #23 am: Do 14.09.2017, 22:11:28 »
Bei mir am Atari TT mit der 1-19-214 wird der Treiber nicht einladen, auch in allen anderen 1-19 Versionen nicht. Mit der 1-18-1 geht es, alles recht Seltsam ...

Offline czietz

  • Benutzer
  • Beiträge: 1.265
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #24 am: Do 14.09.2017, 22:21:34 »
Wird denn der MiNT-Net TCP/IP Stack bei Dir ohne Fehlermeldung geladen wie auf meinem Foto?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 7.073
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #25 am: Do 14.09.2017, 22:36:19 »
Da liegt vielleicht das Problem, vielleicht nutzen die Entwickler alle Emulatoren. Ist die Frage ob das eine Krankheit oder ein Segen ist ...

Offline czietz

  • Benutzer
  • Beiträge: 1.265
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #26 am: Do 14.09.2017, 23:04:15 »
Mir ist jetzt nicht ganz klar, wie Du jetzt auf Emulatoren kommst. Wird der TCP/IP Stack nun bei Dir geladen oder nicht?

Offline Arthur

  • Benutzer
  • Beiträge: 6.712
  • Mein Atari erinnert mich an die gute alte Zeit..
    • Atari Wiki
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #27 am: Do 14.09.2017, 23:30:51 »
Da liegt vielleicht das Problem, vielleicht nutzen die Entwickler alle Emulatoren. Ist die Frage ob das eine Krankheit oder ein Segen ist ...

Christian, Frank schrieb doch vielleicht... weil er sich das evtl. nicht erklären kann, denke ich jetzt einfach mal so. ;D

Offline Nervengift

  • Benutzer
  • Beiträge: 1.220
    • Ein wenig was über mein anderes Hobby. :-)
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #28 am: Fr 15.09.2017, 08:33:00 »
Ich hab die Erfahrung gemacht, dass es auch auf die Reihenfolge der Treiber im MiNT-Ordner ankommt. Wenn man die nicht in eine halbwegs logische Reihenfolge bringt, dann hatte ich auf dem Milan Abstürze oder manche Dinge funktionierten einfach nicht wie z. B. NFS. Bei dem Netzwerksachen habe ich zuerst den Netzwerkkartentreiber stehen. Dann den TCP/IP-Stack und dann den NFS-Treiber.
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline czietz

  • Benutzer
  • Beiträge: 1.265
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #29 am: Fr 15.09.2017, 08:39:50 »
Zumindest bei einem aktuellen MiNT lädt der TCP/IP-Stack, also inet4.xdd ja die Netzwerkkartentreiber.
Insofern kann man den Netzwerkkartentreiber ja gar nicht in der falschen Ladereihenfolge haben.
Siehe auch meinen Screenshot.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 7.073
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #30 am: Fr 15.09.2017, 13:24:53 »
inetd ist im 1-19-214 und 1-19-cur da ...

Seltsam das ganze, auf einem Falcon mit CT60 funktioniert es wie jemand auf github schrieb.

Offline czietz

  • Benutzer
  • Beiträge: 1.265
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #31 am: Fr 15.09.2017, 14:18:51 »
inetd ist im 1-19-214 und 1-19-cur da ...

Ich sprach von inet4.xdd, nicht inetd; das ist was ganz anderes. Ich frage zum dritten Mal: "Wird denn der MiNT-Net TCP/IP Stack bei Dir ohne Fehlermeldung geladen wie auf meinem Foto?"

Wenn Du Dir nicht sicher bist, wie Du die Meldungen zu interpretieren hast, mach doch eine Reihe Fotos aller Meldungen, die Du beim Start siehst, dann gucke ich sie mir an, ob hier "MiNT-Net TCP/IP" darin auftaucht und was nach "Loading interfaces" steht.

Seltsam das ganze, auf einem Falcon mit CT60 funktioniert es wie jemand auf github schrieb.

Auf dem TT wird der Treiber ja auch geladen, siehe mein Screenshot. Natürlich findet er in meinem Fall die Karte nicht -- wie auch -- aber geladen wird er.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 7.073
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #32 am: Fr 15.09.2017, 15:13:50 »
Ich meinte ja auch inet4.xdd ...

Das Bild ist von der 1-18-1 Version, da funktioniert ja alles wie es soll. Die Netzwerkkarte ist am BNC Ausgang defekt, muss ich noch reparieren. Das hat aber nichts mit dem Problem beim Atari TT und allen 1-19 Versionen zu tun ...



Im Post #9 sieht man ja auch das bei der 1-18-1 alles in Ordnung ist und der Treiber auf dem Atari TT geladen wird, was in den 1-19 Versionen nicht passiert.
« Letzte Änderung: Fr 15.09.2017, 15:16:36 von Lukas Frank »

Offline HelmutK

  • Benutzer
  • Beiträge: 667
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #33 am: Fr 15.09.2017, 17:58:48 »
Was steht denn im boot-log, oder hast Du das ausgeschaltet?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 7.073
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #34 am: Fr 15.09.2017, 18:59:19 »
Hier ist mein boot.log ...


lance.xif und inet4.xdd liegen im \mint\1-19-cur\ Ordner. Ich nutze zur Zeit den helmut Kernel vom 23062017.


Resident TOS version 3.06
Kbshft 0x000010BB.
p             *** WARNING ***              q
You have turned off the memory protection.
This is not recommended and may not be
supported in the future.

Calibrating delay loop ... 7.91 BogoMIPS

p High quality random number generator q
 courtesy of Theodore Ts'o.
 Copyright ½ 1994-1998 Theodore Ts'o
 All Rights Reserved.
 See the file COPYRAND for details.

Initializing built-in domain ops ... done!
Loading external modules ...

p MiNT-Net TCP/IP 1.6 PL 1,  q
½ 1993-1996 by Kay Roemer.
½ 1997-1999 by Torsten Lang.
½ 2000-2010 by Frank Naumann.

Loading interfaces:
AM7990: driver for PAMs EMega/VME (C) 1996, 1997, 1998 by T. Lang
AM7990: driver v1.2 (ple0) for PAMs EMega/VME (00:00:5B:E8:02:DD)
IP  masquerading by Mario Becroft, 1999.
FTP masquerading support by Torsten Lang, 1999.

p xconout2 output catcher version 0.3 q
½ Jan  1 1995 by TeSche <itschere@techfak.uni-bielefeld.de>
½ 2000-2010 by Frank Naumann.

Spooled Centronics device driver, by T.Bousch (version 0.9).
This program is FREE SOFTWARE, and comes with NO WARRANTY.
See the file "COPYING" for more information.

p MFP serial driver version 0.31 q
½ 1998, 1999 by Rainer Mannigel.
½ 2000-2010 by Frank Naumann.

original MFP (supported)
TT MFP (supported)

p SCC serial driver version 0.27 q
½ 1998, 1999 by Rainer Mannigel.
½ 2000-2010 by Frank Naumann.

PCLK is 8.053976 MHz

p Ext2 filesystem driver version 0.63 q
½ 1998, 1999 by Axel Kaiser.
½ 2000-2010 by Frank Naumann.
½ 2013 by Alan Hourihane.

p Network file system driver version 0.57 q
½ 1993, 1994 by Ulrich Khn.
½ 2000-2010 by Frank Naumann.
See the file COPYING for copying and using conditions.

p dynamic RAM filesystem driver version 0.57 q
½ Mar  3 1999 by Frank Naumann.


Starting up the update daemon ... done!
Starting up the idle process (pid 0) ... done!
Installing keyboard table `u:/c/mint/1-19-cur/keyboard.tbl' ... AKP 1, ISO 0.

Reading `u:/c/mint/1-19-cur/mint.cnf' ... 1811 bytes done.
[u:/c/mint/1-19-cur/mint.cnf:11] unknown variable 'FS_NEWWFATFS', skipped.
pVFAT active:q J
[u:/c/mint/1-19-cur/mint.cnf:13] unknown variable 'FS_CACHE', skipped.


Checking filesystem on drive e.
e_: clean, 10912/122160 files, 74924/488280 blocks

Current date and time: Fri Sep 15 18:49:40 2017
Time zone in use: CEST
East of Greenwich Mean Time: 2:00:00
Kernel clock mode: localtime

INIT 'u:\sbin\init' ''
Setup complete, now booting system...

AESSYS:read_inf:u:\c\MINT\1-19-CUR\XAAES\xaaes.inf
Reading `u:\c\MINT\1-19-CUR\XAAES\xaaes.inf' ... 350 bytes done.


So wie es aussieht wird der Netzwerkkarten Treiber doch geladen allerdings bei mir ohne Ausgabe beim booten über den Bildschirm. Ich arbeite auf TT-Mittel oder TT-Hoch also nicht über eine Grafikkarte.

Offline czietz

  • Benutzer
  • Beiträge: 1.265
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #35 am: Fr 15.09.2017, 19:25:34 »
Zitat
So wie es aussieht wird der Netzwerkkarten Treiber doch geladen

Also ist jetzt alles OK? Und die Aussage: "Ich weiss ja nicht was die MiNT/XaAES Leute da immer machen, totales Chaos ... Die 1-19-cur ist so nicht zu gebrauchen, schade." ist hinfällig?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 7.073
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #36 am: Fr 15.09.2017, 19:31:29 »
Ist halt ein wenig blöd wenn keine Bildschirmausgabe kommt und man meint der Treiber wird nicht geladen. Schön ist das nicht.

Offline HelmutK

  • Benutzer
  • Beiträge: 667
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #37 am: Fr 15.09.2017, 20:23:05 »
Alles was ins boot-log geht, erscheint nicht auf dem Bildschirm. Das ist Absicht, war schon immer so, und bisher hat sich auch noch keiner darüber beschwert.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 7.073
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #38 am: Fr 15.09.2017, 20:36:21 »
Habe mal zum Probieren MiNT 1-18-1 installiert und siehe da lance.xif wird geladen. Scheint alles in Ordnung zu sein ...

Ich weiss ja nicht was die MiNT/XaAES Leute da immer machen, totales Chaos ...

Die 1-19-cur ist so nicht zu gebrauchen, schade.



Die Meldung beim booten des Kernels über das Laden des Netzwerktreibers sollte doch kommen. So kenne ich das. Bei der 1-18-1 geht es doch. Warum in der 1.19 nicht mehr ?

Offline czietz

  • Benutzer
  • Beiträge: 1.265
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #39 am: Fr 15.09.2017, 21:53:16 »
Ich wette, wenn Du das Bootlog wieder abschaltest, erscheinen die Meldungen auch wieder...