Autor Thema: "Bad Apple!!" Musik-Video auf Atari 400!  (Gelesen 1616 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline TPAU

  • Benutzer
  • Beiträge: 288
  • Atari-Fan der ersten Stunde! ;-)
"Bad Apple!!" Musik-Video auf Atari 400!
« am: Sa 09.05.2020, 18:39:55 »
Vielleicht kennt ihr ja das "Bad Apple!!" Musik-Video (eine Demo in dem Sinne ist es eigentlich nicht), von dem es Versionen auf so ziemlich jedem Konsolen- und Computer-System gibt.
Neben Atari 2600, Intellivision, Jaguar, ZX Spectrum, C64, Atari STE usw. gibt es das Ding auch in mehreren Versionen für die Atari 8-Bit Computer.

Hier mal die technisch interessanteste Version, die aus einer Kombination aus ROM-Modul und Cassette (!) besteht, vorgeführt auf einem stock Atari 400 plus 410 Datasette! Kommt imho durchaus an die STE-Version ran und hat "drumherum" noch ein paar Features. ;D
Auch mal die Links in seiner Videobeschreibung durchlesen, sehr interessant wie ich finde.

Video zur "Demo"

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 982
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #1 am: Sa 09.05.2020, 19:33:01 »
Eben nicht stock Atari 400. Les mal die Kommentare.

Da wird ziemlich gecheatet.

Offline TPAU

  • Benutzer
  • Beiträge: 288
  • Atari-Fan der ersten Stunde! ;-)
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #2 am: So 10.05.2020, 00:03:17 »
Ja natürlich liegt das Geheimnis (wenn man so will) in jenem Modul.
Wenn ich das richtig verstanden hab, wurde das Video Bild für Bild abgespeichert und per Bank-Switching ins Atari Bildschirm-RAM geschrieben usw.

Nur ist der Atari auf dem das Ganze läuft halt ein unmodifizierter 400er!

Ich schätze mal, würde man das ganze in einen 600/800XL mit 1010 Datasette packen, würde es genauso laufen (wenn das Bankswitching mit den gleichen Adressen läuft, aber da stecke ich nicht in der Materie).

Offline neogain

  • Benutzer
  • Beiträge: 1.274
  • ...?
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #3 am: So 10.05.2020, 00:46:30 »
Trotzdem beachtlich. Selbst auf meinem Falcon spielt die Demo nur ruckelnd ab. Vielleicht sollte ich es doch mal auf dem STe probieren. Auf jeden Fall echt stark, was der 400er da leistet

Offline alers

  • Benutzer
  • Beiträge: 506
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #4 am: So 10.05.2020, 00:49:33 »
Ich schätze mal, würde man das ganze in einen 600/800XL mit 1010 Datasette packen, würde es genauso laufen (wenn das Bankswitching mit den gleichen Adressen läuft, aber da stecke ich nicht in der Materie).
Ja macht es. Es rennt auch auf einem 130XE, sofern man TheCart! hat und das vorher da drauf macht. Auch auf dem UNO geht das.

Eben nicht stock Atari 400. Les mal die Kommentare.
Da wird ziemlich gecheatet.
Klar geht das auch auf einem STOCK_400er, da das Modul das wichtige ist. Denn dort liegen die Daten auf ROMs (eher auf EPROMs), der 400er mit seinen 16K kann das schon so verarbeiten, der ist "STOCK" und nicht gepimped.
CU AleX

---

afk & #IaM

Offline TPAU

  • Benutzer
  • Beiträge: 288
  • Atari-Fan der ersten Stunde! ;-)
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #5 am: So 10.05.2020, 18:27:49 »
@neogain Also auf meinem 1040STE mit 4MB und Micro-Ultrasatan hab ich die "Demo" (die Version aus meinem Link im ersten Post, gibt auch noch andere) bisher nicht zum laufen gebracht.
Es kommt nur dieser Anfangs-Text und dann sieht man am linken Bildschirmrand irgendein kryptisches Symbol, mutmasslich Bomben.
Vielleicht muss ich das Ding mal auf C: kopieren, sprich in die ersten 512MB.
Soll ja bei diesen Streaming-Sachen oftmals helfen. :-\

Offline Lynxman

  • Benutzer
  • Beiträge: 1.962
  • Nicht Labern! Machen!
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #6 am: So 10.05.2020, 22:23:20 »
Modul hin oder her, das Endergebnis ist das was zählt.
Und solange man transparent bleibt wie man es geschaft hat ist das für mich OK.

Ich finde z.B. die Vectrex Version irre, das System ist ja auch ziemlich limitiert.

Das Youtube Video zur STE Version in dem erklärt wird wie sie es gemacht haben finde ich auch sehr interessant.

Für mich das Interessanteste an der 8- und der 16-Bit Ära ist wie man die Limitierungen der Kisten aufgehoben hat und Effekte hinbekommen hat die man nicht für möglich gehalten hat.
« Letzte Änderung: So 10.05.2020, 22:24:52 von Lynxman »
Aktuelle Lynx FlashCard Firmware: hier klicken

Nerd? I prefer the term INTELLECTUAL BAD ASS

Ich kann nicht alle glücklich machen, ich bin ja keine Pizza!

Werde auch Du Fan von Lynxmans Basteltagebuch!  Klick mich, Du willst es doch auch! ;)

Offline alers

  • Benutzer
  • Beiträge: 506
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #7 am: Mo 11.05.2020, 09:03:37 »
Für mich das Interessanteste an der 8- und der 16-Bit Ära ist wie man die Limitierungen der Kisten aufgehoben hat und Effekte hinbekommen hat die man nicht für möglich gehalten hat.
Da gebe ich Dir vollkommen Recht. Was viele Coder da "noch" so rausholen, was vermutlich die Entwickler nie für möglich oder bedacht haben, ist enorm. Wenn ich sehe, welche Hardware am A8 mittlerweile rennt, zeigt es doch nur, daß es auch Heutzutage noch sehr aktive Aktivisten gibt, vor allem, wenn man bedenkt, daß es wirklich sich nur um ein Hobby dreht, ohne reale finanzielle Interessen... :-)
CU AleX

---

afk & #IaM

Offline tuxie

  • Benutzer
  • Beiträge: 6.719
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #8 am: Di 12.05.2020, 20:42:53 »
Ich denke auf dem Modul ist das Video ansichtig gespeichert und von Kassette wird nur das Programm geladen.

2008 war ich mit dem Abbuc zur Games Convention in Leipzig, dort hat Mr. Atari einen 800XL laufen gehabt, der ein Video abgespielt hat, Bild und Ton. Dort war es so das er ein IDE Interface in den XL eingebaut hatte und das Video Bitweise auf die Platte gespeichert hat, er musste quasi nur Daten kopieren in den Videospeicher und den Pokey mit Infos füttern. Klar bei der Auflösung und in Schwarz weiß war das was an gesehen hat nicht viel, aber es war Ruckelfrei. Und mit seinen 1,79Mhz echt eine Meisterleistung.

Tschau Ingo


PC Intel i7 4820, 16gb quad @2400,Mac OS X El Capitan
http://tuxie.de http://hwbot.org/user/tuxie/

Offline RetroKid

  • Benutzer
  • Beiträge: 120
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #9 am: Di 12.05.2020, 22:19:19 »
HIer wird doch genau beschrieben, wie er/sie es realisiert haben:
https://www.wudsn.com/index.php/productions-atari800/demos/badapplehd
* Atari Falcon 030 14MB
* Atari 1040 STE TOS 2.06 4MB UltraSatan
* Atari SC1224

Offline TPAU

  • Benutzer
  • Beiträge: 288
  • Atari-Fan der ersten Stunde! ;-)
Re: "Bad Apple!!" Musik-Video auf Atari 400!
« Antwort #10 am: So 15.11.2020, 18:57:15 »
@neogain Also auf meinem 1040STE mit 4MB und Micro-Ultrasatan hab ich die "Demo" (die Version aus meinem Link im ersten Post, gibt auch noch andere) bisher nicht zum laufen gebracht.
Es kommt nur dieser Anfangs-Text und dann sieht man am linken Bildschirmrand irgendein kryptisches Symbol, mutmasslich Bomben.
Vielleicht muss ich das Ding mal auf C: kopieren, sprich in die ersten 512MB.
Soll ja bei diesen Streaming-Sachen oftmals helfen. :-\
Zwar etwas OT aber ich hab das Problem (welches auch einige andere HDD-kritische Demos betraf) gelöst: In den HDDRIVER-Util irgendwo bei Einstellungen "Atari ACSI Beschleunigter Modus" aktivieren. Schon laufen die Demos! :D
Die Harddisk-streamenden Spielversionen "Xenon 2" und "Giana Sisters" von P. Petari laufen (hier) auch ohne diesen Modus.