Autor Thema: Externe Floppys werden nicht erkannt  (Gelesen 4186 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline AlCarbonara

  • Benutzer
  • Beiträge: 5
Externe Floppys werden nicht erkannt
« am: Sa 21.11.2015, 00:06:47 »
AMD,

ich habe hier einige Probleme mit 4 externen Floppys für den Atari.......2 mal Atari SF314, 1 mal Atari SF354 und ein externes HD-Floppy unbekannter Hersteller.

Testequipment:

- 5 Mega ST 1 und 2
- 3 Floppykabel
- 2 Floppynetzteile

Die Mega ST sind bis auf Speichererweiterungen original.


Egal in welcher Konstellation ich die Floppys anschliesse habe ich folgende Fehler:

- entweder wird beim Versuch auf Floppy B zuzugreifen von Floppy A gelesen, wobei Floppy B aber der Motor auch läuft...so als wenn beide Floppys als A gemeldet wären !!!
oder
- es kommt beim Versuch auf Floppy B zuzugreifen die Fehlermeldung das Laufwerk B sich nicht meldet.

Laut Schaltplan sind ja der externe und der interne Floppyanschluss parallel gelegt oder irre ich mich da ?
Es können doch nicht alle 4 Floppys defekt sein....wobei ich beim externen HD-Floppy wohl die interne Schaltung zum Betrieb von HD-Floppys brauchen werde ?!?!


Ich bin gerade etwas ratlos ????


CU,

AC

Offline czietz

  • Benutzer
  • Beiträge: 3.606
Re: Externe Floppys werden nicht erkannt
« Antwort #1 am: Sa 21.11.2015, 11:07:27 »
Dass der Motor bei manchen nicht selektierten Floppy-LW mitläuft, kann vorkommen. Es gibt beim
Diskettenlaufwerksanschluss nur ein Signal für "Motor on", manche Laufwerke schalten dann bereits den Motor an, obwohl sie nicht selektiert wurden.

Wenn sich die Laufwerke nicht so ansprechen lassen, wie gewollt, kannst Du mal die Drive-Select-Einstellungen (meist Jumper) der Laufwerke überprüfen. Am MegaST müssen wimre sowohl(!) das interne als auch das externe Laufwerk auf "Drive Select 0" eingestellt sein.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 13.154
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Externe Floppys werden nicht erkannt
« Antwort #2 am: Sa 21.11.2015, 12:18:05 »
Genau, alle Atari Diskettenlaufwerke sind auf DriveSelect 0 gejumpert. Atari macht das so damit die Laufwerke auch am 260/520ST als Laufwerk A funktionieren ohne da etwas umstellen zu müssen. Ausser beim 260/520ST sind die DriveSelect Signale an dem externen anschlüssen vertauscht damit das ganze so funktioniert. Im Prinzip so ähnlich wie das verdrehte Shugart Flachbandkabel beim AT/PC ...

Burkhard Mankel

  • Gast
Re: Externe Floppys werden nicht erkannt
« Antwort #3 am: Sa 21.11.2015, 14:10:22 »
Also - etwas ausführlicher - mal etwas über die Laufwerksgeschichte bei Atari:
Generell - egal welche Kostellation einer Atari ST/TT Anlage - hat Atari geplant, bis zu zwei Laufwerke zu betreiben und dabei jede erdenkliche Laufwerk-Konfiguration dem User fernzuhalten. Das wird dadurch erreicht, daß man immer Laufwerke mit DS0 einsetzen kann, egal, ob 1 oder 2 Laufwerkbetrieb. Hier ein paar Beispiele:
- 260/520 ST mit 2 Laufwerken: Drive 1 extern (A:) geht als DS0 an den Rechner wie überall! Drive 2 extern geht als als DS1 in den Rechner. Das wird dadurch erreicht, das dar Pin für DS1 an der Eingangsbuchse am Laufwerk ist mit dem Pin für DS0 an der Ausgangsbuchse von LW2 geschaltet.
- 1040STf/STE: Internes Laufwerk DS0, externes Laufwerk DS1, intern muß das LW aber mit DS0 gejumpert sein. Die Buchsen am STf/STE haben am Pin für DS0 das DS1 Signal geführt, während der offizielle DS1 Pin mit Pull-Up an +5V geschaltet ist
- Mega ST(E)/TT: entspricht der Beschaltung der STf/STE Ataris.

Also - ich kann mir nicht vorstellen, daß bei 4 gleichen ST und 4 passenden Laufwerken eines Users den gleichen Defekt aufweisen, darum gestatte mir - ich möchte Dich damit aber nicht beleidigen oder Dir auf die Füße treten - eine Frage: Hast Du überhaupt die richtige Anschlußbuchse an den Floppys zum Computer verwendet? Wenn Du nämlich die din ST an der Ausgangsbuchse der Floppys angeschlossen hast, kann gar nichts laufen, weil dann der Pin für das anzusprechende LW nämlich generell in der Luft hängt - also unbeschaltet sein dürfte!

Offline AlCarbonara

  • Benutzer
  • Beiträge: 5
Re: Externe Floppys werden nicht erkannt
« Antwort #4 am: Sa 21.11.2015, 14:42:10 »
Schäm...ich hatte das mit den unterschiedlichen Buchsen gar nicht gesehen........Atari ist für mich absolutes Neuland !

Vielen Dank, ohne diesen Hinweis hätt ich wohl noch den ganzen Tag rumprobiert..... ;)


CU,

AC


Burkhard Mankel

  • Gast
Re: Externe Floppys werden nicht erkannt
« Antwort #5 am: Sa 21.11.2015, 16:11:23 »
Also klappts doch? Funzt alles?

Ja - ich bin manchmal sehr direkt! Andere bekommen bei solcherlei Gedanken das Gefühl sie könnten Dich verletzen und traun sich vielleicht nicht, sowas direkt anzusprechen! Aber Du mußt verstehen, daß ich versuche in meinen Gedanken erst mals logisch zu hinterfragen und prüfen und bei einer Person gleich 4 Geräte Defekte haben, die zur gleichen Symptomatik führen, ist so gut wie das eine Person einen kompletten Lotto Jackpot abräumt - und das dürfte so gut wie nie passieren!