Autor Thema: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS  (Gelesen 31935 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Burkhard Mankel

  • Gast
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #160 am: Do 02.06.2016, 14:49:02 »
@tuxie
Du irrst!  Das "Große" hat 512k! Mir sind nur diese beiden Größen bekannt und die von @czietz angepaßte und einige Posts wo. verfügbar gemachte ist eben die Kleinere!

Offline tuxie

  • Benutzer
  • Beiträge: 6.476
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #161 am: Do 02.06.2016, 14:49:52 »
Ach echt ?

emutos-192k-20160530.zip

https://sourceforge.net/projects/emutos/files/snapshots/20160530/

Auszug aus der Readme

EmuTOS - 192 KB versions

These ROMs are suitable for the following hardware:
- ST / STf
- Mega ST
- emulators of the above
« Letzte Änderung: Do 02.06.2016, 14:53:19 von tuxie »
Tschau Ingo


PC Intel i7 4820, 16gb quad @2400,Mac OS X El Capitan
http://tuxie.de http://hwbot.org/user/tuxie/

Offline czietz

  • Benutzer
  • Beiträge: 2.173
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #162 am: Do 02.06.2016, 17:09:07 »
tuxie hat Recht. Es muss auch immer möglich sein, eine EmuTOS-Version in 192 kByte compiliert zu bekommen, ggf. unter Abschaltung optionaler Features. (So ist IDE-Unterstützung afaik erst ab der 256-kByte-Version enthalten.)

Und 192 kByte sind echt eng, da wird fast um jedes Byte Platzeinsparung gerungen.

Burkhard Mankel

  • Gast
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #163 am: Do 02.06.2016, 17:52:02 »
Sorry bitte! Aber seit ich mich mit dem EmuTOS doch etwas stärker befasse, habe ich nur eine Download-Seite gefunden, über die die 256er und und die 512er Versionen zum Download angeboten wurden und daher bin ich davon ausgegangen, daß es eben nur diese Versionen gibt! Als bitte nochmals um Entschuldigung, daß ich hier aufgrund erlangter Fehlinfos selber fehlerhafte Infos weitergab!

Offline tuxie

  • Benutzer
  • Beiträge: 6.476
  • Falcon! Milan! Schuetzt die Raubvoegel!
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #164 am: Do 02.06.2016, 18:30:06 »
Kein ding sowas hab ich mir schon gedacht... deswegen hab ich den Link gepostet.
Tschau Ingo


PC Intel i7 4820, 16gb quad @2400,Mac OS X El Capitan
http://tuxie.de http://hwbot.org/user/tuxie/

Burkhard Mankel

  • Gast
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #165 am: Mo 10.10.2016, 14:01:45 »
Hallo Leute - ich muß hier mal weitermachen! Da meine Tests mit der GOTEK bislang nicht zum gewünschten Erfolg führten, habe ich mich erstmal mit weitere Einrichtungsarbeiten meines Mega ST4+ beschäftigt. Dabei sind neue Fragen aufgekommen:

- bezüglich EmuTOS:
Da hier zuletzt darüber recht positiv debattiert wurde, will ich mich doch auch ein bißchen stärker damit befassen, aber ich würde gerne das aussehen für mich ansprechender umgestalten lassen, da ich nicht selbst programmieren kann!

- bezüglich TOS 2.(0)6:
Beim Start erscheint erst einmal "Bad ... in ROM ...", es läßt sich aber im Desktop anstandslos arbeiten ohne erkennbaren Fehler! Mir waren solche Probleme bei Anwendung von SWE-Patch aufgefallen, wenn ich ein damit erstelltes TOS.IMG im STeEm testete - dann aber für beide ROMs! Worauf deutet das hin?

- bezüglich MagiC - Frage speziell an @neogain :
Mir ist aufgefallen, daß MagiC nach Wahl der betreffenden Bootpartition immer noch nicht einwandfrei startet - ich gehe davon aus, daß ich den Treiber noch nicht auf den czietz-Patch aktualisierte! Kann ich einfach einen der von ihm gepatchten Ppera Treiberinstaller starten, um den Treiber auf der CF zu aktualisieren oder hattest Du anschließend Startschwierigkeiten und mußtest alles neu einrichten?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.415
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #166 am: Mo 10.10.2016, 14:09:53 »
Wegen dem TOS 2.06, das scheint nicht richtig gepatcht zu sein wegen dem CRC Fehler beim booten. Wieso musst du das denn überhaupt patchen ?

Burkhard Mankel

  • Gast
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #167 am: Mo 10.10.2016, 14:18:19 »
Wegen dem TOS 2.06, das scheint nicht richtig gepatcht zu sein wegen dem CRC Fehler beim booten. Wieso musst du das denn überhaupt patchen ?
Ich habe noch kein eigenes Flashing vorgenommen und das Flash-TOS so vorliegen, wie @neogain es mir einrichtete - daher kann ich nicht sagen, ob hier überhapt ein gepatchtes TOS oder das oTOS 2.(0)6 vorliegt!

Offline neogain

  • Benutzer
  • Beiträge: 1.139
  • ...?
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #168 am: Mo 10.10.2016, 17:41:06 »
Wegen dem TOS 2.06, das scheint nicht richtig gepatcht zu sein wegen dem CRC Fehler beim booten. Wieso musst du das denn überhaupt patchen ?
Ich habe noch kein eigenes Flashing vorgenommen und das Flash-TOS so vorliegen, wie @neogain es mir einrichtete - daher kann ich nicht sagen, ob hier überhapt ein gepatchtes TOS oder das oTOS 2.(0)6 vorliegt!

Du hast schon das gepatchte TOS2.06, sowie Magic drauf. Der Prüfsummenfehler hängt einfach damit zusammen, weil das TOS gepatcht ist und ich hier nicht die Prüfsumme gefixt hatte. Kannste aber nachholen mit dem Romsplit. @czietz hat hier die Treiber angepasst, damit man von MagiC booten kannst. Also nehmen und drüberkopieren, dann kannst du auch in MagiC booten. Inzwischen habe ich die TOSe komplett anders gestrickt bei meinen STs, du hast halt das Interface von mir bekommen, wo ich noch selber am rumbasteln war. Kannst aber alles umflashen nach belieben.
* ATARI 1040STe, 4MB Ram, TOS 2.06 (der Unantastbare)
* ATARI Mega ST2; 4MB Ram; ET4000; FTOS 4x; IDE SD Adapter 16 GB
* ATARI 1040 STf; 1MB (der erste nach 20 Jahren wieder)... rote LED's ;)
* ATARI Portfolio 512KB Ram; 128MB CF IDE; 6Mhz Overclock
* ATARI 260ST; 4MB Ram; FTOSx4; IDE 9GB

Burkhard Mankel

  • Gast
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #169 am: Di 18.10.2016, 13:23:24 »
Vor ein paar Tagen habe ich jetzt den Treiber mit dem Patch von @czietz aktualisiert - und MagiC startet trotzdem nicht (Fehlerausgabe siehe Anhang)
Erst dachte ich, ich habe einen Fehler bei der Treiber Installation gemacht und habe es gerade eben noch einmal vollzogen - aber man kann eigentlich keinen Fehler machen: "I"(nstall) oder "S"(ave to Disc) - oder andere Tasten zum Abbruch!

Meine Bootpartition für MagiC ist "K:", ich drücke also bei der entsprechenden Anzeige die Taste <K>, damit diese Partition zu "C:" wird und MagiC das korrekte Drive als Bootdrive hat und dort seine Dateien findet, die ich über TOS 2.(0)6 auf deise Partition kopiert habe!

Alle anderen TOSse starten anscheinend korrekt ...

Worauf deutet der Fehler hin - wurden evtl. die MagiC-Dateien fürs Root nicht richtig auf die Festplatte kopiert?

edit: installiert habe ich die Treiberversion IDEP_98B (AUDU98B.PRG)!
« Letzte Änderung: Di 18.10.2016, 13:40:47 von Burkhard Mankel »

Offline czietz

  • Benutzer
  • Beiträge: 2.173
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #170 am: Di 18.10.2016, 19:35:00 »
Das sieht so aus, als hättest Du eben nicht den gepatchten Treiber installiert. Du hast wirklich das Programm aus idefix.zip(.pdf) genommen, das als Anhang an meinem von neogain verlinkten Posting hängt?

Leider hast Du auf Deinem Screenshot just die spannende Zeile weggeschnitten. Welche Versionsnummer taucht in der Zeile "IDE driver V[...]" auf?

Burkhard Mankel

  • Gast
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #171 am: Di 18.10.2016, 19:51:52 »
TW IDE harddisk driver for DOS part's
V0.98ß P.Putnik, 2010. Use with BIGDOS !
Press F1 or Help for HELP


ST , TOS 6.0P , 4 MB

...

Partitions :10
 ...
... und ich habe die Treiberdownloads genommen, die ich auf dem Thread gezogen habe, wo Du den Hinweis auf den Patch gegeben und diese eben zum Download verfügbar gemacht hast!

Offline czietz

  • Benutzer
  • Beiträge: 2.173
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #172 am: Di 18.10.2016, 19:57:20 »
TW IDE harddisk driver for DOS part's
V0.98ß P.Putnik, 2010. Use with BIGDOS !

... und das ist die ungepatchte Version, die Du da installiert hast. Andernfalls stünde dort V0.98p.

Daher wiederhole ich meine Frage: Du hast wirklich das Programm aus idefix.zip(.pdf) genommen, das als Anhang an meinem von neogain verlinkten Posting hängt?

Burkhard Mankel

  • Gast
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #173 am: Di 18.10.2016, 20:40:11 »
Die aus diesem Thread meinst Du doch? Ja - die habe ich genommen - entweder hat er jetzt nicht korrekt den alten Treiber gelöscht und der alte Treber bootet noch! Anders kann ich mir das jetzt nicht vorstellen! Also - ich lade mir die aktuell noch mal runter und versuche nochmals das Darüber installieren - ansonsten, wenn es wieder schiefgeht, muß ich mir am PC das Drive C nochmal komplett löschen und dann am Atari neu einrichten - oder habt ihr für letzteren Fall noch 'ne andere Idee, die nicht so zeitaufwendig wäre?

Offline czietz

  • Benutzer
  • Beiträge: 2.173
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #174 am: Di 18.10.2016, 21:06:32 »
Ja, den Thread meine ich. Und dort eben den Anhang:

Zitat
* idefix.zip.pdf (17.26 KB - runtergeladen 25 Mal.)

... und nicht die ebenfalls im Thread verlinkten Originaldateien (IDEDUD91.ZIP und IDEP_98B.ZIP).

Burkhard Mankel

  • Gast
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #175 am: Di 18.10.2016, 21:26:42 »
Oje - der Fehler liegt wohl bei mir wieder im Detail - ich habe wohl "nur" die Komplettarchive unter den Links gezogen! Danke für den Hinwes, ich kopiere die also nochmal auf meine Installationsdisk!

Burkhard Mankel

  • Gast
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #176 am: Do 20.10.2016, 22:38:59 »
Jetzt habe ich mit dem gepatchten Treiber Installer den Treiber installiert und die Fehlerausgabe bei MagiC bleibt aus - aber es kommt immer noch kein Desktop! Auf der entsprechenden Partition (K: - wird nach Wahl zu C:) sind die Dateien für MagiC Root vorhanden!
Was läuft hier noch verkehrt?
Bei der RAM Version von MagiC war mal dokumentiert, daß MagiC einen AUTO-Ordner nicht weiter abarbeitet, weshalb der Starter auch als Letztes in den AUTO Ordner soll. Weil ich aber einen anderen Namen für die Einrichtung der Automatisch zu startenden Programme nicht kenne, habe ich hierfür auch einen "AUTO" Ordner angelegt!
« Letzte Änderung: Do 20.10.2016, 23:49:32 von Burkhard Mankel »

Offline gh-baden

  • Benutzer
  • Beiträge: 1.189
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #177 am: Sa 22.10.2016, 13:32:59 »
Bei der RAM Version von MagiC war mal dokumentiert, daß MagiC einen AUTO-Ordner nicht weiter abarbeitet, weshalb der Starter auch als Letztes in den AUTO Ordner soll.

Wenn du mit "RAM-Version" das ganz normal installierte MagiC meinst -- dann ist das praktisch falsch. Wird der MagiC-Starter im Auto-Ordner ausgeführt, nach einem normalen ROM-TOS-Coldreset, dann installiert es den MagiC-Kernel und führt einen Reset aus. Nach dem Reset überspringt sich der MagiC-Auto-Starter dann und der AUTO-Ordner wird normal ausgeführt.

Auf den ersten Blick bzw. Coldreset-Boot sieht es also so aus, als ob nach dem MagiC-Lader nix mehr vom AUTO-Ordner ausgeführt wird. Auf den zweiten, bzw. MagiC-Boot, nicht mehr.
Wider dem Signaturspam!

Offline Lukas Frank

  • Benutzer
  • Beiträge: 9.415
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #178 am: Sa 22.10.2016, 13:45:21 »
Du hast doch MagiC im Rom, brauchst du den MagiC Loader im Autoordner überhaupt ?

Bei meiner normalen Festplatten MagiC Installation ist der Loader das erste Programm im Autoordner ...

Offline neogain

  • Benutzer
  • Beiträge: 1.139
  • ...?
Re: Mega ST 4 mit IDE, 4GB SanDisk CF und F-TOS
« Antwort #179 am: Sa 22.10.2016, 14:23:20 »
@Burkhard Mankel, siehe Anhang...
* ATARI 1040STe, 4MB Ram, TOS 2.06 (der Unantastbare)
* ATARI Mega ST2; 4MB Ram; ET4000; FTOS 4x; IDE SD Adapter 16 GB
* ATARI 1040 STf; 1MB (der erste nach 20 Jahren wieder)... rote LED's ;)
* ATARI Portfolio 512KB Ram; 128MB CF IDE; 6Mhz Overclock
* ATARI 260ST; 4MB Ram; FTOSx4; IDE 9GB