atari-home.de - Foren

Hardware => Hardware (Classic 16-/32-Bit) => Thema gestartet von: jeloneal am Do 10.09.2020, 23:28:02

Titel: Korrosion? Grund zur Sorge?
Beitrag von: jeloneal am Do 10.09.2020, 23:28:02
Hallo zusammen,

Mir ist ein weiterer STE zugeflogen. Das Gerät läuft bislang fehlerfrei. Einzig eine Spule (L203) fiept fürchterlich und wird die Tage getauscht. Beim inspizieren musste ich allerdings auf der Unterseite des Boards einiges an Korrosion feststellen. Siehe die Bilder.

Was kann/sollte man da tun?

Titel: Re: Korrosion? Grund zur Sorge?
Beitrag von: neogain am Do 10.09.2020, 23:51:40
Essigessenz mit Wattestäbchen auftragen, gewisse Zeit einwirken lassen, mit Isopropanol auswaschen, schauen ob Leiterbahnen durch sind, wenn ja neu verzinnen, Low cost Variante mit Nagellack versiegeln, teuerer mit lötstoplack. Auf den Fotos sieht das aber noch nicht so extrem aus, hab da schon schlimmere Sachen gefixt.
Titel: Re: Korrosion? Grund zur Sorge?
Beitrag von: jeloneal am Sa 12.09.2020, 07:12:44
Danke! Das werd ich mal versuchen. Löst die Essigessenz die Versiegelung auf?
Titel: Re: Korrosion? Grund zur Sorge?
Beitrag von: Arthur am Sa 12.09.2020, 15:00:21
Ich würde es nur mit Isopropanol reinigen, es dann Ausdünsten lassen und anschließend mit Lack versiegeln.
Titel: Re: Korrosion? Grund zur Sorge?
Beitrag von: Lukas Frank am Sa 12.09.2020, 18:03:28
Sieht nach Batteriesäure aus oder was ist da passiert? Wenn so eine Durchkontaktierung mal durch ist wird die Fehlersuche schwer wenn alles sauber ist und man nichts mehr sehen kann.
Titel: Re: Korrosion? Grund zur Sorge?
Beitrag von: jeloneal am Sa 12.09.2020, 18:21:20
Ich würde mal sagen, der STE wurde etwas zu feucht gelagert.

Die Oberseite sieht aus wie neu aber unten sieht man ja was los ist. Das isolierende Kartonteil war auch leicht gewellt und hat wohl Feuchtigkeit gezogen.

In Betrieb ist der Rechner absolut unauffällig, aber ich fürchte das wird nicht ewig so bleiben.
Titel: Re: Korrosion? Grund zur Sorge?
Beitrag von: Arthur am Sa 12.09.2020, 19:12:02
Unter Lack und damit unter Luftausschluss stoppt der Korrosionsprozess... vor dem Lackieren mit dem Föhn richtig trocknen.
Titel: Re: Korrosion? Grund zur Sorge?
Beitrag von: alers am Sa 12.09.2020, 20:36:59
Unter Lack und damit unter Luftausschluss stoppt der Korrosionsprozess... vor dem Lackieren mit dem Föhn richtig trocknen.

Ist leider ein Irrglauben.
Die Korrosion geht auch "unter" Lack weiter, weil der nicht zu 100% Luftdicht ist. Selbst mit Lötstoplack nicht, außer Du schaffst das in einem Reinraum, was aber wohl nicht gegeben ist. Und selbst da ist es fraglich. Warum? Weil Sauerstoff sich ja eh schon gebunden hat, und wenn Du den Lack draufpinselst, befindet sich ja trotzdem Sauerstoff dazwischen...

Ich würde mit einem Glasradierer die defekten Stellen abreiben, hoffen, daß noch genügend Leiterbahn überbleibt, neu verzinnen und dann lackieren. Da das Zinn eh dabei als Opfermetall dient, wird auch das (Was ja auch passiert ist) zuerst oxydieren, also ist auch davon auszugehen, daß die Leiterbahn ansich noch (fast) vollständig vorhanden sein sollte...

Und ja, vor dem lackieren mit Lötstoplack sollte mit Isopropanol (gen 100%) die Stellen gereinigt werden, was ich einfach mal eh als vorausgesetzt hinstelle.
Titel: Re: Korrosion? Grund zur Sorge?
Beitrag von: Atariosimus am Sa 12.09.2020, 20:59:01
...wobei man sagen muss dass bei einem Auto mit Unterbodenschutz die Haltbarkeit doch
sehr beeindruckend ist. Im Vergleich dazu ist das bisschen "Korossion" auf der Platine ein Witz.

Ich möchte sogar mal behaupten, dass der Rechner immer noch funktioniert während viele
schon biologisch das Zeitliche gesegnet haben.

Habe zuhause noch eine Platine ca. 30 Jahre alt. Vor 4 Jahren mal mit Lack versiegelt. Die
Leiterbahnen aus Kupfer haben trotzdem, bei etwa 5 Schichten mit Lack, angefangen Grünspan
anzusetzen. Die Funktion ist jedoch gleich. Denkbar wäre das der Grünspan zweier Leiterbahnen
irgendwann zusammen wächst, dann wäre das natürlich das Ende. Sieht aber er danach aus
dass ich das nicht mehr erlebe.


Titel: Re: Korrosion? Grund zur Sorge?
Beitrag von: alers am So 13.09.2020, 21:56:37
Denkbar wäre das der Grünspan zweier Leiterbahnen irgendwann zusammen wächst,
Und? Weder Grünspan, Patina, Rost noch andere "Korrosion" in "unserem" Bereich leitet Strom, ist ein physikalischer Fakt.