atari-home.de - Foren

Hardware => Hardware (Classic 16-/32-Bit) => Thema gestartet von: Lukas Frank am Do 26.07.2018, 21:44:56

Titel: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Do 26.07.2018, 21:44:56
Habe zum Ausschlachten ein Board geschenkt bekommen und fand es zu Schade dafür. Es waren einige Leiterbahnen aufgetrennt. FDC Sockel musste neu. Hatte noch einen TOS 1.04 PROM Satz. Board läuft jetzt über ein Testmodul über die RS232 Einwandfrei ohne Fehler. Über einen Monitor am Board angeschlosssen bekomme ich allerdings kein Bild. Bin auf Fehler Suche ...

Ich habe noch ein großes AT Towergehäuse, eine weitere PuPla + Panther auf einer Platine aus Polen, eine PAK68/3 und eine weitere FRAK/2. Jetzt sitzt auf dem Board schon ein AT PC Netzteilanschluss. Resettaster muss noch raus. Speichererweiterung mit PS/2 Modul auf 4MB muss ich noch machen. Tastaturanschluss einbauen wie beim Mega ST.
Titel: Re: Instandsetzung 520STM Board ...
Beitrag von: Lukas Frank am Fr 27.07.2018, 16:58:33
Fehler gefunden und behoben. H-Sync war durchtrennt. Als nächstes muss die CPU raus, die vier Latches für die Rambänke gegen F Typen tauschen und Pullups auf den Daten und Adressleitungen halbieren.
Titel: Re: Instandsetzung 520STM Board ...
Beitrag von: Lukas Frank am So 29.07.2018, 18:35:56
4MB Simm mit PS/2 Simm Sockel ist eingebaut. CPU Sockel ist drin. Die Floppybuchse ist auch drin. Habe 34 Löcher in die Massefläche am Rand gebohrt.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: RetroKid am So 29.07.2018, 19:00:18
Was kann der dann, wenn's fertig ist? Bin nicht so der Mod-Pro ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: 1ST1 am So 29.07.2018, 19:37:17
Was kann der dann, wenn's fertig ist? Bin nicht so der Mod-Pro ...
Geschirr spülen, Staub saugen, Spaghetti kochen, Mülleimer rausbringen, Rasen mähen, Betten machen, Fahrrad reparieren, ... *scnr*
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am So 29.07.2018, 19:56:00
Was kann der dann, wenn's fertig ist? Bin nicht so der Mod-Pro ...

Das Mainboard wird angepasst für einen PC Towerumbau/einbau mit PAK, FRAK (TT Ram) und Panther mit ET4000 oder ATI MACH32 Grafikkarte und ISA Netzwerkkarte.

Hätte auch noch ein Mega ST1 Board gehabt aber der 520iger reizt da schon mehr ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am So 29.07.2018, 21:04:12
Ich habe noch eine PuPan aus Polen, das ist eine Kombination aus Panther/2 und PuPla/2. Das Teil läuft noch nicht da ich nur den Mainboardteil bekommen habe und der ISA Slot Teil ein original Panther/2 Teil ist. aber das wird schon ...
Titel: Re: Instandsetzung 1040STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mo 28.01.2019, 14:23:23
Habe mich jetzt anders entschieden und ein 1040ST Mainboard für die PAK68/3 umgebaut. Habe mit etwas Glück noch eine PuPla/2 bekommen und eine Panther/2. Die Polnische PuPla/Panther läuft nicht richtig, aber macht ja nichts da ich originalen Ersatz habe.

(https://fglukas.lima-city.de/forum/1040vorne.jpg)

(https://fglukas.lima-city.de/forum/1040rueck.jpg)

Bis jetzt ist eine Shugart Bus Wannensteckerleiste verbaut und ein HD Modul mit AJAX. CPU Sockel eingelötet und die 10k Datenbus und Adressbus Pullups durch weitere 10k halbiert. Ein 4MB -70ns PS/2 Simm verbaut. Die beiden LS244/373 muss ich noch gegen F Typen tauschen.

Der Rechner soll mal eine PuPla/2, PAK68/3-020, FRAK/2 mit 64MB, Panther/2 mit MACH32 und NE2000 Netzwerkkarte haben, mal schauen ...
Titel: Re: Instandsetzung 1040STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 02.02.2019, 19:27:04
Habe mal den Panther/2 Adapter aufgebaut und die PuPan Platine aus Polen probiert. Funktionieren beide, mal schauen welche ich verwende. Ich habe leider nur eine ISA Slot Platine. Vielleicht baue ich mir für die PuPan eine Version aus Lochraster, mal schauen. FRAK/2 ist auch schon da, jetzt warte ich noch auf die PAK68/3 ...

(https://fglukas.lima-city.de/forum/pupan.jpg)

(https://fglukas.lima-city.de/forum/puplapanther.jpg)
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: ari.tao am Sa 02.02.2019, 20:33:41
Parbleau, ich staune immer wieder über Deine HW-Fähigkeiten. (Mich verläßt schon beim Anblick so vieler Drähte der Mut).
Titel: Re: Instandsetzung 1040STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 02.02.2019, 20:40:58
Es ist eins deiner Boards die kaputt waren. Das zweite habe ich für den geplanten Tower Umbau zersägt um eine Romport und Midi Anschlussleiste zu erhalten für den Tower.

Wenn ich Lust habe gehe ich mal an den Tower Einbau. Dazu muss die Tower Rückwand neu, das macht jede Menge Arbeit ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: ari.tao am Sa 02.02.2019, 21:03:37
Es ist eins deiner Boards die kaputt waren.
Das freut mich besonders! Viel Glück & gutes Gelingen!
Titel: Re: Instandsetzung 1040STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mi 27.03.2019, 18:14:58
p2int.prg im Autoordner meldet beim booten unter TOS 1.04 das kein Interrupt möglich ist. Das tritt bei beiden Panther/2 Platinen mit PuPla/2 auf. Sollte doch auch ohne PAK also mit 68000 CPU gehen, oder nicht?
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am Mi 27.03.2019, 19:32:12
Ist zumindest bei mir eine reine Konzentrationssache. Arbeit macht es aber wenn mal ein Draht vertauscht ist. >:D

Edit: Hast du noch eine PS//2-Sockel Bezugsquelle?
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mi 27.03.2019, 19:51:57
Die Panther/2 und die PuPan aus Polen sind beide in Ordnung. Genauer Testen kann ich nicht da meine zweite PAK noch bei pakman ist und von dem Desktop Rechner mit PAK stecke ich nichts hin und her.

Dein Beitrag bezieht sich auch die PS/2 4MB Erweiterung.
Ist zumindest bei mir eine reine Konzentrationssache. Arbeit macht es aber wenn mal ein Draht vertauscht ist. >:D

Edit: Hast du noch eine PS//2-Sockel Bezugsquelle?
PS/2 Sockel habe ich noch von Exxos einen ganzen Karton ...
Titel: Re: Instandsetzung 1040ST Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Fr 10.05.2019, 19:15:38
Habe mal angefangen den PC Tower den ich von einem Forum Mitglied bekommen habe für eine PAK68/3-020/FRAK/2/Panther/2/PuPla/c´t IDE Interface und ein paar andere Sachen wie ein HD Modul mit AJAX und RS-Speed umzubauen und anzupassen.
 
Als erstes eine Papierschablone für das 1040ST Mainboard angefertigt. Das alte originale Rückwandblech rausgescshnitten mit Flex und Stichsäge. Da unten die Slotplatine der Panther sitzt musste das Board recht hoch. Das Netzteil musste versetzt werden. Die Ausbrüche für die Sub-D Buchsen und die runden habe ich mit Hilfe von selbst geschliffenen Dornen zu kleinen Meißeln. Dann sauber gefeilt und fertig. Das ging recht zügig. Aals Dummy habe ich noch einen defekten ICD Hostadapter eingebaut. Die Sub-D 19pol Buchsenabstände sind genormt. Ich habe aber vor den Suska ACSI/SCSI Hostadapter einzubauen mit einer externen SCSI Buchse. Ist aber zweitrangig da ich eine SATA 8GB kleine SSD mit IDE auf SATA Adapter und ein IDE CD-R einbaue. Bis jetzt bin ich soweit das die Rückwand Lackiert ist. Als nächstes wird beschriftet und dann kommt Klarlack drauf.

Nächste Arbeiten sind die Panther befestigen mit zwei Abstandsbolzen und auf der anderen Seite über kleine Winkel. Dann wird die Romport/Midi Platine befestigt und die Ausbrüche passend in der Front hergestellt. Als Verbindung zur Romportbuchse kommt eine kleine Buffer/Treiber Platine zum Einsatz. In die Front kommt auch die Mega ST Tastatur RJ12 Buchse.
Titel: Re: Instandsetzung 1040ST Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 11.05.2019, 20:48:42
Ich hatte ja schon das neue Rückwandblech Lackiert aber den SCSI Ausgang vergessen. Also schnell den SCSI Ausbruch hergestellt, das ganze geschliffen und dann neu Lackiert. Leider musste ich feststellen das der Lack plötzlich kräusel zieht. Ich hatte Aceton benutzt zum säubern vor dem Lackieren. Dachte erst es liegt am Aceton. Also alles abgeschliffen und neu Lackiert ohne Aceton zu benutzen und schon wieder kräusel. Schnell alles abgeputzt und nochmal geschliffen und dieses Mal mit dem Heißluftgebläse das Blech und die Lackdose erwärmt und siehe da jetzt ist alles gut. Es war einfach zu Kalt und der Aceton hatte keine Schuld.

Die externe SCSI Buchse habe ich bei partsdata für knapp 12,- Euro bestellt. Das ist die Firma Zellmer die früher Atari Zubehör verkauft hat und sich jetzt auf allerlei Kabel und Adapter spezialisiert hat.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: ari.tao am So 12.05.2019, 00:02:26
Ja, SCSI-Zubehör gibt´s auch nicht mehr ´ümme Eck´.
Titel: Re: Instandsetzung 1040ST Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mi 15.05.2019, 17:34:49
Mal ein Bild von dem 1040ST Mainboard. RSVE Serielle Erweiterung eingebaut, HD Modul, IDE Interface ebenso.

In Planung ist auf das IDE Interface eine PuPla/2, dann PAK68/3-020 und FRAK/2 mit 32MB und obenauf eine Panther/2 mit ET4000 und NE2000 Netzwerkkarte zu setzen.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: gh-baden am Mi 15.05.2019, 19:00:18
Jetzt noch Nietschke/troed-16MHz-Boardtakt und ab geht es :-)

Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mi 15.05.2019, 19:49:32
Ich hatte damals mal einen Mega ST mit 10/12Mhz Bustakt und PAK. Weiss nicht ob die 16Mhz mit der PAK laufen ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Di 28.05.2019, 17:59:17
Wegen dem Lack aber ich irgendwie Scheiße an den Fingern ...

Der graue Lack war nach dem dritten Versuch gut und ich habe die Platte mit Abreibe Buchstaben beschriftet. Dann Klarlack drauf und alles hat sich wieder gekräuselt. Ich habe jetzt erstmal die Nase voll und warte bis in den Hochsommer wegen der Temperaturen ...

Am IDE Bus hängt jetzt eine kleine Sata 8GB SSD über einen DeLock IDE auf Sata Adapter und ein CD/DVD Brenner. Warte jetzt noch auf den Inventronic SCSI Hostadapter und die PAK/FRAK fehlt noch.

PuPla/2 und Panther/2 ist drin und ich kann das schonmal einrichten mit einer ET4000 ...


Die beiden Midi Kabel müssen auch noch gelötet werden.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: 1ST1 am Di 28.05.2019, 18:12:07
Da hsat du zwei Farben benutzt, die sich chemisch nicht miteinander vertragen.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Di 28.05.2019, 18:43:25
Ein Bild von innen ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am Di 28.05.2019, 19:02:07
Gut gemacht... aber MiDi und Romport ist etwas unglücklich verbaut. Das wär auf der Rückseite des Towers, meiner Ansicht nach, besser aufgehoben gewesen.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Di 28.05.2019, 19:48:16
Vorne finde ich das so eben gut. Hinten wäre auch kein Platz da dort die beiden ISA Slots mit Grafik und Netzwerkkarte sitzen. Mit den beiden ISA Slots unten geht das Mainboard knapp bis ganz nach oben hoch.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Di 28.05.2019, 20:54:59
Da hsat du zwei Farben benutzt, die sich chemisch nicht miteinander vertragen.

Hatte den gleichen Lack auch beim Desktop Gehäuse verwendet. Ich vermute da mir das auch beim grauen Grundlack passiert ist das es zu kalt war.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Di 28.05.2019, 21:19:37
So mal ein bisschen eingerichtet und Netzwerkkarte läuft fein unter MiNT ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Do 13.06.2019, 20:37:31
Habe noch einen ACSI/SCSI Hostadapter eingebaut. Da ich keinen LINK96/97 oder ICD finden konnte habe ich mir den von Inventronik gekauft. Nach anfänglichen Problemen läuft es jetzt sehr gut ...

Inventonik Hostadapter (terminiert)-> 1,2m 50pol Falchbandkabel mit 4 Abgriffen -> IBM 18GB UW SCSI Festplatte für Adapter 68/50 unterminiert -> 25pol Sub-D SCSI Slotblech mit Abschlußwiderstand
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Do 13.06.2019, 20:38:38
Fehlt jetzt noch ein kleiner 1Watt NF Verstärker für den Lautsprecher ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mo 17.06.2019, 18:30:44
So eine ET40007W32i erreicht im Mega STE mit Nova Adapter nur knapp genau die gleicche Geschwindigkeit wie eine normale ET4000AX. Mit dem Panther/2 Adapter und einer PAK68/2 ist da sehr wohl ein Unterschied vorhanden.

ET4000AX = 244%
ET4000/W32i = 365%
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am Mo 17.06.2019, 20:18:21
So eine ET40007W32i erreicht im Mega STE mit Nova Adapter nur knapp genau die gleicche Geschwindigkeit wie eine normale ET4000AX. Mit dem Panther/2 Adapter und einer PAK68/2 ist da sehr wohl ein Unterschied vorhanden.

ET4000AX = 244%
ET4000/W32i = 365%

Also wenn ET4000AX und ET4000/W32i in der Panther laufen kommt es zu diesen Unterschieden? Was meinst du woran das liegt... bessere bzw. effektivere "GPU"?
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mo 17.06.2019, 20:25:15
Also wenn ET4000AX und ET4000/W32i in der Panther laufen kommt es zu diesen Unterschieden

Ja genau

Im Mega STE sind die beiden fast gleich. Vielleicht gibt es auch größere Unterschiede im Atari TT?

Was meinst du woran das liegt... bessere bzw. effektivere "GPU"?

Der W32i hat einen Blitter in Hardware, habe aber keine Ahnung da musst du Idek fragen.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am Mo 17.06.2019, 20:49:03
Wegen dem Lack aber ich irgendwie Scheiße an den Fingern ...

Sag einfach das ist Hammerschlagfarbe. (http://www.koer-onlineshop.de/WebRoot/Store21/Shops/81497987/5838/20C4/9484/7565/09CA/C0A8/2BB8/80B4/s-l1600_1_ml.jpg) :D
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mi 19.06.2019, 18:48:44
Habe mir mal über Ebay einen 5,25er Schacht mit zwei USB Buchsen geholt für eine Lightning ST USB. Ich musste den Schacht rechts ausschneiden weil das 1040ST Mainboard etwas in den 5,25 Schacht hinein reicht in die unteren drei Einschübe. Der 3,5 Zoll Schacht passt leider überhaupt nicht da er genau nahe am CPU Sockel des Mainboards sitzt.

Der Inventronik ACSI/SCSI Hostadapter ist sehr gut. Ich habe aktuell eine 4,5GB LVD 68pol SCSI Platte verbaut mit Adapter 68/50. Ebenfalls getestet habe ich diverse SCA80 pol SCSI Platten mit 9GB und 72GB. Das einzige was mir am Inventronik Hostadapter fehlt ist ein DMA Ausgang und eine ICD kompatible Ausführung mit zwei 19pol. Sub-D Buchsen.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am Mi 19.06.2019, 20:27:07
Echt Lightning ST?
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: tuxie am Mi 19.06.2019, 21:00:01
Echt Lightning ST?

Jup Lightning ST, denke da gibt es die nächsten Tage/Wochen noch details...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Fr 21.06.2019, 17:48:16
Habe jetzt noch einen NF Verstärker für den Lautsprecher eingebaut. Gab es auf Ebay für kleines Geld. Es ist ein kleiner 2x3Watt Digital Verstärker. Jetzt ist der Tastaturklick wieder zu Hören ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: ari.tao am Sa 22.06.2019, 04:46:48
Wo hast Du denn den Eingang des Verstärkerchens angeschlossen?
Für den Tastaturklick braucht man doch aber kein Stereo.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 22.06.2019, 08:10:38
Angeschlossen hinter Q1 am Audioausgang vom Soundchip. Nutze nur den linken Kanal. Ist ja auch nur im PC Gehäuse immer dieser eine kleine Lautsprecher verbaut. Möchte das auch nicht ändern.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: ari.tao am So 23.06.2019, 04:09:34
Danke, Frank.
Ich möchte meinem MSTE eine TonQuetsche nachrüsten (für den Tastaturklick  ;) ). Vielleicht ist dieses Teil dafür geeignet (-> Anhang).
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am So 23.06.2019, 08:46:58
Scheint ja die gleiche zu sein wie meine nur mit Lautstärkeregler.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am So 23.06.2019, 10:44:19
Das Teil gefällt mir ganz gut... auch das Poti ist bestimmt praktisch da man nicht extra ein Programm zur Lautstärkeregelung starten muss. Bedenken hab ich das der Regler beim Transport von A nach B mal irgendwo hängen bleibt.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Di 16.07.2019, 19:23:09
Mega ST kompatibles Uhrenmodul verbaut. Glücklicherweise von einem Forum User günstig bekommen.
Titel: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Guus.Assmann am Mi 17.07.2019, 09:22:29
Hallo Frank,

Lasst sich diese Uhr vielleich auch nachbauen?
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mi 17.07.2019, 09:46:57
->   https://forum.atari-home.de/index.php/topic,15263.msg241952.html#msg241952
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 31.08.2019, 14:50:56
Heute habe ich mal die neue Lightning ST in den 1040 Tower eingebaut. Alles läuft einwandfrei zusammen mit einer PuPla/2 und einem Panther/2 ISA Adapter mit TSENG ET4000/W32i und einer NE2000 Netzwerkkarte. Zusammen mit einer PAK68/2-020 besteht ebenfalls kein Problem.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am So 19.07.2020, 14:56:45
Habe jetzt übergangsweise eine Storm ST im Rechner zusammen mit einer PAK68/2 bis meine PAK68/3-020 mit FRAK/2 fertig ist. Mit W32i und Netzwerkkarte auf der Panther/2 und NVDI plus ExtenDOS bleiben mir knapp 3,6MB ST und 1MB TT Ram an freiem Speicher.

USB lief erst nicht mit der PAK68/2 weil der MiNT Kernel einen 030 CPU cookie gesetzt hatte. Dank der MiNT Entwickler ist der Fehler nun beseitigt und alles läuft Wunderbar ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Do 10.12.2020, 15:29:41
Habe mir eine TF536 gekauft weil meine PAK68/3-020 mit FRAK noch nicht fertig ist. Verkaufe die aber wieder weil der IDE Port mit der Lightning ST nicht mehr läuft was im Grunde kein Problem wäre da es eine Atari Firmware gibt mit TF IDE Port disable. So würden sich die beiden IDE Ports nicht mehr in die Quere kommen. Großes Problem ist aber das die TF nicht mit der PuPla/2 + Panther/2 Kombi läuft. Das geht natürlich gar nicht.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 12.12.2020, 14:12:22
Habe noch ein wenig probiert und mit der originalen PuPla/Panther Kombi bootet der Rechner nicht. Der System Bildschirm wird zwar weiss aber der Rechner ist tot. Mit einer Nachbau PuPla/Panther Kombi läuft es aber nicht ohne Probleme. Beim ersten Einschalten ist der Rechner tot, nach einem Reset bootet er dann. EmuTOS 1.0.1 stürzt aber mit einer Error/Panik ab beim laden vom Nova Emulator Programm. Erst nachdem ich z.B. von einem leeren Laufwerk D:\ gebootet habe und irgendein Programm von C:\ manuell gestartet habe kann ich Reseten und ordnungsgemäß von C:\ booten mit allen Autoordner Programmen.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: neogain am Sa 12.12.2020, 19:48:08
sehe ich da richtig, dass die TF536 64MB TT Ram bietet? Dachte immer bisher die TF Karten würden mit STs funktionieren oO
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 12.12.2020, 20:00:11
Ist ein 1040ST Mainboard mit Lightning ST PuPla/Panther Kombi und TF536. Die TF536 bietet einen 50Mhz 68030, einen IDE Port und 64MB Fastram
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: neogain am Sa 12.12.2020, 21:15:15
ah ok, ich meinte natürlich nicht funktionieren. Sehr schick, hab mal die google suche bemüht und im Exxos Forum scheint sich einiges über die Karte zu tun. Sehr interessant, alleine die tatsache das sich jetzt doch SD Rams einsetzen lassen für Altram.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 12.12.2020, 21:58:55
Liest sich gut macht aber bei mir nur Probleme. Eine PAK mit FRAK wäre mir lieber da weiss ich das alles einwandfrei läuft. Nächste Aktion bei der TF ist eine Firmware mit IDE disable. Ich habe aber keine Pi zum flashen, muss das Teil dazu nach England zurück schicken.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: neogain am Sa 12.12.2020, 23:30:42
Liest sich gut macht aber bei mir nur Probleme. Eine PAK mit FRAK wäre mir lieber da weiss ich das alles einwandfrei läuft. Nächste Aktion bei der TF ist eine Firmware mit IDE disable. Ich habe aber keine Pi zum flashen, muss das Teil dazu nach England zurück schicken.

Ein JTAG Programmer müßte es doch auch tun. Der TL866II China Progger könnte das, oder halt das Altera Flash tool. Damit kann man gut CPLDs beschreiben. Aber preislich gesehen, ist ein PI billiger. Aber ich liebäugle jetzt mit der TF.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am So 13.12.2020, 14:46:20
Entweder im Exxos Shop eine leere Platine kaufen oder im Forum PhilC fragen nach einer fertigen für 140 Pfund plus Porto ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: neogain am So 13.12.2020, 22:54:23
Entweder im Exxos Shop eine leere Platine kaufen oder im Forum PhilC fragen nach einer fertigen für 140 Pfund plus Porto ...

ne leerplatine reicht vollkommen ;)
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mi 23.12.2020, 14:31:37
Meine TF536 ist von flashen mit der letzten Firmware ohne IDE Port zurück und es läuft mit der Lightning ST gar nicht. Man kann Programme vom IDE Gerät starten aber keine Daten kopieren.


Edit: Habe nochmal ein Setup mit einem Mega ST, Lightning und TF536 aufgebaut sowie EmuTOS 1.0.1

Das oben beschriebene Problem liegt nicht an der Kombi mit der Lightning ST sondern wahrscheinlich an der PuPla/Panther Kombi.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Do 18.02.2021, 14:20:32
So die TF536 habe ich pakman gegeben war nicht glücklich mit dem Teil. Wunderbarerweise hat pakman mir eine PAK68/3-020 die ich mal eingetauscht hatte gegen eine PAK68/3-030 fertig umgebaut damit diese mit einer FRAK/2 zusammen arbeitet die ich noch hatte. Das ganze war heute in der Post und ich habe alles mal zur Probe aufgebaut und läuft sehr gut zusammen mit Lightning ST, PuPla/2 und Panther/2 auf der eine NE2000 Netzwerkkarte und eine 2MB ATI MACH32 Grafikkarte sitzt. Ich brauche jetzt noch ein PAK TOS mit IDE Patch dann ist alles komplett. Die PAK68/3-020 läuft mit 32Mhz und erreicht eine sehr gute Geschwindigkeit ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 20.02.2021, 14:32:25
Betreibe jetzt die PAK68/3-020 mit 40Mhz anstatt mit 32Mhz und die FPU ist jetzt eine 882 anstatt der 881

Die GemBench 6 Werte sind etwas seltsam das Referenzsystem ist die 32Mhz Variante. Wahrscheinlich laufen die 32Mhz synchroner zum Bustakt als die 40Mhz, keine Ahnung?
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: czietz am Sa 20.02.2021, 15:59:54
Wenn Du die Zugriffsgeschwindigkeit auf das RAM messen willst, würde ich statt GEMBench eher MEMSPEED (http://atariftp.czietz.de/pub/atari/Utils/Misc/memspeed.lzh) und/oder Nembench (https://milan.kovac.cc/atari/software/download.php?file=./rsync/SYSTEM/NEMBENCH.FTP/NEMBENCH.LZH) empfehlen.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: tuxie am Sa 20.02.2021, 16:11:47
Da stimmt das Timing nicht, da kommt die PAK mit dem Shifter ins Gehege, ich wette du hast mit memspeed nur 1.8MB/s ST Ram speed, weil das kommt mir bekannt vor!
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am Sa 20.02.2021, 16:35:21
Betreibe jetzt die PAK68/3-020 mit 40Mhz anstatt mit 32Mhz und die FPU ist jetzt eine 882 anstatt der 881

Die GemBench 6 Werte sind etwas seltsam das Referenzsystem ist die 32Mhz Variante. Wahrscheinlich laufen die 32Mhz synchroner zum Bustakt als die 40Mhz, keine Ahnung?

(https://forum.atari-home.de/index.php?action=dlattach;topic=14556.0;attach=28454;image)

Bei solchen Vergleichen würde ich mir eine Referenz mit und ohne NVDI erstellen und entsprechend auswählen. So, finde ich ergibt das wenig Sinn und verfälscht den Vergleich unnötig.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 20.02.2021, 17:22:29
Da ist kein NVDI. NVDI läuft wegen dem Nova Treiber nur als GDOS ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am Sa 20.02.2021, 17:36:21
Da ist kein NVDI. NVDI läuft wegen dem Nova Treiber nur als GDOS ...

Das ist aus dem Screenshot nicht ersichtlich und ich vermute das es, wenn auch nur, eine minimale Abweichung geben wird oder könnte.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 20.02.2021, 17:36:59
@czietz , @tuxie ...

32Mhz (Memspeed)

        L1       L2      Main
Read   29.7     30.1     3.7
Write   3.6      3.5     3.6

        L1       L2      Main
Read   19.5     19.3     19.3
Write  23.5     23.5     23.8



40Mhz

        L1       L2      Main
Read   37.8     37.3     3.7
Write   3.7      3.7     3.7

        L1       L2      Main
Read   24.5     24.7     24.7
Write  29.7     29.7     29.4


----------------------------
32Mhz
NemBench v2.1 - precision CPU/FPU profiler.

Integer multiply (16bit)     -> 1.229 Mips (~200%)
Integer divide (16bit)       -> 0.726 Mips (~200%)
Linear (stalled) integer     -> 16.000 Mips (~200%)
Interleaved (piped) integer  -> 16.031 Mips (~201%)

Float multiply (64bit)       -> 0.537 MegaFlops (~202%)
Float divide (64bit)         -> 0.348 MegaFlops (~201%)
Linear (stalled) float       -> 1.058 MegaFlops (~198%)
Interleaved (piped) float    -> 1.139 MegaFlops (~214%)

16bit read (100% hit)        -> 6.879 MByte/sec (~87%)
16bit write (100% hit)       -> 10.593 MByte/sec (~176%)
32bit read (100% hit)        -> 13.745 MByte/sec (~87%)
32bit write (100% hit)       -> 21.186 MByte/sec (~317%)

Linear 32bit read (ST-Ram)   -> 2.635 MByte/sec (~49%)
Linear 32bit write (ST-Ram)  -> 2.553 MByte/sec (~39%)
Linear 32bit copy (ST-Ram)   -> 1.550 MByte/sec (~48%)

Linear 32bit read (FastRAM)  -> 13.667 MByte/sec (~257%)
Linear 32bit write (FastRAM) -> 20.400 MByte/sec (~316%)
Linear 32bit copy (FastRAM)  -> 10.208 MByte/sec (~316%)


40Mhz
NemBench v2.1 - precision CPU/FPU profiler.

Integer multiply (16bit)     -> 1.535 Mips (~250%)
Integer divide (16bit)       -> 0.907 Mips (~250%)
Linear (stalled) integer     -> 19.980 Mips (~250%)
Interleaved (piped) integer  -> 19.980 Mips (~250%)

Float multiply (64bit)       -> 0.671 MegaFlops (~253%)
Float divide (64bit)         -> 0.435 MegaFlops (~251%)
Linear (stalled) float       -> 1.347 MegaFlops (~252%)
Interleaved (piped) float    -> 1.332 MegaFlops (~250%)

16bit read (100% hit)        -> 8.654 MByte/sec (~110%)
16bit write (100% hit)       -> 13.297 MByte/sec (~221%)
32bit read (100% hit)        -> 17.301 MByte/sec (~110%)
32bit write (100% hit)       -> 26.595 MByte/sec (~398%)

Linear 32bit read (ST-Ram)   -> 3.529 MByte/sec (~66%)
Linear 32bit write (ST-Ram)  -> 3.378 MByte/sec (~52%)
Linear 32bit copy (ST-Ram)   -> 1.624 MByte/sec (~50%)

Linear 32bit read (FastRAM)  -> 17.201 MByte/sec (~323%)
Linear 32bit write (FastRAM) -> 25.650 MByte/sec (~397%)
Linear 32bit copy (FastRAM)  -> 12.825 MByte/sec (~397%)
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Sa 20.02.2021, 17:39:55
Da ist kein NVDI. NVDI läuft wegen dem Nova Treiber nur als GDOS ...

Das ist aus dem Screenshot nicht ersichtlich und ich vermute das es, wenn auch nur, eine minimale Abweichung geben wird oder könnte.

Das macht keinen Unterschied. Die Auflösung macht einen kleinen Unterschied. Und der USB Stack frisst etwas CPU Leistung wenn er aktiv ist.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: czietz am Sa 20.02.2021, 20:49:42
MEMSPEED-Interpretation. Wenn man die Spalten für L1- und L2-Cache mal weglässt (die 68020-CPU hat gar keinen Datencache) und sich nur auf die Spalte "Main" konzentriert, dann zeigen die Ergebnisse (anders als GEMBench) nicht, dass der ST-RAM-Zugriff langsam(er) wäre.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: pakman am So 21.02.2021, 13:06:43
Wenn man die Spalten für L1- und L2-Cache mal weglässt (die 68020-CPU hat gar keinen Datencache)

Die PAK/3 hat 32kB L2-Cache (nur für ST-RAM, Daten und Befehle gemischt).
Der wird beim ST-RAM unter L1 und L2 angezeigt..
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am So 21.02.2021, 15:35:01
Deshalb auch die hohen Ramwerte ...

Habe noch Probleme mit MiNT in Zusammenhang mit dem Nova Treiber und der 020 Karte und deshalb mal die MACH32 gegen eine ET4000/W32i getauscht aber ohne Erfolg ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mo 22.02.2021, 13:41:27
Habe noch Probleme mit MiNT in Zusammenhang mit dem Nova Treiber und der 020 Karte und deshalb mal die MACH32 gegen eine ET4000/W32i getauscht aber ohne Erfolg ...

Das Problem war Teradesk. Das läuft nicht richtig wenn eine 020 CPU Fastram hat. Thing hat die gleichen Probleme.

https://github.com/freemint/freemint/issues/214

Mit Jinnee 2.5 läuft alles wunderbar und Fehlerfrei mit MiNT und XaAES.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am Mo 22.02.2021, 14:58:44
Ist schon klasse zu sehen wie vorausschauend man damals schon programmiert hat.
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Do 25.02.2021, 14:01:54
Das Problem war Teradesk. Das läuft nicht richtig wenn eine 020 CPU Fastram hat. Thing hat die gleichen Probleme.

Scheint wohl das alles was mit dem Nova Treiber zu tun hat egal ob ET4 oder ATI und egal ob 000 oder 020/030 Version. Mit einer 030 PAK gibt es die Probleme nicht. Single TOS hat auch kein Problem.

Ist die Kombi MiNT + 020 + Fastram + Nova

... weil eine PAK68/2 mit 020 ohne Fastram auch keine Probleme macht.


Ob man jetzt alleine dem Nova Treiber den schwarzen Peter zuschieben kann weiss ich nicht !?!
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mo 01.03.2021, 14:36:50
Ich muss noch die Front machen. Komplett schwarz Lackieren geht nicht weil da eine Rauchglas (Plexi) Scheibe dran ist die eingeklebt ist. Deshalb habe ich mir überlegt nur die Laufwerksschächte und die Floppy schwarz zu machen.

Die PAK68/3-020 mit dem ganzen Zusätzen läuft sehr stabil. Cubase Score 2.07 läuft auch über die MACH32 Grafikkarte bei 1280x1024. Der Monitor ist kaputt und deshalb immer Gelb weil Blau fehlt, macht aber nichts weil es mich nicht Stört ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mo 01.03.2021, 18:34:28
Aktueller Snapshot unter MiNT mit Netzwerk und USB and allem Drum und Dran ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: gh-baden am Di 02.03.2021, 00:50:51
Der Monitor ist kaputt und deshalb immer Gelb weil Blau fehlt,

Ist bei anderen Plattformen ein zusätzliches Software-Feature namens "Night Shift", besser für die Augen! ;)
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Gaga am Di 02.03.2021, 07:01:49
Aktueller Snapshot unter MiNT mit Netzwerk und USB and allem Drum und Dran ...

Beeindruckend.

Welches Snapshot Programm benutzt du?
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Di 02.03.2021, 08:03:15
Xaaesnap in der letzten Version. Ist die 0.12b meine ich. Finde die aber nicht im Netz, hänge die später mal an ...

@Gaga ... schreibe Lonny mal. Ich weiss nicht ob ich so weitergeben darf. Vielleicht gibt es auch was neueres mittlerweile?

XaAESnap v0.12b (beta-ware)

Screen snap module for XaAES.

Supported modes:

Bits   Colors   Output Format      Back Ground Task
----   ------   ------------------   ----------------
1   2   8-bit Color Map      No
2   4   8-bit Color Map      No
4   16   8-bit Color Map      No
8   256   8-bit Color Map      Yes
15      32k   24-bit High Color   Yes
16   64k   24-bit High Color   Yes
24   16.7m   24-bit True Color   Yes
32   16.7m   24-bit True Color   Yes

Color Map  = Type 1 uncompressed
True Color = Type 2 uncompressed
High Color = Type 2 uncompressed
'Back Ground Task' means the image data is processed off screen.  Modes
marked 'no' will be locked until the file creation is complete.
 
Normally the Targa file will be 8 or 24 bits per pixel.  However, if your
video hardware happens to match the Targa specification exactly, then a 16
or 32 bit file might be created.  If this condition occurs the snap module
is extremely fast.  This applies only to full screen snaps.
 
Currently it must be started before pressing Control-Alt-D in XaAES.
Currently always dumps screen snaps to u:\ram\ (the MiNT ramdisk).
Generates files as 'snap_xxx.tga' where xxx is a number from 0 to 999.
It will never overwrite and existing snap even if restarted, unless you
happen to exceed 1000 snaps.

Don't like Targa?  Simply build your own screen snap module.  Contact the
current maintainer of XaAES or the MiNT-Mailing List for further information
regarding module creation.

Please report any problems to:
http://www.bright.net/~gfabasic/

Coded by Lonny Pursell
(C)2006 Lonny Pursell and ENCOM
All rights reserved.

Use entirely at your own risk!

eof
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Di 02.03.2021, 17:49:37
https://docs.dev-docs.org/htm/search.php?find=xaaesnap
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am So 07.03.2021, 17:44:51
Das Problem war Teradesk. Das läuft nicht richtig wenn eine 020 CPU Fastram hat. Thing hat die gleichen Probleme.

Scheint wohl das alles was mit dem Nova Treiber zu tun hat egal ob ET4 oder ATI und egal ob 000 oder 020/030 Version. Mit einer 030 PAK gibt es die Probleme nicht. Single TOS hat auch kein Problem.

Ist die Kombi MiNT + 020 + Fastram + Nova

... weil eine PAK68/2 mit 020 ohne Fastram auch keine Probleme macht.


Ob man jetzt alleine dem Nova Treiber den schwarzen Peter zuschieben kann weiss ich nicht !?!

Der Nova Treiber hat keine Schuld, die Probleme kommen aus der Nutzung von NVDI5 als reines GDOS neben dem Nova Treiber installiert. Wohl auch nur auf Maschinen mit 000-020 CPU. @czietz .. hat das heraus gefunden. Ich wäre da niemals drauf gekommen ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am So 07.03.2021, 19:01:55
Und was machst du jetzt wenn du mal ein GDOS benötigst?
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am So 07.03.2021, 19:08:19
NVDI ist schon ok, es lag an der Startreihenfolge im Autoordner ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Arthur am So 07.03.2021, 19:52:25
Auch bezogen auf #79?
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am So 07.03.2021, 20:04:05
Ja klar. Ich hatte fälischlicherweise NVDI immer vor STA_VDI was der Fehler war. Manche Programme liefen so und einige nicht. Da kam ich nicht drauf ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Mo 15.03.2021, 13:57:29
Habe mal den PAK Turm gegen herausfallen gesichert weil das Mainboard ja aufrecht im Tower Gehäuse steht und den Deckel angebracht. Bin sehr zufrieden. Jetzt noch den Lack für die Laufwerksschächte aber dazu ist es noch zu kalt, warte damit bis in den Sommer ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: TheNameOfTheGame am Mo 15.03.2021, 15:14:05
Das ist cool!
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Di 12.10.2021, 18:09:54
Ein Snapshot unter MiNT ...
Titel: Re: Instandsetzung 520STM Board für PAK/FRAK/Panther ...
Beitrag von: Lukas Frank am Fr 26.11.2021, 14:22:02
Hatte eine MACH32 im Rechner mit 1497% bei Gembench 4.03 und jetzt eine MACH64 ...

Tut sich nicht viel. Man muss auch dazu sagen das NVDI5 installiert ist mit der Option "NOVA", das beschleunigt das ganze um knapp 200%. Nur bei den ATI Karten und dem Nova Treiber, bei den ET4000 wird nichts beschleunigt.