Autor Thema: Forum nur noch über SSL Verschlüsselung erreichbar  (Gelesen 623 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Johannes

  • Administrator
  • *****
  • Beiträge: 1.551
  • ATARI-HOME.DE - online for more than 15 years...
    • atari-home.de
Forum nur noch über SSL Verschlüsselung erreichbar
« am: Do 21.12.2017, 23:05:25 »
Hallo zusammen,

ab sofort ist das Forum nur noch mit SSL Verschlüsselung über HTTPS erreichbar. Grund dafür sind Vorbereitungen auf die neue EU-DSGVO, die uns allen viel Spaß macht.

Nebenbei sind eure Eingaben hier nun auch zwischen eurem COmputer und dem Server verschlüsselt, das sollte eigentlich sowieso standard sein. Bisher hatte ich mich immer noch ein bisschen dagegen gesträubt, da damit auch der ein oder andere ältere Browser außen vor bleibt.

Aber mittlerweile gibt es keine große Wahl mehr. Was ändert sich jetzt für euch? nicht viel, statt http://forum.atari-home.de heißt es jetzt https://forum.atari-home.de. Alte Links auf http funktionieren immer noch, werden dann aber auf die https-Variante weitergeleitet.

Happy encrypted surfing
Johannes
Falcon060 - TT030 - Mega STE4 - Mega ST4 - Mega ST2 - 1040 ST(F/M) - Lynx II - Portfolio
non-Atari: HP 9000 712/60, SUN Ultra 1/Sparcstation 20/Netra T1, SGI Indigo 2, Casio PB-1000
http://blog.atari-home.de - my blog on ATARI and other stuff
atari-home.de is sponsored by http://www.swiftconsult.de

Offline 1ST1

  • Benutzer
  • Beiträge: 6.741
  • Da kringelt sich doch die Locke in der Glocke!
    • HomeCon - der Homecomputer-Treff in Rhein-Main - auch für ATARI
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #1 am: Do 21.12.2017, 23:32:20 »
Super! Firefox meldet mir aber noch ein gelbes Ausrufezeichen vor dem HTTPS-Schloß, wenn man das anklickt, bekomme ich angezeigt, dass einzelne Elemente der Seite noch ohne HTTPS-Verschlüsselung geladen werden. Das ist bestimmt noch anpassbar. Danke für die Arbeit die du ins Forum reinsteckst!
Power without the Price. _/|\_ ATARI

Beware of D.A.U.

1040STFM Twer (PAK68/2,Ovrscn,4MB,1GB SCSI,DVD), 4x1040STFM, 520/1040STE, 520STFM, 260ST, 3x520ST/+, Mega ST1+2+4, 2x Mega STE, 2x Falcon030 20GB/14MB, Stacy4, STBook, TT030/Nova/20MB/72GB, SMM804,SLM-804+605, 5xPofo

Offline gh-baden

  • Benutzer
  • Beiträge: 673
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #2 am: Do 21.12.2017, 23:42:32 »
ab sofort ist das Forum nur noch mit SSL Verschlüsselung über HTTPS erreichbar.

Ist doch prima, danke für die Arbeit. Und alte Rechner können über einen Proxy, der das SSL wegstrippt, ja immer noch ran.
Wider dem Signaturspam!

Offline Johannes

  • Administrator
  • *****
  • Beiträge: 1.551
  • ATARI-HOME.DE - online for more than 15 years...
    • atari-home.de
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #3 am: Do 21.12.2017, 23:52:27 »
Super! Firefox meldet mir aber noch ein gelbes Ausrufezeichen vor dem HTTPS-Schloß, wenn man das anklickt, bekomme ich angezeigt, dass einzelne Elemente der Seite noch ohne HTTPS-Verschlüsselung geladen werden. Das ist bestimmt noch anpassbar. Danke für die Arbeit die du ins Forum reinsteckst!


Das sind dann von den Usern per HTTP verlinkte Bilder, wie z.B. In den Footern. Das kann ich nicht überall nachziehen. Ggf. werde ich Bilder in den Signaturen abschalten.

Falcon060 - TT030 - Mega STE4 - Mega ST4 - Mega ST2 - 1040 ST(F/M) - Lynx II - Portfolio
non-Atari: HP 9000 712/60, SUN Ultra 1/Sparcstation 20/Netra T1, SGI Indigo 2, Casio PB-1000
http://blog.atari-home.de - my blog on ATARI and other stuff
atari-home.de is sponsored by http://www.swiftconsult.de

Offline 1ST1

  • Benutzer
  • Beiträge: 6.741
  • Da kringelt sich doch die Locke in der Glocke!
    • HomeCon - der Homecomputer-Treff in Rhein-Main - auch für ATARI
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #4 am: Fr 22.12.2017, 00:02:23 »
Nein, selbst auf der Hauptseite des Forums ist das gelbe Ausrufezeichen da.
Power without the Price. _/|\_ ATARI

Beware of D.A.U.

1040STFM Twer (PAK68/2,Ovrscn,4MB,1GB SCSI,DVD), 4x1040STFM, 520/1040STE, 520STFM, 260ST, 3x520ST/+, Mega ST1+2+4, 2x Mega STE, 2x Falcon030 20GB/14MB, Stacy4, STBook, TT030/Nova/20MB/72GB, SMM804,SLM-804+605, 5xPofo

Offline gh-baden

  • Benutzer
  • Beiträge: 673
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #5 am: Fr 22.12.2017, 00:08:03 »
Nein, selbst auf der Hauptseite des Forums ist das gelbe Ausrufezeichen da.

Kann ich nicht nachvollziehen. Und auch mit SSL selbst ist alles gut.
« Letzte Änderung: Fr 22.12.2017, 00:12:20 von gh-baden »
Wider dem Signaturspam!

Offline Johannes

  • Administrator
  • *****
  • Beiträge: 1.551
  • ATARI-HOME.DE - online for more than 15 years...
    • atari-home.de
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #6 am: Fr 22.12.2017, 06:22:16 »
Ich bemühe mal Deine Signatur ;) Cache geleert?
Falcon060 - TT030 - Mega STE4 - Mega ST4 - Mega ST2 - 1040 ST(F/M) - Lynx II - Portfolio
non-Atari: HP 9000 712/60, SUN Ultra 1/Sparcstation 20/Netra T1, SGI Indigo 2, Casio PB-1000
http://blog.atari-home.de - my blog on ATARI and other stuff
atari-home.de is sponsored by http://www.swiftconsult.de

Offline 1ST1

  • Benutzer
  • Beiträge: 6.741
  • Da kringelt sich doch die Locke in der Glocke!
    • HomeCon - der Homecomputer-Treff in Rhein-Main - auch für ATARI
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #7 am: Fr 22.12.2017, 07:29:22 »
Hab ich mal gemacht, wenn ich dann die Hauptseite öffne, ist es kurz grün, dann wieder gelb.
Power without the Price. _/|\_ ATARI

Beware of D.A.U.

1040STFM Twer (PAK68/2,Ovrscn,4MB,1GB SCSI,DVD), 4x1040STFM, 520/1040STE, 520STFM, 260ST, 3x520ST/+, Mega ST1+2+4, 2x Mega STE, 2x Falcon030 20GB/14MB, Stacy4, STBook, TT030/Nova/20MB/72GB, SMM804,SLM-804+605, 5xPofo

Offline dbsys

  • Benutzer
  • Beiträge: 3.161
  • n/a
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #8 am: Fr 22.12.2017, 08:45:21 »
Vielen Dank für diese Umstellung. Ich hatte mich schon eine Weile lang gefragt, wann das Forum auf SSL Verschlüsselung umgestellt wird. Es ist sinnvoll und notwendig, will man als Webseitenbetreiber nicht abgehängt werden von der Weiterentwicklung.

Ich nutze Firefox 53 und Atari-Home funktioniert prima!

Nix "gelbe Ausrufezeichen"....  ;)

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 34
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #9 am: Fr 22.12.2017, 09:03:40 »
Kann ich nur bestätigen, alles super hier, keine Warnungen von Firefox, auch auf dieser Seite nicht (benutze Firefox 57 Quantum).

Vielen Dank für dei Arbeit die du hier reinsteckst.

Offline Johannes

  • Administrator
  • *****
  • Beiträge: 1.551
  • ATARI-HOME.DE - online for more than 15 years...
    • atari-home.de
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #10 am: Fr 22.12.2017, 11:03:41 »
Hab ich mal gemacht, wenn ich dann die Hauptseite öffne, ist es kurz grün, dann wieder gelb.

Benutzt Du nicht den non-Standard Theme? Der ist out-of-scope ... sorry.
Falcon060 - TT030 - Mega STE4 - Mega ST4 - Mega ST2 - 1040 ST(F/M) - Lynx II - Portfolio
non-Atari: HP 9000 712/60, SUN Ultra 1/Sparcstation 20/Netra T1, SGI Indigo 2, Casio PB-1000
http://blog.atari-home.de - my blog on ATARI and other stuff
atari-home.de is sponsored by http://www.swiftconsult.de

Offline Arthur

  • Benutzer
  • Beiträge: 6.716
  • Mein Atari erinnert mich an die gute alte Zeit..
    • Atari Wiki
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #11 am: Fr 22.12.2017, 11:04:04 »
Besten Dank.

Offline 1ST1

  • Benutzer
  • Beiträge: 6.741
  • Da kringelt sich doch die Locke in der Glocke!
    • HomeCon - der Homecomputer-Treff in Rhein-Main - auch für ATARI
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #12 am: Fr 22.12.2017, 11:55:07 »
Ich bleibe bei dem Skin. Denn der Standard-Skin lässt mir nach wie vor zu viel Bildschirmfläche brach liegen. Mit dem Browser in die Mitte des Standardskins zoomen ist auch keine Lösung. Übrigens vermisse ich an dem Skin keinerlei Funktion, also lebe ich lieber mit dem gelben Ausrufezeichen.
Power without the Price. _/|\_ ATARI

Beware of D.A.U.

1040STFM Twer (PAK68/2,Ovrscn,4MB,1GB SCSI,DVD), 4x1040STFM, 520/1040STE, 520STFM, 260ST, 3x520ST/+, Mega ST1+2+4, 2x Mega STE, 2x Falcon030 20GB/14MB, Stacy4, STBook, TT030/Nova/20MB/72GB, SMM804,SLM-804+605, 5xPofo

Online czietz

  • Benutzer
  • Beiträge: 1.269
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #13 am: Sa 23.12.2017, 13:56:31 »
Nachdem es vorhin noch fehlerfrei funktionierte, ist jetzt allerdings irgendwie die SSL-Konfiguration kaputt. Der Server verwendet ein Let's-Encrypt-Zertifikat (S/N 03:61:A1:E8:2A:38:34:93:4C:45:24:E8:3D:D3:42:FD:C2:46, ausgestellt 23. Dezember 2017 10:56:18 GMT), das nur für "sch.auerte.de" gültig ist.
Entsprechend (und korrekterweise) bemängeln das die Browser mit großen Warnhinweisen.

Bitte korrigieren.

Offline Johannes

  • Administrator
  • *****
  • Beiträge: 1.551
  • ATARI-HOME.DE - online for more than 15 years...
    • atari-home.de
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #14 am: Sa 23.12.2017, 14:15:48 »
Da läuft ein seltsames Tool, um die Letsencrypt Zertifikate abzurufen und im IIS zu konfigurieren. Das hat die Zertifikate für verschiedene Seiten wohl vertauscht. Habs korrigiert.

Danke!
Falcon060 - TT030 - Mega STE4 - Mega ST4 - Mega ST2 - 1040 ST(F/M) - Lynx II - Portfolio
non-Atari: HP 9000 712/60, SUN Ultra 1/Sparcstation 20/Netra T1, SGI Indigo 2, Casio PB-1000
http://blog.atari-home.de - my blog on ATARI and other stuff
atari-home.de is sponsored by http://www.swiftconsult.de

Offline Mathias

  • Benutzer
  • Beiträge: 1.538
    • www.firebee.org
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #15 am: Mi 10.01.2018, 10:40:19 »
Was ändert sich jetzt für euch? nicht viel, …

Tja, ich bin so jemand, der mit dieser Maßnahme nun komplett ausgeschlossen ist. Ich kann home.de also auf meinen Computern nichteinmal mehr lesen. Den Meisten wird das egal sein, aber vielleicht können ein paar nachvollziehen, wie sich das anfühlt, wenn man nach 1 1/2 Dekaden Teilnahme hier die Seite einfach nicht mehr öffnen kann, …

Meine einzige Möglichkeit ist jetzt, daß ich einen fremdem Rechner verwende, wie jetzt gerade. Was mir aber selten möglich ist. Und es bringt natürlich nicht viel, weil die Kommunikation über das Forum somit sinnentleert wird. Das wars vermutlich endgültig mit mir und home.de :(

Und nein, ich stelle mir auch für home.de keinen aktuellen PC mit einem der 3 Mainstream-Betriebssysteme hin!

Es ist auch nicht richtig daß eine Verschlüsselung unumgänglich ist. Im Art. 32 DSGVO Abs. 1 (a) geht es nämlich erstens um Firmen (!) und zweitens um "personenbezogene Daten" die gespeichert werden (als ob ein Forum nicht sowieso pseudonymisiert wäre). Warum sogar das Lesen damit nur mehr per https möglich sein sollte erschließt sich mir nicht.
MegaST 4 mit Sounddesigner II MegaBus-Hardware und 56001, MegaSTE, Hades 040, MagiC Mac auf Mac OS 9 und eine FireBee.

Offline Arthur

  • Benutzer
  • Beiträge: 6.716
  • Mein Atari erinnert mich an die gute alte Zeit..
    • Atari Wiki
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #16 am: Mi 10.01.2018, 10:53:30 »
Muß ja kein PC sein... ein Raspi tuts auch. ;) Mit Linux Mint,

Offline Mathias

  • Benutzer
  • Beiträge: 1.538
    • www.firebee.org
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #17 am: Mi 10.01.2018, 11:14:09 »
Muß ja kein PC sein... ein Raspi tuts auch. ;) Mit Linux Mint,
Arthur, danke für die Anteilnahme, aber wie praktikabel soll denn das sein? Weiterer Arbeitsplatz? Oder nur Switchboxen für Tastatur/Maus und DVI (+ HDMI auf DVI)? Und dann zum home.de lesen immer ein andere System hochfahren? Noch dazu eines das Textbasiert ist und den Gehirnen von abstraktionslayer-fanatischen Mathematiker- und Physikergehirnen entsprungen ist? Win und Max OS X, oder Smartphones sind sowieso indiskutabel!

Oder doch am Besten assimilieren lassen und alles hinnehmen, und in weiterer Folge Alternativen eh nicht mehr ernst nehmen?

Nein, es tut mir leid, aber es liegt nicht in der Verantwortung von Nutzis von Alternativsystemportalen den Voraussetzungen zum lesen (!) mit neuer Hardware und Mainstreambetriebssystem hinterherzuhecheln.
« Letzte Änderung: Mi 10.01.2018, 11:17:03 von Mathias »
MegaST 4 mit Sounddesigner II MegaBus-Hardware und 56001, MegaSTE, Hades 040, MagiC Mac auf Mac OS 9 und eine FireBee.

Offline Thorsten Otto

  • Benutzer
  • Beiträge: 34
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #18 am: Mi 10.01.2018, 11:14:47 »
Bin da zwar kein Experte, aber sollte es nicht über einen Proxy funktionieren?

Offline RealLarry

  • Benutzer
  • Beiträge: 89
Re: Forum nur noch über SSL Verschlüsselung erreichbar
« Antwort #19 am: Mi 10.01.2018, 11:44:20 »
Tja, ich bin so jemand, der mit dieser Maßnahme nun komplett ausgeschlossen ist.
Mit welchen Compi/Browser greift Du denn hierauf zu? Mit einem Atari?
Aber prinzipiell gebe ich Dir Recht. Wenn es mein Forum wäre, würde ich die Pages mit und ohne SSL ausliefern.
Switchen die modernen Browser mittlerweile nicht sogar selber um, wenn SSL verfügbar ist?