Autor Thema: PAM Netzwerkkarte wird nicht erkannt ...  (Gelesen 413 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
PAM Netzwerkkarte wird nicht erkannt ...
« am: Di 12.09.2017, 19:00:07 »
Das PAM lancetst.tos zeigt Fehler die aber wohl daher kommen das kein Netzwerk extern angeschlossen ist., oder ?





Auf jeden Fall wird lance.xif nicht geladen. Selbst wenn die Hardware ein Problem hat sollte doch eine Meldung vom lance.xif beim booten kommen. Wieso wird lance.xif nicht angezeigt beim booten von MiNT 1-19-cur ?
« Letzte Änderung: Di 12.09.2017, 19:04:26 von Lukas Frank »

Offline Arthur

  • Benutzer
  • Beiträge: 6.581
  • Mein Atari erinnert mich an die gute alte Zeit..
    • Atari Wiki
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #1 am: Di 12.09.2017, 19:10:59 »
Hallo Frank, hab noch nie so eine PAM VME Ethernet Karte gehabt und kann da keine Tipps geben was da schief geht mit dem Treiber.

Offline 1ST1

  • Benutzer
  • Beiträge: 6.297
  • Da kringelt sich doch die Locke in der Glocke!
    • HomeCon - der Homecomputer-Treff in Rhein-Main - auch für ATARI
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #2 am: Di 12.09.2017, 20:35:54 »
Das gab es früher bei PCs öfters, dass Netwerkkarten-Treiber/Testtools Fehler angezeigt haben, wenn kein LAN angeschlossen ist. Soweit ich mich erinnere ist doch PAMs NET BNC, oder? Häng mal testweise parallel zwei 50 Ohm Widerstände dran...
Power without the Price. _/|\_ ATARI

Beware of D.A.U.

1040STFM Twer (PAK68/2,Ovrscn,4MB,1GB SCSI,DVD), 4x1040STFM, 520/1040STE, 520STFM, 260ST, 3x520ST/+, Mega ST1+2+4, 2x Mega STE, 2x Falcon030 20GB/14MB, Stacy4, STBook, TT030/Nova/20MB/72GB, SMM804,SLM-804+605, 5xPofo

Offline mfro

  • Benutzer
  • Beiträge: 904
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #3 am: Di 12.09.2017, 21:18:48 »
Das PAM lancetst.tos zeigt Fehler die aber wohl daher kommen das kein Netzwerk extern angeschlossen ist., oder ?

Ja. Beim externen Loopback muß eine zweite Station (oder ein Hub) am Bus sein, damit das hinhaut. Die Abschlußwiderstände alleine reichen nicht aus.

Ich habe selber keine PAM's Karte, sondern eine Riebl. Soweit ich mich erinnere, wird bei der der MiNT-Treiber nur geladen, wenn er eine gültige MAC-Adresse im batteriegepufferten RAM gefunden hat. Wenn da nichts vernünftiges drinsteht, wird's nix. Hat die PAM's-Karte auch eine Knopfzelle auf dem Board?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #4 am: Di 12.09.2017, 21:31:19 »


Die PAM hat keine Batterie, es steht im Speicher der auf der Karte verbaut ist.

Vielleicht hat ja jemand ein Tool von PAM um die HW Adresse sehen zu können. Das Testprogramm sagt ja beim EEpromtest "OK" ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #5 am: Mi 13.09.2017, 12:56:28 »
Habe mal mit dem PAM TUW TCP/IP Paket rumgespielt und die Treiber werden geladen ohne Fehlermeldung. Um die Ausgaben sehen zu können habe ich von Diskette gebootet.

Gibt es ein Tool das nach jedem Abarbeiten eines Autoordner Programmes auf einen Tastendruck wartet um die Ausgaben in Ruhe lesen zu können ?

Offline Gaga

  • Benutzer
  • Beiträge: 1.727
  • Wer nicht nachfragt, bekommt auch keine Antwort!
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #6 am: Mi 13.09.2017, 13:42:27 »
Ja, das gibt es, frag mal Ektus danach. Er hat eines geschrieben.
Mitglied des Bündnisses gegen Bevormundung und willkürliches Löschen von Beiträgen.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #7 am: Mi 13.09.2017, 14:32:17 »
Habe ihn mal angeschrieben ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #8 am: Mi 13.09.2017, 17:58:52 »
Habe mal Bilder machen können vom TUW Treiber. Wenn TUWTCP.PRG geladen wird gibt es zwei Bomben ...



« Letzte Änderung: Mi 13.09.2017, 18:00:44 von Lukas Frank »

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #9 am: Mi 13.09.2017, 18:54:56 »
Habe mal zum Probieren MiNT 1-18-1 installiert und siehe da lance.xif wird geladen. Scheint alles in Ordnung zu sein ...

Ich weiss ja nicht was die MiNT/XaAES Leute da immer machen, totales Chaos ...

Die 1-19-cur ist so nicht zu gebrauchen, schade.


Offline Arthur

  • Benutzer
  • Beiträge: 6.581
  • Mein Atari erinnert mich an die gute alte Zeit..
    • Atari Wiki
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #10 am: Mi 13.09.2017, 19:37:47 »
Habe mal zum Probieren MiNT 1-18-1 installiert und siehe da lance.xif wird geladen. Scheint alles in Ordnung zu sein ...

Ich weiss ja nicht was die MiNT/XaAES Leute da immer machen, totales Chaos ...

Die 1-19-cur ist so nicht zu gebrauchen, schade.

Ich denke das ist auch alles  schwierig  zu testen... vor allem wenn man die entsprechende Hardware nicht hat könnte ich mir vorstellen. Und wenn hier ein Fehler gefunden wird hat eigentlich immer Helmut und Co. geholfen. Dafür nochmal mein Dank an die MiNT-Programmier-Guru's.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #11 am: Mi 13.09.2017, 20:00:16 »
Das nervt wenn Sachen die mal über eine lange Zeit gingen plötzlich nicht mehr gehen ...

Ich verstehe nicht warum man an solche Sachen Hand an legt wenn man die Gerätschaffen nicht hat und nichts überprüfen kann. Oder man muss sich eine reihe von Betatestern zulegen ...

Offline mfro

  • Benutzer
  • Beiträge: 904
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #12 am: Mi 13.09.2017, 20:03:39 »
Ich weiss ja nicht was die MiNT/XaAES Leute da immer machen, totales Chaos ...

Zwischen 1-18 und 1-19 gibt's - soweit ich das sehe - keinerlei Änderungen am Treiber.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #13 am: Mi 13.09.2017, 20:14:21 »
Beim booten des 1-19 Kernel kommt für den lance.xif gar keine Bootmeldung. Da sollte minimal eine Statusmeldung kommen. So in der Art keine Karte gefunden oder sowas.

Offline czietz

  • Benutzer
  • Beiträge: 1.147
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #14 am: Mi 13.09.2017, 21:08:20 »
Nur Nörgeln hier im Forum behebt das Problem nicht. Mach einen Bugreport auf, das geht bei Freemint über die "Issues"-Funktion von Github ganz einfach. Dazu ist es aber wichtig, dass Du genau die Umstände beschreibst: Was für ein Rechner? Welche MiNT-Version genau, 1-19 ist da zu unspezifisch. Am besten den vollständigen Download-Link der Version, mit der es nicht geht.

Offline czietz

  • Benutzer
  • Beiträge: 1.147
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #15 am: Mi 13.09.2017, 21:13:58 »
So ist bspw. in den 1-19-Snapshots, die Du hier beziehen kannst: https://github.com/freemint/freemint.github.io/blob/master/builds/freemint/master/new/ (z.Zt. aktuell https://github.com/freemint/freemint.github.io/blob/master/builds/freemint/master/new/freemint-1-19-214-020.zip), der Lance-Treiber auf inaktiv gesetzt, Dateiendung .xix. Falls Du solch ein Snapshot nutzt: Hast Du die Datei (in passenden Ordner, also z.B. "TT") auch in lance.xif umbenannt?


Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #16 am: Mi 13.09.2017, 21:29:50 »
Erkläre mir doch Bitte mal ganz genau wie ich auf github eine Meldung absetzen kann. Die alte MiNT Mailing Liste ist ja wohl nicht mehr. Was die 1-19 angeht habe ich so einige durchprobiert von 2015 bis 2017 jeweils trunk und helmut und auf allen geht nichts. Das der Treiber XIF heißen muss ist mir klar ...

Offline gh-baden

  • Benutzer
  • Beiträge: 470
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #17 am: Mi 13.09.2017, 21:47:19 »
Habe mal zum Probieren MiNT 1-18-1 installiert und siehe da lance.xif wird geladen. Scheint alles in Ordnung zu sein ...

Ich weiss ja nicht was die MiNT/XaAES Leute da immer machen, totales Chaos ...

Die 1-19-cur ist so nicht zu gebrauchen, schade.

Ich weiß auch nicht was „die“ machen, da ich bei MiNT nicht mitarbeite.

Da ich aber auch schonmal für’n Atari Hardware-Treiber geschrieben habe (damals, als Rolf noch frisch war), kann ich zumindest davon berichten, dass es gar nicht so einfach ist, den Hardwarezoo, den es da gibt, sauber zu unterstützen.  Oft hat man widersprüchliche oder halbgare Informationen, und soll dazu dann Code schreiben. Oft sogar noch, ohne die passende Hardware selbst zu haben. Bei mir ging das nur durch regelmäßige Treffs (CETiK u.a.), bei denen man sein Code dann auf allem vom 520ST bis zu MagiCMac, MiNT, Hades, Milan, Milan mit Soundkarte, Atari-Emulator am Amiga etc.pp. testen konnte. Und was hagelte es da z.T. Bomben …

An solchen Tagen brachte ich es dann auf mehrere Releases am Tag.

Insofern habe ich viel Verständnis, dass bei neuen Versionen bereits „sicher“ geglaubtes kaputtgehen kann.
Wider dem Signaturspam!

Offline czietz

  • Benutzer
  • Beiträge: 1.147
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #18 am: Mi 13.09.2017, 22:31:47 »
Erkläre mir doch Bitte mal ganz genau wie ich auf github eine Meldung absetzen kann.

https://github.com/freemint/freemint/issues, auf "New issue" klicken. Vermutlich ist ein Github-Account Voraussetzung dafür.

Die alte MiNT Mailing Liste ist ja wohl nicht mehr. Was die 1-19 angeht habe ich so einige durchprobiert von 2015 bis 2017 jeweils trunk und helmut und auf allen geht nichts.

Es gibt auch eine (neue) Mailingliste, falls Du den Bugreport dorthin schicken möchtest: http://wiki.sparemint.org/index.php/FreeMiNT_mailing_list

Du machst es den Entwicklern aber einfacher, wenn Du jeweils einen konkreten Link postest auf eine Version die geht und eine die nicht geht.


Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.692
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: PAM Netzwerkkarte wird nicht erkannt ...
« Antwort #19 am: Mi 13.09.2017, 22:39:34 »
Vielen Dank ...