Autor Thema: EmuTOS und Grafikkartentreiber ...  (Gelesen 641 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
EmuTOS und Grafikkartentreiber ...
« am: Mi 01.02.2017, 19:08:38 »
Ich habe das noch mal probiert mit der EmuTOS 0.97 Bootdiskette auf einem Atari Mega STE mit Nova ET4000 VME Bus Grafikkarte und dem dazu gehörigem Nova Treiber.

Nach dem booten erscheint der Desktop ganz normal und man kann auch alle Menüs aufrufen. Wenn man aber ein Programm startet, bei mir QED wird Müll unleserlich über die Grafikkarte ausgegeben. Wahrlich eine Abstütztmeldung von EmuTOS. Da nach hängt der Rechner und reagiert nicht mehr ...

Mit EmuTOS 0.97 auf Eproms, genau das gleiche verhalten und was mir Aufgefallen ist das beim Arbeitsspeicher viel zu viel frei ist.

« Letzte Änderung: Mi 01.02.2017, 19:11:24 von Lukas Frank »

Offline mfro

  • Benutzer
  • Beiträge: 883
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #1 am: Mi 01.02.2017, 20:11:42 »
Ja, das ist wahrscheinlich eine Panic-Meldung von EmuTOS. Die ist nicht lesbar, weil der Console-Output nicht zum Grafikkarten-Plane-Format paßt.

QED hat mit EmuTOS ein bekanntes Problem, weil seine USERDEF-Dialoge gewaltig (zu) viel Stack belegen.

Laufen Programme ohne AES-Tricks (USERDEFS/benutzerdefinierte Dialogbox-Elemente) besser oder gibt's da auch das Problem?

Der Inhalt der Panic-Meldung ist für eine Fehlersuche notwendig. Dafür ist eine speziell compilierte Version vorgesehen, die die Meldungen auf die serielle Schnittstelle schickt. Wenn ich dir so eine machen würde, hättest Du die Testmöglichkeit (Kabel und Terminal) und wärst Du bereit, zu testen?


Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #2 am: Mi 01.02.2017, 20:22:28 »
Ja immer her damit, ich teste dann ...

Was für andere Programme könnte ich denn nehmen ?

Offline gh-baden

  • Benutzer
  • Beiträge: 455
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #3 am: Mi 01.02.2017, 20:26:01 »
Ja immer her damit, ich teste dann ...

Was für andere Programme könnte ich denn nehmen ?

Everest? 1st Word plus? PureC? RCS? Adimens?
Wider dem Signaturspam!

Offline mfro

  • Benutzer
  • Beiträge: 883
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #4 am: Mi 01.02.2017, 20:35:14 »
Everest? 1st Word plus? PureC? RCS? Adimens?

CHECKDSK3?

Atari-Programme benutzen normalerweise solche Gimmicks nicht.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #5 am: Mi 01.02.2017, 21:02:00 »
Habe die Programme nicht, muss ich erstmal im Netz suchen ...

HDDriver Util oder auch sysinfo stützt genau so ab, bis jetzt jedes Programm.

Offline mfro

  • Benutzer
  • Beiträge: 883
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #6 am: Mi 01.02.2017, 21:21:33 »
Habe die Programme nicht, muss ich erstmal im Netz suchen ...

HDDriver Util oder auch sysinfo stützt genau so ab, bis jetzt jedes Programm.

Dann brauchst Du wahrscheinlich nicht weiter zu probieren.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #7 am: Mi 01.02.2017, 21:32:25 »
Ausser alles auf dem Desktop geht wie z.B. zControl mit den CPX Modulen und Snapshot ...

Offline mfro

  • Benutzer
  • Beiträge: 883
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #8 am: Mi 01.02.2017, 21:34:46 »
wie sieht dein AUTO-Ordner aus?

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #9 am: Mi 01.02.2017, 22:22:46 »
Autoordner nichts, nur die drei Nova Treiber sachen  ...

1. emulator.prg
2. xmenu.prg
3. sta_vdi.prg

Offline mfro

  • Benutzer
  • Beiträge: 883
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #10 am: Mi 01.02.2017, 22:24:12 »
kannst Du mal probieren ob das bei dir läuft? Umbenennen in .zip und unzippen.

Weil wir nicht wissen, wonach wir suchen, ist Debugging überall eingeschaltet.

Wenn mich nicht alles täuscht, müsste der Output an der seriellen Schnittstelle mit 19200 Bd ankommen.




Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #11 am: Mi 01.02.2017, 23:00:11 »
Sind 9600 Baud.

Der Schreibt immer mit und läuft sehr langsam. Zum booten bis zum Desktop dauert es bestimmt so 2-3 Minuten. Ich teste das Morgen mal näher. QED hängt und EmuTOS schreib auch nichts über die Serielle ...

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #12 am: Do 02.02.2017, 10:04:26 »
Hier mal die Ausgabe über die Serielle beim booten bis der Desktop erscheint im Anhang ...

Wenn ich irgendein Programm starte hängt der Rechner einfach sofort ohne etwas über die serielle Schnittstelle auszugeben. Auch ein Tastatur Reset geht nicht mehr.

Offline mfro

  • Benutzer
  • Beiträge: 883
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #13 am: Do 02.02.2017, 12:45:22 »
Hier mal die Ausgabe über die Serielle beim booten bis der Desktop erscheint im Anhang ...

Nachdem MODEM.CPX gestartet wurde, sieht man im Log nur noch Kauderwelsch. Wahrscheinlich stellt das die Baudrate um.

Kannst Du das mal  deaktivieren?

Bis dahin sieht alles gut aus.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #14 am: Do 02.02.2017, 14:29:52 »
Wenn ich den Mega STE mit 8Mhz boote lassen sich auch Programme einwandfrei starten, vielleicht ist etwas mit meiner Maschine. Keine Ahnung ...

Andere sollten das ganze auch mal probieren und Berichten.

Bei einer 16 Farbdarstellung war die Crashmeldung auch Leserlich auf dem Bildschirm.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #15 am: Do 02.02.2017, 15:09:07 »
Gerade mal auf einem Atari Mega ST mit VOFA Adapter und ET4000 probiert und läuft einwandfrei. Da stimmt doch wohl mit dem Mega STE etwas nicht ...

Offline mfro

  • Benutzer
  • Beiträge: 883
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #16 am: Do 02.02.2017, 15:28:33 »
So wie's aussieht, passiert der Crash bei einem RTE mit zerstörtem Stack.

Möglicherweise im VDI, sicher nicht im gestarteten Programm (ist das immer noch QED?) und auch nicht im EmuTOS selbst.

Offline tuxie

  • Benutzer
  • Beiträge: 5.786
  • Falcon! Milan! Schuetzt die Raubvoegel!
    • tuxie.de
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #17 am: Do 02.02.2017, 15:33:57 »
Könnte es heute mal am TT mit Nova Testen..
Tschau Ingo


PC Intel i7 4820, 16gb quad @2400,Mac OS X El Capitan
http://tuxie.de http://hwbot.org/user/tuxie/

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #18 am: Do 02.02.2017, 15:40:48 »
So wie's aussieht, passiert der Crash bei einem RTE mit zerstörtem Stack.

Möglicherweise im VDI, sicher nicht im gestarteten Programm (ist das immer noch QED?) und auch nicht im EmuTOS selbst.

Habe immer mit sysinfo 5.0x probiert. Seltsamerweise läuft unter TOS 2.06 alles mit 16Mhz einwandfrei. Ich vermute aber trotzalledem das es an meinem Rechner liegt. Vielleicht läuft da etwas in den Caches schief, keine Ahnung ...

Mit dem Mega ST und der ET4000 ist alles wunderbar.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.614
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: EmuTOS und Grafikkartentreiber ...
« Antwort #19 am: Do 02.02.2017, 15:47:37 »
Interessant ist auch wie es mit NVDI bei den ET4000 und Matrix Karten ausschaut und den anderen die es da so noch gibt ...