Autor Thema: Frage zu Patches für TOS 1.04  (Gelesen 523 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline kolli

  • Benutzer
  • Beiträge: 34
Frage zu Patches für TOS 1.04
« am: Do 12.01.2017, 12:04:45 »
Hallo,

meine Erinnerungen sind leider etwas eingestaubt, daher benötige ich mal Eure Hilfe.

Auf meinem 1040STFM werkelt ein gepatchtes TOS 1.04 aus den frühen 90ern. Das Patchen habe ich seinerzeit selbst gemacht, ein Freund hat das dann in EPROMs gebrannt. Eingebaut habe ich einen anderen Systemfont (sieht aus wie der Monaco, also viel eleganter als der holprige Atari Font) und eine Auswahl an Patches. Es gab damals irgendein Projekt, um die Funktionalität der diversen Autoordner-Patches und -fixes in ein TOS-ROM einzubauen. Leider finde ich dazu nichts im Netz, denn ich wüsste gern, welche Fehlerbereinigungen mein Rechner nun eigentlich hat und welche ich ggf. über den Autoordner ergänzen muss.

Gehe ich eigentlich recht in der Annahme, dass ich zumindest FOLDRXXX.PRG ab TOS 1.04 nicht mehr brauche?

Gruß,
Kolli

Offline 1ST1

  • Benutzer
  • Beiträge: 6.526
  • Da kringelt sich doch die Locke in der Glocke!
    • HomeCon - der Homecomputer-Treff in Rhein-Main - auch für ATARI
Re: Frage zu Patches für TOS 1.04
« Antwort #1 am: Do 12.01.2017, 13:31:14 »
bei Folderxxx.prg kommts drauf an, wie groß deine Platte ist und wieviele Ordner du pro Rechnersitzung erzeugst/änderst/reinwechselst. Denn der Patch verschiebt den Fehler nur nach oben, sprich der Buffer wird vergrößert, er kann immer noch voll laufen. 100 ist der Default in TOS 1.04, ich weiß natürloch nicht, ob du das damals auch noch weiter gepatcht hast. Wenn der Fehler dennoch auftritt, solltest du das Tool mal als Folder200.prg oder so in den Autoordner packen.Richtig beseitigen kann man den Fehler nur mit BIGDOS im AUTO-Ordner, denn das ersetzt das komplette GEMDOS durch eine stark verbesserte Version.

Was du mit der Auswahl an TOS-Patches meinst, könnte das hier sein: http://www.markusheiden.de/atari/tospatch.html
Power without the Price. _/|\_ ATARI

Beware of D.A.U.

1040STFM Twer (PAK68/2,Ovrscn,4MB,1GB SCSI,DVD), 4x1040STFM, 520/1040STE, 520STFM, 260ST, 3x520ST/+, Mega ST1+2+4, 2x Mega STE, 2x Falcon030 20GB/14MB, Stacy4, STBook, TT030/Nova/20MB/72GB, SMM804,SLM-804+605, 5xPofo

Offline kolli

  • Benutzer
  • Beiträge: 34
Re: Frage zu Patches für TOS 1.04
« Antwort #2 am: Do 12.01.2017, 14:48:14 »
Zitat von: 1ST1 dlink=topic=13340.msg213462#msg213462 date=1484224274
Was du mit der Auswahl an TOS-Patches meinst, könnte das hier sein: http://www.markusheiden.de/atari/tospatch.html

Das kommt mir bekannt vor, aber nur so ein bisschen... 25 Jahre ist doch echt lange her... Guck ich mir mal an.

Ich hab damals eigentlich nur um den "hübscheren Macintosh-Font" benutzen zu können ein Image von TOS 1.04 reloziert und dann von Diskette geladen.

Als die Idee aufkam, man könnte doch das im ST vorhandene ROM mit TOS 1.02 durch EPROMs mit umschaltbarem 1.02 und 1.04 ersetzen, hab ich gleich die irgendwo gefundenen Fixes und Patches mit in 1.04 eingebaut. Und so habe ich es nach 25 Jahren wiedergefunden, als ich den Rechner wiederbelebt habe. Nur leider hat mein Gedächtnis nicht so gut gehalten wie die EPROMs...

Offline kolli

  • Benutzer
  • Beiträge: 34
Re: Frage zu Patches für TOS 1.04
« Antwort #3 am: Do 12.01.2017, 21:27:26 »
Hab's mir angeguckt. Ich glaube, das ist die Software, mit der ich damals gearbeitet habe. Anscheinend kein Patch für FOLDRXXX dabei. Dann werd ich den mal in den AUTO-Ordner tun oder den ICD-Pro-Treiber entsprechend konfigurieren.

Vielen Dank für den Tipp!

Offline 1ST1

  • Benutzer
  • Beiträge: 6.526
  • Da kringelt sich doch die Locke in der Glocke!
    • HomeCon - der Homecomputer-Treff in Rhein-Main - auch für ATARI
Re: Frage zu Patches für TOS 1.04
« Antwort #4 am: Fr 13.01.2017, 10:17:07 »
Du nutzt den ICD-Treiber? Schau mal in dessen Optionen. Ich meine mich zu erinnern, dass ICD im Plattentreiber auch was für das Ordnerproblem drin hat, wo man die Anzahl der Ordner einstellen kann. Muss ja nicht doppelt gemoppelt sein...
Power without the Price. _/|\_ ATARI

Beware of D.A.U.

1040STFM Twer (PAK68/2,Ovrscn,4MB,1GB SCSI,DVD), 4x1040STFM, 520/1040STE, 520STFM, 260ST, 3x520ST/+, Mega ST1+2+4, 2x Mega STE, 2x Falcon030 20GB/14MB, Stacy4, STBook, TT030/Nova/20MB/72GB, SMM804,SLM-804+605, 5xPofo

Offline kolli

  • Benutzer
  • Beiträge: 34
Re: Frage zu Patches für TOS 1.04
« Antwort #5 am: Fr 13.01.2017, 11:30:02 »
Du nutzt den ICD-Treiber? Schau mal in dessen Optionen. Ich meine mich zu erinnern, dass ICD im Plattentreiber auch was für das Ordnerproblem drin hat,

Genau, das meinte ich mit "oder den ICD-Pro entsprechend konfigurieren". :-)