Autor Thema: NE2000 kompatible ISA Netzwerkkarte im Milan040  (Gelesen 2901 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
NE2000 kompatible ISA Netzwerkkarte im Milan040
« am: So 17.01.2016, 00:26:35 »
Ich wollte mal wieder ein paar meiner Erfahrungen hier mitteilen. ;D

In meinem Milan werkelt eine PCI Netzwerkkarte mit RTL8139 Chipsatz. Die funktioniert auch echt gut, es gibt allerdings nur Treiber für MiNT. Die Tage fiel mir dann meine allererste Netzwerkkarte in die Hände. Eine E2000+ Plug'n'Play ISA Netzwerkkarte mit UMC 9008F Chipsatz, die NE2000 kompatibel ist. Für solche Karten gibt es unterschiedliche Treiber für MiNT, Magic und sogar für Sting! Also dachte ich mir, probiere ich das aus und setze die in den Milan ein, dann habe ich vielleicht sogar unter TOS Netzwerkzugang und vor allem auch unter MagiC, mit dem ich angefangen hatte rumzumachen. Ich habe mich als erstes für den EtherNE Treiber von Thomas Redelberger entschieden:

http://home.arcor.de/thomas.redelberger/prj/atari/etherne/index.htm

Vorteil des EtherNE-Treibers, er lässt sich unter MiNT, MagiC und unter TOS (Sting) einsetzen. Bevor man die Karte in den Milan einsetzt muss man sie allerdings etwas vorbereiten. Auch wenn es eine Plug'n'Play Karte ist, ist ISA nicht unbedingt eine solch trivale Sache u. a. wegen der IRQs. Die Karte muss auf jeden Fall auf einen IRQ eingestellt werden, der nicht belegt ist. Generell freie IRQs bei Milan sind 5, 9, 10, 11 und 13. IRQ 5 belegt bei mir die Soundkarte. IRQ 9 und 11 werden durch PCI-Karten belegt. Blieben für die Netzwerkkarte also nur IRQ 11 oder 13. Also habe ich die Karte in meinen alten Cyrix 6x86 AT PC gesteckt und mit dem entsprechenden Konfigurationsprogramm unter DOS 6.22 konfiguriert. Dabei wurden echt Erinnerungen wach wie ich an die Karte kam und dergleichen. 8) Die Treiberdiskette mit dem Setup-Programm hatte ich sogar noch. :D Das Konfigurationsprogramm bietet unterschiedliche Betriebsmodi der Karte an:

"Plug'n'Play" - Werte für IRQ und Port sind fest eingestellt. Leider auf solche Werte, dass es zu Konflikten kommt im Milan.

"Autosense" - Keine Ahnung wozu dieser Modus wirklich gut ist, aber die Werte für IRQ und Port sind auch hier fest eingestellt. Leider auch auf solche Werte, dass es zu Konflikten kommt im Milan.

"Jumperless" - Werte für IRQ und Port können angepasst werden. Hatte ich dann auch gemacht. Leider konnte ich nur den IRQ 10 auswählen im Konfigurationsprogramm. IRQ 13 bietet es nicht an. Dafür aber noch 12 und 15. Warum auch immer. Den Port habe ich auf 300 gestellt, weil das der Port ist, auf dem der EtherNE-Treiber die Karte sucht.

Nach dieser Vorbehandlung habe ich die Karte in den Milan eingebaut und sie wird vom EtherNE Treiber auch erkannt und die MAC Adresse der Karte korrekt ausgelesen. Leider war's das dann auch schon, was noch korrekt lief. :'( Der EtherNE-Treiber scheint mit der Karte nicht wirklich zurecht zu kommen. Pingen schlägt fehl. Die LED an der Karte leuchtet nur einmal kurz orange auf unter TOS. Unter MagiC gibt's dafür ein oranges Dauerblinken und "ping.ttp" hängt dann. Auch unter MiNT sieht's nicht besser aus.

Also dachte ich mir, probiere ich nochmal den AssemSoft NE2000-Treiber aus, den es für MiNT gibt:

http://assemsoft.atari.org/ne2k/

Auch der Treiber erkennt die Karte und spuckt sogar einiges mehr an Infos aus als der EtherNE-Treiber, der nur die MAC-Adresse ausgibt:

AssemSoft's NE2000 ISA Milan ISA driver v0.0.18 (68020+),
IO Base = 0xc0000000
 probing -<>0xc0000300
 Device found at port 0x0300
 Attempting IRQ line autodetection...Success!
   Using IRQ line 13
install ISR 0x03117194 for card 0
Card 0 is a "NE2000 or clone" at interface "ne0"
        hwadr: 00:80:ad:1e:5c:20
        hwpriv: 0x0314eea4, netif: 0x0314efa4, ISR: 0x03117194
        got 52 Rx pages, maxpackets = 0
ISR hwpriv table: 0x0314eea4, 0x00000000, 0x00000000, 0x00000000
ISR routines:     0x03117194, 0x031171a0, 0x031171ac, 0x031171b8

Sieht soweit ich das beurteilen kann, auch sehr gut aus, aber leider will auch dieser Treiber nicht mit meiner Karte. Auch hier funktioniert der Ping nicht und "ifconfig" gibt aus, dass es bei den Paketen, die rausgegangen sind zu Fehlern kam. :'(

Eigentlich schade. So hätte die Karte noch einen gewissen Nutzen gehabt und es wäre eine nette Sache für Magic und TOS gewesen. Ich denke, dass die besagten Treiber sehr wahrscheinlich nicht mit dem Chipsatz der Karte klarkommen oder irgendetwas anderes ist da noch was stört? Leider wird der Chipsatz meiner Karte auch bei den Treibern, die ich verwendet habe, nicht als getestet oder kompatibel aufgelistet.

Anbei noch ein Foto meiner allerersten Netzwerkkarte.
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.744
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #1 am: So 17.01.2016, 00:35:16 »
Mit einer ISA Ethernetkarte mit RTL Chipsatz sollte das aber gehen. Der EtherNEC Adapter ist das gleiche wie eine Netusbee und die verwenden auch einen RTL Netzwerkchip, ich meine es wäre ein RTL8019 ...

Die PCI Karte sollte doch unter MagiC mit MagiCNet 1.42b auch laufen, meine Netusbee läuft auch dem Mega ST wunderbar unter MagiC. Nur mit STING natürlich nicht.

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #2 am: So 17.01.2016, 01:04:00 »
Zitat
Die PCI Karte sollte doch unter MagiC mit MagiCNet 1.42b auch laufen [...]

Das ist interessant. Ich habe nur MagiCNet 1.3.9b im Netz gefunden. Wo gibt's denn die 1.42b Version? Dann teste ich nochmal den AssemSoft RTL8139-Treiber unter Magic:

Zitat
http://assemsoft.atari.org/rtl8139/index.html

Netzwerk unter TOS wäre das non plus ultra. >:D Unter Magic wäre es schon nicht schlecht, wenn das Netzwerk liefe.
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #3 am: So 17.01.2016, 01:11:01 »
Hab's jetzt selbst gefunden, nachdem ich wußte, dass es die Version gibt:

http://www.ektus.de/magxnetb.zip

http://dhs.nu/bbs-ct60/index.php?request=9929

Der Hoster der Version sollte nicht unbekannt sein. Nette Grüße in diese Richtung! :D
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #4 am: So 17.01.2016, 18:30:29 »
Ich habe mal MagiCNet 1.42b installiert und den AssemSoft RTL8139 Treiber, den ich auch unter MiNT nutze:

http://assemsoft.atari.org/rtl8139/index.html

Nach dem ersten Reboot war alles super. Die Karte wurde erkannt. Das Interface war da und Pingen ging auch. Dann dachte ich mir, ich installiere auch gleich mal Gluestick dazu. Also nochmal neu gestartet und nach dem Laden von Jinnee friert Magic mit einer Absturzmeldung ein. Also wieder deaktiviert. Aber Magic stürzt weiterhin ab. Ich habe MagiCNet dann deaktiviert und MagiC wollte wieder. Nach erneutem Aktivieren gab's denn wieder ein Einfrieren. Insofern sieht es zur Zeit so aus als liefe das doch nicht wirklich mit der PCI Netzwerkkarte unter MagiC. Vielleicht hat ja noch jemand ein paar Ideen?
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Online Ektus

  • Moderator
  • *****
  • Beiträge: 604
    • Meine Homepage, u.a. mit Atari links
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #5 am: Di 19.01.2016, 18:26:23 »
PCI Netzwerkkarte im Milan habe ich nie versucht. Da ist seit 1,5 Jahrzehnten eine ISA NE2000 drin und funktioniert sowohl unter MagiC als auch unter MiNT problemlos. Ich verwende ebenfalls jinnee, an der Kombination sollte es also nicht liegen.


MfG
Ektus.

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.744
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #6 am: Di 19.01.2016, 18:46:19 »
Dann besorge dir doch mal über Ebay eine ISA Ethernet Karte mit RTL Chipsatz ...

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #7 am: Di 19.01.2016, 20:18:48 »
Ich habe jetzt mal die MagiCNet Gemdos Erweiterung von Gerhard Stoll installiert:

http://rz-home.de/~gstoll/MagiCNet.htm

Jetzt läuft MagiCNet erstmal wieder. Mit Gluestick will es dennoch nicht.

Zitat
Dann besorge dir doch mal über Ebay eine ISA Ethernet Karte mit RTL Chipsatz ...

Ich hatte dort mal geschaut, aber die werden dort wohl auch eher selten angeboten. Hat aber auch nicht so große Priorität bei mir. MiNT läuft ja sehr rund und vor allem das Netzwerk funktioniert sehr gut unter MiNT. Unter MagiC gab es z. B. Paketverluste beim Pingen. Unter MiNT dagegen nicht. Aber Magic ist bei mir eh noch Großbaustelle. ;)

Ich habe mal rausgesucht mit welchen Chipsätzen der EtherNE-Treiber getestet wurde:

Realtek RTL8019AS, Winbond W89C90 und UMC UM9090

Der AssemSoft NE2000-Treiber wurde mit folgenden Chipsätzen getestet:

Realtek RTL-8029, Winbond 89C940, Compex RL2000, KTI ET32P2, NetVin NV5000C, Via 86C926, SureCom NE34, Winbond W89C940F, Holtek HT80232, Holtek HT80229

Wobei AssemSoft wohl nur wirklich PCI-Versionen getestet hat.
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.744
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #8 am: Di 19.01.2016, 20:31:36 »
Da müssten welche dabei sein ->   Ebay 231814652515

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #9 am: Di 19.01.2016, 21:15:39 »
Ja. Leider lässt sich nur nicht erkennen, welche Chipsätze auf den Netzwerkkarten drauf sind und wenn dann bräuchte ich nur eine Karte und nicht die ganze Sammlung. Vor allem wichtig ist ein Setupprogramm, mit dem ich die Karte konfigurieren kann und auf den richtigen Port und IRQ etc. einstellen kann. Wie gesagt, das hat keine so hohe Priorität. Wenn mir mal eine entsprechende Karte vor die Füße fällt, werde ich sie auch nicht verschmähen. ;D
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline 1ST1

  • Benutzer
  • Beiträge: 6.349
  • Da kringelt sich doch die Locke in der Glocke!
    • HomeCon - der Homecomputer-Treff in Rhein-Main - auch für ATARI
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #10 am: Di 19.01.2016, 21:32:48 »
Momentmal, eine Frage: War das bei den ISA PnP Karten nicht so, dass die nach jedem Reset bzw. wenn sie mal stromlos waren, erstmal von einem ISA PnP BIOS oder einem entsprechenden Software-Treiber in der AUTOEXEC.BAT/CONFIG.SYS wieder auf ihre Ressourcen eingestellt werden müssen. Kann das der Milan, oder gibts dafür für den Milan ein entsprechendes PnP Tool für den Auto-Ordner? Ohne das müssten doch sochle ISA PnP Karten ständig ihre Ressourceneinstellungen verlieren? Dann doch eher noch ältere NE-2000(-kompatible) Karten nehmen, die noch per Jumper konfigurierbar sind.
Power without the Price. _/|\_ ATARI

Beware of D.A.U.

1040STFM Twer (PAK68/2,Ovrscn,4MB,1GB SCSI,DVD), 4x1040STFM, 520/1040STE, 520STFM, 260ST, 3x520ST/+, Mega ST1+2+4, 2x Mega STE, 2x Falcon030 20GB/14MB, Stacy4, STBook, TT030/Nova/20MB/72GB, SMM804,SLM-804+605, 5xPofo

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #11 am: Di 19.01.2016, 21:48:24 »
Im Moment ist meine ISA-Netzwerkkarte im Milan fest auf Port 300 und IRQ 10 eingestellt. Ich kann sie mit dem dazugehörigen DOS-Setupprogramm auf den Betriebsmodus "jumperless" einstellen und die Werte für "Port" und "IRQ" dann manuell vergeben. Wenn ich sie in den Betriebsmodus "plug'n'play" versetze, dann wird sie anscheinend fest auf Port 240 und IRQ 5 vom Setupprogramm eingestellt. Zumindest werden mir diese Werte dann immer angezeigt im Setupprogramm, wenn ich diesen Modus wähle.

Zitat
War das bei den ISA PnP Karten nicht so, dass die nach jedem Reset bzw. wenn sie mal stromlos waren, erstmal von einem ISA PnP BIOS oder einem entsprechenden Software-Treiber in der AUTOEXEC.BAT/CONFIG.SYS wieder auf ihre Ressourcen eingestellt werden müssen. Kann das der Milan, oder gibts dafür für den Milan ein entsprechendes PnP Tool für den Auto-Ordner?

Gibt es für den Autoordner. Zur Zeit ist meine ISA-Netzwerkkarte nur nicht auf "plug'n'play" eingestellt. ;) Die Karte wird von den entsprechenden Treibern auch gefunden und erkannt. Das ist nicht das Ding. Nur der Betrieb schlägt dann fehl. :(
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline KarlMüller

  • Benutzer
  • Beiträge: 174
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #12 am: Sa 23.01.2016, 18:13:18 »
PCI Netzwerkkarte im Milan habe ich nie versucht.
Geht aber und auch unter MagiC. Hier läuft eine PCI Netzwerkkarte mit den Treiber von AssemSoft.

Ding. Nur der Betrieb schlägt dann fehl. :(
Wie ist denn die Definition von "der Betrieb schlägt dann fehl"?

Wenn die Erweiterung von Gerhard Stoll was bringt dann läuft ja MagiCNet erstmal, denn diese jetzt nur auf was vorhandens auf.

Hast Du Gluestick aus dem MagiCNet Paket genommen oder den von MiNT? Der erstere ist meines Wissen nach etwas verändert.

Mit welchen Programmen hast Du den Test gemacht?

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #13 am: So 24.01.2016, 01:10:10 »
Zitat
Wie ist denn die Definition von "der Betrieb schlägt dann fehl"?

Das bezieht sich auf meine E2000+ ISA-Netzwerkkarte, die NE2000 kompatibel ist. Sie wird zwar von den entsprechenden Treibern erkannt, aber Pingen z. B. funktioniert nicht und bei den Paketen, die rausgehen, gibt es lauter Fehler. Eingehende Pakete werden anscheinend erst gar icht erkannt. Inzwischen habe ich die E2000+ auch wieder in den ursprünglichen Plug'n'Play-Modus versetzt und die Karte entsprechend über die "isapnp.cnf" konfiguriert. Leider ändert das rein gar nichts was die beschriebenen Fehler angeht.

Zitat
Geht aber und auch unter MagiC. Hier läuft eine PCI Netzwerkkarte mit den Treiber von AssemSoft.

Die PCI-Karte läuft bei mir auch soweit unter MagiC. Allerdings gibt's beim Pingen eben manchmal Verluste. Warum auch immer? Und Gluestick legt MagiCNet lahm. Muss ich in MagiCs Startordner bzw. Extensionsordner auch auf die Reihenfolge achten?

Zitat
Hast Du Gluestick aus dem MagiCNet Paket genommen oder den von MiNT? Der erstere ist meines Wissen nach etwas verändert.

Ich habe Gluestick aus dem MagiCNet 1.42b Paket genommen.

Zitat
Mit welchen Programmen hast Du den Test gemacht?

Bislang habe ich unter MagiC nur Pings durchgeführt mit dem Ping-Programm, das MagicNet 1.42b beiliegt.
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #14 am: Fr 14.10.2016, 20:04:24 »
Irgendwie hatte mir die Sache nicht wirklich Ruhe gelassen, weil ich auch gerne unter TOS mit dem Milan ins Netz wollte. Also hatte ich in letzter Zeit mal u. a. in der Bucht nach ISA Netzwerkkarten mit Realtek RTL8019AS Chipsatz Ausschau gehalten und bin dann für 12 € fündig geworden. Die Karte war nicht weiter getestet und keinerlei Anleitung oder Treiber dabei. Ich hab's mal riskiert und siehe da, die Karte funktioniert unterm Single TOS mit EtherNE-Treiber. 8) :D Tests unter Magic folgen noch.
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #15 am: So 16.10.2016, 12:55:14 »
Die Karte läuft auch unter Magic mit dem entsprechenden EtherNE-Treiber! ;D Auch Gluestick läuft jetzt unter Magic einwandfrei und stürzt nicht mehr ab. Sting-basierte Software läuft einwandfrei unter Magic. Software, die auf Mintnet aufsetzt, will allerdings noch nicht. Ich forsche mal weiter.
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline KarlMüller

  • Benutzer
  • Beiträge: 174
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #16 am: Mo 17.10.2016, 19:44:52 »
Sting-basierte Software läuft einwandfrei unter Magic. Software, die auf Mintnet aufsetzt, will allerdings noch nicht. Ich forsche mal weiter.
Mit welchen (MiNTNet) Programme hast Du es getestet?

Bei Troll und Litchi benötigst Du die MiNTNet Erweiterung von Gerhard Stoll.

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #17 am: Mo 17.10.2016, 20:21:40 »
Zitat
Bei Troll und Litchi benötigst Du die MiNTNet Erweiterung von Gerhard Stoll.

Gerhard Stolls MiNTNet-Erweiterung hatte ich bereits installiert. Litchi, AtarICQ und CAB sowie Highwire laufen alle auch ohne Probleme. Allerdings nur mit der *.ovl für Sting. Will man CAB stattdessen mit der *.ovl für MiNTNet nutzen, stürzt CAB ab. Mehr habe ich bislang nicht getestet. Wobei mir jetzt so aus dem Kopf aber auch kein MiNTNet only Programm einfällt.
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)

Offline Lukas Frank

  • Benutzer
  • Beiträge: 6.744
  • fancy Atari Musik anDA Dance "Agare Hinu Harukana"
    • Muss mir auch mal eine schöne Websaite bauen ...
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #18 am: Mo 17.10.2016, 20:44:19 »
Welche MagiCNet Version nutzt du denn mit MagiC 6.2 ?

Offline Nervengift

  • Benutzer
  • Beiträge: 1.120
    • Ein wenig was über mein anderes Hobby. :-)
Re: NE2000 kompatible ISA Netzwerkkarte im Milan040
« Antwort #19 am: Mo 17.10.2016, 20:53:05 »
Zitat
Welche MagiCNet Version nutzt du denn mit MagiC 6.2 ?

Nein. MagiC Milan 6.1 mit MagiCNet 1.42b. ;)
520 ST(M) (TOS 1.02), Falcon030 (16 MHz, 16 MB RAM, CF-Karte, MiNT & MyAES), Milan040 (25 MHz, 48 MB RAM, EasyMiNT 1.90), Firebee (2nd Edition), PowerMac G5 Late 2005 (2 x 2,3 GHz, Mac OS 10.5), iMac 4K Late 2015 (intel Core i7 4 x 3,3 GHz, Mac OS 10.11.6), IBM XT SFD (640 KB RAM, DR DOS 6.0), Compaq LTE 5300 (Pentium/133 MHz, DR-DOS 7.03), AT-PC (Cyrix 6x86L/200 MHz, Windows 98 SE/MS-DOS 6.22 & Windows 3.11)